对 SharePoint 库签入或签出文件

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

在从 Microsoft Windows SharePoint Services 网站上的库中签出文件时,应确保在您编辑该文件时,其他人无法对其进行更改。在文件签出之后,您可以编辑、关闭、重新打开该文件,甚至是在硬盘上处理该文件。其他用户要在您签入该文件之后才能更改该文件或看到您的更改。

本文内容

概述

签出的 SharePoint 库文件

签入到 SharePoint 库文件

更改您处理签出文件的位置

概述

在处理文件之前将其签出有助于在多人处理同一组文件时避免冲突和混淆。将文件签出给您时,只有您能对其进行更改。您可以签出对其拥有权限的 SharePoint 网站上的任何文件,并且可以从下列 2007 Microsoft Office 系统 程序中直接签出文件:Word、Excel、PowerPoint 和 Visio。

在签入文件时,可以键入有关您对文件所做更改的注释。这可以帮助用户了解文件的各版本之间哪些内容发生了更改。这在多人处理一个文件或者文件可能经过多次修改的情况下尤其有用。如果库跟踪文件的版本,则注释将成为该文件的版本历史记录的一部分,在用户需要查看或还原以前的版本时,注释可能很有帮助。

您所在的组织可能要求您在编辑文件之前先签出文件。如果要求签出,则在库中创建文件或将其上载到库中时必须签入新文件。

当文件对您签出时,您所做的更改要在您再次将该文件签入之后,才能由其他人看到。可能存在这样的情况:您想签入文件以使他人可看到您的更改,但是您又想使文件保持签出状态,以便继续对其进行处理。在签入文件时,除非您的库同时跟踪主要版本和次要版本,并且您正在签入主要版本,否则您可以选择继续处理该文件。主要版本通常自上一个主要版本以来进行了重大更改,而次要版本通常自上一个版本以来只进行了轻微的更改。例如,主要版本可能包含大部分新内容,而次要版本可能只包含对拼写错误的纠正。

当使用 Office 程序签出 Windows SharePoint Services 3.0 网站上的文件时,默认情况下,该文件存储在硬盘上“我的文档”文件夹内的草稿文件夹中。可将此位置更改为硬盘或网络上的其他位置,或者可以在处理签出的文件时指定这些文件存储在 Web 服务器上。管理员可能根据组织的需要指定自定义位置,或者禁止该位置被更改。

在从 Microsoft Windows SharePoint Services 2.0 网站签出文件时,该文件在您对其进行处理时存储在服务器上,但您仍然必须签入该文件才能让其他人看到您的更改。多数情况下,在从 Windows SharePoint Services 3.0 网站签出文件时,您将收到一条消息告诉您在文件签出时文件将存储到哪个位置。在从 Windows SharePoint Services 2.0 网站签出文件时,您不会收到这样的消息。

文档签出时,Office 程序中的“文档管理”任务窗格将提供用于签入该文件的命令。

如果同时跟踪文件的主要版本和次要版本,则系统可能提示您是选择签入主要版本还是次要版本。

返回页首

从 SharePoint 库签出文件

使用此过程签出已在 Office 程序中打开的文件。也可以从 SharePoint 网站上的库中签出文件。

在以下 2007 Office 版本程序中,请执行下列操作:

Word、Excel 或 PowerPoint

  1. 单击Microsoft Office 按钮 Office 按钮图像 ,单击服务器,然后单击签出

    默认情况下,Word 文档通常在全屏阅读视图中打开。如果情况如此,可能需要先单击“页面视图”以切换到“页面视图”,才能完成此步骤。

  2. 如果出现描述签出期间文件存储位置的消息,则单击“确定”

    多数情况下,如果从 Windows SharePoint Services 3.0 网站签出文件,则会出现此消息。

    提示: 在描述签出期间文件存储位置的消息中,您可以更改用于处理签出的文件的选项。

Visio

  1. “文件”菜单上,单击“签出”

  2. 如果出现描述签出期间文件存储位置的消息,则单击“确定”

    多数情况下,如果从 Windows SharePoint Services 3.0 网站签出文件,则会出现此消息。

    提示: 在描述签出期间文件存储位置的消息中,您可以更改用于处理签出的文件的选项。

返回页首

将文件签入 SharePoint 库

使用此过程签入 Office 程序中打开的文件。也可以从 SharePoint 网站上的库中签入文件。

在以下 2007 Office 版本程序中,请执行下列操作:

Word、Excel 或 PowerPoint

  1. 单击Microsoft Office 按钮 Office 按钮图像 ,单击服务器,然后单击签入

    默认情况下,Word 文档通常在全屏阅读视图中打开。如果情况如此,可能需要先单击“页面视图”以切换到“页面视图”,才能完成此步骤。

  2. 在提示是签入主要版本还是次要版本时,如果进行了轻微更改,则单击“次要版本”,如果进行了重大更改,则单击“主要版本”

  3. “版本备注”框中,键入要对更改所做的任何注释。

    这些注释将作为文件的版本历史记录的一部分出现在 SharePoint 库中,如果您或其他人需要查看有关以前的版本的信息,则这些注释可能很有用。

  4. 如果“签入此版本后,是否将文档保持为签出状态”复选框可用,那么,如果打算继续处理文件,请选中该复选框。

    如果库不跟踪版本,库以相同方式跟踪所有版本,或者您正在签入次要版本,则该选项可用。如果您正在签入主要版本或发布文件,则此选项不可用。

Visio

  1. “文件”菜单上,单击“签入”

  2. 在提示是签入主要版本还是次要版本时,如果进行了轻微更改,则单击“次要版本”,如果进行了重大更改,则单击“主要版本”

  3. “版本备注”框中,键入要对更改所做的任何注释。

    这些注释将作为文件的版本历史记录的一部分出现在 SharePoint 库中,如果您或其他人需要查看有关以前的版本的信息,则这些注释可能很有用。

  4. 如果“签入此版本后,是否将文档保持为签出状态”复选框可用,那么,如果打算继续处理文件,请选中该复选框。

    如果库不跟踪版本,库以相同方式跟踪所有版本,或者您正在签入次要版本,则该选项可用。如果您正在签入主要版本或发布文件,则此选项不可用。

返回页首

更改处理签出文件的位置

此设置将更改您处理下一个签出文件时的位置。如果您当前正在处理某个签出文件,则此过程不会更改其位置。

在以下 2007 Office 版本程序中,请执行下列操作:

Word、Excel 或 PowerPoint

  1. 单击Microsoft Office 按钮 Office 按钮图像 中,,然后单击程序的选项︰ Word 选项Excel 选项PowerPoint 选项

  2. 在出现的对话框中,单击“保存”

  3. “文档管理服务器文件的脱机编辑选项”部分中,请执行下列操作之一:

    • 使用以下过程在硬盘上或网络位置上处理签出的文件:

      1. “将签出文件保存到”下,单击“此计算机的服务器草稿位置”

      2. “服务器草稿位置”框中,键入硬盘上要用于处理签出文件的位置,或者单击“浏览”找到该位置。

    • 若要在 Web 服务器上处理签出的文件,则在“将签出文件保存到”下,单击“Web 服务器”

      如果选择此选项,则您将在存储您的文件的 Web 服务器或网站上处理签出的文件。您不可自定义该特定位置。

  4. 单击“确定”

Visio

  1. “工具”菜单上,单击“选项”

  2. “选项”对话框中,单击“常规”选项卡,然后单击“服务选项”

  3. 在出现的对话框中,单击“脱机编辑选项”

  4. “文档管理服务器文件的脱机编辑选项”部分中,请执行下列操作之一:

    • 使用以下过程在硬盘上或网络位置上处理签出的文件:

      1. 若要在硬盘上处理签出的文件,则在“将签出文件保存到”下,单击“此计算机的服务器草稿位置”

      2. “服务器草稿位置”下,键入硬盘上您要用于处理签出文件的位置,或者单击“浏览”找到该位置。

    • 若要在服务器位置上处理签出的文件,则在“将签出文件保存到”下,单击“Web 服务器”

      如果选择此选项,则您将在存储您的文件的 Web 服务器或网站上处理签出的文件。您不可自定义该特定位置。

  5. 单击“确定”

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×