对 Microsoft Visual C++ 6.0 源代码进行反向工程

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

  1. 自定义 Visual C++。

    如何

    1. 在 Visual C++ 的“工具”菜单上,单击“自定义”

    2. “自定义”对话框中,单击“加载项和宏文件”选项卡。

    3. “加载项和宏文件”列表中,选择“Visio UML 加载项”

      随即显示“Visio UML 加载项”,并在旁边带有一个复选标记。

    4. 单击“关闭”

      随即出现浮动式的五按钮“Visio UML 加载项”工具栏。

    5. 如果希望在每次打开 Visual C++ 时该工具栏都可用,请通过将其拖到工具栏区域来停靠该工具栏。

      提示: 如果希望为每个“Visio UML 加载项”工具栏按钮创建键盘快捷方式,则请在“工具”菜单上单击“自定义”,单击“键盘”选项卡,然后选择“加载项”类别。

      若要进一步指定系统您想要实施反向工程 (MFC、 ATL 或包含) 文件,请单击 “UML 选项”按钮图像 Visio UML 选项按钮。

  2. 生成浏览信息文件。

    如何

    1. 在 Visual C++ 的“项目”菜单上,单击“设置”

    2. “项目设置”对话框中,选择所需的生成配置类型,单击“C/C++”选项卡,然后选择“生成浏览信息”

    3. 单击“浏览信息”选项卡来指定浏览信息文件的名称和位置,选择“生成浏览信息文件”,然后单击“确定”

  3. 在 Visual C++ 中生成项目。

    注意: 如果在对 Visual C++ 项目实施反向工程后对其进行了更改,则必须重新生成项目,然后将项目反向工程为 Visio 程序以查看所做的更改。

  4. 在 Visual c + +,单击工具栏上的Visio UML 加载项反向工程 UML 模型工具栏按钮 “UML 反向工程”按钮图像

    如果 Visual C++ 工作区中存在多个项目,则请选择希望实施反向工程的项目(在“选择项目”对话框中),然后单击“确定”

    如果项目层次结构中有多个浏览文件,则请选择浏览文件(在“选择浏览文件”对话框中),然后单击“确定”

    可能需要花数秒钟的时间从浏览信息文件中提取类信息。提取完成后,Visio“UML 模型图”将随即打开,并包含一个空白静态结构图绘图页,在“模型资源管理器”中会显示树视图,其中填充了反映源代码中的类定义的图标。

  5. “Visio UML 模型图”中,将图标从树视图中拖到绘图页上,以创建表示模型的视图的静态结构图。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×