对项目中的任务进行链接

您可以在项目中链接任何两个任务,以显示它们的关系(也称为任务相关性)。相关性驱动项目日程 - 在您链接任务之后,您对前置任务所做的每项更改均会影响后续任务,继而影响下一个任务,依此类推。

以上说明仅适用于 Microsoft Project 2016、2013 和 2010。

您想做什么?

链接任务

  1. 单击“视图”>“甘特图”。

    “视图”选项卡上的“任务视图”组

  2. 按住 Ctrl 并单击要链接的两个任务(在“任务名称”列中)。

  3. 单击“任务”>“链接任务”。

    “任务”选项卡上“日程”组中的“链接”按钮

若要删除链接,请选择两个链接的任务,然后单击任务>取消链接任务 功能区“任务”选项卡上的“取消链接任务”按钮。

项目将默认创建一个简单的“完成-开始”任务链接,表示在开始第二个任务(后续任务)前需要先完成第一个任务(前置任务)。

如果您是Project Online 订户,也可以选择特定的任务链接到使用下拉框中,从前置任务后续任务列。

  1. 单击“视图”>“甘特图”。

  2. 找到前置任务后续任务列并选择要链接的任务的单元格。

    注︰默认情况下未显示后续列。要显示它,请转到最后一个行、 列,然后选择添加新列。选择后续任务

  3. 在您的所有任务的分层列表中,向上滚动或下查找任务所需,选择它,旁边的复选框,然后单击下拉框以外的任意位置。您正在链接到的任务的任务 ID 将显示在单元格中。

从下拉列表中选择链接是非常有用,如果您想要链接到的任务不接近从链接的任务。

在已链接任务之间插入任务

您可以设置 Project ,以便在链接的任务之间插入新任务时,将新任务自动链接到外围任务。

  1. 单击“文件”>“选项”。

  2. 在“项目选项”对话框中,单击“日程”,然后滚动到“此项目中的计划选项”部分。

  3. 请选中“自动链接插入或移动的任务”复选框。

  4. 插入新的任务。

在网络图中链接任务

  1. 单击“视图”>“网络图”。

    “视频”选项卡上的“网络图”按钮图片。

  2. 将指针移至前置任务框的中心。

  3. 将该行拖动到后续任务框。

    在网络图上链接的两个任务的图片

在日历中链接任务

  1. 单击“视图”>“日历”

    “视图”选项卡,“任务视图”组,“日历”按钮。

  2. 将指针移至前置任务的日历栏上。

  3. 将该行拖动到后续任务的日历栏上。

链接手动计划任务

当您将手动计划任务链接到另一个任务时,Project 将使手动计划任务与该另一个任务相关。

您可以配置 Project,以便手动计划任务在链接到另一个任务时不会移动:

  1. 单击“文件”>“选项”。

  2. 在“项目选项”对话框中,单击“日程”,然后滚动到“此项目中的计划选项”部分。

  3. 取消选中“编辑链接时更新手动计划任务”复选框。

了解更多手动和自动计划任务

更多链接任务的方式

  • 如果您要执行依赖于整个项目顺利完成的任务,请考虑设置主项目

  • 若要突出显示单个任务如何与其他任务相关,请使用任务路径

返回页首

以上说明仅适用于 Microsoft Project 2007。

您要做什么?

关于链接任务

链接项目中的任务后,默认链接类型是完成-开始。但是,完成-开始链接不起作用在各种情形。项目提供了其他类型的任务链接,以便您可以实际建模项目。

链接类型

示例

说明

完成 - 开始 (FS)

完成以开始链接图像

这取决于 (A) 该任务已完成取决于任务 (B) 才能开始。

例如,如果您有两个任务,"挖地基"和"浇注混凝土","挖地基"任务完成之前无法开始"浇注混凝土"任务。

开始 - 开始 (SS)

“开始到开始”链接图像

取决于任务 (B) 才能开始的任务,这取决于 (A) 开始。

这取决于任务开始之后,可以随时开始取决于任务。SS 链接类型不需要两个任务同时开始。

例如,有两个任务“浇注混凝土”和“平整混凝土”,“平整混凝土”任务要在“浇注混凝土”任务开始之后才能开始。

完成 - 完成 (FF)

完成到完成任务链接图像

相关任务 (B) 取决于任务 (A),(A) 完成之后 (B) 才能完成。

这取决于任务完成之后,可以随时完成取决于任务。FF 链接类型不需要同时完成这两项任务。

例如,如果您有两个任务,"增加线路"和"电气检查","检查电气"无法完成任务的"增加线路"任务完成之前。

开始 - 完成 (SF)

“完成到开始”任务链接图像

相关任务 (B) 取决于任务 (A),(A) 开始之后 (B) 才能完成。

这取决于任务开始之后,可以随时完成取决于任务。SF 链接类型不需要取决于任务的完成这取决于的任务的开始。

例如,建筑项目的屋架现场建造。两个项目中的任务是"Truss 传递"和"装配屋顶"。"装配屋顶"任务"Truss 传递"任务开始之后才能完成。

在插入链接任务之间的一个任务时,您可以有新任务自动链接或根本不链接。

  • 要链接的新任务,请单击所需的前面,新任务的任务,然后单击插入菜单上的新任务

    注意: 如果这不起作用,在工具菜单上,单击选项,然后单击日程选项确保已选中自动链接插入或移动的任务复选框。

  • 要添加新任务,而不将其链接,请单击新任务将与同时,出现,然后拖动以在网络图中的空白部分中创建新任务的任务。

使用甘特图视图链接任务

  1. 视图菜单上,单击甘特图

  2. 任务名称字段中,选择要链接,请在您想要将它们链接的顺序中的两个或多个任务。

    • 若要选择不相邻的任务,请按住 CTRL 并单击要链接的任务。

    • 若要选择相邻的任务,按住 SHIFT 并单击要链接的第一个和最后一个任务。

  3. 单击链接任务 按钮图像

    项目将默认创建一个任务完成-开始链接。您可以更改此任务链接到开始-开始、 完成-完成或开始-完成。

使用网络图视图链接任务

  1. 视图菜单上,单击网络图

  2. 将指针放在前置任务框的中心。

  3. 拖动到后续任务框。

使用日历视图链接任务

  1. 在“视图”菜单上,单击“日历”。

  2. 前置任务的日历栏上,将鼠标指针。

  3. 拖动到后续任务的日历栏。

打开或关闭自动链接

默认情况下,当您之间插入任务链接的任务新任务自动链接与周围的任务。例如,如果您有三个任务的完成-开始链接和添加新任务在它们之间,新任务将花费在任务上方和下方它的完成-开始链接。

您可以轻松地将关闭此选项,以便插入新任务不会自动链接它与周围的任务。如果自动链接处于关闭状态,您可以轻松地将其重新打开。

  1. 工具菜单上,单击选项,然后单击日程选项卡。

  2. 若要关闭自动链接,请清除自动链接插入或移动的任务复选框。

    若要打开自动链接,选择自动链接插入或移动的任务复选框。

返回页首

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×