对用户隐藏 VBA 代码

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

如果 Access 数据库包含 Visual Basic for Applications (VBA) 代码, 则可以通过将数据库 保存为 accde 文件格式来隐藏该代码。 将数据库另存为 accde 文件将编译所有 VBA 代码模块、删除所有可编辑的源代码并压缩目标数据库。 VBA 代码保留其功能, 但无法查看或编辑代码。 通常情况下, 数据库将继续正常工作, 您仍然可以更新数据并运行报表。

本文内容

创建 accde 文件

在 accde 文件中更改的功能

修改窗体、报表或模块时出现的问题

将数据库另存为 accde 文件的限制

引用如何处理 accde 文件

创建 accde 文件

使用以下过程创建 accde 文件。 此过程会将原始 .accdb 文件保留为未修改。

  1. 打开数据库, 然后单击 "文件>另存为"。

  2. 在 "另存为" 区域的 "数据库另存为" 下, 选择 "创建 ACCDE ", 然后单击 "另存为"

  3. 在 "另存为" 对话框中, 浏览到要在其中保存 accde 文件的位置。

  4. (可选) 在 "文件名" 框中键入文件的新名称。

  5. 单击“保存”。

    如果你指定的名称的文件已存在, Access 会提示你替换现有文件。 单击"是"覆盖现有的 accde 文件, 或单击 "" 以返回到 "另存为" 对话框, 然后键入新文件名。

Access 将创建 accde 文件, 关闭原始 .accdb 文件, 然后打开 accde 文件。

在 accde 文件中更改的功能

将 Access 数据库另存为 accde 文件不会完全阻止对数据库设计所做的更改。 但是, 无法在 accde 文件中执行以下任务:

  • 修改或创建窗体、报表或模块。

  • 使用 " VBA 引用" 对话框添加、删除或更改对对象库或数据库的引用。

  • 查看或修改 VBA 代码。

  • 导入或导出 Access 窗体、报表或模块。 但是, 可以从 .accdb 数据库导入或导出表、查询和宏。

修改窗体、报表或模块时出现的问题

请确保保留原始 Access 数据库的副本。 如果要在 accde 文件中修改窗体、报表或模块的设计, 必须修改原始 Access 数据库 (.accdb 文件), 然后将其另存为 accde 文件。 如果稍后想要修改窗体、报表或模块的设计, 则将包含表的 Access 数据库另存为 accde 文件可能会导致出现与不同版本的数据协调相关的问题。 因此, 将 Access 数据库另存为 accde 文件最适合用于前端/后端应用程序 的前端数据库。

将数据库另存为 accde 文件的限制

某些限制可防止将 Access 数据库另存为 accde 文件:

  • 您必须具有对 VBA 代码的密码访问权限。

  • 如果 access 数据库引用其他 Access 数据库或加载项, 则必须将引用链中的所有 Access 数据库或加载项保存为 accde 文件。

如果在将数据库另存为 accde 文件之前对其进行加密, 则 accde 文件也将被加密, 并且每次打开该文件时都必须输入密码。 如果您不希望加密 accde 文件, 则必须先解密 .accdb 文件, 然后再将其另存为 accde 文件。 将数据库另存为 accde 文件后, 可以再次加密 .accdb 文件。 使用以下过程解密 .accdb 文件:

  1. 在“文件”选项卡上,单击“信息”,然后单击“解密数据库”。 (注意, 如果您使用的是 Access 2007, 请在 "数据库工具" 选项卡上的 "数据库工具" 组中, 单击 "解密数据库"。

    随即出现“撤消数据库密码”对话框。

  2. 在 "撤消数据库密码" 对话框的 "密码" 框中, 键入数据库密码。

  3. 单击“确定”。

引用如何处理 accde 文件

如果您尝试从Access 数据库 (.accdb) 或从引用另一个 Access 数据库或加载项的Access 加载项 (accda) 创建 accde 文件, 则Access 会显示错误消息, 并且不会让您完成该操作。 若要将引用另一个数据库的数据库另存为 accde 文件, 必须将引用链中的所有数据库保存为 accde 文件, 从第一个引用的数据库开始。 将第一个数据库另存为 accde 文件后, 必须先更新下一个数据库中的引用以指向新的 accde 文件, 然后再将其另存为 accde 文件, 等等。

例如, 假设 Database1 引用 Database2 和 Database2 引用 Database3。 accda。 若要将 Database1 保存为 accde 文件, 请执行下列操作:

  1. 将 Database3 另存为 Database3 accde。

  2. 打开数据库 2 .accdb, 然后将其引用更改为指向名为 Database3 的新文件。

  3. 将 Database2 另存为 Database2。

  4. 打开 Database1, 并将其引用更改为指向名为 Database2 的新文件。

  5. 将 Database1 另存为 Database1。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×