对现有数据库实施反向工程转化为数据库模型

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

使用 Visio Pro for Office 365、 Microsoft Visio 专业版和 Microsoft Visio 高级版中反向工程向导,您可以从现有数据库或 Microsoft Excel 工作簿中创建数据库模型。数据库模型以图形方式显示数据库的结构,以便您可以查看如何数据库元素,例如表和视图,相互而不显示实际数据。这可以简化创建新数据库或了解现有的结构。

本文内容

在何处找到数据库 Visio Pro for Office 365 的建模功能?

查看反向工程向导的提取

准备启动向导

现有数据库实施反向工程

在何处找到数据库 Visio Pro for Office 365 的建模功能?

Visio 加载项的数据库建模允许您从现有数据库创建数据库模型。此加载项仅适用于 Visio Pro for Office 365。如果您不确定您正在使用哪个版本的 Visio,单击文件>帐户>有关 Visio。请参阅Visio Pro for Office 365若要了解有关订阅的 Visio 版本。

下载 Visio 加载项中的数据库建模

  1. 请从此处下载该加载项。

  2. 选择您下载页面上的语言,然后单击下载

  3. 选择与您的 Visio Pro for Office 365 版本相匹配的 64 位 (x64) 或 32 位 (x86) 版本。您还可以选择要下载 PDF 文件包含安装说明进行操作。单击下一步将文件下载到您的计算机或设备。

  4. 如果您有打开的程序,请在下一步前关闭 Visio。

  5. 找到您下载的 MSI 安装文件并双击它以开始安装。单击安装,出现提示时,单击安装屏幕以完成安装过程之间。

  6. 数据库模型图现已提供用于 Visio Pro for Office 365 订阅计划。

查看反向工程向导的提取

向导可以提取的架构定义信息取决于多种因素,如数据库管理系统 (DBMS) 和 ODBC 驱动程序的功能。向导中显示的所有元素,它可以提取并允许您选择所需的。例如,您可能感兴趣仅 5 10 个表和 2 外出时的 4 的视图。

运行时您可以选择让它自动向导将创建此外列出进行反向工程的项表和视图窗口中的绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

范围内它们都可以从目标 DBMS,您可以提取下列各项:

  • 表格

  • 视图

  • 主键

  • 外键

  • 索引

  • 触发器 (包括代码)

  • 检查子句 (包括代码)

  • 存储的过程 (包括代码)

准备启动向导

如果您是反向工程启动向导之前的 Excel 工作簿,您需要打开的工作簿和命名包含列标题的单元格组 (或区域)。如果您想要使用多个工作表,只需名称列中每个工作表的单元格组。这些范围视为向导中的表。有关如何命名单元格区域的详细信息,请参阅 Microsoft Office Excel 帮助。

为获得最佳结果,为您想要实施反向工程运行反向工程向导之前的目标数据库中设置默认驱动程序。这样可以确保该向导将本机数据类型正确映射,并在代码窗口中正确显示该向导提取的所有代码。

  1. 单击文件选项卡,单击新建,单击模板,单击软件和数据库,并双击数据库模型图

  2. 数据库选项卡上的管理组中,单击数据库驱动程序

  3. 驱动程序选项卡上选择 DBMS Visio 提供的驱动程序。例如,如果您要设计 Access 数据库将选择 Microsoft Access。

    如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

  4. 单击“设置”。

  5. ODBC 驱动程序选项卡上,选中提供商驱动程序复选框为您 DBMA。例如,如果您要设计 Access 数据库将选择Microsoft Access 驱动程序 (*.mdb,您可能正在)复选框。

  6. 单击每个对话框中的确定

供应商提供 32 位 ODBC 驱动程序必须从 ODBC 数据访问包大于版本 2.0 和 ODBC 级别 1 符合或更高版本。供应商提供的 OLE DB 提供程序必须符合的 OLE DB 1.0 版或更高版本的说明。

返回页首

现有数据库实施反向工程

  1. 在数据库模型图,在数据库选项卡上,单击反向工程

  2. 在反向工程向导的第一个屏幕上,请执行下列操作:

    1. 选择您的数据库管理系统 (DBMS) 的 Microsoft Visio 数据库驱动程序。如果您尚未 Visio 数据库驱动程序与特定的 ODBC 数据源关联,单击设置来执行此操作现在。

      如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

    2. 选择您正在更新的数据库的数据源。如果尚未创建现有数据库的数据源,单击新建来立即执行此操作。

      当您创建新的源时,其名称将添加到数据源列表中。

    3. 当您对设置感到满意时,请单击下一步

    4. 按照任何特定驱动程序对话框中的说明进行操作。例如,在连接的数据源对话框中,键入用户名和密码,,然后单击确定。如果您的数据源不受密码保护,请单击确定

  3. 选择要从中提取的信息类型对应的复选框,然后单击下一步

    某些项目可能会灰显,因为不是所有系统都支持所有类型的向导可以提取的元素。

  4. 选择您想要提取,或单击选择所有提取的表和视图,如果有) 对应的复选框,然后单击下一步

    如果您进行反向工程 Excel 工作表,并看不到此列表中的任何内容,则可能需要包含您的电子表格中的列标题的单元格区域命名。

  5. 如果您在步骤 5 中选择存储过程复选框,选择要从中提取的过程,或单击全选提取所有,然后单击下一步

  6. 选择是否希望反向工程的项目自动添加到当前页面。

    您可以选择向导将自动添加到列表反向工程表和视图窗口中的项目中创建绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

  7. 检查您的选择,以验证所提取的信息,然后单击完成

如果您使用通用 ODBC 驱动程序,您可能会收到指示反向工程的信息可能不完整的错误。在大多数情况下这不是问题-只需单击确定,然后继续按照向导。

向导提取选定的信息和输出窗口中显示有关提取过程的笔记。

返回页首

Visio 2016 不支持反向工程向导

反向工程向导不可用 Visio 专业版 2016年或 Visio 标准版 2016年中。为了使用数据库建模功能,请考虑升级到 Visio Pro for Office 365。

尝试使用新版本的 Outlook

Visio 2013 不支持反向工程向导

反向工程向导不可用 Visio 专业版 2013年或 Visio 标准版 2013年中。为了使用数据库建模功能,请考虑升级到 Visio Pro for Office 365。

尝试使用新版本的 Outlook

本文内容

查看反向工程向导的提取

准备启动向导

现有数据库实施反向工程

查看反向工程向导的提取

向导可以提取的架构定义信息取决于多种因素,如数据库管理系统 (DBMS) 和 ODBC 驱动程序的功能。向导中显示的所有元素,它可以提取并允许您选择所需的。例如,您可能感兴趣仅 5 10 个表和 2 外出时的 4 的视图。

运行时您可以选择让它自动向导将创建此外列出进行反向工程的项表和视图窗口中的绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

范围内它们都可以从目标 DBMS,您可以提取下列各项:

  • 表格

  • 视图

  • 主键

  • 外键

  • 索引

  • 触发器 (包括代码)

  • 检查子句 (包括代码)

  • 存储的过程 (包括代码)

返回页首

准备启动向导

如果您是反向工程启动向导之前的 Excel 工作簿,您需要打开的工作簿和命名包含列标题的单元格组 (或区域)。如果您想要使用多个工作表,只需名称列中每个工作表的单元格组。这些范围视为向导中的表。有关如何命名单元格区域的详细信息,请参阅 Microsoft Office Excel 帮助。

为获得最佳结果,为您想要实施反向工程运行反向工程向导之前的目标数据库中设置默认驱动程序。这样可以确保该向导将本机数据类型正确映射,并在代码窗口中正确显示该向导提取的所有代码。

  1. 单击文件选项卡,单击新建,单击软件和数据库,然后双击数据库模型图

  2. 数据库选项卡上的管理组中,单击数据库驱动程序

  3. 驱动程序选项卡上选择 DBMS Visio 提供的驱动程序。例如,如果您要设计 Access 数据库将选择 Microsoft Access。

    如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

  4. 单击“设置”。

  5. ODBC 驱动程序选项卡上,选中提供商驱动程序复选框为您 DBMA。例如,如果您要设计 Access 数据库将选择Microsoft Access 驱动程序 (*.mdb)复选框。

  6. 单击每个对话框中的确定

供应商提供 32 位 ODBC 驱动程序必须从 ODBC 数据访问包大于版本 2.0 和 ODBC 级别 1 符合或更高版本。供应商提供的 OLE DB 提供程序必须符合的 OLE DB 1.0 版或更高版本的说明。

返回页首

现有数据库实施反向工程

  1. 在数据库模型图,在数据库选项卡上,单击反向工程

  2. 在反向工程向导的第一个屏幕上,请执行下列操作:

    1. 选择您的数据库管理系统 (DBMS) 的 Microsoft Visio 数据库驱动程序。如果您尚未 Visio 数据库驱动程序与特定的 ODBC 数据源关联,单击设置来执行此操作现在。

      如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

    2. 选择您正在更新的数据库的数据源。如果尚未创建现有数据库的数据源,单击新建来立即执行此操作。

      当您创建新的源时,其名称将添加到数据源列表中。

    3. 当您对设置感到满意时,请单击下一步

    4. 按照任何特定驱动程序对话框中的说明进行操作。例如,在连接的数据源对话框中,键入用户名和密码,,然后单击确定。如果您的数据源不受密码保护,请单击确定

  3. 选择要从中提取的信息类型对应的复选框,然后单击下一步

    某些项目可能会灰显,因为不是所有系统都支持所有类型的向导可以提取的元素。

  4. 选择您想要提取,或单击选择所有提取的表和视图,如果有) 对应的复选框,然后单击下一步

    如果您进行反向工程 Excel 工作表,并看不到此列表中的任何内容,则可能需要包含您的电子表格中的列标题的单元格区域命名。

  5. 如果您在步骤 5 中选择存储过程复选框,选择要从中提取的过程,或单击全选提取所有,然后单击下一步

  6. 选择是否希望反向工程的项目自动添加到当前页面。

    您可以选择向导将自动添加到列表反向工程表和视图窗口中的项目中创建绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

  7. 检查您的选择,以验证所提取的信息,然后单击完成

如果您使用通用 ODBC 驱动程序,您可能会收到指示反向工程的信息可能不完整的错误。在大多数情况下这不是问题-只需单击确定,然后继续按照向导。

向导提取选定的信息和输出窗口中显示有关提取过程的笔记。

返回页首

本文内容

查看反向工程向导的提取

准备启动向导

现有数据库实施反向工程

找不到该数据库建模功能?

您的 Visio 版本未包含您要查找的功能很可能是。要了解你拥有的是哪个版本的 Visio,请单击帮助菜单上的关于 Microsoft Office Visio 。在对话框中的最上面一行是文本的版的名称。

  • Microsoft Office Visio 标准不包括数据库模型图模板。

  • Microsoft Office Visio 专业版 (即,使用现有数据库以在 Visio 中创建模型) 在数据库模型图模板支持反向工程功能,但它不支持转发工程 (即,使用 Visio 数据库模型若要生成 SQL 代码)。

  • 您可以找到数据库的完整套件建模功能,包括反向工程和转发工程,企业设计师 Visio 中。企业设计师 Visio 将包含在 MSDN 高级版订阅,这是可用于 Visual Studio 专业版和 Visual Studio 工作组系统基于角色的版本。

查看反向工程向导的提取

向导可以提取的架构定义信息取决于多种因素,如数据库管理系统 (DBMS) 和 ODBC 驱动程序的功能。该向导将显示所有的元素,它可以提取并允许您选择所需的。如您可能仅有兴趣 5 10 个表和 2 外出时的 4 视图。

运行时您可以选择让它自动向导将创建此外列出进行反向工程的项表和视图窗口中的绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

范围内它们都可以从目标 DBMS,您可以提取下列各项:

  • 表格

  • 视图

  • 主键

  • 外键

  • 索引

  • 触发器 (包括代码)

  • 检查子句 (包括代码)

  • 存储的过程 (包括代码)

返回页首

准备启动向导

如果您是反向工程启动向导之前的 Excel 工作簿,您需要打开的工作簿和命名包含列标题的单元格组 (或区域)。如果您想要使用多个工作表,只需名称列中每个工作表的单元格组。这些范围视为向导中的表。有关如何指定单元格区域的详细信息,请参阅主题定义已命名的单元格引用或区域中您的 Microsoft Office Excel 帮助。

为获得最佳结果,为您想要实施反向工程运行反向工程向导之前的目标数据库中设置默认驱动程序。这样可以确保该向导将本机数据类型正确映射,并在代码窗口中正确显示该向导提取的所有代码。

  1. 数据库菜单上,指向选项,然后单击驱动程序

  2. 驱动程序选项卡上选择 DBMS Visio 提供的驱动程序。例如,如果您要设计,您可以选择 Microsoft Access 数据库。

    注意: 如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

  3. 单击“设置”。

  4. ODBC 驱动程序选项卡上,选中提供商驱动程序复选框为您 DBMA。例如,如果您要设计 Access 数据库将选择Microsoft Access 驱动程序 (*.mdb)复选框。

  5. 单击每个对话框中的确定

注意: 供应商提供 32 位 ODBC 驱动程序必须从 ODBC 数据访问包大于版本 2.0 和 ODBC 级别 1 符合或更高版本。供应商提供的 OLE DB 提供程序必须符合的 OLE DB 1.0 版或更高版本的说明。

返回页首

现有数据库实施反向工程

  1. 文件菜单上,指向新建软件和数据库,指向,然后单击数据库模型图

  2. 数据库菜单上,单击反向工程

  3. 在反向工程向导的第一个屏幕上,请执行下列操作:

    • 选择您的数据库管理系统 (DBMS) 的 Microsoft Office Visio 数据库驱动程序。如果您尚未 Visio 数据库驱动程序与特定的 ODBC 数据源关联,单击设置来执行此操作现在。

      注意: 如果您是反向工程 Excel 工作表,选择 ODBC 通用驱动程序。

    • 选择您正在更新的数据库的数据源。如果尚未创建现有数据库的数据源,单击新建来立即执行此操作。

      当您创建新的源时,其名称将添加到数据源列表中。

    • 当您对设置感到满意时,请单击下一步

    • 按照任何特定驱动程序对话框中的说明进行操作。例如,在连接的数据源对话框中,键入用户名和密码,,然后单击确定。如果您的数据源不受密码保护,请单击确定

  4. 选择要从中提取的信息类型对应的复选框,然后单击下一步

    注意: 某些项目可能会灰显,因为不是所有 DBMS 都支持所有类型的向导可以提取的元素。

  5. 选择您想要提取,或单击选择所有提取的表和视图,如果有) 对应的复选框,然后单击下一步

    注意: 如果您进行反向工程 Excel 工作表,并看不到此列表中的任何内容,则可能需要包含您的电子表格中的列标题的单元格区域命名。

  6. 如果您在步骤 5 中选择存储过程复选框,选择要从中提取的过程,或单击全选提取所有,然后单击下一步

  7. 选择是否希望反向工程的项目自动添加到当前页面。

    注意: 您可以选择向导将自动添加到列表反向工程表和视图窗口中的项目中创建绘图。如果您决定不会自动创建绘图,您可以将项目从表和视图窗口中拖动到绘图页上,以便手动组合数据库模型。

  8. 检查您的选择,以验证所提取的信息,然后单击完成

注意: 如果您使用通用 ODBC 驱动程序,您可能会收到指示反向工程的信息可能不完整的错误。在大多数情况下这不是问题-只需单击确定,然后继续按照向导。

向导提取选定的信息和输出窗口中显示有关提取过程的笔记。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×