对宏项目进行数字签名

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

本文介绍如何使用 证书 对 宏项目 进行数字签名。如果您还没有数字证书,必须获取一个。要在您自己的计算机上测试宏项目,可以使用 Selfcert.exe 工具创建自己的自签名证书。

本文内容

获取数字证书以用于签名

宏项目和 Microsoft Office

创建自签名证书

对 Excel、PowerPoint、Publisher、Visio 或 Word 中的宏项目进行数字签名

获取数字证书以用于签名

您可以从商业证书颁发机构 (CA) 那里获得数字证书,也可以从内部安全管理员或信息技术 (IT) 专业人员那里获得数字证书。

若要了解有关为 Microsoft 产品提供服务的证书颁发机构的详细信息,请参阅Microsoft 根证书计划成员的列表。

返回页首

宏项目和 Microsoft Office

由于您创建的数字证书不是由正式受信任的证书颁发机构,使用此类证书签名的宏项目称为自签名的项目。Microsoft Office 信任自签名的证书仅在已添加到受信任的根证书颁发的证书-当前用户的文件夹存储自签名证书的计算机上。

若要了解如何创建自签名证书,请参阅下面一节。

创建自签名证书

Windows7、Windows Vista 或 Windows XP

  1. 单击“开始”,指向“所有程序”,单击“Microsoft Office”,单击“Microsoft Office 工具”,然后单击“VBA 项目的数字证书”
    此时将出现“创建数字证书”对话框。

  2. “您的证书名称”框中,为证书键入一个描述性名称。

  3. 单击“确定”。

  4. 在出现“SelfCert 成功”消息时,单击“确定”

“创建数字证书”对话框

使用 Internet Explorer 查看证书

要查看个人证书存储中的证书,请执行下列操作:

  1. 打开 Internet Explorer。

  2. “工具”菜单上,单击“Internet 选项”,然后单击“内容”选项卡。

  3. 单击“证书”,然后单击“个人”选项卡。

返回页首

对 Excel、 PowerPoint、 Publisher、 Visio、 Outlook 或 Word 中的宏项目进行数字签名

  1. 打开包含要签名的宏项目的文件。

  2. “开发工具”选项卡上的“代码”组中,单击“Visual Basic”

    注意: 如果“开发工具”选项卡不可用:单击“文件”选项卡。单击“选项”。单击“自定义功能区”。在“自定义功能区”列表中,选中“开发工具”,然后单击“确定”

  3. 在 Visual Basic 中的“工具”菜单上,单击“数字签名”

  4. 将出现“数字签名”对话框。

  5. 选择一个证书,然后单击“确定”

    注意: 如果尚未选择数字证书,或者要使用其他证书,单击“选择”。选择一个证书,然后单击“确定”

    注释: 

    • 因此,建议仅您的解决方案已经过测试并准备进行分发时对宏进行签名:以任何方式更改已签名的宏项目中的代码时,将删除它的数字签名。但是,如果您具有以前用于登录计算机上项目的有效数字证书,则当您保存宏项目时会自动对其重新进行签名。

    • 若要避免您的解决方案用户因无意中修改宏项目而使签名无效,请先锁定宏项目,然后再对其进行签名。数字签名意味着您保证该项目在经过签名后未被篡改。您的数字签名并不能证明项目是由您撰写的。因此,锁定您的宏项目不会阻止其他用户将此数字签名替换为另一个签名。企业管理员可以对模板和加载项重新签名,以便他们控制用户在其计算机上运行的项目。

    • 如果创建将代码添加到宏项目的加载项,则代码应当确定该项目是否已经过数字签名,并在用户继续操作之前告知用户更改已签名项目的后果。

    • 对宏进行数字签名时,务必获取时间戳,以便其他用户验证您的签名,看用于签名的证书是否已过期,或是否在签名后已撤消。如果您对宏进行签名时未使用时间戳,则签名只在证书的有效期内保持有效。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×