如何对无法登录到 Office 365、Azure 或 Intune 的非浏览器应用进行故障排除

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问题

当用户尝试将非浏览器应用程序从特定客户端计算机的 microsoft 云服务 (如 Office 365、microsoft Azure 或 microsoft Intune) 进行身份验证时, 可能会出现以下一个或多个问题:

  • 管理员无法使用以下管理工具对云服务进行身份验证:

    -Microsoft Azure Active Directory 同步工具 (在目录同步服务器上)

    -用于 Windows PowerShell 的 Microsoft Azure Active Directory 模块 (在安装它的计算机上)
     

  • 用户无法使用以下胖客户端应用程序对云服务进行身份验证

    : -Microsoft Outlook

    -Microsoft Lync 2010

    -Microsoft Office 专业增强

    版 -Microsoft Office 应用程序

当用户尝试使用同一台计算机上的 web 浏览器访问云服务门户时, 用户可能遇到以下症状之一:

  • Internet Explorer 无法显示该网页。

  • 加载网页之前, 系统会提示用户输入凭据。

当用户使用相同的用户帐户信息访问其他计算机上的云服务时, 他们不会遇到这些症状。 用户可以成功访问其他计算机上的云服务。

原因

通常情况下, 此问题在特定客户端计算机上或在一组客户端计算机上发生。 只有当公司没有为云服务设置任何计算机时, 所有客户端计算机都可能会出现此问题。 如果未正确实现云服务客户端设置, 则非浏览器应用身份验证可能不会完全正常运行。

以下客户端计算机方案可能会导致此问题:

  • 与云服务的网络连接受到限制。

  • 防火墙、代理服务器或两者都需要本地身份验证。

  • 不满足非浏览器应用的先决条件。

  • 安装了早期版本的 Microsoft Online Services 登录助手。

  • 未为云服务设置非浏览器应用。

在继续解决此问题之前, 请确保满足以下所有条件:

解决方案

若要解决此问题, 请使用以下一种或多种方法, 具体取决于问题的可能原因。

解决方案 1: 网络连接受限

使用浏览器并尝试访问http://www.msn.com。 如果无法访问此网站, 请解决网络连接问题。

  1. 在命令提示符处, 使用ipconfigping工具对 IP 连接进行故障排除。 有关如何执行此操作的详细信息, 请参阅以下 Microsoft 知识库文章:

        如何解决基本 tcp/ip 问题

  2. 在命令提示符处, 运行nslookup www.msn.com以确定 DNS 是否正在解析 Internet 服务器名称。

  3. 如果本地网络中使用了代理服务器, 请确保 "Internet 选项" 中的代理服务器设置反映相应的代理服务器。

  4. 如果在网络边界上安装了 Forefront 威胁管理网关 (TMG) 防火墙, 并且防火墙要求客户端身份验证, 则你可能需要在客户端设备上安装和配置 Forefront TMG 客户端程序才能访问 Internet。 有关帮助, 请与你的云服务管理员联系。

解决方案 2: 防火墙或代理服务器需要其他身份验证

若要解决此问题, 请从身份验证代理为 Office 365 url 和应用程序配置例外。 例如, 如果您运行的是 Microsoft Internet 安全和加速服务器 (ISA) 2006, 请创建满足以下条件的 "允许" 规则:

  • 允许到以下目标的出站连接: * microsoftonline.com

  • 允许到以下目标的出站连接: * microsoftonline-p.com

  • 允许到以下目标的出站连接: * sharepoint.com

  • 允许到以下目标的出站连接: * outlook.com

  • 允许到以下目标的出站连接: * lync.com

  • 允许到以下目标的出站连接: osub.microsoft.com

  • 端口80/443

  • 协议 TCP 和 HTTPS

  • 规则必须应用于所有用户。

  • HTTPS/SSL 超时设置为8小时

解决方案 3: 未满足非浏览器应用程序的先决条件, 或者 Microsoft Online Services 登录助手已过期

如果某些操作系统或非浏览器应用未使用适当的先决条件进行更新, 他们可能无法访问预期的服务。 请确保计算机和应用程序满足云服务的系统要求。 有关 Office 365 系统要求的详细信息, 请单击此处:

    Office 365 系统要求

确保你的计算机适合 office 365 的最简单方法是运行 office 365 桌面设置工具。 请按照以下步骤进行安装:

  1. 在 web 浏览器中, 通过浏览找到https://portal.office.com的 "登录", 然后单击右窗格中的 "下载"。

  2. 滚动到页面底部。 在 "设置和配置你的 Office 桌面应用" 下, 单击 "设置", 然后在系统提示你运行 office 365 桌面设置工具时进行确认。

或者, 你可以从以下 Microsoft 网站下载并手动安装所需的更新和程序包:

手动安装 Office 365 桌面更新

解决方案 4: 未针对云服务设置非浏览器应用

如果尚未为某些非浏览器应用创建配置文件, 这些应用程序将无法正确访问预期服务。

确保你的计算机适合 office 365 的最简单方法是运行 office 365 桌面设置工具。 请按照以下步骤进行安装:

  1. 在 web 浏览器中, 通过浏览找到https://portal.office.com的 "登录", 然后单击右窗格中的 "下载"。

  2. 滚动到页面底部。 在 "设置和配置你的 Office 桌面应用" 下, 单击 "设置", 然后在系统提示你运行 office 365 桌面设置工具时进行确认。

或者, 你可以从以下 Microsoft 网站下载并手动安装所需的更新和程序包:

手动安装 Office 365 桌面更新

或者, 您可以手动设置应用程序配置文件。

解决方案 5: 无法使用 office 2016 或 office 2013 通过 Surface Pro 3 上的新式验证进行登录

此问题已在 Windows 10 版本1511中修复。 若要解决此问题, 请从 windows 更新安装 windows 10 的所有累积更新。 或者-最低-安装适用于 Windows 10 的累积更新:

    Windows 10 版本1511的累积更新: 2015 年11月10日


如果无法安装此更新, 请执行以下步骤。

重要提示:请仔细按照本部分中的步骤操作。 如果注册表修改错误,可能会出现严重问题。 修改之前, 请按照以下步骤备份注册表, 以便在发生问题时 https://support.microsoft.com/en-us/help/322756 还原。

  1. 在 Windows 10 中, 在任务栏上的 "搜索" 框中, 键入 regedit, 然后按 enter 打开注册表编辑器。

  2. 根据您所运行的 Office 版本, 执行下列操作之一:

  • 如果您有 Office 2016, 请删除以下注册表项:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity\Identities

  • 如果您有 Office 2013, 请删除以下注册表项:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Common\Identity\Identities

详细信息

有关特定非浏览器应用的问题的详细信息, 请参阅以下 Microsoft 知识库文章:

是否仍需要帮助? 转到Microsoft 社区Azure Active Directory 论坛网站。

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