在 Visio 中显示形状的大小或尺寸

在 Visio 中显示形状的大小或尺寸

若要查看形状的尺寸或度量,请将其选中,然后在 "形状" 窗口下方的状态栏中查看。 宽度、高度和角度将会自动列出。 或者,使用本文中介绍的其他方法之一查看维度。

若要了解如何使用 "大小" & 位置"窗口更改形状的尺寸或角度,请参阅使用" 调整大小 "& 位置窗口指定尺寸

在图表页面上显示度量值

如果您有 Visio Standard,则可以使用链接到形状的 "高度" 和 "宽度" 属性的字段来显示形状的尺寸。 有关使用字段的详细信息,请参阅使用字段使显示的信息保持最新

如果您有 Visio Professional,则可以使用尺寸形状显示大小。 尺寸形状显示其粘附到的形状的大小,并在您调整原始形状时自动更新。

"维度" 形状包含在某些模板中,您可以在任何模板中打开标注形式的模具。

打开尺寸标注模具

  1. 在“形状”窗口中,单击“更多形状”。

  2. 指向 "其他Visio 方案",然后单击 "标注尺寸-结构" 或 "标注形式-工程"。

  3. 将尺寸形状拖动到要测量的形状,然后将尺寸形状的端点粘附到要测量的点。

注意: 若要更改度量单位,请右键单击尺寸形状,然后单击快捷菜单上的 "精度 & 单位"。

带显示测量值的尺寸形状的隔间形状。

示例

如果你有 Visio Professional,以下过程将指导你完成如何使用维度形状的示例。

使用维度形状(示例)

  1. 单击 "文件" 选项卡,单击 "新建",单击 "类别",单击 "地图和平面布置图",然后双击 "开始计划"。

  2. 单击 "菜园附件" 模具的标题栏,然后将 "混凝土通道" 形状拖到绘图页上。

    您可能需要滚动 "模具" 下的列表,才能找到该模具或其他模具。

  3. 拖动 "混凝土通道" 形状上的图柄以放大它。

  4. 单击 "尺寸度量-结构" 模具的标题栏,然后将水平形状拖到 "通道" 形状上方的绘图页。

    如果在列表中看不到此模具,请按照上述过程中的说明打开标注标注模具

  5. 将 "水平尺寸" 形状右侧的形状手柄拖到通道形状的右边缘,直到出现绿色框,指示形状已粘附在一起。

  6. 水平形状左侧的形状手柄拖动到通道形状的左边缘。

  7. 将尺寸形状右侧的黄色菱形( 控制手柄图像 - 黄色菱形 )拖动到通道上方的某个位置,以便尺寸线不会遮住通道形状。

您要做什么?

查看形状的整体宽度、高度和角度

显示形状内形状的宽度、高度和角度

显示形状旁边的 "宽度"、"高度" 和 "角度"

显示形状的各个部分的度量

查看形状的整体宽度、高度和角度

  1. 选择绘图中的形状。

  2. 查看状态栏,查看形状的宽度、高度和角度。

显示形状内形状的宽度、高度和角度

如果只想显示几个形状的整体度量值,则可以向具有文本框的形状快速添加度量字段。

  1. 单击要向其中添加字段的形状。

  2. 在 "插入" 选项卡上的 "文本" 组中,单击 ""。

  3. 在 "" 对话框中的 "类别" 列表中,单击 "几何图形"。

  4. 在 "域名" 列表中,单击要显示的度量值。

    提示: 若要向数字添加设备(如英尺),请单击 "数据格式",然后在 "数据格式" 对话框中选择 "新单位"。

  5. 单击“确定”。

  6. 对要添加的每个字段重复这些步骤。

    提示: 若要在其之间显示 "高度" 和 "宽度",请插入形状文本框中的第一个字段,然后键入空格,键入 " x",键入另一个空格,然后插入第二个字段。

返回页首

显示形状旁边的 "宽度"、"高度" 和 "角度"

注意: 数据图形功能仅在 Visio Professional 和 Premium 版本中可用。

数据图形提供了一种快速方式,可显示形状的高度、宽度和角度以及其他形状数据。 本文介绍如何显示度量值。

  1. 在 "数据" 选项卡上的 "显示数据" 组中,单击 "数据图形"。

  2. 单击 "新建数据图形"。

  3. 在 "新建数据图形" 对话框中,单击 "新建项目"。

  4. 在 "新建项目" 对话框中的 "数据字段" 列表中,单击 "其他字段"。

  5. 在 "" 对话框中的 "类别" 列表中,单击 "几何图形"。

  6. 在 "域名" 列表中,单击要显示的度量值,然后单击"确定"

  7. 在 "新建项目" 对话框中的 "显示为" 列表中,单击 "文本"。

  8. 在 "详细信息" 下的 "标签" 框中,键入度量值的名称(如 Width 或 Height),然后单击"确定"

  9. 对要显示的每个度量值重复这些步骤。

  10. 在 "新建数据图形" 对话框中,单击"确定"

    新数据图形将出现在数据图形库中的 "可用数据图形" 下。

  11. 选择绘图中要显示度量的形状,然后在 "数据图形" 库中,单击创建的数据图形。

新的数据图形将应用于所选的形状。

返回页首

显示形状的各个部分的度量

带显示测量值的尺寸形状的隔间形状。

注意: 只有在 Visio Professional 和 Premium 版本中,维度形状才可用。

可以使用尺寸形状测量其他形状。 将尺寸形状粘附到要测量的形状时,该形状的度量将显示在尺寸形状上。 调整原始形状的大小时,将自动更新度量单位。

有许多维度形状,每个形状都测量一个不同的方位。 你可以通过查看模具(如 "标注尺寸-工程" 模具)来充分了解不同维度形状可以测量的内容。

为了让你了解维度形状的工作方式,以下过程演示了如何使用其中一个维度形状来测量 home 计划中的通道。

  1. 单击 "文件" 选项卡,单击 "新建",单击 "地图和平面布置图",然后双击 "开始计划"。

  2. 单击 "菜园附件" 模具的标题栏,然后将 "混凝土通道" 形状拖到绘图页上。

  3. 单击 "尺寸度量-结构" 模具的标题栏,然后将 "水平尺寸" 形状拖到 "通道" 形状上方的绘图页上。

  4. 将 "水平尺寸" 形状右侧的形状手柄拖到通道形状的右边缘,直到出现红色框,指示形状已粘附在一起。

  5. 水平形状左侧的形状手柄拖动到通道形状的左边缘。

  6. 将尺寸形状右侧的黄色菱形拖动到通道上方的某个位置,以便尺寸线不会遮住通道形状。

注意: 若要更改度量单位,请右键单击尺寸形状,然后单击快捷菜单上的 "精度 & 单位"。

返回页首

您要做什么?

查看形状的整体宽度、高度和角度

查看形状的区域或周长度量值

显示形状内形状的宽度、高度和角度

显示形状旁边的 "宽度"、"高度" 和 "角度"

显示形状的各个部分的度量

查看形状的整体宽度、高度和角度

显示所选形状的宽度、高度和角度的状态栏。

  1. 选择绘图中的形状。

  2. 查看状态栏,查看形状的宽度、高度和角度。

查看形状的区域或周长度量值

显示所选形状的度量的“面积和周长”对话框。

注意: "形状区域" 和 "周长" 对话框仅在 Microsoft Office Visio Professional 中可用。

  1. 选择绘图中的形状。

  2. 在 "工具" 菜单上,单击 "加载项",单击 "其他Visio 方案",然后单击 "形状区域和周长"。

    "形状区域" 和 "周长" 对话框随即打开,并显示形状的测量值。

  3. 若要查看不同单位的度量值,请在 "总区域" 框或 "总周长" 框中选择所需的单位。

返回页首

显示形状内形状的宽度、高度和角度

形状的高度和宽度显示在文本框中的矩形。

如果只想显示几个形状的整体度量值,可以快速将度量字段添加到形状的文本框。 如果您有 Office Visio 专业版 2007 ,并且想要显示多个形状的度量值,则可以使用数据图形来节省时间,如 "显示形状旁边的形状的宽度、高度和角度" 部分所述。

  1. 单击要向其中添加字段的形状。

  2. 在“插入”菜单上单击“”。

  3. 在 "" 对话框中的 "类别" 列表中,单击 "几何图形"。

    显示可输入形状的文本框中的字段的“字段”对话框。

  4. 在 "域名" 列表中,单击要显示的度量值。

    提示: 若要向数字添加设备(如英尺),请单击 "数据格式",然后在 "数据格式" 对话框中选择 "新单位"。

  5. 单击“确定”。

  6. 对要添加的每个字段重复步骤2到步骤5。

    提示: 若要在其之间显示 "高度" 和 "宽度",请插入形状文本框中的第一个字段,然后键入空格,键入 " x",键入另一个空格,然后插入第二个字段。

注意: 调整形状大小时,字段中的度量将自动更新。

返回页首

显示形状旁边的 "宽度"、"高度" 和 "角度"

在数据图形中显示宽度、高度和角度的灌木形状。

注意: 数据图形功能仅在 Office Visio 专业版 2007 中可用。

数据图形提供了一种快速方式,可显示形状的高度、宽度和角度以及其他形状数据。 本文介绍如何显示度量值。 有关如何充分利用数据图形的信息,请参阅使用数据图形增强数据

  1. 在 "数据" 菜单上,单击 "显示形状上的数据"。

  2. 在 "数据图形" 任务窗格中的 "新建数据图形" 下,单击 "新建数据图形"。

  3. 在 "新建数据图形" 对话框中,单击 "新建项目",然后单击 "文本"。

    “数据图形”任务窗格和“新建数据图形”对话框。

    1. "数据图形" 任务窗格

    2. "新建数据图形" 命令

    3. 包含 "新建项目" 框和 "文本" 命令的 "新建数据图形" 对话框

  4. 在 "新建文本" 对话框中的 "显示" 下的 "数据字段" 列表中,单击 "其他字段"。

  5. 在 "" 对话框中的 "类别" 列表中,单击 "几何图形"。

  6. 在 "域名" 列表中,单击要显示的度量值,然后单击"确定"

    显示可键入数据图形中的字段的“字段”对话框。

  7. 在 "新建文本" 对话框中的 "详细信息" 下的 "标签" 框中,键入度量值的名称(如 "宽度"、"高度" 或 "角度"),然后单击"确定"

  8. 对要显示的每个度量值重复步骤3到步骤7。

  9. 在 "新建数据图形" 对话框中,单击"确定"

    新的数据图形将出现在 "数据图形" 任务窗格中的 "应用数据图形" 下。

  10. 选择绘图中要显示度量的形状,然后在 "数据图形" 任务窗格中,单击创建的数据图形。

新的数据图形将应用于所选的形状。

应用了新创建的数据图形的三个树形状。

返回页首

显示形状的各个部分的度量

带显示测量值的尺寸形状的隔间形状。

注意: 尺寸形状仅在 Office Visio 专业版 2007 中可用。

可以使用尺寸形状测量其他形状。 将尺寸形状粘附到要测量的形状时,该形状的度量将显示在尺寸形状上。 调整原始形状的大小时,将自动更新度量单位。

有许多维度形状,每个形状都测量一个不同的方位。 你可以通过查看模具来了解不同维度形状可以衡量哪些内容。 下图显示了 "尺寸度量-工程" 模具上的形状。

“尺寸标记 - 工程用”模具。

为了让你了解维度形状的工作方式,以下过程演示了如何使用维度形状之一来测量 home 计划中的钢琴。

  1. 在 "文件" 菜单上,单击 "新建",单击 "地图和平面布置图",然后单击 "开始计划"。

  2. 单击 "家具" 模具的标题栏,然后将 "大钢琴" 形状拖到绘图页上。

  3. 单击 "尺寸度量-结构" 模具的标题栏,然后将 "水平尺寸" 形状拖到 "钢琴" 形状上方的绘图页上。

    上方有一个水平尺寸形状的“大钢琴”形状。

  4. 将 "水平尺寸" 形状右侧的绿色形状图柄拖动到钢琴形状的右边缘,直到出现红色框,指示形状已粘附在一起。

    尺寸形状连接到钢琴形状的一个形状手柄上。

  5. 水平形状左侧的绿色形状手柄拖动到钢琴形状的左边缘。

    尺寸形状连接到钢琴形状上的两个形状手柄上。

  6. 将尺寸形状右侧的黄色菱形拖动到钢琴上方的某个位置,以便尺寸线不会遮住钢琴形状。

    扩展线延长了的尺寸形状已连接到钢琴形状。

注意: 若要更改度量单位,请右键单击尺寸形状,然后单击快捷菜单上的 "精度 & 单位"。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×