在 Office for Mac 中创建、运行、编辑或删除宏

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

为了节省您经常执行的任务的时间, 您可以将这些任务的步骤记录为宏。 然后, 当你想要执行其中一个录制的任务时, 你可以激活宏来为你执行这些步骤。

Word

在 Word 2016 for Mac 中, 你可以创建具有键盘快捷方式、运行宏以及删除不再需要的宏的宏。

  1. 单击“视图”>“”>“录制宏”。

    在“视图”选项卡上,单击“宏”,然后单击“录制宏”,可开始创建宏。
  2. 键入宏的名称, 或接受Word 提供的默认值。

    在“宏名”中输入宏的名称,或接受 Word 提供的通用名称。
  3. 若要在创建的任何新文档中使用此宏, 请验证 "将宏保存在" 列表中是否已选中 "所有文档 (常规) "。

  4. 单击 "键盘" 为宏分配组合键。

    Word 显示 "自定义键盘" 对话框。

  5. 在 "按新键盘快捷键" 框中键入组合键。

    如果有组合键,则在你按组合键后,Word 将显示已分配给该组合的命令或宏。

    按下键组合时, Word 将显示当前分配给该组合键的命令或操作 (如果有)。

  6. 如果你选择的组合键已分配, 请从 "按新键盘快捷方式" 框中删除它, 然后选择一个新的组合键。

    找到未分配的键组合后, 转到下一步。

    当你按下尚未分配给命令或宏的组合键时,Word 可识别出来。
  7. 若要在任何新文档中使用此键盘快捷方式, 请确保在 "将更改保存在" 列表中选中 " normal.dotm"。

    选择“Normal.dotm”,以使宏可供在你创建的新文档中使用。
  8. 单击“指定”

  9. 准备好录制宏时, 单击"确定"

  10. 单击命令或者按下任务中每个步骤对应的键。

    Word 记录你的单击和击键, 但不会记录用鼠标选择的文本。 若要在录制宏时选择文本, 请使用键盘。

  11. 若要停止录制,请单击“视图”>“”>“停止录制”。

    单击“宏”菜单上的“停止录制”,可以停止录制宏。

若要运行宏, 请按分配给它的键盘快捷方式, 或从 "" 列表中运行宏。

  1. 单击“视图”>“”>“查看宏”。

    单击“查看宏”可查看和编辑与当前文档相关联的宏。
  2. 在 "宏名称" 下的列表中, 选择要运行的宏。

  3. 单击“运行”

    在“宏名”中选择宏后,单击“运行”以运行它。

  1. 单击“视图”>“”>“查看宏”。

    单击“查看宏”可查看和编辑与当前文档相关联的宏。
  2. 验证由指定的位置是否包含要删除的宏的位置。

    选择想要在列表中“宏”查看的宏的位置。

    该列表将包含当前窗口中打开的文档以及全局模板和Word 命令。

  3. 在 "宏名" 下, 选择要删除的宏, 然后单击列表下方的减号。

    选择要删除的宏,然后在列表中单击减号 (-)。
  4. 当Word 要求确认是否要删除宏时, 请单击"是"

Excel

在 Excel 2016 for Mac 中, 你可以创建具有键盘快捷方式、运行宏以及删除不再需要的宏的宏。

录制宏时,宏录制器会记录需要宏来执行的完成操作的必需步骤。 这些步骤包括键入文本或数字,单击单元格或功能区或菜单上的命令,格式设置,选择单元格、行或列,以及拖动鼠标来选择电子表格上的单元格。

注意: 功能区上的 "开发工具" 选项卡上也提供了用于录制、创建和删除宏以及其他高级功能的命令。 有关使用 "开发工具" 选项卡的详细信息, 请参阅使用 "开发工具" 选项卡在 Excel 2016 for Mac 中创建或删除宏

  1. 选择 "工具" >> "新建"。

    依次选择 "工具"、"宏" 和 "录制新宏"

  2. 在“宏名”框中,输入宏的名称。

    输入宏名称、位置和快捷键

  3. 若要为宏创建键盘快捷方式, 请在 "选项 + Cmd " 框中键入一个字母。

  4. 从下拉列表中选择宏的位置。

    宏的保存位置

    单击

    在要创建宏的文档中

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

  5. 可选添加对宏的描述。

  6. 准备好录制后, 单击"确定"

  7. 单击命令或者按下任务中每个步骤对应的键。

  8. 若要停止录制, 请选择 "工具" >> "停止录制"。 (此步骤不会录制在宏中。)

    选择 "停止录制"

若要运行宏, 请按分配给它的键盘快捷方式, 或从 "" 对话框中运行宏。

  1. 在“视图”选项卡上,单击“查看宏”。

  2. 在弹出菜单中单击 "", 然后选择 "此工作簿"。

  3. 从列表中选择宏,然后单击“运行”。

    Excel for Mac 中的“宏”对话框

  1. 选择 "工具" >>

    选择 "宏", 然后选择 "宏"

  2. 选择要删除的宏, 然后按减号。

    选择 "宏名", 然后选择 "负号"

  3. 将显示一条确认消息。 单击“”以确认删除。

    确认删除

您也可以从 "开发工具" 选项卡中删除宏。

  1. 在“开发工具”选项卡上,单击“”。

  2. 在列表中,单击要删除的宏,然后单击删除按钮。

    选择一个宏,然后单击减号将其删除

Word

要自动执行重复任务,可以在 Word 中快速创建宏。 也可以在 Microsoft Visual Basic for Applications 中使用Visual Basic 编辑器编写你自己的宏脚本,或将一个宏的全部或部分脚本复制到新宏中。

录制宏时, 将记录完成要执行的宏所需操作的所有步骤。 但是,录制的步骤中不包括为了停止录制而返回选项卡的导航。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,输入宏的名称。

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    [文档名](文档)

    所有已打开的文档中

    所有文档 (Normal)

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,单击“停止”。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“Word”菜单上,单击“关闭并返回 Microsoft Word”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“Word”菜单上,单击“关闭并返回 Microsoft Word”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

PowerPoint

若要自动执行重复性任务, 您可以使用 Visual Basic for Applications 在 PowerPoint 中创建宏 。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“PowerPoint”菜单上,单击“关闭并返回 Microsoft PowerPoint”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“PowerPoint”菜单上,单击“关闭并返回 Microsoft PowerPoint”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

Excel

要自动执行重复任务,可以在 Excel 中快速创建宏。 也可以在 Microsoft Visual Basic for Applications 中使用Visual Basic 编辑器编写你自己的宏脚本,或将一个宏的全部或部分脚本复制到新宏中。

将录制完成希望宏执行的所有操作所需的全部步骤。 但是,录制的步骤中不包括为了停止录制而返回选项卡的导航。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,输入宏的名称。

    提示: 要为宏创建键盘快捷方式,请在“Option+Cmd+”框中键入一个字母。

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

    个人宏工作簿位于用户/用户名/library/application support 支持/Microsoft/Office/Excel 中。

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,再次单击“录制”。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“Excel”菜单上,单击“关闭并返回 Microsoft Excel”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

    提示: 要通过使用键盘快捷键运行宏,请按 OPTION + 命令 + 创建该键盘快捷键时键入的字母。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“Excel”菜单上,单击“关闭并返回 Microsoft Excel”。

完成此过程之后,只要打开包含宏的工作簿,都将运行该宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,键入 Auto_Open

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,再次单击“录制”。

  6. “文件”菜单上,单击“另存为”

  7. 在“格式”弹出菜单上,单击“启用宏的 Excel 工作簿(.xlsm)”,然后单击“保存”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×