在 Visio 中添加形状之间的连接线

在 Visio 中添加形状之间的连接线

凭借 Visio,可以轻松连接绘图中的形状。可以使用“自动连接”功能在添加形状时连接这些形状,也可以使用“连接线”工具连接现有形状。

连接类型

连接线可对形状采用两种连接类型:点连接或动态连接。点连接使连接线粘附到形状上的某个特定点,即使该形状被移动或旋转后也不例外。动态连接使连接线能够更改其在形状上的位置,这样,某个形状被移动或旋转时,连接线会移至该形状上离连接线的起始点最近的连接点。

在下图中,形状 A 具有到形状 C 的点连接,无论 C 是否移动,从 A 引出的连接线始终连接到 C 上的同一点。相反,形状 B 具有到 C 的动态连接,从 B 引出的连接线会连接到离 C 上最近的连接点。

A 具有到 C 的点连接,但 B 具有到 C 的动态连接。

你可以在连接线的任一端采用任意类型的连接线。如果使用“自动连接”功能连接形状,则两端将采用动态连接。如果手动选择连接线在形状上的连接点,则可以指定连接类型。

添加形状时自动连接该形状

连接形状的一种方法是在将形状添加到绘图时让 Visio 自动连接这些形状。在创建流程图时,此做法特别方便。

使用以下过程将形状添加到绘图,这样 Visio 便会自动连接到现有形状。

注意: 若要使用以下过程,请确保“自动连接”功能处于活动状态。在“视图”选项卡上的“视觉帮助”组中,确认“自动连接”处于已选中状态。

添加形状并自动将其连接到现有形状

  1. 如果页面上还没有形状,请从“形状”窗口中将一个形状拖入页面。

  2. 将指针放置在该开始形状上,直到该形状周围显示“自动连接”箭头。

    当自动连接处于活动状态时,将鼠标悬停在某个形状上以显示连接箭头。

    如果未看到“自动连接”箭头,请查看“视图”选项卡,以检查“自动连接”是否处于已选中状态。

  3. 将指针放置在要按其方向添加形状的箭头上。

    将鼠标悬停在自动连接箭头上可显示要添加的形状的工具栏。

    会显示一个浮动工具栏,其中包含当前在“快速形状”模具中的前四个快速形状。指向工具栏上的某个形状时,Visio 会在页面上显示该形状的预览。

  4. 单击要添加的形状。

  5. 如果要继续,请在新添加的形状上指向“自动连接”箭头,以添加也会被自动连接的另一个形状。

    将鼠标悬停在新添加的形状上可显示用于添加另一个形状的自动连接箭头。

注意: 如果需要与浮动工具栏上显示的形状不同的形状,请将所需形状从“形状”窗口拖到页面上的相应位置。若要连接形状,请使用下一节中所述的方法。

连接页面上已存在的形状

当然,你可以通过使用“自动连接”功能或使用“连接线”工具连接绘图中已存在的形状。

连接形状时,可以采用两种连接类型:点连接或动态连接。有关这些连接类型的详细信息,请参阅上述的连接类型

若要创建点连接以将连接线保持为粘附到形状上的某个特定点,请从第一个形状上的连接点拖动到第二个形状上的连接点。形状连接后,连接线端点变为绿色。

将连接线粘附到形状上的特定点来修复到该点的连接线。
将连接线粘附到形状上的特定点来修复到该点的连接线。

若要创建动态连接以使连接线能够自动移到形状上最近的连接点,请将“连接线”工具放在第一个形状中心的上方,直到形状周围出现绿色框。按住鼠标按钮并拖动到第二个形状的中心。第二个形状周围出现绿色框时,释放鼠标按钮。

将连接线粘附到形状,以使连接线能够动态移动至形状上的连接点。
将连接线粘附到形状,以使连接线能够动态移动至形状上的连接点。

使用“自动连接”功能连接现有形状

  1. 将指针放置在一个形状上,直到该形状周围显示“自动连接”箭头。

    当自动连接处于活动状态时,将鼠标悬停在某个形状上以显示连接箭头。
  2. 单击“自动连接”箭头,然后拖到另一个形状上,将连接线的端点放置在该形状的中部来获得动态连接,或者将连接线放置到形状上的特定连接点来获得点连接。

    在将指针放置在“自动连接”箭头上时,会显示相应形状的预览。但是,你可以忽略该形状;将连接线拖到其目标位置时它会消失。

使用“连接线”工具连接形状

  1. 在“开始”选项卡上的“工具”组中,单击“连接线”。

    “连接线”工具使用每个形状末端的连接点来连接到形状。
  2. 单击某个形状,并将连接线拖到另一形状上。

  3. 完成后,请在“开始”选项卡上的“工具”组中,单击“指针工具”。

快速任务

任务

操作

将连接线类型更改为直角、直线或曲线。

右键单击此连接线,然后单击快捷菜单中的连接线类型:直角、直线或曲线。

对齐形状并调整间距,使连接线保持整齐。

选择要对齐的所有形状,然后在“开始”选项卡上的“排列”组中,单击“对齐”>“自动对齐”或者单击“位置”>“自动调整间距”。可以在单击多个形状时通过按 Ctrl 键,或通过使用“开始”选项卡上“编辑”组中的“选择”选项来选择多个形状。

将连接从动态连接更改为点连接,或反之。

选择该连接线,然后将该连接线的端点拖离形状。然后将连接线放置在特定的点上来获得点连接,或在到形状的中部获得动态连接。

打开或关闭“自动连接”功能

可以激活或停用所有 Visio 绘图中的“自动连接”功能,也可以只激活或停用活动绘图中的“自动连接”功能。

打开或关闭活动图表中的“自动连接”功能

  • 在“视图”选项卡上的“视觉帮助”组中,选中或清除“自动连接”。

    在“视图”选项卡上选中或清除“自动连接”以激活或停用自动连接。

注意: 如果“自动连接”复选框不可用,请通过执行以下过程检查是否已关闭了所有图表的“自动连接”功能。

打开或关闭所有图表中的“自动连接”功能

  1. 单击“文件”选项卡,然后单击“选项”。

  2. 在“Visio 选项”中,单击“高级”。

  3. 在“编辑选项”下,选择“启用自动连接”复选框可激活“自动连接”功能。清除“自动连接”复选框可停用“自动连接”功能。

    选中或清除“启用自动连接”以对所有图和绘图激活或停用自动连接。
  4. 单击“确定”

另请参阅

向连接线添加箭头、点或其他线条端点

使用“连接点”工具添加、移动或删除连接点

添加形状时自动连接该形状

连接形状的一种方法是在将形状添加到绘图时让 Visio 自动连接这些形状。在创建流程图时,此做法特别方便。

使用以下过程将形状添加到绘图,这样 Visio 便会自动连接到现有形状。

  1. 如果页面上还没有形状,请从“形状”窗口中将一个开始形状拖入页面。

  2. 将指针放置在该开始形状上,直到该形状周围显示蓝色的自动连接箭头。

  3. 将指针放置在您要按其方向添加形状的箭头上。

    包含当前处于“快速形状”模具中的前四个“快速形状”的浮动工具条出现。从模具中所选形状的实时预览显示在此页面上。

  4. 在该浮动工具栏中的四个形状上移动指针,查看每个形状在页面上的实时预览。

  5. 单击您要添加的形状。

如果您需要不同的形状,请移动指针使其远离自动连接箭头,预览将消失。然后,您可以从“形状”窗口中拖动所需的形状。

快速任务

任务

操作

更改模具的快速形状。

打开模具,并将“快速形状”拖动为您所需的顺序。您可以将形状拖入或拖出“快速形状”区域。

更改浮动工具栏上显示的形状。

在“快速形状”模具中,从“快速形状”组中选择一个您想要显示在浮动工具栏上的形状。包含所选形状的组显示在工具栏上。

或者,您可以将包含您希望首先显示的形状的模具拖放到该“快速形状”标题栏正下方。您可以通过在“形状”窗口中将形状拖的更高或更低来更改其他模具中的顺序;它们在“快速形状”模具中以相同顺序显示。

连接页面上已经存在的形状

可以通过使用“自动连接”功能或使用“连接线”工具连接绘图中已存在的形状。

使用“自动连接”功能连接形状

  1. 将指针放置在一个形状上,直到该形状周围显示蓝色的“自动连接”箭头。

  2. 单击“自动连接”箭头,然后拖到另一个形状上,将连接线的端点放置在该形状的中部来获得动态连接,或者将连接线放置到特定的连接点上来获得点连接。

    在将指针放置在蓝色箭头上时,会显示相应形状的实时预览。但是,您可以忽略该形状;指针移开时它会消失。

使用连接线工具连接形状

  1. 在“开始”选项卡上的“工具”组中,单击“连接线”。

  2. 单击相应的形状,并将连接线拖到另一形状上。

若要保持将连接线粘附到形状上的某个特定点,请从第一个形状上的连接点拖动到第二个形状上的连接点。形状连接后,连接线端点变为红色。这称为点连接。

若要允许连接线在形状移动时在其周围移动,请将“连接线”工具放在第一个形状中心的上方,直到形状周围出现红色框。按住鼠标按钮并拖动到第二个形状的中心。第二个形状周围出现红色框时,释放鼠标按钮。这称为动态连接。

快速任务

任务

操作

将连接线类型更改为直角、直线或曲线。

右键单击相应的连接线,然后单击快捷菜单中的连接线类型。

对齐形状并调整间距,使连接线保持整齐。

选择要对齐的所有形状,然后在“开始”选项卡上单击“自动对齐和自动调整间距”。可以在单击所有形状时通过按 Ctrl 键,或通过使用“选择”选项来选择多个形状。

将连接从动态连接更改为点连接,或反之。

选择该连接线,然后将该连接线的端点拖离形状。然后将连接线放置在特定的点上来获得点连接,或在到形状的中部获得动态连接。

打开或关闭“自动连接”功能

您可以打开或关闭所有 Visio 绘图中的“自动连接”功能,也可以只打开或关闭活动绘图中的“自动连接”功能。

打开或关闭活动图表中的“自动连接”功能

  • 在“视图”选项卡上的“视觉帮助”组中,选中或清除“自动连接”复选框。

如果“自动连接”复选框不可用,请通过执行以下步骤来检查是否已关闭了所有图表的“自动连接”功能。

打开或关闭所有图表中的“自动连接”功能

  1. 单击“文件”>“选项”。

  2. 单击“高级”类别。

  3. 在“编辑选项”下,选择“启用自动连接”复选框可打开“自动连接”功能。清除该复选框可关闭“自动连接”功能。

另请参阅

向连接线添加箭头、点或其他线条端点

添加、移动或删除连接点

使用“自动连接”功能连接形状

连接形状的一种方法是在将形状添加到绘图时让 Visio 自动连接这些形状。在创建流程图时,此做法特别方便。

使用以下过程将形状添加到绘图,这样 Visio 便会自动连接到现有形状。

将形状拖入页面时使用自动连接

  1. 将形状从模具拖到绘图页上,并将其放置在靠近另一个形状的位置。

    放到另一个形状附近的形状

  2. 按住鼠标按钮的同时将指针移到一个蓝色三角形上。三角形会变为深蓝色。

    指针停留在蓝色三角形上

  3. 释放鼠标按钮。形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

    形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

提示: 如果不喜欢拖动形状,则可以通过以下方法实现相同的效果:首先在模具中选择一个形状,将指针停留在绘图中的某个形状上,然后单击该形状周围显示的蓝色三角形之一。

对页面上已存在的形状使用“自动连接​​”功能

  1. 将指针停留在要从其进行连接的形状上。

    停留在要从其进行连接的形状上的指针。

  2. 将指针放在离要连接到的形状最近的蓝色三角形上。

    放置在离要连接到的形状最近的蓝色三角形上的指针。

    三角形会变为深蓝色,并且要连接到的形状周围会出现一个红色的框。

    注意: 如果要连接到的形状周围未出现红色的框,该形状可能离得太远了。将形状移到相对近一点的位置然后重试,或者使用“连接线”工具

  3. 单击蓝色的三角形。两个形状上会添加并粘附一条连接线。

    形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

启用或禁用“自动连接”功能

可以启用或禁用所有 Visio 绘图中的“自动连接”功能,也可以只启用或禁用当前绘图中的“自动连接”功能。对于所有绘图:

  1. 在“工具”菜单上,单击“选项”。

  2. 单击“常规”选项卡。

  3. 在“绘图窗口”选项下,选择“启用自动连接”复选框。

仅对于当前绘图:

  • 在“标准”工具栏上,单击“自动连接”工具。

    注意: 如果单击“自动连接”工具未能启用自动连接,请首先确保“选项”对话框中的“启用自动连接”复选框处于选中状态。

使用“连接线”工具连接形状

用于添加和粘附连接线的最灵活的方法之一是使用“标准”工具栏上的“连接线”工具 按钮图像 绘制此连接线。

  1. 在“标准”工具栏上单击“连接线”工具 按钮图像

  2. 执行下列操作之一:

    • 若要使连接线保持为粘附到某个形状的特定点上,请从第一个形状上的连接点 连接点图像 - 蓝色 X 拖动到第二个形状上的连接点。形状连接后,连接线端点会变为红色。这称为点对点连接。凭借点对点连接,在移动其中一个形状时可以使连接线能始终粘附到相同的连接点。

    • 若要使连接线能够移动到最近的可用连接点,请将“连接线”工具放在第一个形状的中心位置,直到该形状周围出现红色的框。按住鼠标按钮,并拖动到第二个形状的中心。第二个形状周围出现红色的框时,释放鼠标按钮。这称为形状到形状的连接。凭借形状到形状的连接,在移动其中一个形状时可以使连接线通过移动到最近的可用连接点以始终粘附到其中一个形状。如果连接点未出现,连接线则会移动到最近的那侧。

      注意: 也可以在形状之间创建连接,其中连接线的一端连接到一个连接点,而连接线的另一端则连接到形状(反之亦然)。

  3. 在“标准”工具栏上单击“指针”工具 指针按钮 以返回正常编辑状态。

    注释: 

    • 若要添加从一个形状到多个形状的连接线,需要添加多条连接线;没有可用的“分支”连接线形状。

    • 如果在尝试创建点对点连接时难以将连接线粘附到所需的确切位置,请尝试其他的对齐和粘附设置:

    • 在“工具”菜单上,单击“对齐和粘附”,然后在“常规”选项卡上选择所需选项。

      如果粘附到形状几何图形、形状句柄或形状顶点,则会自动添加连接点(如果连接点尚不存在)。

另请参阅

向连接线添加箭头、点或其他线条端点

添加、移动或删除连接点

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×