在 Visio 中录制宏

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

创建宏自动执行的步骤或重复执行的流程。在开发工具选项卡上的录制宏命令。

注意:  宏可以触发安全警报,因为它们可能是出于恶意目的而创建和使用的。有关宏的风险和如何处理安全警报的详细信息,请参阅启用或禁用 Office 文件中的宏

  1. 在“开发工具”选项卡上,单击“录制宏”。(如果您看不到“开发工具”选项卡,请参阅下面的“显示‘开发工具’选项卡”。)

    “宏”命令

  2. 在“宏名”框中,键入宏名称。

  3. 在“快捷键”框中,键入与 Ctrl 键一起使用可运行宏的快捷键。

  4. 在“宏的存储位置”框中,单击要用来保存宏的文档。

  5. 在“说明”框中,键入宏的描述。

  6. 单击“确定”开始录制宏。

  7. 执行要包含在宏中的操作。在“开发工具”选项卡上,根据需要使用“暂停录制”。

    录制宏时,可以使用鼠标单击命令和选项,也可以处理绘图中的形状和对象。

  8. 若要停止录制宏,请在“开发工具”选项卡上单击“停止录制”。

还可以使用“录制”工具栏上的按钮暂停或继续宏录制。

要查看生成的代码,请在“工具”菜单上,指向“”,依次单击“”、宏名,然后单击“编辑”。

显示“开发工具”选项卡

  1. 单击“文件”选项卡,然后单击“选项”

  2. 单击“自定义功能区”

  3. 在“自定义功能区”和“主选项卡”下,选中“开发工具”复选框。

    开发工具”选项卡显示在功能区末尾,与“文件”选项卡在一排。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×