在 Publisher 中创建邮件或电子邮件合并

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

当您想要创建大量的大部分相同而包括一些唯一信息的文档时,您可以使用邮件或电子邮件合并。例如,可以使用邮件合并与个性化的笔记或唯一的地址和称呼创建单独的自定义的出版物。您也可以使用邮件合并创建要发送给特定人员之前自定义产品发布。出版物的文本总是相同,但的姓名和地址是不同的每个收件人。

本文内容

选择邮件合并或电子邮件合并

创建或连接到的收件人列表

准备您的出版物

创建合并的出版物

取消合并

选择邮件合并或电子邮件合并

执行的第一件事是选择是否您正在创建邮件合并打印或电子邮件合并对联机分发内容。

  • 单击邮件选项卡,然后选择邮件合并电子邮件合并

创建或连接到的收件人列表

若要执行邮件合并时,您将需要打开一个新的或现有出版物,然后连接到数据源 (包含您要包括的唯一信息的文件)。数据文件中可能包含列表的名称和地址、 产品数据或图片。数据文件可以为不同的格式,包括︰

  • Outlook 的联系人列表

  • Excel 工作表

  • Word 表格

  • Access 数据库表

  • 文本文件中的制表符或逗号分隔的列,和段落返回单独的行

您可以连接到现有列表或数据源,也可以创建新的收件人列表。如果您想要仅使用某些条目列表中,您可以通过特定条件筛选您的列表。您也可以按字母顺序的项目进行排序。

注意: 如果您想要将图片合并到出版物页面,文件名或路径要合并的图片文件必须包含数据源。不包括实际图片或图像中的数据源。

从功能区选择收件人

使用现有列表

  1. 单击邮件>选择收件人>使用现有列表

    默认情况下,Publisher 在我的数据源文件夹中存储的数据源。您可能需要浏览以找到您的数据源。

  2. 选择数据源对话框中,单击所需的数据源,然后单击打开

    根据您所选择的数据源的类型,可能出现其他对话框请求特定信息。例如,如果您的数据源是 Excel 工作簿与多个工作表上的信息,您需要选择包含要查看其的信息的工作表。

从 Outlook 联系人中选择

  1. 单击邮件>选择收件人>从 Outlook 联系人中选择

    如果出现提示时选择邮件配置文件,单击所需的配置文件,然后单击确定

  2. 选择联系人对话框中,单击所需的联系人列表,然后单击确定

    所有文件夹中的联系人显示在邮件合并收件人对话框中,您可以在其中筛选和排序要在合并中包括的收件人列表。

键入新列表

如果您没有连接到现有列表,您可以创建新列表。

  1. 单击邮件>选择收件人>键入新列表

  2. 新建地址列表对话框中,键入您的邮件相关的字段中的第一项的信息。

    注意: 若要更改默认列,单击自定义列并添加、 删除、 重命名,并重新排序的列列表中。

  3. 完成第一个条目输入信息后,单击新建条目

  4. 重复步骤 2 和步骤 3,直到完成添加条目,然后再单击确定

  5. 保存地址列表对话框中,在文件名框中键入地址列表的名称,并将其保存。

    注意: 默认情况下,Publisher 将地址列表保存在我的数据源文件夹。最好是要保留的地址列表,因为这也是 Publisher 查找数据源的默认文件夹。

    所有新列表中的联系人显示在邮件合并收件人对话框中,您可以在其中筛选和排序要在合并中包括的收件人列表。

选择收件人

邮件合并收件人对话框中,您可以选择您想要在合并中包括的收件人。选择您想要包括的收件人旁边的复选框,然后清除要排除的收件人旁边的复选框。

如果您想要仅使用某些条目列表中,您可以筛选列表中的,按特定字段或条件。筛选列表后,您可以使用对应的复选框包括或排除记录。

筛选列表中的项目︰

  1. 单击要作为筛选依据的项目的列标题旁边的箭头。

  2. 单击以下任一操作︰

    • (空白)显示对应的域为空白的所有记录。

    • (非空白)显示相应的字段中包含的信息的所有记录。

    • (高级)将打开筛选和排序对话框中,您可以使用多个条件对其进行筛选。此外可以在调整收件人列表邮件合并收件人对话框中打开筛选和排序对话框中下单击筛选器

    • 若要快速选择或清除所有项目,请选中或都清除复选框的列标题。

      提示: 如果您的数据源包含共享相同的信息,记录,并且有 10 个或更少的唯一值的列中,您可以筛选按特定信息。例如,如果有多个地址为国家/地区的澳大利亚该列表,您可以筛选澳大利亚

      邮件合并收件人对话框中显示指定的记录。若要再次显示所有记录,请单击(全部)

如果您想要查看按字母顺序的项目,您可以对项排序列表中。

在列表中的项目进行排序︰

  • 邮件合并收件人对话框中,单击要作为排序依据的项目的列标题。例如,如果您想要按姓氏的字母顺序显示列表,请单击姓氏列标题。

  • 若要排序使用多个条件,在邮件合并收件人对话框中,单击排序。在出现筛选和排序对话框中,选择要作为排序依据的条件。

返回页首

准备您的出版物

邮件合并从单个模板使用占位符信息和添加到每个文档的占位符信息的唯一信息创建多个文档。获取后的收件人列表放在一起,您可以准备主模板。

插入文本框

  1. 单击插入>绘制文本框 按钮图像

  2. 在出版物中,指向一个角的文本框中,才能显示位置,然后沿对角线方向拖动,直到得到所需的文本框大小。

在每个版本中添加所需的文本

  • 在文本框中,单击,然后键入您希望在每个版本的邮件合并出版物中显示的文本。

将数据域添加到您的出版物

插入邮件合并域

  1. 在邮件合并出版物中,单击文本框中要插入的数据字段的位置。

  2. 插入下列任意操作︰

    • 包含姓名、 地址和其他信息的地址块︰

      1. 编写和插入域组中,单击地址块

      2. 插入地址块对话框中,单击您想要包括的地址元素,然后单击确定

        注意: 如果您的数据源中的数据字段的名称不匹配 Publisher 用于地址块域的名称,您可能需要单击匹配域插入地址块对话框。在匹配域对话框中,使用下拉列表以选择从数据源中对应于 Publisher 字段的字段。

    • 问候语

      1. 编写和插入域组中,单击问候语

      2. 问候语对话框中,选择问候语格式,其中包括称呼、 姓名格式和标点。

      3. 选择要在 Publisher 无法解释收件人的姓名; 时显示的文本例如,当数据源不包含第一个或最后一个收件人,而只公司名称,并单击确定

        注意: 如果您的数据源中的数据字段的名称不匹配 Publisher 用于问候语域的名称,您可能需要单击匹配域对话框中的问候语。在匹配域对话框中,使用下拉列表以选择从数据源中对应于 Publisher 字段的字段。

    • 图片

      1. 中的编写和插入域组中,单击图片,然后单击插入图片域.

      2. 插入图片域对话框中,选择要插入的图片字段。

      3. 注意: 如果您想要将图片合并到出版物页面,文件名或路径要合并的图片文件必须包含数据源。在数据源中不要包括实际图片或图像。

    • 每个字段的信息

      • 编写和插入域组中,选择插入合并域,,然后单击您想要包括在文本框中的字段。

设置数据字段的格式

您可以为数据字段和已添加如 (Hello 问候语) 或称呼亲爱...更改合并数据的外观的任何其他文本应用格式。若要设置合并的数据的格式,您将需要设置邮件合并出版物中的数据字段的格式。

在邮件合并出版物中,选择包含要设置格式的信息的字段。

  • 如果字段是地址块或问候语,在编写和插入域组中选择格式

  • 如果字段是单个数据字段,在文本框工具格式菜单上,单击字体,然后选择所需的选项。

  • 如果选定的字段被识别 Publisher 为数字、 货币、 日期或时间,单击格式并更改这些类型的字段的显示方式的格式。

在出版物中的数据字段中的预览收件人数据

您可以查看您的出版物中合并域的实际数据的显示方式。

要预览出版物,请单击预览结果,然后执行以下任一操作︰

  • 若要按顺序预览条目,请单击导航按钮 “前进”按钮 [返回] 按钮 以查看每个条目合并出版物中的显示方式。

    第一条记录中的数据源的信息将填充合并域。不能编辑数据源条目在出版物页面,但您可以设置格式、 移动或删除那里数据字段。

  • 若要查找并预览您的数据源中的特定项,请单击查找收件人,然后在查找条目对话框中输入搜索条件。

如果需要您可以对收件人列表中进行更改。执行下列任一操作︰

  • 若要从合并中排除特定的收件人,请单击排除此收件人

  • 要更改的收件人列表,请单击编辑收件人列表,然后在邮件合并收件人对话框中进行更改。

完成邮件合并出版物并插入合并域,文件的所有后 > 单击另存为,命名为出版物中,单击保存

返回页首

创建合并的出版物

若要创建合并的出版物,单击完成并合并按钮,然后按照下面的说明来打印、 预览、 将其保存,将合并的页面添加到另一个出版物中,或通过电子邮件发送。

完成邮件合并

打印合并的出版物

  1. 单击合并到打印机

  2. 打印空间中,选择所需的选项,然后单击确定

    重要: 若要打印不同的合并数据集 — 例如,不同的名称和地址-在纸张的每个工作表,单击打印选项部分中的每版打印多页。如果您选择每版打印多份,每张纸将包含相同的数据的多个副本。

    每版打印多页

保存以供将来合并的出版物

如果您想要编辑合并的页面、 将其保存以备将来使用,或将在以后它们打印出来,您可以收集和将所有合并页面另存为一个新合并出版物包含实际数据,而不是合并域。

  1. 单击合并到新出版物

  2. 在新出版物中,在邮件合并任务窗格中,单击保存此发布。命名新出版物,然后单击保存

将合并的页面添加到现有出版物

如果您打算将合并的页面添加到现有出版物的末尾,请确保邮件合并出版物通过以下方式与现有出版物相匹配︰

  • 页面大小 (高度和宽度)

  • 页面视图 (单页或跨页)

  • 出版物类型 (web 或打印)

  • 页面顺序 (从左到右或从右到左)

Publisher 将合并的页面添加到新的或现有出版物,但不能将它们添加到打开的出版物。如果您想要合并到出版物处于打开状态,请确保保存并完成合并之前将其关闭。

  1. 单击添加到现有出版物

  2. 打开出版物对话框中,找到您要向其添加合并的页,的出版物,然后单击打开

  3. 在现有出版物中,在邮件合并任务窗格,以保存您的更新中单击保存此发布

发送电子邮件

如果要创建电子邮件合并唯一可用在完成并合并下的选项将发送电子邮件

  1. 单击发送电子邮件

  2. 合并到电子邮件对话框中,从下拉列表中选择收件人字段。在大多数情况下,这将电子邮件地址

  3. 主题下键入主题行。若要插入的项目下, 单击您想要在主题行中插入任何数据字段。

  4. 单击选项来指定您希望,如抄送或密件抄送收件人或消息附件的任何其他选项,然后单击发送

保存邮件合并出版物

如果您还可以保存包含合并的域的发布,您可以返回和编辑的字段并创建新的合并的出版物。若要保存出版物合并,请执行下列操作︰

  1. 单击“文件”>“保存”。

  2. 为出版物指定名称,然后单击保存

返回页首

取消合并

您可以取消断开其数据源的邮件合并出版物或目录合并模板合并。

  1. 单击邮件选项卡 >选择收件人,然后单击取消合并

    取消邮件合并

  2. 当系统询问您是否想要取消合并,请单击

    注意: 如果您取消邮件合并,地址字段、 线条问候语和地址块之外的字段将转换为普通文本。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×