在 Project 中复制报表、日历和视图

在 Project 中复制报表、日历和视图

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

管理器是一种可用于将报表、日历和其他元素复制到其他项目或全局模板 (Global.MPT) 的工具。将元素复制到全局模板以使其可用于所有项目。

但是, 你可能无需使用组织者来完成所需的操作。事实上, Project 的默认行为是自动将您创建的所有新视图和相关元素复制到全局模板。这也适用于使用新名称保存的现有元素。若要更改此行为, 请选择 "文件" > "选项" > "高级"。该设置位于 "显示" 部分中:

“将新的视图、表格、筛选器和组自动添加到全局”选项

使用管理器

如果您取消选中上述设置,并希望将所选元素复制到全局模板,或者希望将元素从一个项目复制到另一个项目,则您需要使用管理器。

管理器也可以将自定义文本样式复制到其他项目或全局模板。有关详细信息,请参阅更改视图中的文本字体

注意: 

  • 您无法使用管理器复制任务信息。如果您希望特定任务成为每个项目的一部分,请将项目文件保存为常规模板

  • 自定义值列表中的值(即查阅值)不能存储在全局模板中。请也为此情形使用常规模板。

将元素复制到全局模板

假定您使用成本列自定义了默认甘特图,现在想要在将来的项目中使用新图表。按照下列步骤将视图复制到全局模板:

  1. 选择 "文件" > "管理器"。

    (在 Project 2007 中, 选择 "工具" > "管理器"。)

  2. 在 "管理器" 对话框中, 选择 "视图" 选项卡。

    “项目管理器”对话框。

    注意: 若要复制其他项目元素, 请选择不同的选项卡, 如 "日历"。

    左侧的列表显示全局模板中的元素,而右侧的列表显示当前项目中的元素。您的工作是将自定义元素从左侧移动到右侧。

    注意:  要查看其他项目中的项目元素,您需要先打开这些项目。

  3. 选择右侧的 "自定义视图", 然后选择 "复制"。

    项目组织显示当前打开的项目中的元素列表。
    自定义视图将被复制到全局模板并显示在左侧。

  4. 如果你的自定义视图包含你添加的列, 那么你需要复制到相关联的表。选择 "" 选项卡, 然后将表复制到全局模板。关联的表可能具有与视图相同的名称, 但如果您看不到匹配的可能, 请复制该条目表。

    你的所有项目都将具有自定义视图供它们使用正确的基础表。

将元素直接复制到另一个项目

如果要将项目元素从一个项目复制到另一个项目(但不是全局模板):

  1. 打开两个项目(包含自定义元素的“源”项目和要向其中复制自定义元素的“目标”项目)。

  2. 在源项目中, 选择 "文件" > "管理器"。

    (在 Project 2007 中, 选择 "工具" > "管理器"。)

  3. 在可用性列表中,选择目标项目。

    在项目管理器中选择一个目标项目文件。

    注意: 若要复制其他项目元素, 请选择不同的选项卡, 如 "日历"。

  4. 选择右侧的自定义元素, 然后选择 "复制" 以将它们复制到目标项目。

如果现有日历具有许多与要在新日历中使用的相同假日和其他日历项目, 则可以将新日历基于现有日历。在Microsoft Project Web App中复制现有日历, 然后在 Project 的桌面版本中修改副本。例如, 如果您的组织中的标准日历捕获组织的所有唯一假日和事件, 但是您需要单独的日历来反映全天、每天的工作计划, 则可以复制标准日历, 然后对其进行修改, 以供全天, 每天的计划。

若要创建新日历作为现有日历的副本, 请执行以下操作:

  1. 在 "快速启动" 的 "设置" 部分中, 选择 "服务器设置"。

  2. 在 "服务器设置" 页面上的 "企业数据" 部分中, 选择 "企业日历"。

  3. 选择包含要复制的日历的行, 然后选择 "复制日历"。

  4. 在 "复制日历" 对话框中, 在 "名称" 框中键入要用于新日历的名称, 然后选择"确定"

    "日历" 将添加到 "企业日历" 页面上的列表中。

  5. 选择包含新的已复制日历的行, 然后选择 "编辑日历"。

    如果出现 "Windows 安全" 对话框, 请登录到Microsoft Project Server 2010。

    Project 专业版随即打开, 并显示 "更改工作时间" 对话框。

  6. 使用 "例外日期" 和 "工作周" 选项卡的日历为您的组织修改工作时间和非工作时间。有关详细信息, 请参阅修改工作时间和非工作时间

  7. 在 "更改工作时间" 对话框中选择"确定" , 将新的日历保存到 Project Server。

  8. 关闭 Project。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×