在 Excel 2016 for Windows 中刷新外部数据连接

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以将 Excel 工作簿连接到外部数据源,如 SQL Server 数据库、OLAP 多维数据集,甚至其他 Excel 工作簿。此连接可以在工作簿中显示为表格、数据透视表或数据透视图。

您可通过刷新数据源链接使工作簿中的数据保持最新。每次刷新连接时,您会看到最新的数据,包括新增或已删除的任何内容。

返回页首

刷新来自 Microsoft Query、数据连接向导或 Web 查询的数据

  1. 单击包含外部数据链接的区域或表格中的任一单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”。

    刷新数据连接

  3. 要仅更新所选的数据,请单击“刷新”。

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  4. 要刷新工作簿中的所有数据连接,请单击“全部刷新”。

    注意: 如果有多个打开的工作簿,则需要在每个工作簿中重复上述操作。

返回页首

刷新导入的文本文件中的数据

  1. 单击包含导入文本文件链接的区域或表格中的任一单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”。

    刷新数据连接

  3. 要仅更新所选的数据,请单击“刷新

  4. 要刷新工作簿中的所有数据连接,请单击“全部刷新”。

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  5. 在“导入文本文件”对话框中,通过浏览找到你的文本文件,然后单击“导入”。

返回页首

刷新 Power Pivot 数据

  1. 在“数据”选项卡上的“连接”组中,单击“连接”。

    数据连接

  2. 在“工作簿连接”对话框中,选择 Power Pivot 数据的连接,然后单击“刷新”。

返回页首

刷新脱机多维数据集文件

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“刷新”。

    刷新数据连接

返回页首

刷新导入的 XML 文件中的数据

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

返回页首

打开工作簿时自动刷新数据

您可以在打开工作簿时自动刷新外部数据区域。或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  1. 单击“使用状况”选项卡。

  2. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  3. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

返回页首

定期自动刷新数据

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

返回页首

刷新外部数据区域时要求密码

存储的密码未经加密,因此我们不建议您使用。如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。下面的过程不适用于从文本文件 (.txt) 或 Web 查询 (.iqy) 检索的数据。

使用强密码大写和小写字母、 数字和符号。弱密码不要混合使用这些元素。例如,强密码: Y6dh ! et5。弱密码: House27。密码应为 8 或更多个字符。使用 14 或多个字符的密码短语是更好。

务必记住密码。如果您忘记了密码,Microsoft 无法为您找回。请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

返回页首

在后台或您等待时运行查询

对于非常大的数据集,请考虑运行后台刷新。这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

返回页首

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。双击该消息可检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

返回页首

相关内容

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×