在 Excel 或 Visio 中创建 Project 数据的可视报表

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

可视报表允许您查看项目信息以图形方式使用 Excel 2010 中的增强数据透视表。一旦项目信息导出到 Excel 后,您可以进一步自定义报表与 Excel 2010 增强数据透视表功能,例如筛选切片器,在数据透视表,在数据透视表以立即,显示趋势的迷你图中进行搜索和OLAP 回写改进。

本文内容

可用的可视报表

使用模板创建可视报表

编辑现有可视报表模板

创建新的可视报表模板

导出报表数据

可用的可视报表

报表模板在“可视报表 - 创建报表”对话框中分为六个类别,可通过单击“Project”选项卡上“报表”组中的“可视报表”来访问该对话框。以下各节对每个类别中的可视报表进行了说明。

您也可以创建自己的自定义报表。自定义报表将显示在使用的数据类型所对应的类别中。

“任务分配状况”类别

下表介绍“任务分配状况”类别中的可视报表。这些报表是以时间分段任务数据为基础的。

注意: 按时间分段的分配数据在“工作分配状况”类别的报表中提供。

名称

类型

说明

现金流量报表

Excel

使用此报表,可以查看按时间显示成本和累计成本金额的条形图。

按时间的盈余分析报表

Excel

使用此报表可以查看绘制一段时间内的 AC(已完成工时的实际成本)、计划分析(计划工时的预算成本)和盈余分析(已完成工时的预算成本)的图形。

“资源使用状况”类别

下表介绍“资源使用状况”类别中的可视报表。这些报表是以按时间分段的资源数据为基础的。

注意: 按时间分段的分配数据在“工作分配状况”类别的报表中提供。

名称

类型

说明

现金流量报表

Visio

使用此报表,可以查看按时间显示项目计划成本和实际成本的图表。成本按资源类型(工时、材料和成本)划分。当计划成本超过比较基准成本时会有标记显示。

资源可用性报表

Visio

使用此报表,可以查看按资源类型(工时、材料和成本)显示项目资源的工时和剩余可用性的图表。每个过度分配的资源旁边将显示一个红色标志。

资源成本摘要报表

Excel

使用此报表可以查看饼图,该图显示三种资源类型(成本、材料和工时)之间的资源成本划分。

资源工时可用性报表

Excel

使用此报表,可以查看按时间显示总工时量、工时以及剩余工时资源可用性的条形图。

资源工时摘要报表

Excel

使用此报表,可以查看按工时单位显示总工时量、工时以及剩余工时资源可用性的条形图。

“工作分配状况”类别

下表介绍“工作分配状况”类别中的可视报表。这些报表是以按时间分段的数据为基础的,类似于“任务分配状况”“资源使用状况”视图中的数据。

名称

类型

说明

比较基准成本报表

Excel

使用此报表,可以查看跨任务显示项目的比较基准成本、计划成本以及实际成本的条形图。

基准报表

Visio

使用此报表,可以查看按季度、然后按任务划分的项目图表。此报表将计划工时和成本与基准工时和成本进行比较。当计划工时超过比较基准工时、或计划成本超过比较基准成本时,会有标记显示。

比较基准工时报表

Excel

使用此报表,可以查看跨任务显示项目的比较基准工时、计划工时以及实际工时的条形图。

预算成本报表

Excel

使用此报表,可以查看按时间显示预算成本、比较基准成本、计划成本以及实际成本的条形图。

预算工时报表

Excel

使用此报表,可以查看按时间显示预算工时、比较基准工时、计划工时以及实际工时的条形图。

按时间的盈余分析报表

Excel

使用此报表可以查看绘制一段时间内的 AC(已完成工时的实际成本)、计划分析(计划工时的预算成本)和盈余分析(已完成工时的预算成本)的图形。

“任务、资源和工作分配摘要”类别

下表介绍“任务摘要”、“资源摘要”和“工作分配摘要”类别中的可视报表。摘要报表不含按时间分段的数据。

类别

名称

类型

说明

任务摘要

关键任务状态报表

Visio

使用此报表,可以查看显示关键及非关键任务的工时与剩余工时的图表。数据栏表明工时完成的百分比。

任务摘要

任务状态报表

Visio

使用此报表可以查看一个图表,该图表显示项目中的任务的工时与工时完成百分比。当比较基准工时超过工时、比较基准工时等于工时,以及工时超过比较基准工时时,会有符号指明。数据栏表明完成工时的百分比。

资源摘要

资源剩余工时报表

Excel

使用此报表,可以查看按工时单位显示每个工时资源的剩余工时和实际工时的条形图。

工作分配摘要

资源状态报表

Visio

使用此报表,可以查看显示每个项目的工时和成本值的图表。图表上每个框中的阴影表示工时完成百分比。随着资源中分配的工时趋于完成,阴影会越来越暗。

返回页首

使用模板创建可视报表

  1. 视图选项卡的报表组中,单击可视报表
    “报表”组图形

  2. “可视报表”对话框中的“全部”选项卡上,单击要创建的报表。

    如果希望创建的报表没有列出,请选中“包括来自以下位置的报表模板”复选框,然后单击“修改”以浏览到包含您的报表的位置。

    提示: 如果您知道哪个类别包含该报表,可以单击该类别的选项卡以查看较短的报表列表。如果只想列出用 Excel 或 Visio 打开的报表,请选中或清除“Microsoft Excel”“Microsoft Visio”复选框。

  3. 若要更改报表所含使用数据的级别,请从“选择要在报表中包含的使用数据级别”列表中选择“年”“季度”“月”“周”“天”

    注意: 默认情况下,Project 会将使用数据的级别设置为建议用于您的项目大小的级别。对大多数项目来说,默认级别为周。如果选择以更详细的级别包含数据,则可能会降低报表性能。为获得最佳性能,一次性查看同一项目的多个报表时,请勿更改数据级别。如果更改了数据级别,则必须重新创建存储在本地的临时报表数据库。如果不需要在报表中包含使用数据,请将数据级别设置为“年”以获得最佳性能。

  4. 单击“视图”生成报表,然后用 Excel 或 Visio 打开。

返回页首

编辑现有可视报表模板

  1. 视图选项卡的报表组中,单击可视报表
    “报表”组图形

  2. “可视报表”对话框中的“全部”选项卡上,单击要编辑的报表。

    提示: 如果您知道哪个类别包含该报表,可以单击该类别的选项卡以查看较短的报表列表。如果只想列出用 Excel 或 Visio 打开的报表,请选中或清除“Microsoft Excel”“Microsoft Visio”复选框。

  3. 单击“编辑模板”

  4. “可视报表 - 域选取器”对话框上,单击要在报表中添加或删除的域,然后单击“添加”“删除”“全部删除”,将域在“可用域”“所选域”框之间或“可用自定义域”“所选自定义域”框之间移动。

    “所选域”“所选自定义域”框中的域将包含在报表中。

  5. 单击“编辑模板”以创建带有修改过的域列表的报表。

  • “可视报表 - 域选取器”对话框上,有些域被标识为维度。应为报表选择六个以下的维度,这一点很重要。如果选择的维度大于六个,会大大降低报表性能。

  • 并非所有域在所有报表中都可用。有些域仅在 Visio 报表中可用,而在 Excel 报表中不可用。

  • 如果无法找到要包含在“可视报表 - 域选取器”对话框上的域,则该域可能存储在不同的数据类别中。例如,许多域看似是“任务摘要”域,实际上是“工作分配摘要”域。

返回页首

创建新的可视报表模板

  1. 视图选项卡的报表组中,单击可视报表
    “报表”组图形

  2. “可视报表”对话框中,单击“新建模板”

  3. “选择应用程序”部分中,单击“Excel”以创建 Excel 模板,或单击“Visio(公制)”以创建 Visio 模板。

  4. “选择数据类型”部分中,选择要在报表中使用的数据类型。

    若要包含按时间分段的数据,请从“选择数据类型”部分的列表中选择“任务分配状况”“资源使用状况”“工作分配使用状况”

  5. 单击“域选取器”

  6. “可视报表 - 域选取器”对话框上,按住 Ctrl 并在“可用域”框中单击要添加到报表中的默认 Project 域。

  7. 单击“添加”将这些域移至“所选域”框中。

  8. 按住 Ctrl 并在“可选自定义域”框中单击要添加到报表中的自定义域。

  9. 单击“添加”将这些域移至“所选自定义域”框中。

  • 如果安装了 Office Project 2007 的英语版本,则可以选择创建使用美制单位的 Visio 模板。

  • 若要从报表中删除域,请在“可视报表 - 域选取器”对话框上单击“所选域”“所选自定义域”框中的域,然后单击“删除”。若要从报表中删除所有默认域或自定义域,请单击“选择域”“选择自定义域”部分中的“全部删除”

  • 并非所有域在所有报表中都可用。有些域仅在 Visio 报表中可用,而在 Excel 报表中不可用。

  • 如果无法找到要包含在“可视报表 - 域选取器”对话框上的域,则该域可能存储在不同的数据类别中。例如,许多域看似是“任务摘要”域,实际上是“工作分配摘要”域。

  • “可视报表 - 域选取器”对话框上,有些域被标识为维度。应为报表选择六个以下的维度,这一点很重要。如果选择的维度大于六个,会大大降低报表性能。

  • 创建可视报表后,可以选择是将它保存到默认模板位置 (c:\Program Files\Microsoft Office\Templates),还是保存到计算机或网络上的其他位置。保存在默认模板位置的模板会自动显示在“可视报表 - 创建报表”对话框中。

  • 如果在保存自定义可视报表模板后开始使用其他语言包,则该模板仍然可用但不会对其进行填充。新语言无法识别原始域名且报表中不会包括这些域名。

返回页首

导出报表数据

您可以选择特定的数据在一个类别(OLAP 多维数据集)中导出,也可以将所有项目数据作为报表数据库导出。

将数据作为 OLAP 多维数据集导出

  1. 视图选项卡的报表组中,单击可视报表
    “报表”组图形

  2. “可视报表”对话框中,单击“保存数据”

  3. “保存报表多维数据集”部分中,选择含有要保存的数据类型的类别。

  4. 单击“域选取器”以修改包含在要导出的数据列表中的域。

  5. “可视报表 - 域选取器”对话框上,单击需要在要导出的数据列表中添加或删除的域,然后单击“添加”“删除”“全部删除”,将域在“可用域”“所选域”框之间或“可用自定义域”“所选自定义域”框之间移动。

    “所选域”“所选自定义域”框中的域将包含在导出的数据中。

  6. “可视报表 - 域选取器”对话框上单击“确定”,然后单击“保存多维数据集”

  7. 浏览到要保存多维数据集数据的位置,然后单击“保存”

  • 多维数据集数据将保存为 .cub 文件。

  • 使用 Visio 访问多维数据集数据时,.cub 文件无法存储在网络共享上。

将数据作为报表数据库导出

  1. 视图选项卡的报表组中,单击可视报表
    “报表”组图形

  2. “可视报表”对话框中,单击“保存数据”

  3. 单击“保存数据库”

  4. 浏览到要保存数据库的位置,然后单击“保存”

    数据将保存为 Microsoft Office Access 数据库 (.mdb) 文件。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×