在 Excel 中创建数据模型

在 Excel 中创建数据模型

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

数据模型是有效地构建关系数据源的 Excel 工作簿内的集成来自多个表,数据的新方法。在 Excel 中,数据模型使用透明,提供用于数据透视表、 数据透视图和 Power View 报表中的表格数据。之前深入的详细信息,您可能希望收回步骤和观看视频,或执行我们学习指南上获取和转换和 Power Pivot。

注意: 本文介绍 Excel 2013 中的数据模型。但是,相同的数据建模和引入 Excel 2013 中的 Power Pivot 功能也适用于 Excel 2016。没有有效小差异这些版本的 Excel。

在大多数情况下,您根本不会知道模型的存在。在 Excel 中,数据模型可视化为字段列表中的表格集合。要直接处理模型,您需要使用 Microsoft Office Microsoft Excel 2013 中的 Power Pivot 加载项。

导入关系数据时,如果选择多个表格,将自动创建模型:

  1. 在 Excel 中,使用“数据”>“获取外部数据”从 Access 或其他包含多个相关表格的关系数据库导入数据。

  2. Excel 将提示您选择一个表。选中“支持选择多个表”。

    “选择表”对话框

  3. 选择两个或更多表格,单击“下一步”,然后单击“完成”。

  4. 在“导入数据”中,选择所需的数据可视化选项(如新工作表中的数据透视表),然后构建您的报表。

现在即已构建了一个数据模型,其中包含您导入的所有表格。由于您选择了数据透视表报告选项,所以将在您要用于构建数据透视表报表的字段列表中显示该模型。

数据透视表字段列表

可使用此模型执行哪些操作?您可以用它在同一工作簿中创建数据透视表、数据透视图和 Power View 报表。您可以通过添加或删除表来修改模型;如果使用 Power Pivot 加载项,您可以通过添加计算列、计算字段、层次结构和 KPI 来扩展模型。

创建数据模型时,可视化选项非常重要。建议您为数据可视化选择“数据透视表”、“ 数据透视图”或“Power View 报表”。这些选项允许您集中处理所有表格。如果您改为选择了“表格”,将把导入的每个表格放入一个单独的工作表中。在这种情况下,表格可以单独使用,但是集中使用所有表格需要数据透视表、数据透视图或 Power View 报表。

注释: 

  • 当您在 Excel 中同时导入两个或更多表格时,将隐式创建模型。

  • 当您使用 Power Pivot 加载项导入数据时,将显式创建模型。在该加载项中,模型表示为选项卡式布局,其中每个选项卡内均包含表格数据。请参阅使用 Power Pivot 加载项获取数据以了解有关使用 SQL Server 数据库导入数据的基本知识。

  • 一个模型可以只包含一个表格。要基于一个表创建模型,请选择该表,然后单击“添加到数据模型”(Power Pivot 中)。如果要使用 Power Pivot 功能(如筛选的数据集、计算列、计算字段、KPI 和层次结构),可以执行此操作。

  • 如果您导入具有主键和外键关系的相关表格,将自动创建表格关系。Excel 通常可以使用导入的关系信息作为数据模型中的表格关系基础。

  • 有关如何减小数据模型大小的提示,请参阅使用 Excel 2013 和 Power Pivot 加载项创建内存高效的数据模型

  • 有关详细信息,请参阅教程:在 Excel 2013 中使用数据模型执行数据透视表数据分析

提示: 您的工作簿中包含数据,但您知道其中是否包含数据模型吗?通过打开 Power Pivot 窗口可以快速确定模型状态。如果选项卡中显示数据,则说明存在模型。详情参阅了解工作簿数据模型中使用哪些数据源

使用另一个数据透视表、数据透视图或 Power View 报表中的数据模型

一个 Excel 工作簿中只能包含一个数据模型,但可以在工作簿内重复使用这个模型。

  1. 在 Excel 中,单击“插入”>“数据透视表”。

  2. 在“创建数据透视表”中,单击“使用外部数据源”,然后单击“选择连接”。

  3. 在“现有连接”中,单击“表格”。

  4. 默认情况下已选中了该工作簿数据模型下的“工作簿数据模型中的表格”。单击“打开”,然后单击“确定”。将出现一个数据透视表字段列表,其中显示模型中的所有表格。

将现有的不相关数据添加到数据模型

假设您导入或复制了希望在模型中使用的大量数据,但在导入期间未选中“将此数据添加到数据模型”框。将新数据推送到模型比您想象的更为简单。

  1. 首先处理您要添加到模型的数据。这些数据可以是任何数据区域,但是使用命名区域效果最好。

  2. 突出显示要添加的单元格,或者如果数据位于表格或命名区域中,则将光标放在一个单元格中。

  3. 使用下面的一种方法添加数据:

  4. 单击“Power Pivot”>“添加到数据模型”。

  5. 单击“插入”>“数据透视表”,然后选中“创建数据透视表”对话框中的“将此数据添加到数据模型”。

现在将区域或表格作为链接表添加到了模型。要了解有关在模型中使用链接表的详细信息,请参阅在 Power Pivot 中使用 Excel 链接表添加数据

在 Power Pivot 加载项中优化和扩展数据模型

在 Excel 中,数据模型可扩大和丰富报告体验,尤其是在该体验包含用于数据浏览和分析的数据透视表或其他报表格式时。 数据模型虽然重要,但仍然有意保留在后台中,以便您可以专注于要使用数据模型执行的操作。

但假设您就希望直接处理模型。既然知道字段列表是基于模型的,也许您会希望删除表格或字段,因为它们在列表中不太有用。您可能希望查看模型提供的所有基础数据,或添加 KPI、层次结构和业务逻辑。出于以上所有这些原因以及其他原因,您会希望直接修改数据模型。

若要修改或管理数据模型,使用Power Pivot加载项。加载项是 Office Professional Plus 版本的 Excel 2013 中的一部分,但未启用默认。启动 Power Pivot in Microsoft Excel 加载项有关详细信息。

Power Pivot 中的表格与工作表中的表格之间的差异

在 Power Pivot 中,您不能通过直接键入新行来向表格添加行,而在 Excel 工作表中则可以。但您可以通过使用“粘贴”命令通过刷新数据来添加行。

Excel 工作表中的数据通常会变动,而且是不规则,即一行可能包含数值数据,而下一行则可能包含图形或文本字符串。而 Power Pivot 中的表更接近关系数据库中的表,其中每一行都具有相同列数且大多数列都包含数据。

在 Power View 中使用数据模型

数据模型用作 Power View 报表的基础。您可以使用 Power Pivot 加载项来优化可改进 Power View 报告的模型。优化包括:指定默认字段列表、选择代表性字段或图像来唯一标识特定行,或指定在报告应用程序中如何处理包含重复值(如同名员工或客户)的行。

  1. 通过导入多个相关表格创建数据模型。

  2. 单击“Power Pivot”>“管理”打开 Power Pivot 窗口。

  3. 选择一个表格并应用优化:

    1. 单击“高级”>“默认字段集”。选择当您单击父表格时 Power View 报表上将自动显示的字段。请参阅配置 Power View 报表的默认字段集以获取详细信息。

    2. 单击“高级">“表行为”。优化用于对数据进行分组的报表布局。分组取决于默认行为,有时会产生意外结果,如合并了本应单独列出的行。请参阅配置 Power View 报表的表行为属性以了解详细信息。

    3. 单击“高级”>“数据类别”。一些报表可视化特定于数据类型。例如,如果您有基于时间或日期的表格,则可以分配日期类别来帮助 Power View 执行基于时间的可视化。

  4. 对其他表格重复执行此步骤。

  5. 在 Excel 中,单击“插入”>“Power View”开始创建新报表。请参阅 Power View:浏览、可视化和呈现数据以获取详细信息。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×