在窗体中插入数据表

数据表是以行和列的简单形式排列的数据视图。如果在导航窗格中双击某个表,Microsoft Office Access 2007 会将该表显示为一个数据表。由于数据表可以紧凑地显示数据,因此在用作子窗体显示来自一对多关系的“多”端的数据时,数据表可以很好地发挥作用。本文介绍如何在 Office Access 2007 中向窗体添加数据表。

你想如何操作?

查看窗体上的数据表的示例

建立表之间的关系

创建包含子窗体数据表使用窗体工具

创建包含子窗体数据表使用布局视图

使用布局视图向现有窗体中插入数据表

使用设计视图向现有窗体中插入数据表

了解分割窗体和数据表的包含子窗体之间的差异

在窗体中查看数据表示例

假设您需要创建一个窗体,以显示有关产品类别以及这些类别中的所有产品的数据。“类别”表中的数据表示关系的“一”端,“产品”表中的数据表示关系的“多”端。每个类别都可以包含多种产品。

包含子窗体的窗体

1. 主窗体显示来自关系的“一”端的数据。

2. 数据表显示来自关系的“多”端的数据。

返回页首

建立表与表之间的关系

设计包含数据表的窗体之前,应当先查看各个表之间的关系并添加所有缺失的关系。这样,Access 便可以自动创建数据表与主窗体之间的链接。若要查看、添加或修改数据库中各表之间的关系,请在“高级工具”选项卡上的“分析”组中,单击“关系”。有关创建关系的详细信息,请参阅“请参阅”部分的链接。

返回页首

使用“窗体”工具创建包含数据表的窗体

当使用“窗体”工具创建基于单个一对多关系的“一”端中的表的窗体时,Access 会自动插入在关系的“多”端中显示数据的数据表。

例如,当下列所有条件均为真时,Access 将插入一个显示每个客户的所有订单的数据表:

  • 您创建了一个基于“客户”表的简单窗体。

  • 您定义了与“订单”表之间的一对多关系,该关系指定“客户”表中的一个记录可以与“订单”表中的多个记录相关。

  • “客户”表不在其他任何一对多关系的“一”端。

  • 在导航窗格中,单击位于一对多关系的“一”端的表。

  • 创建选项卡的窗体组中,单击窗体按钮图像

Access 将创建一个底部包含数据表的窗体。如果 Access 没有创建数据表,则说明用于窗体的表不是任何单个一对多关系的一部分,或者该表是多个一对多关系的一部分。

注释: 

  • 除创建主窗体外,此过程不会创建其他任何窗体对象。数据表是表的直接视图。

  • 隐藏数据表中的某个列    右键单击该列,然后单击“隐藏列”。此设置将保存;如果您保存并关闭该窗体,然后重新打开它,则该列将保持隐藏状态。

  • 还原数据表中隐藏的列    在数据表中右键单击任何列标题,然后单击“取消隐藏列”。选中您要还原到视图的每列旁边的复选框,然后单击“关闭”

返回页首

使用布局视图创建包含数据表的窗体

如果您已经定义了数据库中各表之间的关系,则可以使用布局视图快速创建包含数据表的窗体。当您将关系的“多”端中的字段添加到基于关系的“一”端的窗体中时,Access 会自动创建一个数据表以显示相关记录。

  1. 创建选项卡上的窗体组中,单击空白窗体按钮图像

    Access 在布局视图中打开一个空白窗体,并显示“字段列表”窗格。

    注意: 如果您不小心关闭了“字段列表”窗格,可以通过执行下列操作之一来重新打开它:

    • 按 Alt+F8。

      - 或 -

      格式选项卡上的控件组中,单击添加现有字段按钮图像

  2. 单击位于一对多关系的“一”端的表旁边的加号,然后将您需要的第一个字段拖动到窗体上。

    请注意,“字段列表”窗格将表分为以下部分:“可用于此视图的字段”及其下面的“相关表中的可用字段”。与主表没有直接关系的其他任何表均列在“字段列表”底部的“其他表中的可用字段”下。

  3. “可用于此视图的字段”部分,将您需要的其他所有字段拖动到主窗体上。

  4. “相关表中的可用字段”部分,将数据表中您需要的第一个字段拖动到窗体上。Access 会创建一个数据表,并将该字段添加到该数据表中。

  5. 要向新数据表中添加其他字段,必须先单击该数据表以选择它。您会看到 Access 重排“字段列表”窗格,以便可用于数据表的字段显示在顶部。从“可用于此视图的字段”部分,将您需要的其他所有字段拖动到该数据表上。在您将每个字段拖动到该数据表中时,Access 会绘制一条插入线,以显示当您松开鼠标按钮时字段将插入到的位置。

  6. 继续将字段添加到主窗体或数据表,方法是:先单击主窗体或数据表以选择它,然后从“字段列表”窗格中拖动字段。

其他表中的可用字段部分中的字段列表窗格中包含不直接相关的表或查询,基于选定的窗体或数据表的表。如果在关系窗口中定义了所有有效的表关系,然后在其他表中的可用字段部分中的字段不会是有效的窗体中构建您选择。如果您将此分区中的字段拖动到窗体时,Access 将显示指定关系对话框。您必须输入在继续之前相互关联两个表的字段。如果执行此操作时,字段列表窗格中将不再根据预定义关系排序的分区。它可能最好是单击在此对话框中的取消和重新检查表关系。关于关系的详细信息,请参阅创建、 编辑或删除关系一文。

返回页首

使用布局视图在现有窗体中插入数据表

如果您已经定义了数据库中各表之间的关系,则可以使用布局视图快速向现有窗体中添加数据表。当您将关系的“多”端中的字段添加到基于关系的“一”端的窗体中时,Access 会自动创建一个数据表以显示相关记录。

  1. 在布局视图中打开现有窗体,方法是:在导航窗格中右键单击该窗体,然后单击快捷菜单中的“布局视图”

    如果未显示“字段列表”窗格:

    • 按 Alt+F8。

      - 或 -

      格式选项卡上的控件组中,单击添加现有字段按钮图像

      请注意,“字段列表”窗格将表分为以下部分:“可用于此视图的字段”及其下面的“相关表中的可用字段”。与主表没有直接关系的其他任何表均列在“字段列表”底部的“其他表中的可用字段”下。

  2. “相关表中的可用字段”部分,展开包含要添加到数据表的第一个字段的表,并将该字段拖动到窗体上。Access 会创建一个数据表,并将该字段添加到该数据表中。

  3. 要向新数据表中添加其他字段,必须先单击该数据表以选择它。您会看到 Access 重排“字段列表”窗格,以便可用于数据表的字段显示在顶部。从“可用于此视图的字段”部分,将您需要的其他所有字段拖动到该数据表上。在您将每个字段拖动到该数据表中时,Access 会绘制一条插入线,以显示当您松开鼠标按钮时字段将插入到的位置。

  4. 继续将字段添加到主窗体或数据表,方法是:先单击主窗体或数据表以选择它,然后从“字段列表”窗格中拖动字段。

其他表中的可用字段部分中的字段列表窗格中包含不直接相关的表或查询,基于选定的窗体的表。如果在关系窗口中定义了所有有效的表关系,然后在其他表中的可用字段部分中的字段不会是有效的窗体中构建您选择。如果您将此分区中的字段拖动到窗体时,Access 将显示指定关系对话框。您必须输入在继续之前相互关联两个表的字段。如果执行此操作时,字段列表窗格中将不再排序成节根据预定义的关系。它可能最好是单击在此对话框中的取消和重新检查表关系。关于关系的详细信息,请参阅创建、 编辑或删除关系一文。

返回页首

使用设计视图向现有窗体中插入数据表

按照此过程,可以在设计视图中直接向现有窗体中添加直接基于表或查询的数据表。

  1. 在设计视图中打开窗体,方法是:在导航窗格中右键单击窗体,然后单击“设计视图”

  2. “设计”选项卡上的“控件”组中,如果选中了“使用控件向导”工具,请单击它将它取消选中。

    按钮图像

    为什么?

    如果使用该工具,则“子窗体控件向导”将生成单独的窗体对象,并使子窗体控件基于该窗体对象。相反,此过程创建的数据表将直接基于表或查询,而不是窗体。

  3. 设计选项卡上的控件组中,单击子窗体/子报表 按钮图像 按钮。 按钮图像

  4. 在窗体设计网格中,在要插入数据表的位置单击。

  5. 通过拖动控件各边和各角的控点,重新定位子窗体控件并调整其大小。

  6. 对子窗体控件的附加标签进行编辑,方法是:先单击该标签,再双击它以选择它的文本,然后键入新的标签。如果想删除该标签,请单击标签一次,然后按 Delete。

  7. 如果尚未显示属性表,请按 F4 显示该表。

  8. 如果当前未选择子窗体控件,请单击一次将它选中。

  9. 在属性表的“数据”选项卡上,单击“记录源”下拉列表,然后单击要在数据表中显示的表或查询。例如,如果要显示“订单”表中的数据,请单击“表.订单”

  10. 如果在开始此过程之前正确设置了关系,则 Access 会使用正确的值自动设置“链接子字段”属性和“链接主字段”属性,以便将主窗体链接至数据表。

    我链接子字段和链接主字段属性为空

    如果 Access 无法确定如何将子窗体控件链接至主窗体,则子窗体控件的“链接子字段”和“链接主字段”属性将保留为空。您必须通过执行下列操作来手动设置这两个属性:

    1. 在设计视图中打开主窗体。

    2. 单击子窗体控件一次将它选中。

    3. 如果当前未显示属性表,请按 F4。

    4. 在属性表的“数据”选项卡上,单击“链接子字段”属性框旁边的(“...”)。

      将显示“子窗体字段链接器”对话框。

    5. “主字段”“子字段”下拉列表中,选择要用来链接窗体的字段。如果不确定要使用哪些字段,请单击“建议”让 Access 来确定链接字段。完成后,请单击“确定”

      如果看不到要用来链接窗体的字段,则可能需要编辑主窗体或子窗体的记录源,以确保该字段位于其中。例如,如果窗体基于查询,则应当确保链接字段出现在查询结果中。

    6. 保存主窗体并切换到窗体视图,验证窗体是否按您预期的方式工作。

  11. 通过单击快速访问工具栏上的保存 按钮图像 或按 CTRL + S 保存窗体。

  12. 切换到窗体视图并验证数据表是否按预期方式工作。

返回页首

了解分割窗体与包含数据表的窗体之间的区别

包含数据表的窗体可以显示来自不同(但通常相关)数据源的数据。例如,某个窗体显示员工,它可以包含显示分配给每个员工的所有任务的数据表。该数据表的数据源不同于包含它的窗体。而分割窗体则不同,它包含两部分(一个窗体和一个数据表),但这两部分显示相同的数据。这两个部分可以相互跟踪并同时为您提供数据的两种不同视图。

有关创建和使用分割窗体的详细信息,请参阅文章创建分割窗体

返回页首

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×