在电子邮件中提交表单数据

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以在表单模板中添加辅助提交数据连接,以允许用户在电子邮件中发送表单数据。您可以使用静态值、基于表单中数据的值或公式指定将表单发送到的电子邮件地址、电子邮件的主题行以及表单的名称。还可以指定要让表单出现在电子邮件的正文中,还是作为电子邮件的附件。

如果您将表单模板配置为在电子邮件中以附件形式包含表单,还可以将表单模板附加到电子邮件中。通过将表单和表单模板作为附件包含在电子邮件中,您可以确保电子邮件收件人能够在 Microsoft Office InfoPath 中打开表单,即使他们在计算机上没有缓存表单模板也如此。为使收件人能够打开附件,他们必须已在计算机上安装了 InfoPath。

当用户在电子邮件中提交表单数据时,InfoPath 会创建一份包含表单数据的电子邮件,并将邮件发送到您在创建数据连接时指定的电子邮件收件人。如果接收已完成的表单的人使用 Microsoft Office Outlook 2007,他们可以在收件箱中添加一个文件夹,用于存放收到的所有 InfoPath 表单,并配置该文件夹以将表单中的数据显示在 Outlook 中的列中。

添加了提交数据连接后,需要配置表单模板,以使用户能够提交其表单数据。此后,当用户打开此表单时,InfoPath 会自动向“常用”工具栏添加一个“提交”按钮,并向“文件”菜单添加一个“提交”命令。您还可以通过以下方式自定义表单模板的提交选项:

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令上显示的文字。

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令的键盘快捷方式。

  • 创建在用户提交表单时向用户显示的自定义消息。

  • 指定在用户提交表单后,是让表单保持打开,关闭表单,还是打开另一个空白表单。

返回页首

添加提交数据连接

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

  3. 单击“将表单数据发送到单个目标”,然后在列表中单击“电子邮件”

  4. 单击“添加”

  5. 在数据连接向导的相应框中,键入收件人电子邮件地址、希望显示在电子邮件中的主题以及需要的任何介绍性文本,然后单击“下一步”

    提示: 您还可以指定一个域,或使用公式为除“介绍”框外的每个框创建值。

    操作方法

    1. 单击“插入公式公式按钮

    2. “插入公式”对话框中,执行下列操作之一:

      • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

      • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

        提示: 如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

      • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

    运算

    符号

    添加

    +

    -

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

    • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

      “请参阅”部分中可以找到有关公式的详细信息的链接。

  6. 在向导的下一页上,执行下列操作之一:

    1. 若要在电子邮件正文中显示表单,请单击“仅发送表单的活动视图(无附件)”

    2. 若要将表单数据作为电子邮件的附件发送,请单击“以附件形式发送表单数据”,选中“附加表单模板以确保用户能够打开表单”复选框,然后在“附件名称”框中键入表单的名称。您还可以指定一个域或使用公式以确保每个表单名称都唯一。

      操作方法

      1. 单击“插入公式公式按钮

      2. “插入公式”对话框中,执行下列操作之一:

        • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

        • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

          提示: 如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

        • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

      运算

      符号

      添加

      +

      -

      *

      /

      • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

      • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

        “请参阅”部分中可以找到有关公式的详细信息的链接。

      注意: 将此表单数据作为电子邮件附件接收的人需要在其计算机上装有 InfoPath 才能打开此附件。

  7. 单击“下一步”

  8. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  9. “摘要”部分验证信息的正确性,然后单击“完成”

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时显示在文件菜单的提交命令的名称,请在提交选项对话框中的标题框中键入新名称。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  10. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下后用户提交表单,, InfoPath 保持表单打开并显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一 ︰

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 在失败框中使用一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×