在电子邮件中提交表单数据

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

您可以添加辅助提交到表单模板,使用户可以将其表单数据发送电子邮件中的数据连接。您可以使用静态值、 基于该窗体,或公式指定窗体发送到的电子邮件地址,电子邮件中,主题行和窗体的名称中的数据值。您还可以指定是否希望显示在电子邮件或以附件形式向邮件正文中的窗体。

如果配置表单模板包含窗体以附件形式向电子邮件,您可以将表单模板附加到电子邮件。通过电子邮件附件的形式包括表单和表单模板,可以帮助确保电子邮件收件人可以在 Microsoft Office InfoPath 中,打开该窗体,即使他们没有在其计算机上缓存的表单模板。为了让收件人打开附件,他们必须在其计算机上安装 InfoPath。

当用户提交表单数据中的电子邮件时,InfoPath 表单数据与创建电子邮件和向创建数据连接时指定的电子邮件收件人发送邮件。如果收到已完成的表单的人员使用Microsoft Office Outlook 2007,他们可以将文件夹添加到其收件箱,以包含所有 InfoPath 表单他们接收和配置该文件夹显示在 Outlook 中的列中的窗体中的数据。

添加提交数据连接后,您可以配置表单模板以允许用户提交表单数据。因此,当用户打开该窗体,InfoPath 自动向提交按钮标准工具栏和到文件菜单提交命令。您也可以通过以下方式自定义表单模板的提交选项:

  • 更改显示在标准工具栏上的提交按钮和文件菜单上的提交命令的文本。

  • 更改标准工具栏上的提交按钮和文件菜单上的提交命令的键盘快捷方式。

  • 创建自定义用户提交表单时向用户显示的消息。

  • 指定是否要保持表单打开、 关闭该窗体或用户提交表单后打开另一个空白表单。

返回页首

添加提交数据连接

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

  3. 单击发送表单数据发送到单个目标,然后在列表中,单击电子邮件

  4. 单击“添加”。

  5. 在数据连接向导中,在相应的框中,键入收件人、 主题,您希望显示在电子邮件,并且所需的任何介绍性文本的电子邮件地址,然后单击下一步

    提示: 此外可以指定一个字段,或使用公式来创建除简介框中的每个框中的值。

    操作方法

    1. 单击插入公式 公式按钮

    2. 插入公式对话框中,执行下列操作之一:

      • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

      • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

        提示: 如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

      • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

    运算

    符号

    添加

    +

    相减

    -

    相乘

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

    • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

      另请参阅部分找到有关公式的详细信息的链接。

  6. 在向导的下一页上,执行下列操作之一:

    1. 若要显示的电子邮件正文中的窗体,请单击发送仅窗体,不发送附件活动视图

    2. 以电子邮件以附件形式发送表单数据,请单击发送作为附件的窗体数据、 选择附加表单模板,以确保用户可以打开该窗体复选框,然后键入附件名称中的窗体的名称框。您还可以指定字段或使用公式来确保每个窗体名称是唯一的。

      操作方法

      1. 单击插入公式 公式按钮

      2. 插入公式对话框中,执行下列操作之一:

        • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

        • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

          提示: 如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

        • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

      运算

      符号

      添加

      +

      相减

      -

      相乘

      *

      /

      • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

      • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

        另请参阅部分找到有关公式的详细信息的链接。

      注意: 接收电子邮件中以附件形式的表单数据的用户需要在其计算机上安装的 InfoPath 打开附件。

  7. 单击“下一步”

  8. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  9. 验证在摘要部分中的信息正确,然后单击完成

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,可在提交的标题框中键入新名称选项对话框。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  10. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一:

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×