在演示文稿中播放 Adobe Macromedia Flash 动画

PowerPoint for Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

如果你有使用 Adobe Macromedia Flash 创建的动画图形, 并将其另存为带有 swf 扩展名的 Shockwave 文件, 则可以在PowerPoint 演示文稿中播放该文件。

通过在幻灯片上嵌入或链接文件, 将 Flash 文件添加到PowerPoint 2010 和更高版本中的演示文稿。

注意: 

  • 在PowerPoint 中使用 Flash 时可能会有一些限制, 包括无法使用特殊效果 (如阴影、反射、发光效果、柔化边缘、棱台和三维旋转)、淡化和裁切功能以及压缩这些功能的功能便于共享和分发的文件。

  • PowerPoint 2010 64 位版本与 QuickTime 或 Flash 的32位版本不兼容。 必须安装64位版本的 QuickTime 或 Flash 或32位版本的PowerPoint 2010 。

嵌入 Flash 文件

  1. 在 "普通" 视图中, 单击要在其中嵌入视频的幻灯片。

  2. 在 "插入" 选项卡上的 "媒体" 组中, 单击 "视频" 下的箭头, 然后单击"我的电脑上的视频" 或 "来自文件的视频"。

  3. 在“插入视频”对话框中,找到并单击要嵌入的视频,然后单击“插入”。  

    若要确保 swf 文件在对话框中列出, 请将文件筛选器 ("插入" 按钮上方) 更改为 "所有文件"。

    "插入视频" 对话框中的 "文件类型" 筛选器具有 "所有文件" 选项。
  4. 若要预览 Flash 动画, 请单击 "视频工具格式" 选项卡上的 "播放"。

链接到 Flash 文件

  1. 在“普通”视图下的“幻灯片”选项卡上,单击要向其添加视频或动态 GIF 文件的幻灯片。

  2. 在“插入”选项卡上的“媒体”组中,单击“视频”下方的箭头。

  3. 单击 "我的电脑上的视频"或 "来自文件的视频", 找到并单击要链接到的文件。

    若要确保 swf 文件在对话框中列出, 请将文件筛选器 ("插入" 按钮上方) 更改为 "所有文件"。

    "插入视频" 对话框中的 "文件类型" 筛选器具有 "所有文件" 选项。
  4. 在“插入”按钮上,单击向下键,然后单击“链接到文件”。

    重要: 若要防止可能出现的链接断开问题, 最好将视频复制到演示文稿所在的文件夹中, 并链接到该文件夹。

  5. 若要预览 Flash 动画, 请单击 "视频工具格式" 选项卡上的 "播放"。

Adobe Macromedia 导演视频

不能在PowerPoint 演示文稿中插入 Adobe Macromedia 导演视频文件。

若要在 PowerPoint 2007 中添加 swf 文件, 请使用名为 Shockwave flash 对象和 Adobe Macromedia flash 播放器的 ActiveX 控件。 若要播放 flash 文件, 请将 ActiveX 控件添加到幻灯片, 并创建一个指向 Flash 文件的链接。

ActiveX 控件安全设置位于信任中心内,您可以在其中找到 2007 Microsoft Office 系统 程序的安全和隐私设置。 您可能需要调整您的安全设置,以便允许 ActiveX 控件运行。 信任中心中的 ActiveX 设置应用于所有 2007 Office 版本 产品。 例如,如果您在 PowerPoint 中更改设置,也将更改使用信任中心的其他 Office 程序的该设置。 有关活动 X 控件和更改设置的详细信息, 请参阅启用或禁用 Office 文件中的 ActiveX 设置

重要: 

  • 必须在您的计算机中注册 Shockwave Flash Object,才能播放演示文稿中的 Flash 文件。 若要查看 Shockwave Flash 对象是否已注册, 请在 "开发工具" 选项卡上的 "控件" 组中, 单击 "其他控件" 按钮图像 。 如果控件列表中显示 Shockwave Flash Object,说明其已在您的计算机中注册。 如果未注册, 请从 Adobe 网站下载最新版本的 flash Player , 以在您的计算机上注册 Shockwave Flash 对象。

  • 若要保证复杂动画正常运行,请安装最新版本的 Flash Player,即使您的计算机上已注册了较低版本的 Shockwave Flash Object。

向演示文稿添加 Flash 文件

  1. 在您的计算机上安装 Flash Player。

  2. 在 PowerPoint 中的“普通”视图下,显示要在其中播放动画的幻灯片。

  3. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“PowerPoint 选项”。

  4. 单击“常用”,在“PowerPoint 首选使用选项”之下选中“在功能区显示‘开发工具’选项卡”复选框,然后单击“确定”。

  5. 在 "开发工具" 选项卡上的 "控件" 组中, 单击 "其他控件 按钮图像 "。

  6. 在控件列表中,单击“Shockwave Flash Object”,单击“确定”,然后在幻灯片上拖动以绘制该控件。

    通过拖动尺寸控点调整控件大小。

  7. 右键单击 Shockwave Flash Object,然后单击“属性”

  8. 在“按字母顺序”选项卡上,单击“影片”属性。

  9. 在值列(“影片”旁边的空白单元格)中,键入要播放的 Flash 文件的完整驱动器路径(包括文件名,如 C\:MyFile.swf)或统一资源定位器 (URL)。

  10. 若要设置如何播放动画的具体选项,请执行以下操作,然后关闭“属性”对话框:

    • 若要在显示幻灯片时自动播放文件,请将“播放”属性设置为“True”。 如果 Flash 文件中内置了“开始/后退”控件,则可以将“播放”属性为“False”。

    • 如果不希望重复播放动画,请将“循环”属性设置为“False”。

在“幻灯片放映”视图中预览动画

  • 在“视图”选项卡上的“演示文稿视图”组中,单击“幻灯片放映”或按 F5。

    若要退出幻灯片放映并返回到“普通”视图,请按 Esc。

注意: 

  • 与图片或绘图不同, Flash 文件始终链接到 PowerPoint 2007 中的演示文稿, 而不是嵌入到演示文稿中。 插入链接的文件时,PowerPoint 将创建指向该文件的当前位置的链接。 如果以后将该文件移动到其他位置,当您希望播放该文件时,PowerPoint 找不到该文件。 插入 Flash 文件之前,不妨将其复制到与演示文稿相同的文件夹中。 PowerPoint 将创建指向该 Flash 文件的链接,并且只要您将该文件保留在演示文稿文件夹中,PowerPoint 都可以找到该文件,即使您将该文件移动或复制到其他计算机也不例外。 另一种可确保链接的文件与演示文稿位于同一个文件夹中的方法是使用“打包成 CD”功能。 这种功能将所有文件与演示文稿一起复制到一个位置(CD 或文件夹),并自动更新这些文件的链接。 当演示文稿包含链接的文件时, 如果计划在另一台计算机上放映演示文稿或通过电子邮件将演示文稿发送给某人, 则必须复制链接的文件和演示文稿。

  • 本文所涉及到的第三方产品由 Microsoft 以外的其他厂商制造;对于这些产品的性能或可靠性,我们不作任何默示或其他形式的保证。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×