在数据视图中编辑、删除或插入记录

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

创建数据视图的 SharePoint 列表或库、 SQL 数据库或 XML 文件具有作为其数据源后,您可以轻松地添加编辑、 删除或插入的数据源中的记录,使用浏览器的链接。

例如,罗斯文商贸,gourmet 食品分布公司,跟踪其库存 XML 文件中。低库存时,工作组成员呼叫的供应商的该产品和订单。建议添加链接以进行编辑的数据视图,以便份订单的团队成员可以立即更新的项目的记录。您也可以添加插入和删除数据视图中的链接,以便工作组成员可以添加或删除产品。这样,罗斯文商贸将始终拥有最新信息在其当前库存。

本文介绍如何添加、 编辑、 删除和插入到现有的数据视图的链接。若要创建示例数据和数据视图所使用的示例中,或了解有关数据视图,请参阅文章创建数据视图

本文内容

开始之前

添加链接以编辑、 删除或插入数据视图中的记录

编辑、 删除或插入记录通过浏览器

自定义的编辑或插入模板

开始之前

Microsoft Office SharePoint Designer 2007具有两个不同的功能使用户能够编辑数据视图,通过浏览器中的数据:

  • 将链接添加到现有的数据视图    您可以添加到现有的数据视图的链接,以便用户可以编辑,删除或插入的数据源中的记录。用户单击记录以将该项目放在编辑模式下的编辑链接。如果将链接添加到数据视图以表单形式插入的链接替换表单按钮。此外,如果将链接添加到以表单形式插入数据视图中,数据视图中将不再显示窗体字段默认设置。默认情况下它只将视图中显示数据。

  • 插入数据视图作为窗体    当您创建数据视图时,您可以选择将其作为单个项目或多项目窗体插入。窗体始终处于编辑模式,并显示一条记录或多个记录。用户可以修改现有记录通过浏览器中,但不是能插入或删除记录。您可能想要选择多项目窗体,如果用户可能希望快速同时编辑多条记录中的数据。有关详细信息,请参阅文章插入数据视图作为窗体

数据格式

此示例使用 XML 文件用作数据源。XML 文件是纯文本文件,因为不能指定的单个字段必须包含的值的类型。例如,没有要防止输入并在字段中保存文本应包含数字,如 UnitsOnOrder。

但是,如果数据源是数据库或 SharePoint 列表或库,则可能创建数据库、 列表或库来指定类型可以包含的各个字段的值时。这种情况下,如果您使用窗体需要数字字段中输入文本,然后单击保存,您收到一条错误消息,指出数据源控件未能执行更新命令。这是因为您正在输入一个值,不能接受的数据源中的字段。如果您收到这样一条错误消息,请单击浏览器的后退按钮。然后单击取消放弃所做的更改的窗体或输入一个值,可以接受的数据源。

设计表单时,您可能想要包括在每个列标题来指示哪些窗体的字段的数据需要的备注。

返回页首

添加链接以编辑、 删除或插入数据视图中的记录

这些链接可以添加到任何数据视图,而不考虑它已插入为视图或窗体。但是,如果为以表单形式插入数据视图中添加这些链接,请插入的链接将替换表单按钮。此外,如果将链接添加到以表单形式插入数据视图中,数据视图中将不再显示窗体字段;在视图中,它将仅显示数据。不能通过使用这些功能提供的按钮和链接数据视图。

  1. 打开包含您要向其添加链接的数据视图的页面。

    要按照此示例中,使用数据视图中创建数据视图中创建。

    数据视图中显示的 products.xml

  2. 单击数据视图,单击箭头 按钮图像 右上角以显示数据视图的常见任务列表,然后单击数据视图属性。再次单击箭头可隐藏列表。

    提示: 或者,您可以数据视图中,右键单击,然后单击快捷菜单上的显示常用控制任务

  3. 数据视图属性对话框中,单击编辑选项卡。

  4. 编辑选项卡上的链接选项,请执行一个或多个下列操作:

    • 若要添加的链接以进行编辑的记录,请选择显示编辑项目的链接复选框。

    • 若要添加一条记录中删除链接,请选择显示删除项目的链接复选框。

    • 若要添加用于插入新记录的链接,请选择显示插入项目链接复选框。

      对于此示例中,选择显示编辑项目的链接显示删除项目的链接显示插入项目链接复选框。

      编辑“数据视图属性”对话框的“编辑”选项卡

      注意: 上面的示例是特定于 XML 文件。使用 SQL 数据库,在数据视图属性对话框中的编辑选项卡到自动同步命令选项也提供一个选项。选中此选项后,将编辑、 删除和插入数据视图中的控件与同步更新、 删除和 SQL 数据源中的插入命令。

  5. 单击“确定”。

    编辑链接和删除链接现在前面数据视图中的每条记录。在数据视图的左下角是插入链接。

    带有插入、编辑和删除链接的数据视图

  6. “文件”菜单上,单击“另存为”

  7. 另存为对话框中,在文件名框中,键入您的文件的名称,然后单击保存

返回页首

编辑、 删除或插入记录通过浏览器

保存包含窗体的页面后,您可以在浏览器中预览和修改窗体中的数据。

预览浏览器中的数据视图

  • 在Office SharePoint Designer 2007,在文件菜单中,单击在浏览器中的预览,然后单击浏览器类型和要使用的大小。

    键盘快捷方式单击您想要在文件夹列表中,预览的页面,然后按 F12。

    在浏览器中显示数据视图中包含的链接。

    浏览器中显示的带有链接的数据视图

编辑记录

  1. 单击要编辑的记录的编辑链接。

    要遵循的示例,请单击编辑链接德威。数据视图,其中包含的数据表单德威记录显示。

    编辑模式下数据视图中的单条记录

    注释: 

    • 当您正在使用 SharePoint 列表和库时,编辑控件不是文本框而 SharePoint 表单字段控件。

    • 当您正在使用只读字段,如 SharePoint 列表或 SQL 数据库中的 ID 字段被显示仅作为文本而不是一个可编辑字段。

    您现在可以编辑任何中显示的信息德威记录。

  2. 编辑该记录的数据,然后单击保存以保存所做的更改,或单击取消以撤消所做的更改并返回到数据视图。

    要关注的示例,在框中的订购量列中,键入企业项目数字 40,然后单击的左侧的保存德威记录。

    显示数据视图中使用已更新的记录。

    带有 UnitsOnOrder 值的记录

删除记录

  • 单击要删除的记录的左侧的删除链接。

    重要: 当您删除一条记录,通过浏览器时,则无提示,询问是否确实要执行此操作,以及没有方法来撤消已删除的记录。

    要遵循的示例,请单击左侧的删除链接激活ProductName列表中的。显示具有仅四条记录的数据视图。

    仅有四条记录显示在数据视图中

插入记录

  1. 单击数据视图的左下角中的插入链接。

    显示具有空窗体字段的记录。

    单击插入链接时显示的带有空表单域的记录

    现在,您可以插入新记录。

  2. 对于该记录,请输入数据,然后单击保存以保存所做的更改,或单击取消以撤消所做的更改并返回到数据视图。

    要关注的示例中,在框中,在产品名称列中,键入奶奶的梅传播。在库存量列中的框中,键入120。在中的订购量列框中,键入0。在再订购量列中的框中,输入25。单击保存。显示具有的新记录中的数据视图。

    插入的新记录显示在数据视图中

返回页首

自定义的编辑或插入模板

使用数据视图中插入或编辑记录略有不同从例如,使用工作如 NewForm.aspx 或 EditForm.aspx 列表窗体添加或编辑 SharePoint 列表中的项目。列表或库向用户显示不同的页面时,他们添加或编辑项目,但数据视图显示不同模式。但是,每个模式提供了您可以完全自定义模板。例如,如果您自定义编辑模板,用户将看到这些自定义仅当可单击编辑链接以置于编辑模式的数据视图。

您可能希望自定义每个模式模板时,例如,要在插入或编辑记录时为用户提供特定的说明进行操作。您可以轻松地插入新行下方的列标题,并将该行的输入值,指定应每一列中输入的数据类型和何种格式的数据应 (文本、 数字等) 中的文本。

  1. 单击数据视图中,然后单击箭头 按钮图像 右上角以显示数据视图的常见任务列表。

    提示: 或者,您可以数据视图中,右键单击,然后单击快捷菜单上的显示常用控制任务

  2. 数据视图预览列表中,单击编辑模板插入的模板

    将显示该模式下数据视图中的模板。您可以通过更改字体、 格式或窗体布局自定义模板的外观。

  3. 若要保存所做的更改,在文件菜单上,单击保存

  4. 若要预览的模板在浏览器中,在文件菜单上,单击在浏览器中的预览,然后单击浏览器类型和要使用的大小。

    键盘快捷方式单击您想要在文件夹列表中,预览的页面,然后按 F12。

当在浏览器中,打开数据视图,然后单击编辑插入时将显示您创建的自定义的模板。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×