在形状之间添加连接线

在形状之间添加连接线

Office 365 订阅, Office 2019, Office 2016, Office 2013, Office 2010

凭借 Visio,可以轻松连接绘图中的形状。 可以使用“自动连接”功能在添加形状时连接这些形状,也可以使用“连接线”工具连接现有形状。 此外还可以更改在浮动工具栏中显示的形状,以及打开或关闭“自动连接”。

自动连接形状

连接页面上已存在的形状

连接到另一页面上的形状

使用主题更改连接线外观

使用备用连接线形状

更改“自动连接”浮动工具栏中的形状

打开或关闭“自动连接”功能

自动连接形状

连接形状的一种方法是在将形状添加到页面时让 Visio 自动连接这些形状。 在创建流程图时,此做法特别方便。

  1. 请确保“自动连接”功能处于活动状态。 在“视图”选项卡上的“视觉帮助”组中,确认“自动连接”处于已选中状态。

  2. 将形状从“形状”窗格拖到页面中。

  3. 将指针放置在该形状上,直到该形状周围显示“自动连接”箭头。

    当自动连接处于活动状态时,将鼠标悬停在某个形状上以显示连接箭头。
  4. 将指针放置在要按其方向添加形状的箭头上。

    将鼠标悬停在自动连接箭头上可显示要添加的形状的工具栏。

    会显示一个浮动工具栏,其中包含当前在“快速形状”模具中的前四个快速形状。 指向工具栏上的某个形状时,Visio 会在页面上显示该形状的预览。

  5. 单击要添加的形状。

  6. 如果要继续,请在新添加的形状上指向“自动连接”箭头,以添加也会被自动连接的另一个形状。

    将鼠标悬停在新添加的形状上可显示用于添加另一个形状的自动连接箭头。

返回页首

连接页面上已存在的形状

提示: “开始”选项卡上“工具”组中的命令会使 Visio 处于不同的状态或模式,不可否认,这有时会让人感到困惑。 使用键盘在“指针工具选择对象 (按 Ctrl+1)和“连接线按钮图像 (按 Ctrl+3)工具之间轻松切换。 无论使用何种工具(例如,“文本块”或“连接点”),请多次按 Esc 以返回到“指针工具”。

  1. 在“开始”选项卡上的“工具”组中,单击“连接线按钮图像 ,或按 Ctrl+3。

  2. 单击相应的形状,并将连接线拖到另一形状上。

  3. 完成后,请在“开始”选项卡上的“工具”组中,单击“指针工具选择对象 ,或按 Ctrl+1。

“连接线”工具使用每个形状末端的连接点来连接到形状。

或者,可将“连接形状”命令添加到功能区,并用于按照选择形状的顺序连接多个形状。

提示: 单击“文件”>“选项”>“自定义功能区”,可添加尚未在功能区中显示的有用命令。

返回页首

连接到另一页面上的形状

只能在同一页面上的形状之间使用连接线。 要连接到另一页面上的形状,请使用“跨页引用”形状创建页面之间的超链接,或将“超链接”和“双击操作”添加到任一形状,使其转到同一文档的其他页面。

使用跨页引用

  1. 打开“基本流程图形状”模具,然后在当前页面上拖动“跨页引用”形状。

    “跨页引用”形状
  2. 在“跨页引用”对话框中,选择“确定”,将形状添加到当前页面和新建页面中。

  3. 在新页面上,请继续创建图表。

  4. 若要更改“跨页引用”形状的外观,请右键单击形状并选择“传出”、“传入”、“圆圈”或“箭头”。

若要在页面之间移动,请在任一页面上双击“跨页引用”形状。 有关详细信息,请参阅“跨页引用”对话框

使用超链接和双击

  1. 右键单击任一形状或按“Ctrl+K”,然后选择“超链接”。

  2. 单击“子地址”字段旁的“浏览”,然后单击“页面”旁边的下拉列表,选择所需页面。

    “超链接”对话框

    注意: 也可为超链接指定目标页面上形状的名称。 单击“开发人员”选项卡,然后选择“形状名称”。使用“名称”字段中的默认名称,或编辑名称,然后单击“确定”。

  3. 要为形状设置双击操作,请单击“开发人员”选项卡,然后选择“行为”。

  4. 单击“双击”选项卡,选择“转到页面”选项,然后单击下拉列表,选择所需页面。

    Visio 双击操作

    注意: 请仅在编辑页面名称后执行此操作,因为它们不会自动更新。

返回页首

使用主题更改连接线外观

虽然连接线的默认外观可能是简单的线条,但为配合主题使用,可能会添加一些修饰,例如箭头。 通过“设计”选项卡的“主题”库可应用内置主题。

注意: 

  • 要查看更多修饰符,单击“设计”选项卡。 单击“变体”组中的下拉箭头,然后选择“连接线”。

使用备用连接线形状

任何连接线形状(例如,“更多形状”>“Visio 方案”>“连接线”模具中所提供的)均可用于连接线形状,而无需使用默认的“动态连接线”形状。 这些连接线形状可拖放至某个页面,选择其与“连接线”和“连接形状”工具配合使用,也可仅用于替换现有的连接线。

  1. 打开包含备用连接线形状的模具。

  2. 在页面中选择要替换的现有连接线。

  3. 在“编辑”组中的“主页”选项卡上,单击“更改形状”,然后选择所需的连接线形状。

注意: Visio 2013 中引入了“更改形状”功能,但“连接线”和“连接形状”工具在 Visio 2007 之前就已引入。

返回页首

更改“自动连接”浮动工具栏中的形状

浮动工具栏上的形状来自图表的“快速形状”模具。 浮动工具栏中至多显示四个形状。 可以自定义浮动工具栏上显示的形状。 以下操作步骤以“基本图表”为例。

  1. 默认情况下,浮动工具栏中的形状是模具中紧跟着“快速形状”模具的前四个形状。 例如,以下是“基础”模具中的前 4 个形状。

    使用默认基本形状的浮动工具栏
  2. 若要针对特定模具在浮动工具栏中显示不同的形状,可以将形状拖动到模具顶部来进行重新排序。 例如,可以将“四角星”、“五角星”、“六角星”和“七角星”形状拖动到“基础”模具的顶部。

    具有新基本形状的浮动工具栏
  3. 还可以在“形状”窗格中向上或向下拖动模具,更改模具的顺序。 这些形状的子集将显示在“快速形状”模具中,且按照在“形状”窗格中的显示顺序进行显示。 例如,如果在“形状”窗格中拖动“装饰性形状”,使其紧跟着“快速形状”模具,则“快速形状”模具中的顺序会发生更改。

    通过重新排序使用不同模具的浮动工具栏

    注意: 在关闭并重新打开图表后,“形状”窗格中的默认模具顺序将自动还原并反映在“快速形状”中。

  4. 若要将不同的模具用作浮动工具栏的基础,请在“快速形状”模具中,在模板的这些形状子集中选择一个形状。 例如,选择“图形和数学形状”模具中的“维恩图”。

    通过选择使用新模具的浮动工具栏

提示: 若要还原到模具中的默认形状顺序,请右键单击“形状”窗格中的模具名称,然后选择“重置模具”。

注意: 并非所有模具均具有可用于浮动工具栏的形状。 例如,浮动工具栏上不显示“箭头形状”模具中的形状。

返回页首

打开或关闭“自动连接”功能

可对当前绘图激活和停用“自动连接”功能,或对所有 Visio 绘图默认激活和默认停用此功能。

打开或关闭活动图表中的“自动连接”功能

  • 在“视图”选项卡上的“视觉帮助”组中,选中或清除“自动连接”。

    在“视图”选项卡上选中或清除“自动连接”以激活或停用自动连接。

如果“自动连接”复选框不可用,请通过执行以下过程检查是否已关闭了所有图表的“自动连接”功能。

打开或关闭所有图表中的“自动连接”功能

  1. 单击“文件”选项卡,然后单击“选项”。

  2. 在“Visio 选项”中,单击“高级”。

  3. 在“编辑选项”下,选择“启用自动连接”复选框可激活“自动连接”功能。 清除“自动连接”复选框可停用“自动连接”功能。

    选中或清除“启用自动连接”以对所有图和绘图激活或停用自动连接。
  4. 单击“确定”

返回页首

使用“自动连接”功能连接形状

连接形状的一种方法是在将形状添加到绘图时让 Visio 自动连接这些形状。 在创建流程图时,此做法特别方便。

使用以下过程将形状添加到绘图,这样 Visio 便会自动连接到现有形状。

将形状拖入页面时使用自动连接

  1. 将形状从模具拖到绘图页上,并将其放置在靠近另一个形状的位置。

    放到另一个形状附近的形状

  2. 按住鼠标按钮的同时将指针移到一个蓝色三角形上。 三角形会变为深蓝色。

    指针停留在蓝色三角形上

  3. 释放鼠标按钮。 形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

    形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

提示: 如果不喜欢拖动形状,则可以通过以下方法实现相同的效果:首先在模具中选择一个形状,将指针停留在绘图中的某个形状上,然后单击该形状周围显示的蓝色三角形之一。

对页面上已存在的形状使用“自动连接​​”功能

  1. 将指针停留在要从其进行连接的形状上。

    停留在要从其进行连接的形状上的指针。

  2. 将指针放在离要连接到的形状最近的蓝色三角形上。

    放置在离要连接到的形状最近的蓝色三角形上的指针。

    三角形会变为深蓝色,并且要连接到的形状周围会出现一个红色的框。

    注意: 如果要连接到的形状周围未出现红色的框,该形状可能离得太远了。 将形状移到相对近一点的位置,然后重试。

  3. 单击蓝色的三角形。 两个形状上会添加并粘附一条连接线。

    形状会置于绘图页上,两个形状上会添加并粘附一条连接线。

启用或禁用“自动连接”功能

可以启用或禁用所有 Visio 绘图中的“自动连接”功能,也可以只启用或禁用当前绘图中的“自动连接”功能。 对于所有绘图:

  1. 在“工具”菜单上,单击“选项”。

  2. 单击“常规”选项卡。

  3. 在“绘图窗口”选项下,选择“启用自动连接”复选框。

仅对于当前绘图:

  • 在“标准”工具栏上,单击“自动连接”工具。

    注意: 如果单击“自动连接”工具未能启用自动连接,请首先确保“选项”对话框中的“启用自动连接”复选框处于选中状态。

使用“连接线”工具连接形状

用于添加和粘附连接线的最灵活的方法之一是使用“标准”工具栏上的“连接线”工具 按钮图像 绘制此连接线。

  1. 在“标准”工具栏上单击“连接线”工具 按钮图像

  2. 执行下列操作之一:

    • 若要使连接线保持为粘附到某个形状的特定点上,请从第一个形状上的连接点 连接点图像 - 蓝色 X 拖动到第二个形状上的连接点。 形状连接后,连接线端点会变为红色。 这称为点对点连接。 凭借点对点连接,在移动其中一个形状时可以使连接线能始终粘附到相同的连接点。

    • 若要使连接线能够移动到最近的可用连接点,请将“连接线”工具放在第一个形状的中心位置,直到该形状周围出现红色的框。 按住鼠标按钮,并拖动到第二个形状的中心。 第二个形状周围出现红色的框时,释放鼠标按钮。 这称为形状到形状的连接。 凭借形状到形状的连接,在移动其中一个形状时可以使连接线通过移动到最近的可用连接点以始终粘附到其中一个形状。 如果连接点未出现,连接线则会移动到最近的那侧。

      注意: 也可以在形状之间创建连接,其中连接线的一端连接到一个连接点,而连接线的另一端则连接到形状(反之亦然)。

  3. 单击“标准”工具栏上的“指针”工具 指针按钮 以返回正常编辑状态。

    注意: 

    • 若要添加从一个形状到多个形状的连接线,需要添加多条连接线;没有可用的“分支”连接线形状。

    • 如果在尝试创建点对点连接时难以将连接线粘附到所需的确切位置,请尝试其他的对齐和粘附设置:

    • 在“工具”菜单上,单击“对齐和粘附”,然后在“常规”选项卡上选择所需选项。

      如果粘附到形状几何图形、形状句柄或形状顶点,则会自动添加连接点(如果连接点尚不存在)。

在形状和点连接之间进行切换

可以将连接线从一个形状上的某点粘附到不同形状上的另一点,或从整个形状粘附到另一整个形状。 还可以创建以下连接:连接线的一端粘附到形状上的点,而另一端粘附到整个形状。

  1. 拖动连接线的端点,使其远离形状。

  2. 执行下列操作之一:

    • 若要将连接线的端点粘附到形状上的连接点,请将端点拖动到形状的某个连接点,直到该连接点周围出现红色的框。

    • 若要将连接线的端点粘附到整个形状,请向形状中部拖动端点,直到整个形状周围出现红色的框。

另请参阅

添加和编辑连接线文本

创建自定义连接线

粘附和取消粘附连接线

Visio 培训

有关 Visio 桌面版连接线的一切(Visio 团队博客)

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×