在单个数据视图中显示多个源中的数据

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

大多数企业将相关的数据存储在不同的位置。例如,产品信息存储在.xml 文件中名为视图,但产品类别的信息存储在名为 categories.xml 的另一个.xml 文件中。一个名为类别 id 字段是与两个数据源相关的另一。

使用Microsoft Office SharePoint Designer 2007,您可以轻松地将包含相关的数据的数据源的链接,然后创建单个数据视图显示这些链接的数据源中的数据。您甚至可以链接不同类型的数据源,例如,您可以链接到 SQL 数据库的 XML 文件。

链接数据源后,您将创建一个数据源显示在所有其他数据源的数据源库中。创建此链接的数据源的视图非常相似创建任何其他数据视图。然后,创建链接的数据源的数据视图之后,您可以筛选、 排序、 分组、 设置格式,或执行任何操作,您可以执行任何其他数据视图的数据视图。

本文介绍了如何创建两个示例 XML 文件,以用作数据源、 如何链接的两个数据源,以及如何创建单个数据视图显示两个数据源中的数据。此文章使用.xml 文件作为数据源,以便您可以轻松地创建数据源并跟踪。但是,下面的过程与任何数据源,包括 SQL 数据库工作。

重要: 本文讨论在位于运行Windows SharePoint Services 3.0的服务器的 SharePoint 网站中创建数据视图。并非所有功能都可能如果您的网站不运行Windows SharePoint Services 3.0的服务器上可用。

若要了解有关数据视图的详细信息,请参阅创建数据视图

本文内容

创建两个.xml 文件作为示例数据源

链接数据源

创建数据视图

建议的后续步骤

创建两个.xml 文件作为示例数据源

罗斯文商贸维护其产品列表中的 XML 格式。它们还维护类别列表。通过一个名为类别 id 字段相关联的两个列表。通过链接这两个 XML 文件,并创建单个数据视图,您可以轻松地创建的产品类别进行组织的产品的列表。

创建视图

如果您已经为创建数据视图创建视图,请跳至下一节。

  1. 文件菜单上,单击打开网站

  2. 打开网站对话框中,浏览到并选择您的 SharePoint 网站,然后单击打开

  3. 如果出现提示,请在连接到对话框中,键入您的用户名和密码,,然后单击确定

  4. “文件”菜单上,单击“新建”

  5. 新建对话框中,双击文本文件

  6. 通过选择它们,然后按 CTRL + C 复制下面的代码行。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. 在Office SharePoint Designer 2007,顶部的页面上,将插入点的位置,然后按 CTRL + V 粘贴您刚刚复制到页面的代码。

  8. “文件”菜单上,单击“另存为”

  9. 另存为对话框中,在文件名框中,键入视图

  10. 保存类型列表中,单击XML,,然后单击保存

创建 categories.xml 的

  1. 如果您有打开 SharePoint 网站,请跳至步骤 4。否则,在文件菜单上,单击打开网站

  2. 打开网站对话框中,浏览到并选择您的 SharePoint 网站,然后单击打开

  3. 如果出现提示,请在连接到对话框中,键入您的用户名和密码,,然后单击确定

  4. “文件”菜单上,单击“新建”

  5. 新建对话框中,双击文本文件

  6. 通过选择它们,然后按 CTRL + C 复制下面的代码行。

    <?xml version="1.0" encoding="utf-8"?>
    <CategoriesRoot>
    <Categories>
    <CategoryID>1</CategoryID>
    <CategoryName>Beverages</CategoryName>
    <Description>Soft drinks, coffees, teas, beer, and ale</Description>
    </Categories>
    <Categories>
    <CategoryID>2</CategoryID>
    <CategoryName>Condiments</CategoryName>
    <Description>Sweet and savory sauces, relishes, spreads, and seasonings</Description>
    </Categories>
    <Categories>
    <CategoryID>3</CategoryID>
    <CategoryName>Confections</CategoryName>
    <Description>Desserts, candies, sweetbreads</Description>
    </Categories>
    <Categories>
    <CategoryID>4</CategoryID>
    <CategoryName>Dairy Products</CategoryName>
    <Description>Cheeses</Description>
    </Categories>
    <Categories>
    <CategoryID>5</CategoryID>
    <CategoryName>Grains/Cereals</CategoryName>
    <Description>Breads, crackers, pasta, and cereal</Description>
    </Categories>
    <Categories>
    <CategoryID>6</CategoryID>
    <CategoryName>Meat/Poultry</CategoryName>
    <Description>Prepared meats</Description>
    </Categories>
    <Categories>
    <CategoryID>7</CategoryID>
    <CategoryName>Produce</CategoryName>
    <Description>Dried fruit and bean curd</Description>
    </Categories>
    <Categories>
    <CategoryID>8</CategoryID>
    <CategoryName>Seafood</CategoryName>
    <Description>Seaweed and fish</Description>
    </Categories>
    </CategoriesRoot>
  7. 在Office SharePoint Designer 2007,顶部的页面上,将插入点的位置,然后按 CTRL + V 粘贴您刚刚复制到页面的代码。

  8. “文件”菜单上,单击“另存为”

  9. 另存为对话框中,在文件名框中,键入categories.xml 的

  10. 保存类型列表中,单击XML,,然后单击保存

返回页首

链接数据源

您可以创建显示多个来源的数据的数据视图之前,必须首先通过使用数据源库链接数据源。要创建的因此您需要创建数据源链接到 categories.xml 的文件的视图文件的产品类别进行组织的产品的列表。

  1. 任务窗格菜单上,单击数据源库

  2. 数据源库任务窗格中,单击链接的源旁边的加号 (+),然后单击创建新的链接源

  3. 数据源属性对话框中,单击配置链接源

  4. 在链接数据源向导中,在可用数据源,下单击categories.xml 的,然后单击添加。接下来,单击视图,,然后单击添加

  5. 单击“下一步”

  6. 选择最适合表示所选源之间的关系的链接类型中,单击加入使用数据源详细信息,以插入数据视图的数据源的内容和联接子视图

    有两个选项︰ 合并或联接。必须具有相同字段要合并到单个数据源的不同数据源时,您可以合并数据。有两个不同数据源中的非公共字段,将一个数据源与其他数据源相关联时,您可以加入数据。视图和 categories.xml 的是公共的类别 id 字段的两个不同数据源,因为您要加入的两个数据源。

  7. 单击“完成”

  8. 数据源属性对话框中,单击常规选项卡。

  9. 名称框中,键入类别和产品

  10. 单击“确定”。

    数据源库的链接源部分,显示名为“类别和产品”的新数据源

    在数据源库中,在链接源,下,您可以看到新的链接的数据源。

返回页首

创建数据视图

既然您已经链接数据源,您可以创建通过使用数据源详细信息任务窗格中显示链接的数据源中的数据的数据视图。

要为其创建数据视图按产品类别的产品列表。对于中 categories.xml 的每个类别,可以在每个类别从视图中显示的产品。

因为想要创建的数据视图,按类别显示每个产品,首先要为其创建 categories.xml 的视图。

数据视图基于 Microsoft ASP.NET 2.0 技术。若要创建数据视图,您必须以 ASP.NET 页 (.aspx 文件) 开头。在此示例中,将创建一个新的 ASP.NET 页,然后在页面中插入数据视图。

  1. “文件”菜单上,单击“新建”

  2. 新建对话框中,双击ASPX

    打开窗体标记的新页面。

    ASP.NET form 标记

  3. 数据视图菜单上,单击插入数据视图

    空数据视图显示在页面上,并且数据源库任务窗格随即打开。

    空数据视图

    既然您已插入数据视图中,您就可以添加数据。

  4. 数据源库任务窗格中,单击链接源旁边的加号 (+),单击类别和产品,然后单击显示数据

    首先,您希望创建的 categories.xml 的数据视图。

  5. 数据源详细信息任务窗格中类别文件夹中,单击类别名称。按下并按住 CTRL 同时单击说明

    在“数据源详细信息”任务窗格的“Categories”文件夹中选中的两个域

  6. 单击插入为选定的域,然后单击插入数据视图中所选的数据的多个项目视图

    注意: 单项目视图数据视图中显示一条记录。多个项目视图显示多个记录,且每个列的标题和列中的字段。

    在数据视图中显示您现在在数据源详细信息任务窗格中选择的字段。

    显示来自 categories.xml 的记录的数据视图

    在下一步中,您将创建新列中的数据视图中显示子视图 (在另一个数据视图的单元格中显示的数据视图)。

  7. 在数据视图中,右键单击说明栏,在快捷菜单上,单击插入,然后单击右侧的列

  8. 将插入点放置在新列中的单元格内。

  9. 数据源详细信息任务窗格中产品文件夹中,单击ProductName。按下并按住 CTRL 的同时单击库存UnitsOnOrder,然后再订购量

    “数据源详细信息”任务窗格中的“Products”文件夹

  10. 单击插入为所选的字段,然后单击联接子视图

    联接子视图是已加入的常见字段的另一个数据源的数据源的子视图。在下一步中,将链接到视图中的类别 Id 字段 categories.xml 的中的类别 Id 字段。

  11. 联接子视图对话框中,在类别下单击类别 Id。下产品,请单击类别 id,,然后单击确定

    “联接子视图”对话框

    您现在在数据源详细信息任务窗格中选择的字段显示在新列中。由于链接两个源之间的类别 id字段,仅在饮料列表中显示的产品的饮料仅调味品调味品列表中显示,依此类推。

    数据视图,在列表中的关联类别内显示产品列表的子视图

返回页首

建议的后续步骤

数据视图是强大、 完全可自定义的实时数据源。创建数据视图的链接的数据源后,您可以自定义数据视图相同数据的任何其他视图。既然您已经学习了如何创建显示多个来源的数据的单个数据视图,您可能希望了解操作方法︰

  • 在数据视图中筛选数据   您可以轻松地筛选数据视图中的数据。有关详细信息,请参阅在数据视图中筛选数据

  • 排序数据视图中的对数据进行分组和    可以快速排序或分组数据视图中的数据。有关详细信息,请参阅排序数据视图中的对数据进行分组和

  • 向数据视图应用条件格式   您可以应用特定格式向数据视图时在数据视图中的数据符合特定条件。有关详细信息,请参阅向数据视图应用条件格式

  • 创建数据视图中的公式栏   就像可以与电子表格,您可以添加到您的数据视图中对数据执行计算,并在单独的列中显示结果的公式。有关详细信息,请参阅创建数据视图中的公式栏

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×