在单个工作簿中创建并保存所有宏

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

当您首次创建宏的工作簿中,其工作方式仅在该工作簿中。但是,如果您想要在其他工作簿中使用宏?每次打开 Excel 提供您的宏,可以在称为 Personal.xlsb 工作簿中创建它们。这是您在后台中每次打开 Excel 时打开的计算机上存储的隐藏工作簿。

宏和 VBA 工具位于“开发工具”选项卡上,由于该选项卡默认是隐藏的,因此第一步是启用选项卡。有关详细信息,请参阅显示“开发工具”选项卡

功能区上的“开发工具”选项卡

接下来,创建宏。我们将录制宏不执行任何操作,但将创建个人宏工作簿。

您可以了解有关创建宏在快速入门: 创建宏

  1. 转到开发工具选项卡,然后单击录制宏

    “开发工具”选项卡上的“代码”组

  2. 录制宏对话框中,不会在宏名框中输入该宏的名称。您可以接受 Excel 为您提供,如 Macro1,因为这是临时的宏的名称。

    当您执行开始创建您自己的宏时,您需要授予其描述性名称,以便您知道他们执行哪些操作。

  3. 将宏保存在框中,选择个人宏工作簿>确定。这是最重要的步骤,因为如果您还没有个人宏工作簿,Excel 会为您创建一个。

  4. 单击开发人员>停止录制、 和 Excel 就可以创建您的个人宏 worbook。

  5. 关闭工作簿时,将提示您保存工作簿,并个人宏工作簿。

若要查看您所创建的宏:

  1. 转到开发人员> Visual Basic以启动Visual Basic 编辑器 (VBE),这是您的宏的存储位置。

  2. 在左侧的项目资源管理器窗格中,您可以找到您的个人宏工作簿。如果您看不到它,请转到视图>项目资源管理器

  3. 双击VBA 项目 (PERSONAL.xlsb)文件夹 >模块> Module1,并且您将找到您录制的空 Macro1。您可以将其删除,或保留它以将代码添加到更高版本。

    注意: 在 Excel 的新实例中录制宏时,VBA 将自动创建一个新的模块文件夹,并增加其号。因此,如果您已经拥有 Module1 和 Module2,VBA 将创建 Module3。可以重命名模块下方的项目资源管理器中,属性窗口中,以便更好地反映在其中的宏执行哪些操作。

将宏从一台计算机移至另一台计算机

Personal.xlsb 文件存储在一个名为XLSTART文件夹中。如果您想要与其他人共享您的宏,您可以将其复制到其他计算机,请 XLSTART 文件夹或复制到其他计算机上的 Personal.xlsb 文件的部分或全部及其宏。您可以搜索 XLSTART 在Windows 资源管理器以找到它。

如果您有一项或只是想要与其他人共享的几个宏,您可以向他们发送包含它们的工作簿。共享的网络驱动器上或从 SharePoint Services 库,也可以使工作簿可用。

有关将宏从一个工作簿复制到另一个工作簿的详细信息,请参阅将宏模块复制到另一个工作簿中

确保在功能区上能够看到“开发工具”选项卡。默认情况下,“开发工具”选项卡不可见,因此请执行以下操作:

  1. 转到Excel >首选项...>功能区和工具栏

  2. 自定义功能区类别中的主选项卡列表中,选择开发工具复选框,然后单击保存

接下来,创建宏。我们将录制宏不执行任何操作,但将创建个人宏工作簿。

您可以了解有关创建宏在快速入门: 创建宏

  1. 转到开发工具选项卡,然后单击录制宏

  2. 录制宏对话框中,不会在宏名框中输入该宏的名称。您可以接受 Excel 为您提供,如 Macro1,因为这是临时的宏的名称。

    当您执行开始创建您自己的宏时,您需要授予其描述性名称,以便您知道他们执行哪些操作。

  3. 将宏保存在框中,选择个人宏工作簿>确定。这是最重要的步骤,因为如果您还没有个人宏工作簿,Excel 会为您创建一个。

  4. 单击开发人员>停止录制、 和 Excel 就可以创建您的个人宏 worbook。

  5. 关闭工作簿时,将提示您保存工作簿,并个人宏工作簿。

若要查看您所创建的宏:

  1. 单击开发人员> Visual Basic以启动Visual Basic 编辑器 (VBE),这是您的宏的存储位置。

  2. 在左侧的项目资源管理器窗格中,您可以找到您的个人宏工作簿。如果您看不到它,请转到视图>项目资源管理器

  3. 双击VBA 项目 (PERSONAL.xlsb)文件夹 >模块> Module1,并且您将找到您录制的空 Macro1。您可以将其删除,或保留它以将代码添加到更高版本。

注意: 在 Excel 的新实例中录制宏时,VBA 将自动创建一个新的模块文件夹,并增加其号。因此,如果您已经拥有 Module1 和 Module2,VBA 将创建 Module3。可以重命名模块下方的项目资源管理器中,属性窗口中,以便更好地反映在其中的宏执行哪些操作。

将宏从一台计算机移至另一台计算机

Personal.xlsb 文件存储在系统启动文件夹中。如果您想要与其他人共享您的宏,您可以将 Personal.xlsb 复制到其他计算机,请在启动文件夹或复制到其他计算机上的 Personal.xlsb 文件的部分或全部及其宏。在Finder中,选择,然后按住Option键,然后选择。 在窗格中,导航到:组容器> xyz。Office (其中 xyz 是文本字符串,如"UBF8T346G9") >用户内容>启动> Excel。将 Personal.xlsb 文件粘贴到 Excel 文件夹。

如果您有一项或只是想要与其他人共享的几个宏,您可以向他们发送包含它们的工作簿。共享的网络驱动器上或从 SharePoint Services 库,也可以使工作簿可用。

有关将宏从一个工作簿复制到另一个工作簿的详细信息,请参阅将宏模块复制到另一个工作簿中

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×