在共享笔记本中进行协作

概述

OneNote 2010 与通过 Web 浏览器连接的其他作者共享 OneNote 2010 笔记本。 从桌面或浏览器启动共享;设置文件夹权限;在笔记本中与其他人共同创作;以及同步更改。

在完成本课程之后,您将能够:

  • 从 OneNote 2010 或 OneNote Online 创建共享笔记本,从而通过OneDrive 网站进行共享。

  • 设置权限级别并邀请其他人在笔记本中工作。

  • 在 OneNote 2010 和 OneNote Online 中共同创作,从而同步更改。

  • 删除共享笔记本。

本课程包括:

  • 一个自定学习进度的课程。

  • 课程结束后,您可以打印课程摘要卡。

如果您不熟悉 OneNote 或想要了解有关 OneNote 2010 的详细信息,请参阅 OneNote 2010 入门

了解Microsoft Office 培训提供的更多课程。

脱机版本 (56 MB)

两个朋友、一个行程

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

从 OneNote 2010 创建共享笔记本

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

在笔记本中同步更改

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

从 OneNote Online 创建共享笔记本

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

从桌面和浏览器共同创作

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

删除共享笔记本

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意 SkyDrive 现在是 OneDrive,而 SkyDrive Pro 现在是 OneDrive for Business。 在从 SkyDrive 到 OneDrive 上阅读有关此更改的详细信息。

反馈

课程摘要卡

另请参阅

从 OneNote 2010 创建共享笔记本

第 1 部分:从 OneNote 连接到 OneDrive

  1. 在 OneNote 中,单击“文件”选项卡,并确保选中“新建”。
    提示    您可以通过单击功能区上的“共享”和“新建共享笔记本”转到同一位置。

  2. 在“将笔记本存储在以下位置”下,确保选中“Web”。

  3. 键入笔记本名称。

  4. 在“Web 位置”下,执行下列操作:

  5. 如果您没有 Windows Live ID,单击“OneDrive”或“注册 OneDrive”,创建 ID,然后登录。

  6. 如果您已拥有 Windows Live ID,请单击“登录”。
    提示    若要在此次之后绕过登录,请选择“记住我的 ID 和密码”复选框。
    请注意,“自动登录”复选框也应处于选中状态。

    OneNote 将连接到 OneDrive。

第 2 部分:创建文件夹并设置共享权限

作为此文件夹的创建者,您是唯一能够设置权限级别的人员。

注意    如果您已创建要在 OneDrive 上使用的文件夹,可以继续第 3 部分步骤 3;但是您需要通过指定朋友的姓名设置文件夹的权限。 下面的“在 OneDrive 上创建和共享文件夹及文档”一节中对此过程进行了介绍。

  1. 在 OneNote 中,OneDrive 上的当前文件夹显示在“Web 位置”下。 (确保 OneNote 仍显示“文件”选项卡、“新建”。)

  2. 若要为笔记本创建文件夹,请单击“新建共享文件夹”。
    将出现 OneDrive 登录页面,并在其中显示您的 ID。

  3. 指向登录区域,然后单击“继续”。

  4. 在 OneDrive 中的“创建文件夹”页面上,键入新文件夹名称。

  5. 在文件夹名称下的“共享者:只有我”旁边,单击“更改”。

  6. 将滑块拖到所需共享级别,例如,拖到“某些朋友”。
    注意    您可以通过“某些朋友”和“朋友”设置授予他人编辑和查看权限。

  7. 所选级别旁边有用于编辑或查看的选项;另请注意,如果添加朋友姓名,则要为每位朋友设置特定权限,操作方法如下..

  8. 若要指定朋友,请在“添加其他联系人”下添加他们的电子邮件地址,然后在每个姓名后按 Enter。 (如果有从“联系人”列表添加姓名的链接,则您将看到此链接。)
    姓名将添加到方框下面的列表中。

  9. 在每个朋友姓名的旁边,选择权限类型,即“可以查看文件”或“可以添加、编辑详细信息和删除文件”。
    注释 此权限级别适用于此文件夹中的所有文件。 因此,如果您授予某个朋友编辑权限,则他或她对此文件夹中的每个文件都具有这些权限。

  10. 单击“下一步”
    这将打开新文件夹并提示您添加文件。

  11. 关闭 OneDrive。

第 3 部分:创建笔记本并通知朋友

  1. 在 OneNote 中,仍应显示“文件”、“新建”选项卡。

  2. 在“Web 位置”下,单击“刷新”,随即将显示您创建的文件夹。
    注意    您将在文件夹上看到“人员”图标,显示您已共享该文件夹。

  3. 选择新文件夹(如果未创建新文件夹,则选择现有文件夹),然后单击“创建笔记本”。

  4. 此时将打开新的笔记本,并且系统会提示您向共享的朋友发送电子邮件。

  5. 单击“通过电子邮件发送链接”,然后填写指定朋友的电子邮件地址。 将自动填充“主题”行。
    消息中将为收件人提供两个共享笔记本链接:其中一个链接将在安装了 OneNote 2010 的计算机上的 OneNote 2010 中打开笔记本;另一个链接将在 OneNote Online 的浏览器中打开笔记本。

  6. 单击“发送”。

    您即可着手在笔记本中工作。

提示    若要日后邀请朋友,请依次单击“文件”选项卡、“共享”;然后确保选中笔记本并单击“向他人发送关于该笔记本的电子邮件”。 您需要授予所有收件人查看或编辑笔记本的权限,以便他们能够访问笔记本。

在以下位置创建和共享文件夹及文档: OneDrive

下面介绍您需要了解如何在 OneDrive 上执行的任务:

注意    我们创建本课程的视频后,OneDrive 网站上将进行一些设计更新。 下面的步骤反映新的设计。

在以下位置登录到您的文档: OneDrive

  1. 使用网址 http://office.live.com 打开 OneDrive 的登录页面。

  2. 使用您的 Windows Live ID 和密码登录。

  3. OneDrive 将打开您的“文档”页面。

创建文件夹并设置权限

  1. 若要为您的笔记本创建新文件夹,请在页面顶部的“创建”旁边单击“创建文件夹”图标(位于 Office Online 图标旁边)。

  2. 为文件夹命名。

  3. 在文件夹名称下的“共享者:只有我”旁边,单击“更改”。

  4. 将滑块拖到所需共享级别,例如,拖到“某些朋友”。
    注意    您可以通过名为“某些朋友”和“朋友”的设置授予他人编辑和查看权限。

  5. 所选级别旁边有用于编辑或查看的选项;另请注意,如果添加朋友姓名,则要为每位朋友设置特定权限,操作方法如下。

  6. 若要指定朋友,请在“添加其他联系人”下添加他们的电子邮件地址,然后在每个姓名后按 Enter。 (如果有从“联系人”列表添加姓名的链接,则您将看到此链接。)
    姓名将添加到方框下面的列表中。

  7. 在每个朋友姓名的旁边,选择权限类型,即“可以查看文件”或“可以添加、编辑详细信息和删除文件”。
    注释 此权限级别适用于此文件夹中的所有文件。 因此,如果您授予某个朋友编辑权限,则他或她对此文件夹中的每个文件都具有这些权限。

  8. 单击“下一步”
    这将打开文件夹并提示您将文件放于此处。 如果要创建笔记本,请参阅下一个练习。

在 OneNote Online 中创建笔记本

  1. 当您登录时,OneDrive 将打开您的“文档”页面。
    提示    如果您处于另一个页面上并且不知道如何查看文件夹视图,请找到页面顶部的“OneDrive”链接,指向该链接,然后单击“文档。 或者,您可能需要单击OneDrive”链接,这将打开“文档”页面。

  2. 单击以打开要放置新笔记本的文件夹。

  3. 在页面顶部的“创建”旁边,单击“OneNote 笔记本”图标。

  4. 为笔记本命名,然后单击“保存”。

    OneNote Online 将打开新的笔记本供您在其中工作。

从 OneNote Online 邀请他人加入笔记本

实际上,您正在更改文件夹权限,虽然不是必须从笔记本内部启动共享,但是您仍可这样操作。

  1. 在笔记本中,单击“文件”选项卡,然后单击“共享”。

  2. 如果您已与他人共享此文件夹,则将打开文件夹的“权限”页面,同时向您显示可以访问此文件夹的人员及其权限级别。
    (如果您以前尚未共享该文件夹,则将显示“编辑权限”页面,您可以向下跳到步骤 5,操作方法如下。)

  3. 若要更改权限以便您能够邀请新用户,请单击位于所有者名称上方的文件夹链接,其中表明权限来自当前文件夹。

  4. 这将显示文件视图;请在右侧单击“编辑权限”。

  5. 在“可访问此文件夹的人员”下更改权限级别,然后添加朋友的姓名。 单击“保存”后,系统将提示您向已添加其姓名的朋友发送通知。

更改权限和发送通知

  1. 在“文档”页面上,单击要更改权限的文件夹。 将显示文件夹中的文件。

  2. 单击右侧的“编辑权限”。 更改权限级别并添加朋友的姓名。 单击“保存”后,系统将提示您向已添加其姓名的朋友发送通知。

向文件夹发送链接

若要向文件夹(及其中的笔记本)发送邀请朋友的链接,请执行下列操作:

  1. 在“文档”页面上,单击要向其发送链接的文件夹。 将显示文件夹中的文件。

  2. 单击右侧的“发送链接”。
    收件人”行中将填充您已与其共享文件夹的人员的姓名。

  3. 为帮助确保只有您的朋友可打开笔记本,请选择“需要收件人使用 Windows Live ID 登录”。

  4. 单击“发送”。

获取发送给朋友或公众的链接

  1. 在“文档”页面上,单击要向其发送链接的文件夹。 将显示文件夹中的文件。

  2. 单击右侧的“获取链接”。

  3. 若要与您已授予权限的朋友进行共享,请单击“复制此链接以共享”,然后粘贴并以电子邮件形式发送链接。

  4. 若要与某个组进行共享并且无需他们拥有权限,请单击“创建链接”;然后单击“复制此链接以共享”,然后粘贴并以电子邮件形式发送链接。

查找和打开共享笔记本

在 OneNote 2010 中打开共享笔记本

如果在 OneNote 2010 中创建共享笔记本,则将在您的计算机上存储此笔记本的链接,并将在启动 OneNote 时始终打开此笔记本。

如果您在 OneNote 2010 中通过右键单击笔记本标题,然后单击“关闭此笔记本”关闭了笔记本,下面是将其再次打开的方法:

  1. 在 OneNote 2010 中,单击“文件”选项卡,然后单击“打开”。

  2. 在“最近关闭的笔记本”下,单击笔记本以将其打开。

如果您从未打开当前计算机上的共享笔记本,请执行下列操作:

  1. 使用网址 http://office.live.com 登录到 OneDrive。

  2. 在 OneDrive“文档”页面上,单击以打开包含笔记本的文件夹。

  3. 单击笔记本,以在 OneNote Online 中将其打开。

  4. 或者:OneDrive单击“开始”选项卡上的“在 OneNote 中打开”。 或者:

  5. 单击“文件”选项卡,然后单击“在 OneNote 中打开”。

通过电子邮件链接打开笔记本

来自 OneNote 2010 的邀请

如果您收到来自 OneNote 2010 的笔记本邀请,则将拥有两个笔记本链接。

指向 OneNote 2010 的链接    如果计算机上已安装 OneNote 2010,请单击 OneNote 2010 链接以在 OneNote 中打开笔记本。
提示    在某些电子邮件程序中,您需要将链接复制并粘贴到浏览器窗口中,以打开笔记本。

指向 OneNote Online 的链接    单击此链接,以在 OneNote Online 的浏览器中打开笔记本。
提示    假定您不是笔记本的创建者也不是笔记本所在文件夹的创建者:当您收到链接时,请在 OneDrive 上将笔记本打开一次(即时您当时不打算使用笔记本),然后将其关闭。 这会将笔记本放于 OneDrive 上的“最近使用的文档”中,当您在 OneDrive 上导航时始终能在此找到该笔记本。

来自 OneNote Online 的邀请

如果您收到来自 OneDrive 的笔记本邀请,则将拥有一个指向包含该笔记本的 OneDrive 文件夹的链接。

  1. 单击电子邮件中的文件夹链接。

  2. 单击笔记本,以在 OneNote Online 中将其打开。

在以下位置的 OneNote Online 中打开笔记本: OneDrive

如果您拥有此笔记本,请执行下列操作:

  1. 使用网址 http://office.live.com 登录到 OneDrive。

  2. 在 OneDrive“文档”页面上,单击以打开包含笔记本的文件夹。

  3. 单击笔记本,以在 OneNote Online 中将其打开。

如果他人与您共享此笔记本,请执行下列操作:

  1. 使用网址 http://office.live.com 登录到 OneDrive。

  2. 在 OneDrive“文档”页面上的“快速视图”下,单击“最近使用的文档”。

  3. 单击笔记本,以在 OneNote Online 中将其打开。

确定其他作者的更改

执行下列任一操作来查找其他作者对笔记本所做的更改。

在 OneNote 2010 中

  • 在“共享”选项卡上,使用“隐藏作者”命令显示作者的姓名缩写。 切换以将其关闭。

  • 在“共享”选项卡上,单击“按作者查找”,然后在“按作者更改”窗格中,单击要跟踪其工作的作者。 单击显示的任何部分链接以查看完成的工作,给定日期的已完成工作在该部分中突出显示。

  • 在“共享”选项卡上,单击“最近的编辑”,然后选择要检查其更改的日期范围。 在“页面更改…”窗格中,向下钻取以检查更改。

在 OneNote Online 中

  • 单击“视图”选项卡,然后单击“显示作者”以查看更改旁边的作者姓名。

提示    若要标记键入到其他作者的文本,请使用“主页”选项卡上的“标记”组来标记问题、待办事项、建议等。

还原页面版本

如果您确定更希望在笔记本中保留早期的页面版本,请使用页面版本将其还原。

在 OneNote 2010 中

  1. 单击“共享”选项卡,然后单击“页面版本”以显示页面的所有版本。

  2. 若要查看页面版本,请单击您要查看的版本的“页面”选项卡。

  3. 若要将页面还原到早期版本,请右键单击所需版本的“页面”选项卡,然后单击“还原版本”。

  4. 若要删除页面版本,请右键单击要删除的版本的“页面”选项卡,然后单击“删除版本

在 OneNote Online 中

  1. 单击“查看”选项卡,然后单击“页面版本”。

  2. 若要查看页面版本,请单击您要查看的版本的“页面”选项卡。

  3. 若要将页面还原到早期版本,请右键单击所需版本的“页面”选项卡,然后单击“还原”。

  4. 若要删除页面版本,请右键单击要删除的版本的“页面”选项卡,然后单击“删除”。

共享笔记本中的同步控制

  • OneNote 每 10 分钟对所有笔记本进行一次同步;每 5 到 30 秒对当前显示页面所做的更改进行一次同步。

  • 若要将 OneNote 2010 上的更改同步到 OneDrive 上的共享笔记本,则您需要打开 OneNote,并且 OneNote 需要具有 OneDrive 的访问权限。

在 OneNote 2010 中同步

同步状态图标

这些图标显示在导航栏中的笔记本标题旁边,其含义如下:

绿色旋转箭头    笔记本已连接,并且正在将更改同步到 OneDrive 上的共享笔记本。

带有选中标记的绿色箭头    已同步所有更改。

带有斜杠的红色符号    无法同步更改。 有时,您需要在打开 OneNote 时单击笔记本顶部要求您登录到 OneDrive 的消息;这以红色符号显示。 或者,这意味着您没有 Internet 连接。

  • 若要获取有关同步错误的详细信息,请右键单击同步图标,然后单击“笔记本同步状态”,这将打开“共享笔记本同步”对话框及更多详细信息。

触发同步

  • 如果要加快同步,请右键单击同步图标,然后单击“立即同步此笔记本”。

关闭自动同步

  1. 右键单击同步图标,然后单击“笔记本同步状态”。
    自动同步默认为启用状态,并可在“共享笔记本同步”对话框顶部进行选择。

  2. 若要将其关闭,请单击“脱机工作”。

  3. 当 OneNote 重新连接到 OneDrive 并且您已准备好同步更改时,请右键单击同步图标并单击“立即同步此笔记本”,或单击“笔记本同步状态”并在对话框中单击“立即同步”。

在 OneNote Online 中触发同步

  • 按 F9。

在 OneNote Online 中切换视图

编辑视图    这将显示功能区并启用编辑命令。 若要切换到“阅读”视图,请单击“视图”,然后单击“阅读视图”。

阅读视图    隐藏功能区和优化笔记本的阅读。 若要切换到“编辑”视图,请单击“在浏览器中编辑”。 若要在 OneNote 中打开笔记本,请单击“在 OneNote 中打开”。

注意    如果您没有笔记本的编辑权限,则只能选择“阅读”视图,同时在浏览器或 OneNote 中打开笔记本的命令将被禁用。

删除共享笔记本

  1. 在 OneNote 2010 中,右键单击笔记本标题,然后单击“关闭此笔记本”。
    注意    如果未在删除共享笔记本之前执行此操作也不会有重大问题,但这样做可在以后阻止同步错误(如果在从 OneDrive 删除笔记本后打开 OneNote 和共享笔记本,将出现这些错误)。

  2. 使用 http://office.live.com 登录到 OneDrive。

  3. 将打开“文档”页面,其中显示您的文件夹。

  4. 单击以打开包含要删除的共享笔记本的文件夹。

  5. 将显示笔记本的行突出显示(请勿单击笔记本,因为这样做会将笔记本打开),然后在页面右侧单击“删除”。

删除计算机上的旧文件副本

有时,OneNote 在本地驱动器上存储笔记本的旧副本或备份副本。 下面是删除这些文件的提示:

  • 如果您在 OneNote 中关闭 OneDrive 上的笔记本之前删除了笔记本,请右键单击标题,然后单击“关闭此笔记本”。 这可能会导致在计算机上存储部分错放的分区。 检查 Documents\OneNote Notebooks 以查看是否仍存在笔记本副本,如果存在,请将其删除。

  • OneNote 会定期创建所有笔记本的备份,这些备份位于 C:\Users\您的名称\AppData\Local\Microsoft\OneNote\14.0\Backup\。 如果找到备份,您可以在此手动将其删除。

  • 如果您在笔记本上执行过脱机操作,则您的脱机缓存中可能包含延迟副本。 最终,OneNote 将优化其缓存并删除副本。 但是,如果您希望自己删除此缓存:请在 OneNote 中,依次单击“文件”选项卡、“选项”、“保存和备份”、“立即开始优化所有文件”。 单击“确定”。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×