刷新 Excel 中的外部数据连接

您可以将 Excel 工作簿连接到外部数据源,如 SQL Server 数据库、OLAP 多维数据集,甚至其他 Excel 工作簿。 此连接可以在工作簿中显示为表格、数据透视表或数据透视图。

您可通过刷新数据源链接使工作簿中的数据保持最新。 每次刷新连接时,您会看到最新的数据,包括新增或已删除的任何内容。

安全说明: 您的计算机上当前可能已禁用到外部数据的连接。 若要在打开工作簿时刷新数据,必须使用 "信任中心" 栏启用数据连接,或者必须将工作簿放在受信任位置。 有关详细信息,请参阅添加、删除或修改文件的受信任位置添加、删除或查看受信任的发布者,以及查看信任中心中的选项和设置

对于大多数连接,请单击使用该连接的区域或表中的任意单元格,然后执行下列操作之一:

  • 仅更新所选数据   按 ALT + F5,或在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新" 下的箭头,然后单击 "刷新"。

    鼠标指针指向功能区上的 "刷新" 命令

  • 更新工作簿中的所有数据   按 CTRL + ALT + F5,或在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新"。

    将鼠标指针放在 "全部刷新" 按钮上

  • 控制连接的刷新方式或时间   在 "数据" 选项卡上,单击 "全部刷新" 下的箭头,然后单击 "连接属性"。

    鼠标指针指向功能区上的 "连接属性" 命令

    在打开的对话框中,在 "使用情况" 选项卡上的 "刷新控件" 下选择所需选项。

您可以在打开工作簿时自动刷新外部数据区域。 或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新" 下的箭头,然后单击 "连接属性"。

    鼠标指针指向功能区上的 "连接属性" 命令

  3. 在 "连接属性" 对话框中的 "使用情况" 选项卡上的 "刷新控件" 下,选中 "打开文件时刷新数据" 复选框。

  4. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 单击外部数据区域中的某个单元格。

  2. 在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新" 下的箭头,然后单击 "连接属性"。

    鼠标指针指向功能区上的 "连接属性" 命令

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态   Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新   要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询   若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新" 下的箭头,然后单击 "刷新"。

    将鼠标指针放在 "全部刷新" 按钮上

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

使用 Power Pivot 加载项刷新以前导入的数据时,您可以看到刷新成功、失败还是被取消。

在 Power Pivot 中,单击 "开始" > "获取外部数据" > "刷新" 或 "全部刷新" 以重新导入当前表或数据模型中的所有表。

为数据模型中使用的每个连接指示刷新的状态。 有三种可能的结果。

PowerPivot 中的数据刷新状态消息

"成功" 报告导入到每个表中的行数。

如果数据库处于脱机状态,您不再拥有权限,或者在源中删除或重命名了表或列,则会出现 "错误"。 通过在其他工作簿中创建新连接来验证数据库是否可用。

"已取消" 表示 Excel 未发出刷新请求,这可能是因为连接上已禁用刷新。

提示:  您是否与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求提供数据的数据源上的权限,帮助您的同事避免数据刷新错误。

表属性显示数据刷新中使用的查询

数据刷新只是重新运行用于获取第一个位置的数据的同一查询。 你可以通过在 " Power Pivot " 窗口中查看表属性来查看和有时修改查询。

  1. 要查看数据刷新期间使用的查询,请单击“Power Pivot”>“管理”以打开 Power Pivot 窗口。

  2. 单击 "设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询对于每种类型的数据源都不可见。 例如,数据馈送导入不会显示查询。

取消数据刷新的连接属性

在 Excel 中,可以设置用于确定数据刷新频率的连接属性。 如果不允许在特定连接上进行刷新,则在运行 "全部刷新" 或尝试刷新使用连接的特定表时,将获得取消通知。

  1. 若要查看连接属性,请在 Excel 中单击 "数据>查询 & 连接" 以查看工作簿中使用的所有连接的列表。

  2. 右键单击连接,然后单击 "属性"。

  3. 使用情况下,在 "刷新控制" 下,如果清除了用于刷新此连接的复选框,则在 Power Pivot "全部刷新" 窗口中尝试全部刷新时,您将收到取消通知。

刷新 SharePoint Server 2013 上的数据

在 SharePoint Server 2013 中,您可以在服务器上安排无人参与的数据刷新,但是这样做需要在 SharePoint 环境中安装和配置 Power Pivot for SharePoint 2013。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。

当您用于地图的数据更改时,您可以在3D 地图中手动刷新。 更改随后会反映在地图中。 操作方法如下:

  • 在3D 地图中,单击 "开始" > "刷新数据"。

“开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要将新数据添加到三维地图Power Map :

  1. 在3D 地图中,转到要向其添加数据的地图。

  2. 使3D 地图窗口保持打开状态,在 Excel 中单击,然后选择要添加的工作表数据。

  3. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。

“将选定数据添加到 Power Map”命令

您的3D 地图将自动更新以显示其他数据。

在 Excel Services 中显示的 Microsoft Office Excel 工作簿中的数据可以来自两个不同的位置。 数据可以直接存储在工作簿中,也可以存储在外部数据源(如数据库或联机分析处理(OLAP)多维数据集)中。

如果数据来自外部数据源,则工作簿作者或管理员已定义连接信息(通常位于 Office 数据连接(.odc)文件中),该文件介绍如何查找、登录、查询和访问外部数据源。

当您连接到 Excel Services 中的外部数据源时,可以执行刷新操作以检索已更新的数据。 每次刷新数据时,您都会看到最新版本的数据,包括自上次刷新以来对数据所做的任何更改。

了解有关刷新数据的信息

下图介绍了刷新连接到外部数据源的数据时所发生情况的基本过程。

刷新外部数据的基本流程

  1. 刷新操作可获取最新的数据。

  2. 连接通常保存到连接文件,定义访问和检索外部数据源中的数据所需的所有信息。

  3. 你可以访问多种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  4. 最新数据将添加到当前工作簿中。

了解有关安全的事项

当你连接到外部数据源并且尝试刷新数据时,请务必注意潜在安全问题,并了解你可以对任何安全问题执行哪些操作。

数据连接文件通常包含用于刷新外部数据的一个或多个查询。 通过替换此文件,具有恶意意图的用户可以设计查询以访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,请务必确保:

  • 连接文件是由可靠的个人创作的。

  • 连接文件是安全的,来自受信任数据连接库(DCL)。

安全说明: 访问外部数据源通常需要凭据(如用户名和密码),用于对用户进行身份验证。 确保以安全安全的方式提供这些凭据,并且不会无意间将这些凭据透露给其他人。

控制数据的刷新方式

你可以通过执行以下一项或多项操作来控制如何刷新外部数据源中的数据:

  • 打开时刷新   在 Microsoft Office Excel 2007 中,工作簿作者可以创建一个工作簿,以便在打开工作簿时自动刷新外部数据,方法是在 "连接属性" 对话框中选中 "打开文件时刷新数据" 复选框。 (在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "使用状况" 选项卡,然后单击 "在打开文件时刷新数据"。) 在这种情况下,Excel Services 在显示工作簿并创建新会话之前始终刷新数据。 如果工作簿作者在打开文件时清除 "刷新数据" 复选框,则将显示与工作簿一起缓存的数据,这意味着当用户手动刷新数据时,用户在当前会话期间可以看到已刷新的最新数据,但数据不会保存到工作簿中。 如果要确保在 Excel Services 中显示工作簿时始终显示最新的数据,请选中 "使用 Office Excel打开文件时刷新数据" 复选框。

    如果你使用的是 Office 数据连接文件(.odc),请确保你还在 "连接属性" 对话框中设置了 "始终使用连接文件" 复选框(在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "定义" 选项卡,然后单击 "始终使用连接文件")。

    受信任文件位置网站设置、短会话超时外部数据缓存生存期也会影响刷新操作。 有关详细信息,请参阅管理员或 Microsoft Office SharePoint Server 管理中心帮助系统。

  • 手动刷新   

    注意: 您只能手动刷新数据透视表。

    1. 在数据透视表中选择一个单元格。

    2. 在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所选连接"。

      注意: 

      • 导致 OLAP 数据源再次查询的任何交互式操作都将启动手动刷新操作。

      • 如果此 "刷新" 命令不可见,则 Web 部件作者已清除 "刷新所选连接"、"刷新所有连接" 属性。 有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 刷新所有连接   在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所有连接"。

  • 定期刷新   通过使用 Office Excel 2007 ,工作簿作者可以指定在为工作簿中的每个连接打开工作簿之后,按指定的时间间隔自动刷新数据。 例如,库存数据库可能每小时更新一次,因此工作簿作者已将工作簿定义为每隔60分钟自动刷新。

    Web 部件作者可以选中或清除 "允许 Excel Web Access 定期数据刷新" 属性,以启用或禁用此定期刷新操作(如果该属性已由工作簿作者定义)。 如果时间间隔已过期,则默认情况下,Excel Web Access Web 部件底部将显示以下刷新警告提示:

    刷新 <连接列表> 的数据? 已都(不再询问)

    Excel Web Access Web 部件作者还可以设置 "显示周期性数据刷新提示" 属性,以控制当 Excel Services 在会话期间执行定期数据刷新时显示的消息的行为:

    •      意味着在每个时间间隔内显示一条提示消息。

    • 同时     表示用户可以选择继续定期刷新而不显示消息。

    • 绝对     意味着 Excel Web Access 将在不显示消息或提示的情况下执行定期刷新。

    有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 取消刷新   由于刷新操作所需的时间可能比预期长,因此您可以取消它。 发生刷新操作时, Excel Services 将显示一条带有提示的消息。 单击 "取消" 以中断操作,以便你可以在更方便的时候完成刷新操作。 将显示取消刷新操作之前由查询返回的数据。

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 下面的过程不适用于从文本文件 (.txt) 或 Web 查询 (.iqy) 检索的数据。

请使用由大写及小写字母、数字和符号组成的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新",然后单击 "连接属性"。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在 "数据" 选项卡上的 "查询 & 连接" 组中,单击 "全部刷新",然后单击 "连接属性"。

    鼠标指针指向功能区上的 "连接属性" 命令

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

  1. 单击包含外部数据链接的区域或表格中的任一单元格。

  2. 在 "数据" 选项卡上的 "连接" 组中,单击 "全部刷新"。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新”。

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

    注意: 如果有多个打开的工作簿,则需要在每个工作簿中重复上述操作。

  1. 单击包含导入文本文件链接的区域或表格中的任一单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  3. 在“导入文本文件”对话框中,通过浏览找到你的文本文件,然后单击“导入”。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“刷新”。

    刷新数据连接

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

需要先连接到另一个工作簿?

若要刷新:

  • 在 "数据" 选项卡上,单击 "全部刷新"。

如果您有多个连接,而您只想更新某一特定的连接,请选择该数据区域内的任意单元格,单击 "全部刷新" 旁边的箭头,然后单击 "刷新"。

刷新数据连接

控制连接的刷新方式或时间

  1. 单击包含已连接数据的任何单元格。

  2. 在 "数据" 选项卡上,单击 "全部刷新" 旁边的箭头,然后单击 "连接属性"。

    连接属性

  3. 在“用法”选项卡上设置要更改的任何选项。

    对于非常大的数据集,请考虑选中 "允许后台刷新" 选项。 这会将 Excel 的控制权返回给你,而不是让你等待刷新完成。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

使用 Power Pivot 加载项刷新以前导入的数据时,您可以看到刷新成功、失败还是被取消。

在 Power Pivot 中,单击 "开始" > "获取外部数据" > "刷新" 或 "全部刷新" 以重新导入当前表或数据模型中的所有表。

为数据模型中使用的每个连接指示刷新的状态。 有三种可能的结果。

PowerPivot 中的数据刷新状态消息

"成功" 报告导入到每个表中的行数。

如果数据库处于脱机状态,您不再拥有权限,或者在源中删除或重命名了表或列,则会出现 "错误"。 通过在其他工作簿中创建新连接来验证数据库是否可用。

"已取消" 表示 Excel 未发出刷新请求,这可能是因为连接上已禁用刷新。

提示:  您是否与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求提供数据的数据源上的权限,帮助您的同事避免数据刷新错误。

表属性显示数据刷新中使用的查询

数据刷新只是重新运行用于获取第一个位置的数据的同一查询。 你可以通过在 " Power Pivot " 窗口中查看表属性来查看和有时修改查询。

  1. 要查看数据刷新期间使用的查询,请单击“Power Pivot”>“管理”以打开 Power Pivot 窗口。

  2. 单击 "设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询对于每种类型的数据源都不可见。 例如,数据馈送导入不会显示查询。

取消数据刷新的连接属性

在 Excel 中,可以设置用于确定数据刷新频率的连接属性。 如果不允许在特定连接上进行刷新,则在运行 "全部刷新" 或尝试刷新使用连接的特定表时,将获得取消通知。

  1. 若要查看连接属性,请在 Excel 中单击 "数据>连接" 以查看工作簿中使用的所有连接的列表。

  2. 选择一个连接,然后单击 "属性"。

  3. 使用情况下,在 "刷新控制" 下,如果清除了用于刷新此连接的复选框,则在 Power Pivot "全部刷新" 窗口中尝试全部刷新时,您将收到取消通知。

刷新 SharePoint Server 2013 上的数据

在 SharePoint Server 2013 中,您可以在服务器上安排无人参与的数据刷新,但是这样做需要在 SharePoint 环境中安装和配置 Power Pivot for SharePoint 2013。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。

注意: Power Query 编辑器是 "获取 & 转换" 的一部分。 若要了解详细信息,请参阅在 Excel 2016 中获取和转换

使用 Power Query 编辑器,您可以刷新查询以将最新数据导入到表中,而无需重新创建查询。

若要刷新查询,请执行以下操作:

  1. 单击 "获取 & 转换" > "显示查询"。

  2. 在 "工作簿查询" 窗格中,选择要刷新的查询。

  3. Power Query 编辑器功能区中,单击 "开始>查询" > "刷新预览"。

查询编辑器功能区

如果您的 Excel 工作簿具有到 Access 数据库中的表或查询的连接,您可以确保其显示最新信息。 使用“刷新”命令(在“数据”选项卡上)执行此操作。

需要先连接到 Access 数据库?

  1. 在工作表上,单击包含 Access 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 Access 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查状态或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列一项或多项操作:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 SQL Server 数据库中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

需要先连接到 SQL Server 数据库?

  1. 在工作表上,单击包含 SQL Server 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 SQL Server 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项,例如启用后台刷新。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 OLE DB 数据源中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

需要先连接到 OLE DB 数据?

  1. 在工作表上,单击包含 OLE DB 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 OLE DB 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击该消息可检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

当您用于地图的数据更改时,您可以在3D 地图中手动刷新。 更改随后会反映在地图中。 操作方法如下:

  • 在3D 地图中,单击 "开始" > "刷新数据"。

“开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要将新数据添加到三维地图Power Map :

  1. 在3D 地图中,转到要向其添加数据的地图。

  2. 使3D 地图窗口保持打开状态,在 Excel 中单击,然后选择要添加的工作表数据。

  3. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。

“将选定数据添加到 Power Map”命令

您的3D 地图将自动更新以显示其他数据。

在 Excel Services 中显示的 Microsoft Office Excel 工作簿中的数据可以来自两个不同的位置。 数据可以直接存储在工作簿中,也可以存储在外部数据源(如数据库或联机分析处理(OLAP)多维数据集)中。

如果数据来自外部数据源,则工作簿作者或管理员已定义连接信息(通常位于 Office 数据连接(.odc)文件中),该文件介绍如何查找、登录、查询和访问外部数据源。

连接到外部数据源时,可以执行刷新操作以检索已更新的数据。 每次刷新数据时,您都会看到最新版本的数据,包括自上次刷新以来对数据所做的任何更改。

了解有关刷新数据的信息

下图介绍了刷新连接到外部数据源的数据时所发生情况的基本过程。

刷新外部数据的基本流程

  1. 刷新操作可获取最新的数据。

  2. 连接通常保存到连接文件,定义访问和检索外部数据源中的数据所需的所有信息。

  3. 你可以访问多种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  4. 最新数据将添加到当前工作簿中。

了解有关安全的事项

当你连接到外部数据源并且尝试刷新数据时,请务必注意潜在安全问题,并了解你可以对任何安全问题执行哪些操作。

数据连接文件通常包含用于刷新外部数据的一个或多个查询。 通过替换此文件,具有恶意意图的用户可以设计查询以访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,请务必确保:

  • 连接文件是由可靠的个人创作的。

  • 连接文件是安全的,来自受信任数据连接库(DCL)。

有关管理员如何创作连接文件、创建受信任位置和安全连接文件的详细信息,请参阅 Microsoft Office Excel 2007 帮助和 Office SharePoint Server 管理中心帮助。

安全说明: 访问外部数据源通常需要凭据(如用户名和密码),用于对用户进行身份验证。 确保以安全安全的方式提供这些凭据,并且不会无意间将这些凭据透露给其他人。

控制数据的刷新方式

你可以通过执行以下一项或多项操作来控制如何刷新外部数据源中的数据:

  • 打开时刷新   在 Microsoft Office Excel 2007 中,工作簿作者可以创建一个工作簿,以便在打开工作簿时自动刷新外部数据,方法是在 "连接属性" 对话框中选中 "打开文件时刷新数据" 复选框。 (在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "使用状况" 选项卡,然后单击 "在打开文件时刷新数据"。) 在这种情况下,Excel Services 在显示工作簿并创建新会话之前始终刷新数据。 如果工作簿作者在打开文件时清除 "刷新数据" 复选框,则将显示与工作簿一起缓存的数据,这意味着当用户手动刷新数据时,用户在当前会话期间可以看到已刷新的最新数据,但数据不会保存到工作簿中。 如果要确保在 Excel Services 中显示工作簿时始终显示最新的数据,请选中 "使用 Office Excel打开文件时刷新数据" 复选框。

    如果你使用的是 Office 数据连接文件(.odc),请确保你还在 "连接属性" 对话框中设置了 "始终使用连接文件" 复选框(在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "定义" 选项卡,然后单击 "始终使用连接文件")。

    受信任文件位置网站设置、短会话超时外部数据缓存生存期也会影响刷新操作。 有关详细信息,请参阅管理员或 Microsoft Office SharePoint Server 管理中心帮助系统。

  • 手动刷新   

    注意: 您只能手动刷新数据透视表。

    1. 在数据透视表中选择一个单元格。

    2. 在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所选连接"。

      注意: 

      • 导致 OLAP 数据源再次查询的任何交互式操作都将启动手动刷新操作。

      • 如果此 "刷新" 命令不可见,则 Web 部件作者已清除 "刷新所选连接"、"刷新所有连接" 属性。 有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 刷新所有连接   在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所有连接"。

  • 定期刷新   通过使用 Office Excel 2007 ,工作簿作者可以指定在为工作簿中的每个连接打开工作簿之后,按指定的时间间隔自动刷新数据。 例如,库存数据库可能每小时更新一次,因此工作簿作者已将工作簿定义为每隔60分钟自动刷新。

    Web 部件作者可以选中或清除 "允许 Excel Web Access 定期数据刷新" 属性,以启用或禁用此定期刷新操作(如果该属性已由工作簿作者定义)。 如果时间间隔已过期,则默认情况下,Excel Web Access Web 部件底部将显示以下刷新警告提示:

    刷新 <连接列表> 的数据? 已都(不再询问)

    Excel Web Access Web 部件作者还可以设置 "显示周期性数据刷新提示" 属性,以控制当 Excel Services 在会话期间执行定期数据刷新时显示的消息的行为:

    •      意味着在每个时间间隔内显示一条提示消息。

    • 同时     表示用户可以选择继续定期刷新而不显示消息。

    • 绝对     意味着 Excel Web Access 将在不显示消息或提示的情况下执行定期刷新。

    有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 取消刷新   由于刷新操作所需的时间可能比预期长,因此您可以取消它。 发生刷新操作时, Excel Services 将显示一条带有提示的消息。 单击 "取消" 以中断操作,以便你可以在更方便的时候完成刷新操作。 将显示取消刷新操作之前由查询返回的数据。

您可以在打开工作簿时自动刷新外部数据区域。 或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  1. 单击“使用状况”选项卡。

  2. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  3. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 下面的过程不适用于从文本文件 (.txt) 或 Web 查询 (.iqy) 检索的数据。

请使用由大写及小写字母、数字和符号组成的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击该消息可检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

  1. 单击包含外部数据链接的区域或表格中的任一单元格。

  2. 在 "数据" 选项卡上的 "连接" 组中,单击 "全部刷新"。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新”。

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

    注意: 如果有多个打开的工作簿,则需要在每个工作簿中重复上述操作。

  1. 单击包含导入文本文件链接的区域或表格中的任一单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  3. 在“导入文本文件”对话框中,通过浏览找到你的文本文件,然后单击“导入”。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“刷新”。

    刷新数据连接

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

需要先连接到另一个工作簿?

若要刷新:

  • 在 "数据" 选项卡上,单击 "全部刷新"。

如果您有多个连接,而您只想更新某一特定的连接,请选择该数据区域内的任意单元格,单击 "全部刷新" 旁边的箭头,然后单击 "刷新"。

刷新数据连接

控制连接的刷新方式或时间

  1. 单击包含已连接数据的任何单元格。

  2. 在 "数据" 选项卡上,单击 "全部刷新" 旁边的箭头,然后单击 "连接属性"。

    连接属性

  3. 在“用法”选项卡上设置要更改的任何选项。

    对于非常大的数据集,请考虑选中 "允许后台刷新" 选项。 这会将 Excel 的控制权返回给你,而不是让你等待刷新完成。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

使用 Power Pivot 加载项刷新以前导入的数据时,您可以看到刷新成功、失败还是被取消。

在 Power Pivot 中,单击 "开始" > "获取外部数据" > "刷新" 或 "全部刷新" 以重新导入当前表或数据模型中的所有表。

为数据模型中使用的每个连接指示刷新的状态。 有三种可能的结果。

PowerPivot 中的数据刷新状态消息

"成功" 报告导入到每个表中的行数。

如果数据库处于脱机状态,您不再拥有权限,或者在源中删除或重命名了表或列,则会出现 "错误"。 通过在其他工作簿中创建新连接来验证数据库是否可用。

"已取消" 表示 Excel 未发出刷新请求,这可能是因为连接上已禁用刷新。

提示:  您是否与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求提供数据的数据源上的权限,帮助您的同事避免数据刷新错误。

表属性显示数据刷新中使用的查询

数据刷新只是重新运行用于获取第一个位置的数据的同一查询。 你可以通过在 " Power Pivot " 窗口中查看表属性来查看和有时修改查询。

  1. 要查看数据刷新期间使用的查询,请单击“Power Pivot”>“管理”以打开 Power Pivot 窗口。

  2. 单击 "设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询对于每种类型的数据源都不可见。 例如,数据馈送导入不会显示查询。

取消数据刷新的连接属性

在 Excel 中,可以设置用于确定数据刷新频率的连接属性。 如果不允许在特定连接上进行刷新,则在运行 "全部刷新" 或尝试刷新使用连接的特定表时,将获得取消通知。

  1. 若要查看连接属性,请在 Excel 中单击 "数据>连接" 以查看工作簿中使用的所有连接的列表。

  2. 选择一个连接,然后单击 "属性"。

  3. 使用情况下,在 "刷新控制" 下,如果清除了用于刷新此连接的复选框,则在 Power Pivot "全部刷新" 窗口中尝试全部刷新时,您将收到取消通知。

刷新 SharePoint Server 2013 上的数据

在 SharePoint Server 2013 中,您可以在服务器上安排无人参与的数据刷新,但是这样做需要在 SharePoint 环境中安装和配置 Power Pivot for SharePoint 2013。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。

使用 Power Query,您可以刷新查询以将最新数据导入到表中,而无需重新创建查询。

重要: 

  • Excel 2010   Power Query 不包含在 Excel 2010 中,但你可以下载、安装和激活Power Query 加载项。

  • 若要激活Power Query加载项,请单击 "文件>选项" >加载项。 在底部的“管理”部分中,从下拉列表中选择“COM 加载项”选项,然后单击“Go”。 单击“Power Query”复选框,再单击“确定”。 "Power Query" 功能区应自动显示,但如果不是,请关闭并重新启动 Excel。

若要刷新查询,请执行以下操作:

  1. 在 "查询编辑器" 功能区中,单击 "刷新预览"。

查询编辑器功能区

注意: 仅当您使用 Power Query 加载、编辑或创建新查询时,“查询编辑器”才会显示。 以下视频显示在 Excel 工作簿中编辑查询后显示的“查询编辑器”窗口。 若要在不加载或编辑现有工作簿的情况下查看“查询编辑器”,请在 Power Query 功能区选项卡的获取外部数据部分中,选择自其他来源 > 空白查询。 以下视频介绍一种显示查询编辑器的方法。

如何在 Excel 中查看查询编辑器

如果您的 Excel 工作簿具有到 Access 数据库中的表或查询的连接,您可以确保其显示最新信息。 使用“刷新”命令(在“数据”选项卡上)执行此操作。

需要先连接到 Access 数据库?

  1. 在工作表上,单击包含 Access 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 Access 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查状态或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列一项或多项操作:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 SQL Server 数据库中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

需要先连接到 SQL Server 数据库?

  1. 在工作表上,单击包含 SQL Server 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 SQL Server 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项,例如启用后台刷新。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击邮件以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 OLE DB 数据源中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

需要先连接到 OLE DB 数据?

  1. 在工作表上,单击包含 OLE DB 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 OLE DB 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击该消息可检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

当您用于地图的数据更改时,您可以在3D 地图中手动刷新。 更改随后会反映在地图中。 操作方法如下:

  • 在3D 地图中,单击 "开始" > "刷新数据"。

“开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要将新数据添加到三维地图Power Map :

  1. 在3D 地图中,转到要向其添加数据的地图。

  2. 使3D 地图窗口保持打开状态,在 Excel 中单击,然后选择要添加的工作表数据。

  3. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。

“将选定数据添加到 Power Map”命令

您的3D 地图将自动更新以显示其他数据。

在 Excel Services 中显示的 Microsoft Office Excel 工作簿中的数据可以来自两个不同的位置。 数据可以直接存储在工作簿中,也可以存储在外部数据源(如数据库或联机分析处理(OLAP)多维数据集)中。

如果数据来自外部数据源,则工作簿作者或管理员已定义连接信息(通常位于 Office 数据连接(.odc)文件中),该文件介绍如何查找、登录、查询和访问外部数据源。

连接到外部数据源时,可以执行刷新操作以检索已更新的数据。 每次刷新数据时,您都会看到最新版本的数据,包括自上次刷新以来对数据所做的任何更改。

了解有关刷新数据的信息

下图介绍了刷新连接到外部数据源的数据时所发生情况的基本过程。

刷新外部数据的基本流程

  1. 刷新操作可获取最新的数据。

  2. 连接通常保存到连接文件,定义访问和检索外部数据源中的数据所需的所有信息。

  3. 你可以访问多种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  4. 最新数据将添加到当前工作簿中。

了解有关安全的事项

当你连接到外部数据源并且尝试刷新数据时,请务必注意潜在安全问题,并了解你可以对任何安全问题执行哪些操作。

数据连接文件通常包含用于刷新外部数据的一个或多个查询。 通过替换此文件,具有恶意意图的用户可以设计查询以访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,请务必确保:

  • 连接文件是由可靠的个人创作的。

  • 连接文件是安全的,来自受信任数据连接库(DCL)。

有关管理员如何创作连接文件、创建受信任位置和安全连接文件的详细信息,请参阅 Microsoft Office Excel 2007 帮助和 Office SharePoint Server 管理中心帮助。

安全说明: 访问外部数据源通常需要凭据(如用户名和密码),用于对用户进行身份验证。 确保以安全安全的方式提供这些凭据,并且不会无意间将这些凭据透露给其他人。

控制数据的刷新方式

你可以通过执行以下一项或多项操作来控制如何刷新外部数据源中的数据:

  • 打开时刷新   在 Microsoft Office Excel 2007 中,工作簿作者可以创建一个工作簿,以便在打开工作簿时自动刷新外部数据,方法是在 "连接属性" 对话框中选中 "打开文件时刷新数据" 复选框。 (在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "使用状况" 选项卡,然后单击 "在打开文件时刷新数据"。) 在这种情况下,Excel Services 在显示工作簿并创建新会话之前始终刷新数据。 如果工作簿作者在打开文件时清除 "刷新数据" 复选框,则将显示与工作簿一起缓存的数据,这意味着当用户手动刷新数据时,用户在当前会话期间可以看到已刷新的最新数据,但数据不会保存到工作簿中。 如果要确保在 Excel Services 中显示工作簿时始终显示最新的数据,请选中 "使用 Office Excel打开文件时刷新数据" 复选框。

    如果你使用的是 Office 数据连接文件(.odc),请确保你还在 "连接属性" 对话框中设置了 "始终使用连接文件" 复选框(在 "数据" 选项卡上的 "连接" 组中,单击 "连接",选择连接,单击 "属性",单击 "定义" 选项卡,然后单击 "始终使用连接文件")。

    受信任文件位置网站设置、短会话超时外部数据缓存生存期也会影响刷新操作。 有关详细信息,请参阅管理员或 Microsoft Office SharePoint Server 管理中心帮助系统。

  • 手动刷新   

    注意: 您只能手动刷新数据透视表。

    1. 在数据透视表中选择一个单元格。

    2. 在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所选连接"。

      注意: 

      • 导致 OLAP 数据源再次查询的任何交互式操作都将启动手动刷新操作。

      • 如果此 "刷新" 命令不可见,则 Web 部件作者已清除 "刷新所选连接"、"刷新所有连接" 属性。 有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 刷新所有连接   在 Excel Web Access 工具栏上的 "更新" 菜单下,单击 "刷新所有连接"。

  • 定期刷新   通过使用 Office Excel 2007 ,工作簿作者可以指定在为工作簿中的每个连接打开工作簿之后,按指定的时间间隔自动刷新数据。 例如,库存数据库可能每小时更新一次,因此工作簿作者已将工作簿定义为每隔60分钟自动刷新。

    Web 部件作者可以选中或清除 "允许 Excel Web Access 定期数据刷新" 属性,以启用或禁用此定期刷新操作(如果该属性已由工作簿作者定义)。 如果时间间隔已过期,则默认情况下,Excel Web Access Web 部件底部将显示以下刷新警告提示:

    刷新 <连接列表> 的数据? 已都(不再询问)

    Excel Web Access Web 部件作者还可以设置 "显示周期性数据刷新提示" 属性,以控制当 Excel Services 在会话期间执行定期数据刷新时显示的消息的行为:

    •      意味着在每个时间间隔内显示一条提示消息。

    • 同时     表示用户可以选择继续定期刷新而不显示消息。

    • 绝对     意味着 Excel Web Access 将在不显示消息或提示的情况下执行定期刷新。

    有关详细信息,请参阅Excel Web Access Web 部件自定义属性

  • 取消刷新   由于刷新操作所需的时间可能比预期长,因此您可以取消它。 发生刷新操作时, Excel Services 将显示一条带有提示的消息。 单击 "取消" 以中断操作,以便你可以在更方便的时候完成刷新操作。 将显示取消刷新操作之前由查询返回的数据。

您可以在打开工作簿时自动刷新外部数据区域。 或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  1. 单击“使用状况”选项卡。

  2. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  3. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 下面的过程不适用于从文本文件 (.txt) 或 Web 查询 (.iqy) 检索的数据。

请使用由大写及小写字母、数字和符号组成的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击该消息可检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

相关内容

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×