刷新连接 (导入) 的数据

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以刷新连接到外部数据源 Excel 工作簿中的数据。此数据源可以是单元格区域、 Excel 表格、 数据透视表、 数据透视图报表、 文本文件或 Web 查询。刷新数据,每次您看到的信息,包括对数据所做的任何更改的数据源中的最新版本。

注意: 可能会在您的计算机上当前禁用到外部数据的连接。若要打开工作簿时刷新数据,必须启用数据连接通过使用信任中心栏中,或在受信任位置,必须将工作簿。

有关详细信息,请参阅添加、 删除或修改文件的受信任的位置添加、 删除或查看受信任的发布者查看我的选项和信任中心中的设置

执行下列操作之一:

  • 若要刷新工作簿中的特定数据连接,请单击外部数据区域中的单元格。在数据选项卡的连接组中,单击全部刷新旁边的箭头,然后单击刷新

  • 若要刷新工作簿中的所有数据连接,请单击全部都刷新数据选项卡上,在连接组中。

注意: 如果您有多个工作簿打开时,您必须重复每个工作簿中的操作。

  1. 选择包含导入的文本文件的工作表。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击刷新

  3. 导入文本文件对话框中,选择您的文本文件,然后单击导入

刷新脱机多维数据集文件,其中重新创建文件时使用从服务器多维数据集的最新数据,可以需要较长时间,并需要大量的临时磁盘空间。一次您不需要立即访问其他文件,并确保您有足够的磁盘空间,以保存该文件,再次启动过程。

  1. 单击基于脱机多维数据集文件的数据透视表报表。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击刷新

    Excel 功能区图像

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果开发工具选项卡不可用,则可以将其显示。有关说明,请参阅显示开发工具选项卡

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    功能区中的 XML 组

当您打开工作簿时,您可以自动刷新外部数据区域。(可选) 您可以保存工作簿,而不保存外部数据,以便减少工作簿的文件大小。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  5. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

注意: 若要在数据透视表报表打开工作簿时刷新数据,您可以选择打开文件时刷新数据复选框。在数据透视表选项对话框中数据选项卡上的数据透视表数据部分下是此复选框。

有关详细信息,请参阅数据透视表选项

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码不加密和不建议。如果您的数据源需要密码连接到它,您可以要求用户输入的密码,他们可以刷新外部数据区域之前。以下过程不适用于检索文本文件 (.txt) 或 Web 查询 (.iqy) 中的数据。

注意: 使用强密码大写和小写字母、 数字和符号。弱密码不要混合使用这些元素。密码应为 8 或更多个字符。使用 14 或多个字符的密码短语是更好。是,一定要记住密码。如果您忘记了密码,Microsoft 不能检索它。存储在安全的位置以外的信息,帮助保护记下密码。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“定义”选项卡。

  4. 清除“保存密码”复选框。

注意: Excel 会提示您输入密码仅在每个 Excel 会话中刷新外部数据区域的第一次。下一次启动 Excel 时,将提示您输入密码再次如果您打开工作簿包含的查询,然后尝试刷新操作。

在后台运行查询,使您能够使用 Excel 时运行查询。

注意: 不能在后台运行 OLAP 查询。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。清除此复选框可在您等待时运行查询。

注意: 当录制包含查询宏时,Excel 不在后台运行查询。若要更改录制的宏,以便在后台运行查询时,编辑Visual Basic 编辑器中的宏。更改该查询表对象的刷新方法BackgroundQuery: = FalseBackgroundQuery: = True。有关编辑宏的信息,请参阅为应用程序帮助的 Visual Basic。

执行下列一项或多项操作:

  • 检查查询的状态   旋转图标将出现在状态栏以表示查询正在运行。双击后台刷新 刷新指示器 图标以检查查询的状态。

  • 停止后台刷新   若要停止在后台运行查询,双击以显示外部数据刷新状态对话框中的状态栏上的后台刷新 刷新指示器 图标,然后单击停止刷新

  • 停止查询   若要停止从启用后台刷新关闭时运行查询,请按 ESC。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×