刷新连接(导入)的数据

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

单元格区域、 Excel 表格、 数据透视表、 数据透视图报表、 文本文件和 Web 查询均可以连接到外部数据源。您可以以更新从该外部数据源的数据刷新的数据。刷新数据,每次您看到的信息,包括对数据所做的任何更改的数据源中的最新版本。

安全注释 : 您的计算机当前可能禁用了到外部数据的连接。若要在打开工作簿时刷新数据,必须使用“信任中心”栏以启用数据连接,或者将工作簿放置在受信任位置。

有关详细信息,请参阅添加、 删除或修改文件的受信任的位置添加、 删除或查看受信任的发布者查看我的选项和信任中心中的设置

请执行下列操作之一:

  • 若要刷新工作簿中的特定数据连接,请单击外部数据区域中的单元格。在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”

  • 若要刷新工作簿中的所有数据连接,请单击“数据”选项卡上的“连接”组中的“全部刷新”

注意: 如果有多个打开的工作簿,则必须在每个工作簿中重复上述操作。

  1. 选择包含导入的文本文件的工作表。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击刷新

  3. “导入文本文件”对话框中选择文本文件,然后单击“导入”

刷新脱机多维数据集文件,其中重新创建文件时使用从服务器多维数据集的最新数据,可以需要较长时间,并需要大量的临时磁盘空间。一次您不需要立即访问其他文件,并确保您有足够的磁盘空间,以保存该文件,再次启动过程。

  1. 单击基于脱机多维数据集文件的数据透视表。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击刷新

    Excel 功能区图像

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果开发工具选项卡不可用,则可以将其显示。有关说明,请参阅显示开发工具选项卡

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    功能区中的 XML 组

可以在打开工作簿时自动刷新外部数据区域,并可以选择在保存工作簿时不保存外部数据,从而减小工作簿的文件大小。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. “刷新控件”下,选中“打开文件时刷新数据”复选框。

  5. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

注意: 若要在打开工作簿时刷新数据透视表的数据,还可以选中“打开文件时刷新数据”复选框。此复选框位于“数据”选项卡“数据透视表数据”部分的“数据透视表选项”对话框下。

有关详细信息,请参阅数据透视表选项

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码不加密和不建议。如果您的数据源需要密码连接到它,您可以要求用户输入的密码,他们可以刷新外部数据区域之前。以下过程不适用于检索文本文件 (.txt) 或 Web 查询 (.iqy) 中的数据。

重要: 使用强密码大写和小写字母、 数字和符号。弱密码不要混合使用这些元素。密码应为 8 或更多个字符。使用 14 或多个字符的密码短语是更好。是,一定要记住密码。如果您忘记了密码,Microsoft 不能检索它。存储在安全的位置以外的信息,帮助保护记下密码。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“定义”选项卡。

  4. 清除“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

通过在后台运行查询,您可以在运行查询时使用 Excel。

注意: 不能在后台运行 OLAP 查询。

  1. 单击外部数据区域中的某个单元格。

  2. 数据选项卡的连接组中,单击刷新,旁边的箭头,然后单击连接属性

    Excel 功能区图像

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。如果清除该复选框,则在您等待时运行查询。

注意: 当录制包含查询宏时,Excel 不在后台运行查询。若要更改录制的宏,以便在后台运行查询时,编辑Visual Basic 编辑器中的宏。更改该查询表对象的刷新方法BackgroundQuery: = FalseBackgroundQuery: = True。有关编辑宏的信息,请参阅为应用程序帮助的 Visual Basic。

请执行下列一项或多项操作:

  • 检查查询的状态   旋转图标将出现在状态栏以表示查询正在运行。双击后台刷新 刷新指示器 图标以检查查询的状态。

  • 停止后台刷新   若要停止在后台运行查询,双击以显示外部数据刷新状态对话框中的状态栏上的后台刷新 刷新指示器 图标,然后单击停止刷新

  • 停止查询   若要停止从启用后台刷新关闭时运行查询,请按 ESC。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×