创建邮件合并

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果要创建大量大体相同但又包含某些特有信息的文档,请使用邮件合并。例如,可以使用邮件合并使用个性化备注逐个地创建自定义出版物。还可以使用邮件合并创建要发送给排名前 100 位客户的产品公告。这类出版物的文字通常相同,但每位客户的姓名和地址不同。

使用“邮件合并”任务窗格可引导您逐步创建邮件合并。若要在新的或现有的出版物中打开“邮件合并”任务窗格,请单击“工具”菜单,指向“邮件和目录”,然后单击“邮件合并”

本文内容

创建或连接到的收件人列表

准备您的出版物

创建合并的出版物

取消合并

创建或连接到收件人列表

若要进行邮件合并,必须打开一个新的或现有的出版物,然后连接到数据源,数据源是一个文件,它包含您要包括的特有信息。数据文件可能包含姓名和地址列表、产品数据或图片。此数据文件可以为多种不同的格式,这些格式包括:

  • Microsoft Office Outlook 联系人列表

  • Microsoft Office Excel 工作表

  • Microsoft Office Word 表格

  • Microsoft Office Access 数据库表

  • 用制表符或逗号分隔列并用段落回车符分隔行的文本文件

可以连接到现有列表或数据源,也可以创建新的收件人列表。如果只需要使用列表中的某些条目,可以按照特定标准筛选列表。还可以按字母顺序对项目进行排序。

注意: 如果您想要将图片合并到出版物页面,文件名或路径要合并的图片文件必须包含数据源。在数据源中不要包括实际图片或图像。

使用现有列表

  1. “创建收件人列表”中,单击“使用现有列表”,然后单击“下一步: 创建或连接到收件人列表”

    默认情况下,Microsoft Publisher 会将数据源存储在“我的数据源”文件夹中。您可能需要通过浏览找到数据源。

  2. “选取数据源”对话框中,单击所需的数据源。

  3. 单击“打开”

    根据所选择的数据源类型,可能会出现其他对话框,要求指定具体信息。

    例如,如果数据源是在多张工作表上都包含信息的 Microsoft Office Excel 工作簿,您需要选择包含所需信息的工作表,然后单击“确定”

从 Outlook 联系人中选择

  1. “创建收件人列表”下,单击“从 Outlook 联系人中选择”,然后单击“下一步: 创建或连接到收件人列表”

  2. 如果提示您选择邮件配置文件,则请单击所需的配置文件,然后单击“确定”

  3. “选择联系人”对话框中,单击所需的联系人列表,再单击“确定”

    文件夹中的所有联系人将出现在“邮件合并收件人”对话框中,您可以在其中筛选和排序要包含在合并中的收件人列表。

键入新列表

如果没有可以连接的现有列表,可以创建一个新列表。

  1. “创建收件人列表”下,单击“键入新列表”,然后单击“下一步: 创建或连接到收件人列表”

  2. “新建地址列表”对话框中的相关域中键入第一个条目的信息。不必填写所有域。

  3. 完成第一个条目的信息输入后,请单击“新建条目”

  4. 重复步骤 2 和步骤 3,直到完成添加条目,然后单击“确定”

  5. “保存地址列表”对话框中的“文件名”框中键入地址列表的名称,并选择要保存该列表的文件夹。

    默认情况下,Microsoft Publisher 会将地址列表保存在“我的数据源”文件夹中。最好将地址列表保存在此处,因为该文件夹也是 Publisher 查找数据源的默认文件夹。

    新列表中的所有联系人将出现在“邮件合并收件人”对话框中,您可以在其中筛选和排序要包含在合并中的收件人列表。

选择收件人

“邮件合并收件人”对话框中,可以选择要包含在邮件合并中的收件人。选中要包含的收件人旁边的复选框,清除要排除的收件人旁边的复选框。

如果要仅使用列表中的某些条目,则可以按特定域或条件来筛选列表。筛选了列表后,可以使用复选框包括和排除记录。

筛选列表中的项目

  1. 单击要作为筛选标准的项目的列标题旁边的箭头。

  2. 单击下列项目之一:

    • “(空白)”显示对应字段为空白的所有记录。

    • “(非空白)”显示其中对应字段包含信息的所有记录。

    • “(高级)”打开“筛选和排序”对话框,使用该对话框可按照多项标准进行筛选。也可以通过在“邮件合并收件人”对话框中单击“简化收件人列表”下的“筛选”来打开“筛选和排序”对话框。

      提示: 如果数据源包含共享相同信息的记录,并且列中包含十个或更少的单独数值,则您可根据特定的信息进行筛选,例如,如果多个地址列出的国家/地区为澳大利亚,可根据“澳大利亚”进行筛选。

      “邮件合并收件人”对话框仅显示指定的记录。若要再次显示所有记录,请单击“(全部)”

如果要按字母顺序查看项目,可对列表中的项目进行排序。

在列表中的项目进行排序

  • “邮件合并收件人”对话框中,单击做为排序依据的项目的列标题。

    例如,如果要按姓氏的字母顺序显示列表,请单击“姓氏”列标题。

  • 若要快速选择或清除所有项目,请选择或清除复选框列标题。

  • 要使用多个条件进行排序,请在“邮件合并收件人”对话框中单击“调整收件人列表”下的“排序”。在“筛选和排序”对话框中,选择要作为排序依据的条件。

单击“确定”以返回“邮件合并”任务窗格。

返回页首

准备出版物

邮件合并将一个文档(包含在每个副本中均相同的信息)和一些占位符(用于每个副本特有的信息)组合起来。在创建出版物后,请插入要显示在邮件合并出版物所有版本中的任何其他文字(如问候语)和用于特有信息的占位符(如地址)。

如果还没有这么做,请插入一个文本框,键入要显示在邮件合并出版物所有版本中的文字,然后添加特有信息的占位符。

插入文本框

  1. 对象工具栏上单击文本框中 按钮图像

  2. 在出版物中,指向希望出现文本框一角的位置,然后沿对角线方向拖动鼠标直到达到所需的文本框大小。

插入要显示在所有版本中的文字

  • 单击文本框内部,再键入要在每个邮件合并出版物版本中出现的文字。

将数据域插入到出版物中

  1. 在邮件合并出版物中,在文本框内部要插入数据字段的位置单击。

  2. 插入下列任意一项:

    包含姓名、地址和其他信息的地址块

    1. “邮件合并”任务窗格(“步骤 2:准备出版物”)中的“其他项目”下,单击“地址块”

    2. “插入地址块”对话框中,单击要包含的地址元素,再单击“确定”

      注意: 如果数据源中数据字段的名称与 Publisher 用于地址块的域名称不匹配,您可能需要单击“插入地址块”对话框中的“匹配域”。在“匹配域”对话框中,使用下拉列表从数据源中选择与 Publisher 域对应的字段。

    问候语

    1. “邮件合并”任务窗格(“步骤 2:准备出版物”)中的“其他项目”下,单击“问候语”

    2. “问候语”对话框中,选择问候语格式,其中包含称呼、名称格式及其后的标点。

    3. 选择在 Publisher 不能解释收件人姓名时(例如,当数据源不包含收件人的名字或姓氏,而只包含公司名称时)要显示的文字。

    4. 单击“确定”

      注意: 如果数据源中的数据域的名称与 Publisher 用于问候语的域名称不匹配,则可能需要单击“问候语”对话框中的“匹配域”。在“匹配域”对话框中,使用下拉列表,从数据源中选择与 Publisher 域对应的域。

    地址字段

    1. “邮件合并”任务窗格(“步骤 2:准备出版物”)中的“其他项目”下,单击“地址域”

    2. “插入地址域”对话框中,单击要包含的每个地址元素。

      注意: 如果数据源中数据字段的名称与 Publisher 用于地址域的域名称不匹配,则您可能需要在“插入地址域”对话框中单击“匹配域”。在“匹配域”对话框中,使用下拉列表从数据源中选择与 Publisher 域对应的字段。

    信息的其他字段

    “邮件合并”任务窗格(“步骤 2:准备出版物”)中“准备出版物”下方的列表框中,将希望包含的域拖动到为它创建的文本框中。

设置数据域的格式

如果愿意,可以对数据域和已添加的任何其他文字(如问候语 HelloDear... 之类的称呼)应用格式,以更改合并数据的外观。若要设置合并数据的格式,必须设置邮件合并出版物中数据域的格式。

  1. 在邮件合并出版物中,选择包含要设置格式的信息的域。

  2. “格式”菜单上,单击“字体”,再选取所需的选项。

预览出版物中数据域中的收件人数据

现在您可以预览在合并域中存在实际数据时出版物的显示情况。

  1. 若要预览出版物,请执行下列操作之一:

    • 若要按顺序预览条目,请单击导航按钮 “前进”按钮 “后退”按钮 以查看每个条目合并出版物中的显示方式。

      来自数据源第一条记录的信息将填充合并域。您无法在出版物页面上编辑数据源条目,但可以设置数据域的格式、移动数据域或删除数据域。

    • 若要查找和预览数据源中的特定条目,请单击“查找收件人”,然后在“查找条目”对话框中输入搜索标准。

  2. 如有必要,可对收件人列表进行更改。请执行下列任何一项操作:

    • 若要从合并中排除特定收件人,请单击“排除此收件人”

    • 若要更改收件人列表,请单击“编辑收件人列表”,然后在“邮件合并收件人”对话框中进行更改。

  3. 完成邮件合并出版物并插入所有合并域后,请单击“文件”菜单上的“另存为”。在“文件名”框中键入出版物的名称,再单击“保存”

  4. 单击“下一步: 创建合并出版物”

返回页首

创建合并出版物

“邮件合并”任务窗格中“创建合并出版物”下,您可以执行以下操作:

  • 打印合并出版物(例如:用于邮寄)

  • 预览合并出版物(在打印所有版本前预览它的外观并解决潜在的问题)

  • 保存合并出版物以备后用

  • 将合并页面添加到其他出版物

预览合并出版物

  • 单击“打印预览”

打印合并出版物

  1. 单击“打印”

  2. “打印”对话框中,选择所需选项,再单击“确定”

    重要: 若要打印不同的合并数据集 — 例如,不同的名称和地址-在纸张的每个工作表,单击打印选项部分中的每版打印多页。如果您选择每版打印多份,每张纸将包含相同的数据的多个副本。

    包含“每版打印多页”选项的“打印”对话框

保存合并出版物以备后用

如果您想要编辑合并的页面、 将其保存以备将来使用,或将在以后它们打印出来,您可以收集和将所有合并页面另存为一个新合并的出版物所包含的实际数据 — 例如,名称和地址,— 而不是合并域。

  1. 单击“合并为新出版物”

    Publisher 将使用这些合并页面创建一个新出版物。

  2. 在新出版物中,单击“邮件合并”任务窗格中的“保存此出版物”。在“文件名”框中键入新出版物的名称,再单击“保存”

将合并页面添加到现有出版物

如果您计划将合并页添加到现有出版物的末尾,请确认您的邮件合并出版物在以下方面与现有出版物相匹配:

  • 页面尺寸(高度和宽度)

  • 页面视图(单页或跨页)

  • 出版物类型(Web 或打印)

  • 页面顺序(从左向右或从右向左)

Publisher 可将合并页面添加到新的或现有的出版物中,但无法将它们添加到已打开的出版物中。如果要合并到的出版物已打开,请务必在合并完成前保存并关闭此出版物。

  1. 单击“添加到现有出版物”

  2. “打开出版物”对话框中,定位到要添加合并页面的出版物,然后单击“打开”

    Publisher 会将合并页面添加到现有出版物中。

  3. 在该现有出版物中,单击“邮件合并”任务窗格中的“保存此出版物”保存更新。

保存邮件合并出版物

如果您还保存了包含合并域的出版物,您可以返回前面的步骤并编辑合并域,然后创建一个新的合并出版物,其中包含新的合并域或更新的收件人列表。若要保存邮件合并出版物,请执行下列操作:

  1. 确保您在邮件合并出版物中。

  2. “文件”菜单上,单击“保存”

  3. 为邮件合并出版物提供一个名称,然后单击“保存”

返回页首

取消合并

可以取消合,以断开邮件合并出版物或目录合并模板与其数据源的连接。

  1. “工具”菜单上,指向“邮件和目录”,再单击“取消合并”

  2. 当询问是否要取消合并时,单击“是”

将取消出版物与数据源之间的连接。

注意: 如果取消邮件合并,则除“地址域”、“问候语”和“地址块”之外的其他域都将转换为常规文字。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×