创建自定义筛选器

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

在 Project 中, 您可以筛选视图, 以便您只看到关键任务、里程碑和对您最重要的其他信息。可通过三种方式筛选项目中的任务或资源提供用于查看任务和资源的特定方面的预定义筛选器。如果这些筛选器都不能满足您的需要, 您可以创建新筛选器或修改现有筛选器。

  • 预定义筛选器    这些是随 Project 提供的筛选器。这些用于快速筛选任务或资源 (如任务不完整或过度分配的资源)。

  • 自定义筛选器    这些是为你的项目需求而设计的筛选器。

  • 自动筛选    当这些功能处于打开状态时, 它们将在工作表视图中显示为每列顶部的箭头。使用以下内容可以快速筛选列中的项目。

本文内容

筛选任务或资源

使用自动筛选

筛选任务或资源

有时, 你只希望查看项目中的特定类型的信息。例如, 您可能只想查看项目的里程碑或查看尚未开始的任务。如果你的项目包含许多任务, 并且涉及到许多资源, 筛选器对于查看特定的信息范围可能非常有用。筛选器允许您仅显示感兴趣的信息并隐藏其余信息。

您可以使用预定义的项目筛选器筛选任务或资源数据。如果没有满足你的需要的筛选器, 则可以创建新筛选器或修改现有筛选器。

应用或删除筛选器

  1. 在 "视图" 选项卡上的 "数据" 组中, 选择 "筛选器" 列表中的筛选器。

    若要应用不在列表中的筛选器, 请选择 "其他筛选器", 然后执行下列操作之一:

    • 若要选择任务筛选器, 请选择 "任务", 在 "筛选器" 列表中选择筛选器名称, 然后选择 "应用"。

    • 若要选择资源筛选器, 请选择 "资源", 在 "筛选器" 列表中选择筛选器名称, 然后选择 "应用"。

      注意: 不能将任务筛选器应用于资源视图或资源筛选器到任务视图。

  2. 如果你应用交互式筛选器, 请键入请求的值, 然后选择"确定"

  3. 若要关闭筛选器, 请在筛选器列表中选择 "无筛选器"。

使用突出显示将颜色应用于已筛选的任务

筛选任务或资源时, 可以应用突出显示。突出显示的任务或资源以非筛选任务显示, 但采用不同的颜色。

  1. 在 "视图" 选项卡上的 "数据" 组中, 在 "筛选器" 列表中选择一个筛选器, 然后选择 "其他筛选器"。

  2. 在 "筛选器" 列表中选择一个筛选器, 然后选择 "突出显示"。

提示: 若要为突出显示的任务应用不同的颜色, 请使用其他文本样式。选择 "格式" 选项卡, 然后选择 "文本样式"。在 "要更改的项目" 列表中, 选择 "突出显示的任务", 然后选择 "格式设置选项"。

创建自定义筛选器

  1. 在 "视图" 选项卡上的 "数据" 组中, 选择 "筛选" 旁边的箭头, 然后选择 "其他筛选器"。

    Project 功能区,显示如何创建自定义筛选器。

  2. 选择 "任务" 或 "资源" (具体取决于要创建的筛选器类型), 然后选择 "新建"。

  3. 键入新筛选器的名称。如果希望将此筛选器包含在“数据”组列表中,请选择“显示在菜单中”。

  4. 在“与/或”列中,选择“”以显示满足您的多个筛选条件的的结果。选择“”以显示满足一个或另一个条件的行。

    选择“与”或“或”,具体取决于您想要从筛选器获得的结果的类型。

  5. 在“域名称”列中,选择要筛选的域。

  6. 在“测试”列中,确定您为“域名称”列选择的内容如何与下一步骤中的“”列相匹配。

  7. 在“”列中,选择所需值或键入新值。

    如果在 "测试" 列中选择 "等于" 或 "不等于", 则可以在 "" 列中键入通配符 (而不是从列表中选择一个选项)。例如, 键入问号 (?) 将找到单个字符。键入星号 (*) 可找到任意数量的字符。如果使用通配符, 请确保您选择的 "字段名称" 列涉及文本 (如名称), 而不是 "数字" (如 "持续时间")。

  8. 若要向筛选器添加另一行 (并选择要筛选的另一个字段名称), 请选择 "插入行"。您可以通过添加空行对行进行分组。在空行中添加 "" 或 "或" 以筛选一个组。

  9. 完成后, 选择 "保存"。

提示: 若要快速删除所有筛选器, 请使用 F3 键。请记住, 任务筛选器只能使用任务视图, 而资源筛选器仅适用于资源视图。

修改现有筛选器

  1. 在 "视图" 选项卡上的 "数据" 组中, 选择 "筛选器" 列表, 然后选择 "其他筛选器"。

  2. 执行下列操作之一:

    • 若要修改任务筛选器, 请选择 "任务", 选择要修改的筛选器, 然后选择 "编辑"。

    • 若要修改资源筛选器, 请选择 "资源", 选择要修改的筛选器, 然后选择 "编辑"。

  3. 使用 "筛选器定义" 对话框中的控件修改筛选器的设置。

使用自动筛选

您可以在任何工作表视图中将自动筛选应用于字段。除了标准筛选器, project 还提供了自动筛选, 在工作表视图中的每一列的顶部可见。

应用和删除自动筛选

  1. 在 "视图" 选项卡上的 "数据" 组中, 选择 "筛选器" 列表的箭头, 然后选择"显示自动筛选"。

  2. 选择包含要显示的信息的列标题旁边的 "自动筛选" 箭头, 然后选择一个值以筛选表。
    自动筛选箭头和字段标题变为蓝色。

  3. 若要基于另一列中的值应用其他条件, 请对另一列重复步骤2。

  4. 若要删除特定行上的筛选, 请在 "自动筛选" 列表中选择 "清除该字段的所有筛选器"。

  5. 若要关闭 "自动筛选", 请再次选择"显示自动筛选"。

    注意: 如果视图的其中一个行中的信息发生变化, 您可以通过选择箭头并重新选择筛选值来刷新 "自动筛选" 设置。

创建自定义自动筛选

  1. 显示 "自动筛选"。

  2. 选择 "自动筛选" 箭头, 指向 "筛选", 然后选择 "自定义"。

  3. 在第一个框中选择要使用的运算符, 然后在第二个框中键入或选择要匹配的值。

    例如, 若要匹配日期字段中的特定日期, 请在第一个框中选择 "等于" 运算符, 然后在第二个框中选择要匹配的日期。

  4. 若要将两个条件应用于 "自动筛选", 请执行下列操作之一:

    • 若要在视图中显示同时满足两个条件的行, 请在 "第二行" 框中选择所需的运算符和值, 然后选择 ""。

    • 若要在视图中显示满足一个条件或另一个条件的行, 请在 "第二行" 框中选择所需的运算符和值, 然后选择 """"。

  5. 若要保存 "自动筛选" 设置, 请选择 "保存"。

    如果你的视图已应用预定义筛选器, 则为 "自动筛选" 设置的条件将作为附加条件包含到当前筛选器中。保存 "自动筛选" 设置时, 筛选器将与文件中的其他筛选器保存在一起, 并且仅通过 "其他筛选器" 对话框提供。

为新项目自动启用自动筛选

  1. 在 "文件" 选项卡上, 选择 "选项"。

  2. 选择 "高级", 然后在 "常规" 部分中, 选中 "为新项目设置自动筛选" 复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×