创建自定义字段

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Microsoft Office Project 2007提供了多种自定义域,您可以定义以满足您的组织的需要。您可以自定义字段,然后将其插入到您的项目。如果您不需要全新的自定义域,您也只需可以重命名现有它们进行自定义的字段。

您要做什么?

自定义字段

导入自定义字段

插入自定义字段

重命名字段

自定义字段

  1. 工具菜单上,指向自定义,,然后单击

  2. 如果您希望在任务视图中不可用,或单击资源,如果您希望将资源视图中可用的字段的字段,请单击任务

  3. 类型列表中选择要自定义的字段的类型。

  4. 单击重命名永久重命名此项目中的字段。在出现的对话框中键入新名称,然后单击确定

  5. 自定义属性下选择您希望如何在字段中输入数据。

    • 如果您希望使用列表的自定义域,例如,若要在您的组织中创建不同的成本中心的列表-单击查找。在出现的对话框中,在列中输入每个列表项,选择是否希望一个列表项默认情况下,显示,然后单击关闭

    • 如果您想要使用公式填充自定义域,请单击公式。在出现的对话框中,字段函数框用于构建公式,,然后单击确定

  6. 任务和组的汇总行的计算,下选择您希望如何在您的自定义字段汇总的值。也就是说,如何汇总的值在任务和分组摘要级别为此自定义的字段。

    注意: 大纲代码和文本字段不会汇总。此外,使用公式选项才可用,如果您已定义的字段,在自定义属性下的公式。

  7. 计算工作分配行,下选择要如何分发的自定义域中的值。

    • 如果此自定义的字段的内容将不在工作分配,请单击

    • 如果此自定义的字段的内容,则分布工作分配,例如,在任务分配状况视图或资源使用状况视图中,单击向下滚动,除非手动输入。在这种情况下,数据划分之间分配到工作分配行手动输入数据的情况。

  8. 要显示的值,下选择要如何显示的自定义域中的数据。

    • 单击要显示实际数据域内容在该字段将显示所有视图中的数据

    • 单击图形指示器以指定的条件和相关联的指示器图像来代替数据字段中显示。

      注意: 如果您正在使用新的自定义字段显示选定更新Microsoft Office Project Server 2007中的字段,您可能需要刷新 [即"更改"] 列中的信息一次以查看Microsoft Office Project Web AccessProject Web Access 中的视图中的新指示器。

一旦域自定义,您可以将其插入适当的任务或资源视图中项目中。

返回页首

导入自定义字段

如果其他项目或模板具有您会发现在项目中很有用的自定义域,您可以导入它可节省您创建相同的新自定义字段所花费的时间。

  1. 工具菜单上,指向自定义,,然后单击

  2. 单击导入字段

  3. 选择要导入从项目列表的字段所在的项目。

  4. 字段类型区域中,选择任务资源项目

  5. 选择要导入从字段列表的字段的名称。

  6. 单击确定,和字段的名称,值列表、 公式和图形指示器导入到您的项目。您可以修改根据需要,这些值,然后在您的项目的视图中插入的域。

返回页首

插入自定义字段

一旦您有自定义字段下, 一步是将其插入视图中。

  1. 单击要自定义字段右侧显示的列的列标题。

  2. 插入菜单上,单击

  3. 单击字段名称列表中的自定义域的名称。如果您永久重命名字段,当您自定义,它将列出在新名称下。

  4. 如果不想使用自定义字段的永久名称,请在标题框中键入新名称。

  5. 选择如何使用所需的列对齐、对齐标题对齐数据列表。

  6. 宽度框中键入一个列的宽度。您可以通过拖动边缘以使其更大或变窄的列来调整列宽,视图中。

  7. 如果您希望列标题文本换到多个线条,如果列太窄,以显示它在一行上,选择标题文本换行复选框。如果您希望仅显示在一行上的页眉,请清除此复选框。

  8. 单击确定以插入列中显示的视图。

返回页首

重命名字段

如果您的项目中的字段捕获适当的数据,但另一个标题会更准确地描述正在捕获,只需可以重命名字段。重命名字段涉及首先隐藏列,然后在新的字段名称与再次显示它。

  1. 记下您要重命名字段的当前名称。

  2. 右键单击您要重命名,然后单击隐藏列的字段列标题。列将消失从当前视图,但仍然安全地存储在数据库中包含列中的数据。

  3. 单击要显示正在重命名字段右侧的列的列标题。

  4. 插入菜单上,单击

  5. 单击字段,记下以前,在字段名称列表中的原始名称。

  6. 标题框中键入新名称的字段。

  7. 单击确定以重命名字段。

    注意: 为当前视图,将使用新名称。如果您有多个视图中显示该字段,您可能想要重命名字段中的其他视图,以及使用这些步骤。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×