创建简单报表

可在 Access 中创建从简单到复杂的各种不同报表。首先需考虑报表的记录源。无论报表是简单的记录列表还是按地区分组的销售汇总,都必须先确定哪些字段包含要在报表中显示的数据,以及它们所在的表或查询。

选择记录源后,通常会发现创建报表最简单的方法是使用“报表向导”。“报表向导”是 Access 中的一个功能,可引导用户完成一系列问题,然后根据回答生成报表。

您要做什么?

选择记录源

使用“报表”工具创建报表

使用“报表向导”创建报表

使用“标签向导”创建标签

使用“空报表”工具创建报表

了解报表节

了解控件

在“布局”视图中微调报表

在“设计​​”视图中微调报表

向报表添加控件

保存工作

查看、打印报表或以电子邮件形式发送报表

查看报表

打印报表

以电子邮件形式发送报表

选择记录源

报表包含从表或查询中拉取的信息,以及与报表设计一起存储的信息(如标签、标题和图形)。提供基础数据的表或查询也称为报表的记录源。如果要包含的字段均位于单个表中,请使用该表作为记录源。如果字段位于多个表中,则需使用一个或多个查询作为记录源。这些查询可能已存在于数据库中,或者可能需要专门创建新的查询来满足报表需求。

使用“报表”工具创建报表

“报表”工具提供创建报表的最快方法,因为它会立即生成报表​​,而不提示用户提供信息。该报表显示基础表或查询中的所有字段。“报表”工具可能无法创建最终希望的无暇报表,但它是快速查看基础数据的极有效方法。随后,可保存报表并在“布局”视图或“设计”视图中进行修改,以便更好地满足自己的需求。

  1. 在“导航窗格”中,单击要作为报表基础的表或查询。

  2. 在“创建”选项卡上的“报表”组中,单击“报表”。 按钮图像

    Access 生成报表并将其显示在“布局”视图中。

  3. 若要深入了解如何查看和打印报表,请参阅查看、打印报表或以电子邮件形式发送报表部分。

查看报表后,可将其保存,然后关闭该报表和用作记录源的基础表或查询。下次打开报表时,Access 将显示记录源中的最新数据。

使用“报表向导”创建报表

可使用“报表向导”更细致地选择报表上要显示的字段。如果事先已指定表和查询之间的关系,则还可指定数据的分组和排序方式,并可使用来自多个表或查询的字段。

  • 在“创建”选项卡上的“报表”组中,单击“报表向导”。

  • 按照“报表向导”页面上的说明进行操作。在最后一页上,单击“完成”。

    预览报表时,可看到报表以打印形式显示。还可增加缩放比例,放大细节。若要深入了解如何查看和打印报表,请参阅查看、打印报表或以电子邮件形式发送报表部分。

注意: 如果希望报表包含多个表和查询中的字段,在“报表向导”的第一页上选择第一个表或查询中的字段后,请不要单击“下一步”或“完成”。而是重复这些步骤,选择一个表或查询,再单击要包括在报表中的任何其他字段。然后单击“下一步”或“完成”继续操作。

使用“标签向导”创建标签

使用“标签向导”轻松创建各种标准尺寸的标签。

  1. 在“导航窗格”中,双击打开将作为标签记录源的表或查询。

  2. 在“创建”选项卡上的“报表”组中,单击“标签”。

  3. 按照“标签向导”页面上的说明进行操作。在最后一页上,单击“完成”。

Access 在“打印预览”中显示标签,以便查看其打印时的外观。可使用 Access 状态栏上的滑块控件放大细节。若要深入了解如何查看和打印报表,请参阅查看、打印报表或以电子邮件形式发送报表部分。

注意: “打印预览”是唯一可用于查看多个列的视图,其他视图均以单列显示数据。

使用“空报表”工具创建报表

如果不想使用“报表”工具或“报表向导”,则可使用“空报表”工具从头开始生成报表。这种方法可快速生成报表,尤其适用于计划仅在报表中包含几个字段的情况。以下步骤介绍如何使用“空报表”工具:

  • 在“创建”选项卡上的“报表”组中,单击“空报表”。 按钮图像

    “布局”视图中随即显示一个空报表,Access 窗口右侧显示“字段列表”窗格。

  • 在“字段列表”窗格,单击要在报表上显示的字段所在的一个或多个表旁边的加号。

  • 一次一个地将每个字段拖动到报表上,或者按住 Ctrl 并选择多个字段,然后将其同时拖动到报表上。

  • 使用“设计”选项卡上“页眉/页脚”组中的工具,向报表添加徽标、标题、页码或日期和时间。请注意,如果使用 Access 2007,则这些工具位于“格式”选项卡上的“控件”组中。

了解报表节

在 Access 中,报表的设计划分为多个节。可在“设计”视图中查看报表,了解各节。若要创建有用的报表,需了解每节的工作原理。例如,选择放置计算控件的节决定 Access 计算结果的方式。以下列表总结了节类型及其用法:

  • 报表​​页眉    本节仅在报表开头出现一次。报表页眉用于显示一般出现在封面上的信息,如徽标、标题或日期。在报表页眉中放置使用求和聚合函数的计算控件时,将计算整个报表的总和。报表页眉位于页面页眉之前。

  • 页面页眉    本节位于每页顶部。例如,使用页面页眉在每页重复显示报表标题。

  • 组标头    本节位于每组新记录的开头。使用组标头显示组名称。例如,在按产品分组的报表中,使用组标头显示产品名称。在组标头中放置使用求和聚合函数的计算控件时,将计算当前组的总和。

  • 详细    本节在记录源中的每一行显示一次。本节用于放置构成报表主体的控件。

  • 组页脚    本节位于每组记录的末尾。使用组页脚显示各组的摘要信息。

  • 页面页脚    本节位于每页末尾。使用页面页脚显示页码或每页信息。

  • 报表页脚    本节仅在报表末尾出现一次。使用报表页脚显示报表总计或整个报表的其他摘要信息。

    注意: 在“设计”视图中,报表页脚显示在页面页脚下方。但打印或预览报表时,报表页脚显示在页面页脚的上方,紧接在最后一个组页脚或最后页上的主体行之后。

返回页首

了解控件

控件是显示数据、执行操作以及查看和处理强化用户界面的信息(例如标签和图像)的对象。Access 支持 3 类控件:绑定控件、未绑定控件和计算控件:

  • 绑定控件    绑定控件是指数据源为表或查询中的字段的控件。使用绑定控件显示数据库中字段的值。这些值可以是文本、日期、数字、“是/否”值、图片或图形。文本框是最常见的一类绑定控件。例如,窗体上显示员工姓氏的文本框可能从“员工”表中的“姓氏”字段获取此信息。

  • 未绑定控件    未绑定控件是指不含数据源(字段或表达式)的控件。使用未绑定控件显示信息、线条、矩形和图片。例如,显示报表标题的标签便是未绑定控件。

  • 计算控件    计算控件是指数据源为表达式(而非字段)的控件。通过将表达式定义为控件的数据源,可指定控件中所需的值。表达式是运算符(如 =+)、控件名、字段名、返回单个值的函数以及常数值的组合。例如,以下表达式通过将“单价”字段中的值乘以常数值 (0.75) 来计算享有 25% 折扣的商品价格。

    = [单价] * 0.75

    表达式所用数据可来自报表的基础表或查询中的字段,或者报表中的控件。

创建报表时,最高效的方法可能是先添加和排列所有绑定控件,特别是在报表中大多数控件均为绑定控件的情况下。然后,可使用“设计”选项卡上“控件”组中的工具,添加完成设计的未绑定控件和计算控件。

通过识别控件从中获取数据的字段,将控件绑定到该字段。通过将字段从“字段列表”窗格拖动到报表,可创建绑定到选定字段的控件。“字段列表”窗格显示报表基础表或查询的字段。若要显示“字段列表”窗格,请在“设计”选项卡的“控件”组中,单击“添加现有字段”。

或者,可通过在控件本身或控件属性表的 ControlSource 值框中键入字段名,将字段绑定到控件。属性表定义控件的特征,例如控件的名称、数据源和格式。

创建控件的最佳方式是使用“字段列表”窗格,这主要有以下两个原因:

  • 绑定控件具有附加标签,默认情况下,该标签使用字段名(或者在基础表或查询中为该字段定义的标题)作为其标题,因此用户无需自行键入标题。

  • 绑定控件继承了许多与基础表或查询中字段相同的设置(例如“格式”、“小数位置”和“输入掩码”属性)。因此,创建绑定到字段的控件时,可确保该字段的这些属性保持不变。

如果已创建未绑定控件并希望将其绑定到某个字段,请将控件的“ControlSource”属性设置为该字段的名称。有关“ControlSource”属性的详细信息,请搜索 "ControlSource" 帮助。

返回页首

在“布局”视图中微调报表

创建报表后,可在“布局”视图中轻松微调报表设计。以实际报表数据为向导,可调整列宽、重新排列各列,并添加分组级别和总计。可在报表设计上放置新字段,并设置报表及其控件的属性。

若要切换到“布局”视图,请在“导航窗格”中右键单击报表名,然后单击“布局视图按钮图像

Access 将在“布局”视图中显示报表。

可使用属性表修改报表及其控件和节的属性。若要显示属性表,请按 F4。

可使用“字段列表”窗格将基础表或查询中的字段添加到报表设计。若要显示“字段列表”窗格,请执行下列操作之一:

  • 在“设计”选项卡上的“工具”组中,单击“添加​​现有字段按钮图像 。请注意,如果使用 Access 2007,则“添加​​现有字段”命令位于“格式”选项卡上的“控件”组中。

  • 按 Alt+F8。

然后,可通过将字段从“字段列表”窗格拖动到报表来添加字段。

返回页首

在“设计​​”视图中微调报表

还可在“设计”视图中微调报表设计。若要向报表添加新的控件和字段,可将其添加到设计网格。通过属性表,可访问大量属性,并可对这些属性进行设置以自定义报表。

若要切换到“设计”视图,请在“导航窗格”中右键单击报表名,然后单击“设计视图按钮图像

Access 将在“设计”视图中显示报表。

可使用属性表修改报表自身及其所含控件和节的属性。若要显示属性表,请按 F4。

可使用“字段列表”窗格将基础表或查询中的字段添加到报表设计。若要显示“字段列表”窗格,请执行下列操作之一:

  • 在“格式”选项卡上的“控件”组中,单击“添加​​现有字段按钮图像 。请注意,如果使用 Access 2007,则“添加​​现有字段”命令位于“格式”选项卡上的“控件”组中。

  • 按 Alt+F8。

然后,可通过将字段从“字段列表”窗格拖动到报表来添加字段。

返回页首

从“字段列表”窗格添加字段

  • 若要添加单个字段,请将字段从“字段列表”窗格拖动到要在报表上显示的节。

  • 若要一次添加多个字段,请按住 Ctrl 并单击所需字段。然后,将所选字段拖动到报表上。

将字段拖放到报表节后,Access 会为每个字段创建绑定文本框控件,并自动在每个字段旁放置一个标签控件。

返回页首

向报表添加控件

某些控件会自动创建,例如将字段从“字段列表”窗格添加到报表时会创建绑定文本框控件。使用“设计”选项卡上“控件”组中的工具,可在“设计”视图中创建许多其他控件。

确定工具名称

  • 将鼠标指针置于工具上。

    Access 会显示该工具的名称。

使用“控件”组中的工具创建控件

  1. 单击要添加的控件类型的工具。例如,若要创建复选框,请单击“复选框按钮图像 工具。

  2. 在报表设计网格中,单击放置控件左上角的位置。单击一次即可创建默认大小的控件,或单击该工具,然后在报表设计网格中拖动以创建所需大小的控件。

  3. 如果首次尝试时未能完美放置控件,可通过以下步骤移动该控件:

    1. 单击控件将其选中。

    2. 将鼠标指针置于该控件边缘,直到指针变为四向箭头 移动指针

    3. 将控件拖至所需位置。

此过程会创建一个“未绑定”控件。如果控件是可以显示数据的类型(例如文本框或复选框),则需先在控件的“ControlSource”属性中输入字段名或表达式,然后控件才会显示任何数据。请参阅本主题中的了解控件部分,了解详细信息。

显示属性表

若要在“设计”视图中显示属性表,请执行下列操作之一:

  • 在“设计”选项卡上的“工具”组中,单击“属性表​​”。请注意,如果使用 Access 2007,则“属性表”命令位于“设计”选项卡上的“显示/隐藏”组中。

  • 按 F4。

返回页首

保存工作

保存报表设计后,可根据需要随时运行该报表。报表设计保持不变,但每次打印或查看报表时均会获取当前数据。如需更改报表,可修改报表设计或根据原报表创建类似的新报表。

保存报表设计

  • 单击“文件”>“保存​​”或按 Ctrl+S。请注意,如果使用 Access 2007,请单击“Microsoft Office 按钮”,然后单击“保存”或按 Ctrl+S。

    或者,在“快速访问工具栏”上单击“保存按钮图像

  • 如果报表未命名,请在“报表​​名称”框中键入名称,然后单击“确定”。

用新名称保存报表设计

  • 如果使用 Access 2013 或更高版本,请单击“文件”>“另存为”>“对象另存为”。

    如果使用 Access 2010,请单击“文件”>“对象另存为”。

    如果使用 Excel 2007,请单击“Microsoft Office 按钮”,然后单击“另存为​​”>“对象另存为​​”。

  • 在“另存为”对话框中的“报表另存为”框内键入新报表的名称,然后单击“确定”。

返回页首

查看、打印报表或以电子邮件形式发送报表

保存报表设计后,即可反复使用。报表设计保持不变,但每次查看或打印报表时均会获取当前数据。如需更改报表,可修改报表设计或根据原报表创建类似的新报表。

查看报表

可通过多种方式查看报表。选择何种方法取决于想要如何使用报表及其数据:

  • 如果要在打印前对报表中的数据进行临时更改,或者要将报表中的数据复制到剪贴板,请使用“报表”视图。

  • 如果希望在查看数据时更改报表的设计,请使用“布局”视图。

  • 如果只想查看打印时报表的外观,请使用“打印预览”。

注意: 如果报表格式设置有多列,“打印预览”中只显示列布局。“布局”视图和“报表”视图将报表显示为单个列。

在“报表”视图中查看报表

在“导航窗格​​”中双击报表时,默认使用“报表”视图显示报表。如果报表未打开,请在“导航窗格”中双击报表,即可在“报表”视图中查看该报表。

如果报表已打开,请在“导航窗格”中右键单击报表名称,然后单击“报表视图”。

在“报表”视图中处理数据

在“报表”视图中,可选择文本并将其复制到剪贴板。若要选择整行,请单击并拖动要选择的行旁边的边距。随后可通过执行下列操作之一,将这些行复制到剪贴板:

  1. 在“开始”选项卡上的“剪贴板”组中,单击“复制”。 按钮图像

  2. 右键单击选中的行,然后单击“复制”。

  3. 使用键盘快捷方式 - 按 Ctrl+C。

使用筛选器可仅显示所需行

无需退出“报表”视图,即可直接将筛选器应用到报表。例如,如果报表中有一列“国家/地区”,而你只想查看国家/地区为“加拿大”的行,请执行以下操作:

  1. 在报表中找到单词“加拿大”,然后右键单击它。

  2. 单击“等于“加拿大””。

Access 随即创建并应用筛选器。

打开和关闭筛选器

可在已筛选和未筛选显示结果之间切换,方法是在“开始”选项卡的“排序和筛选​​”组中单击“切换筛选​​”。这只是打开和关闭筛选器,而不会将其删除。

删除筛选器

  1. 右键单击要从中删除筛选器的字段。

  2. 单击“从字段名中清除筛选器”。(系统会列出字段名的实际字段。)

删除筛选器后,使用“切换筛选”命令无法将其切换回打开状态。必须先重新创建筛选器。

注意: 如果将筛选器应用于报表,然后保存并关闭该报表,则会保存该筛选器。但是,下次打开报表时,Access 不会应用该筛选器。若要重新应用筛选器,请在“开始”选项卡上的“排序和筛选”组中,单击“切换筛选”。

使用“打印预览”预览报表

在“导航窗格”中,右键单击报表,然后在快捷菜单上单击“打印预览”。

可使用导航按钮按顺序查看报表每一页或跳转到报表中的任意页。

导航按钮

1.单击此处显示第一页。

2.单击此处显示上一页。

3.单击此处显示下一页。

4.单击此处显示最后一页。

5.在此框中键入页码,然后按 Enter 键,跳转到特定页。

在“打印预览”中,可放大查看细节,也可缩小查看数据在页面上的位置布局。将光标放在报表上方,单击一次。若要使缩放效果相反,则再单击一次。此外,还可以使用 Access 状态栏上的缩放控件进一步放大或缩小。

若要关闭“打印预览”,请执行下列操作之一:

  • 在“打印预览”选项卡上,单击“关闭打印预览”。

  • 在“导航窗格”中,右键单击报表,然后在快捷菜单上单击“布局视图​​按钮图像 或“设计视图按钮图像

提示: 预览报表后,可将结果导出到 Microsoft Word、Microsoft Excel 或多个其他 Office 程序。在“外部数据”选项卡上的“导出”组中,单击所需格式按钮,并按照说明进行操作。

返回页首

打印报表

可在报表处于打开状态(任何视图中皆可),甚至关闭状态时,打印报表。打印前,请务必仔细检查页面设置,例如页边距或页面方向。Access 将页面设置随报表一起保存,因此只需设置一次。如果打印需求有变,可在之后再次进行设置。

更改页面设置

  1. 在“打印预览”中打开报表。可在任何视图中更改页面设置,但“打印预览”是最佳选择,因为在此视图中可即时查看任何更改效果。

  2. 在“打印预览”选项卡上的“页面布局”和“页面大小”组中,单击“纵向按钮图像 或“横向按钮图像 设置页面方向,单击“大小按钮图像 设置纸张大小,单击“页边距按钮图像 调整页边距等。

  3. 更改后,使用导航按钮查看多个页面,确保后续页面上未产生任何格式设置问题。

将报表发送到打印机

  1. 在任意视图中打开报表,或在“导航窗格”中选择报表。

  2. 单击“文件”>“打印”>“打印”。请注意,如果使用 Access 2007,请单击“Microsoft Office 按钮”,然后单击“打印”>“打印”。

    Access 随即显示“打印”对话框。

  3. 在打印机、打印范围和打印份数等选项中输入自己的选择。

  4. 单击“确定”。

返回页首

以电子邮件形式发送报表

可以电子邮件形式将报表发送给收件人,而不是打印纸质版本:

  1. 在“导航窗格”中,单击报表将其选中。在“外部数据”选项卡上的“导出”组中,单击“电子邮件”。请注意,如果使用 Access 2007,请在“导航窗格”中,单击报表将其选中,单击“Microsoft Office 按钮”,然后单击“电子邮件”。

  2. 在“对象发送为”对话框的“选择输出格式”列表中,单击要使用的文件格式。

  3. 完成其余的对话框。

  4. 在电子邮件应用程序中,键入邮件详细信息,然后发送邮件。

返回页首

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×