创建目录合并

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Publisher 功能可用于创建简短目录的模板。只需选择目录模板,然后替换为您自己的占位符图片和键入所需文本。

如果您想要创建一个较长的目录,您可以使用目录合并。您可以使用目录合并创建目录、 相册或任何其他类型的出版物中,每个页面上显示一个或多个项目。Microsoft Office 目录合并任务窗格将指导您完成目录合并过程的分步说明。

本文内容

目录合并的工作原理

规划您的目录

创建模板

连接到数据源

插入合并域

完成、 打印和保存出版物目录

目录合并的工作原理

目录合并是类似于邮件合并。使用目录合并时,创建目录合并模板,然后再将模板合并以生成合并的页数据源中的信息。

数据源与合并模板结合使用以生成出版物页面

1.数据源记录的信息,如项目名称和说明。

2.目录合并模板目录合并区域,并将合并域占位符的记录的信息。

3.使合并的页显示每页的多条记录。

可以将目录合并另存为新出版物,也可以将其添加到现有出版物的末尾。每次更新数据源中的信息时,您还可以保存目录合并模板并重新使用它,以便创建更多组合并页。

开始前

下面的提示将帮助您创建成功的目录合并:

  • 在新出版物中开始目录合并。

  • 将目录合并为一个页面模板的长度限制。

  • 使用想用于最终合并页的页尺寸设置目录合并模板。

  • 如果计划将创建的合并页添加到现有出版物的末尾,请确保目录合并模板与现有出版物在以下方面匹配:

    • 页面尺寸(高度和宽度)

    • 页面视图(单页或跨页)

    • 出版物类型(Web 或打印)

    • 页面顺序(从左向右或从右向左)

返回页首

规划目录

开始目录合并之前,应考虑要在最终合并页上列出的信息类别。

  • 要列出项名称和价格吗?

  • 要包含对每一项的说明吗?

  • 要包含每一项的图片吗?

规划数据源

确定要在目录中包含的信息类别后,您可以创建将要用于目录合并的数据源。如果您已经有一个数据源,则可以确保该数据源中包含您要在合并中包括的所有信息。

目录合并任务窗格中可以使用各种数据源格式。如果您还没有要用于合并的数据源,您可以生成在 Publisher 中的一项。在 Microsoft Office Excel 工作表或 Microsoft Office Word 表格中,您也可以创建数据源。

数据字段包含在数据源中对应插入目录合并模板合并域。

设置数据源时,请为每一类信息创建一列,例如项名称、物料编号和价格。每一行或每条记录对应于每一项的信息。

重要: 请确保您的数据源包括数据字段或列中,对于每种将合并的信息。根据您的数据源的类型,您可能能够对数据进行一些更改之后您连接到其在 Publisher 中,但最好是在开始之前确定最终信息。

如果您打算照片合并到目录页面,您需要包含您打算如何使用每个图片文件路径的栏。在数据源中不要包括实际图片或图像。

如果您打算在 Publisher 中创建数据源,您可以执行的后创建模板。

返回页首

创建模板

现在,您可以创建目录合并模板中,设计的最终合并页面布局的位置。当您完成合并时,使用目录合并模板以生成合并的页,您可以将其另存为新出版物或添加到现有出版物的末尾。

目录合并模板应具有相同的布局 (页面大小和方向) 所需的最终合并页。此外,它应包含任何文本或图形所需例如最终出版物的每个页面上显示、 背景图像或您的公司的名称。

如果计划将合并页添加到现有出版物的末尾,请确保目录合并模板与现有出版物在以下方面匹配:

  • 页面尺寸(高度和宽度)

  • 页面视图(单页或跨页)

  • 出版物类型(Web 或打印)

  • 页面顺序(从左向右或从右向左)

创建目录合并模板

  1. “文件”菜单上,单击“新建”

  2. 新出版物任务窗格中,单击空白页面尺寸,,然后选择所需的大小。

    如果您计划发布到网站目录中,单击空白页面尺寸下的网站,然后单击匹配目标屏幕分辨率的大小。

  3. 单击“创建”

  4. “文件”菜单上,单击“页面设置”

  5. 页面设置对话框中,对所需的页边距进行任何更改,然后单击确定

  6. “工具”菜单上,指向“邮寄和目录”,然后单击“目录合并”

返回页首

连接到数据源

设置您的目录合并模板页面的格式后,可以使用目录合并任务窗格中创建或查找并连接到数据源。选择下一步选项取决于您是否已拥有数据源或是否希望在 Publisher 中创建新的列表。

  1. 目录合并任务窗格下选择产品列表中,执行下列操作之一︰

  2. 单击下一步︰ 创建或连接到产品列表

使用现有列表

  1. 选择数据源对话框中,找到,然后单击所需的数据源。

    默认情况下,Publisher 在我的数据源文件夹中保存数据源。您可能需要通过浏览找到我的数据源文件夹以查找您的数据源。

  2. 单击“打开”

    根据所选数据源的类型,可能出现其他对话框请求特定信息。例如,如果您的数据源是 Excel 工作表中包含多个选项卡的信息,您必须选择选项卡包含的信息,然后单击确定

从 Outlook 联系人中选择

  1. 请执行下列操作之一:

    • 选择联系人对话框中,单击要使用的联系人列表中。

    • 选择配置文件对话框中,选择要使用的联系人的正确配置文件。

  2. 单击“确定”。

键入新列表

  1. 新的产品列表对话框中,键入第一个项目或您想要包括在目录中的记录的信息。

    如果您想要添加或删除列 — 例如,如果未包括的图片,单击自定义列,然后进行所需的更改。

  2. 在为第一条记录键入所有信息后,单击“新建条目”,然后为下一条记录键入相关信息。继续操作,直到为要包括的所有记录都键入了信息。

  3. 新列表完成后,单击“确定”

  4. “保存通讯录”对话框中,为新列表键入名称,然后单击“保存”

添加更多列表

如果希望在目录合并中使用多个列表,您可以添加列表。

  1. 目录合并产品列表中,在添加到产品列表中,下单击选择现有列表从 Outlook 联系人中选择,具体取决于您正在创建的出版物。

添加更多项目

如果您想要添加的几个项目,可以创建新的那些项目的列表,并将其与已选定列表结合。

  1. 目录合并产品列表中,单击添加到产品列表中,中的键入新列表

  2. 新的产品列表对话框中,键入您想要包括在目录中的第一个项目的信息。

    如果您想要添加或删除列,以便匹配的其他列表中使用的,单击自定义列,然后,进行所做的更改所需。

  3. 在为第一条记录键入所有信息后,单击“新建条目”,然后为下一条记录键入相关信息。继续操作,直到为要包括的所有记录都键入了信息。

  4. 新列表完成后,单击“确定”

  5. “保存通讯录”对话框中,为新列表键入名称,然后单击“保存”

  6. 在在目录合并产品列表对话框中的数据源下,您的新列表会自动显示。

选择要包括的记录

  1. 目录合并产品列表对话框中,执行下列操作之一︰

    • 选中要包括的记录旁边的复选框,并清除要排除的记录旁边的复选框。

      如果您想要仅包含几个记录列表中,单击全部清除,然后选择所需的记录。

    • 按照特定条件对列表进行筛选,具体方法是单击要作为筛选依据的项的列标题旁边的箭头,然后单击要作为筛选器的值。

      • (空白)显示对应的域为空白的所有记录。

      • “(非空白)”显示其中对应字段包含信息的所有记录。

        注意: 如果您的数据源包含共享相同的信息,记录,并且有 10 个或更少的唯一值的列中,您可以筛选按特定信息。例如,如果您的数据源是销售的属性的列表,并且有多个属性记录北京市/县为该列表,您可以筛选北京

        目录合并产品列表对话框中显示指定的记录。若要再次显示所有记录,请单击(全部)

    • 通过单击列标题中您想要作为排序依据的项目排序列表中的项目。例如,如果您想要按市/县按字母顺序显示列表,请单击市/县列标题。

  2. 单击确定以返回到目录合并任务窗格。Publisher 将使用您指定的记录进行合并。

  3. 单击下一步︰ 准备出版物

返回页首

插入合并域

现在,可以排列您要在出版物中显示的信息了。要设置页面版式,可以向目录合并区中添加合并域。每个合并域都表示数据源中的一列,目录合并区显示将如何显示一条记录中的信息。

可以按照需要的方式排列目录合并区,然后指定合并区在每一页上的重复次数。例如,您可能想在每一页显示 4 项。根据您的目录合并区排列方式,每一项都将按照相同方式显示。您可以调整每一项的大小,并且可以更改目录合并区的大小。

如果插入目录合并区之外的合并域时,它们不会重复当您完成合并。

目录合并区中插入合并域

  • 目录合并任务窗格中,单击准备出版物中,中的您想要插入的第一个合并域。

  • 在目录合并区中选择合并域,然后通过执行下列操作移动合并域并调整其大小:

    • 若要移动的合并域,直到指针变为移动指针 移动指针 ,将鼠标指针置于合并域,然后将合并字段拖动到新位置。

    • 若要调整大小的合并域,在文本或图片框上的控点之一将鼠标指针,直到指针变为调整指针 移动标尺 ,然后拖动鼠标,直到文本或图片框是所需的大小。

  • 单击合并域的外部,使其不再处于选中状态。

  • 重复步骤 1-3,直到从数据源中插入所有需要的域。

    如果选择以前插入的合并域插入一个新的合并域时,Publisher 将插入新的合并域与以前插入的合并域。

设置合并字段的格式

通过设置在目录合并模板合并字段的格式,可以设置格式的目录合并的数据。

  1. 在目录合并模板中,选择包含要设置格式的信息的域,包括两边的合并域字符 («« »»)。

  2. “格式”菜单上,单击“字体”,然后选择所需的选项。

移动目录合并区或者调整其大小

如果设置了格式的合并域不再适合目录合并区,可以调整目录合并区的大小。

如果增加的大小,您可能需要在每页上适合较少的项目或记录。

  1. 单击目录合并区域以选中它。

  2. 将鼠标指针置于某个目录合并区域中,在控点,然后拖动鼠标。

  3. 指定多少个项目应显示在每一页上键入所需的页面向下和目录合并版式工具栏上的页面跨项目的数字。

完成并预览模板

  1. 键入任何重复出现的文字或您想要从数据源的信息旁边显示的信息。例如,添加合并字段的价格旁边货币符号。

  2. 预览页上,单击箭头以查看合并数据的每一页。

    如果您决定不包括的项,请单击该项目,目录合并区域,然后单击在目录合并任务窗格中的排除此项目

  3. 当您准备就绪后,单击下一步︰ 创建合并的出版物

返回页首

完成、打印和保存目录出版物

要完成合并,您有以下三种选择:

  • 可以直接打印合并出版物。

  • 可以创建和打印包含合并内容的新出版物。正如您可以在 Publisher 中更改任何其他出版物一样,您可以对此出版物的内容进行更改。

  • 可以将合并内容添加到现有出版物中。

如果要向出版物添加封面和封底,或者如果要添加任何其他页面,您需要创建一个新出版物或者将内容添加到现有出版物。

打印合并出版物

  • 目录合并任务窗格中,单击打印

    Publisher 打印合并的页面。

合并到新出版物

如果您想要编辑合并的页面、 将其保存以备将来使用,或将在以后它们打印出来,您可以收集和将所有合并页面另存为一个新合并的出版物所包含的实际数据 — 例如,产品名称和价格,而不是合并域。

  • 目录合并任务窗格中,单击合并到一个新的出版物

    Publisher 中创建一个新的出版物,您可以保存和编辑。您甚至可以添加前端和后封面。

    如果您打算打印为小册子目录,请确保总页数为 4 的倍数。

  • 目录合并任务窗格中,单击保存此发布

  • 文件名框中,为新出版物中,键入一个名称,然后单击保存

  • 如有必要,请保存对目录合并模板所做的任何更改。您可以再次使用此目录合并模板数据源中更新信息时创建其他合并的页。

添加到现有出版物

如果已经在另一出版物内设置了封面,或者想将目录放置在一个更长出版物的末尾,您可以直接添加合并内容。

在向现有出版物的末尾添加合并页之前,请确保目录合并模板与现有出版物在以下方面匹配:

  • 页面尺寸(高度和宽度)

  • 页面视图(单页或跨页)

  • 出版物类型(Web 或打印)

  • 页面顺序(从左向右或从右向左)

注意: Publisher 无法将合并的页面添加到打开的出版物。如果您正在处理您想合并的出版物,请确保保存并完成合并之前将其关闭。

  1. 目录合并任务窗格中,单击添加到现有出版物。在打开出版物对话框中,找到并选择您要向其添加合并的页,的出版物,然后单击打开

    Publisher 会将合并页添加到现有出版物的末尾。

    若要重新排列中更新后的出版物的页面,请单击您想要移动的页排序器中,在任何页上,然后将其拖到所需的位置。

  2. 在现有出版物中,单击以保存您的更新文件菜单上的保存

  3. 如有必要,请保存对目录合并模板所做的任何更改。您可以再次使用此目录合并模板以在您的数据源中更新信息时创建其他合并的页。

打印和保存出版物目录

如果您创建新的合并的出版物或添加目录合并至现有出版物,您可以通过单击文件菜单上打印打印出版物。

打印小册子作为目录出版物

  1. “文件”菜单上,单击“页面设置”

  2. 边距参考线,单击高级

  3. 版式类型,下单击小册子

  4. 页面上,下,使其与您的出版物的原始尺寸调整宽度高度设置。

    如果不调整页面宽度和高度,Publisher 的页数位置两个小册子在原始页面尺寸,并将不适合您的目录。

保存您的模板,以便可以再次使用它

最好保存目录合并模板。您可以使用其再次创建其他合并页集时数据源中更新的信息。以保存出版物目录合并,请执行下列操作︰

  1. 请确保您已在目录合并出版物。

  2. “文件”菜单上,单击“保存”

  3. 目录合并出版物命名,,然后单击保存

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×