创建目录合并

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

Publisher 功能能够连接到数据源,如数据库、 电子表格或甚至文本文件,并使用这些数据来轻松地创建您的产品或服务的目录。您可以使用目录合并创建目录、 相册或任何其他类型的出版物中,每个页面上显示一个或多个项目。

目录合并的工作原理

规划您的目录

创建模板出版物

连接到数据源

插入合并域

完成、 打印和保存出版物目录

目录合并的工作原理

目录合并是类似于邮件合并。使用目录合并时,您创建目录合并模板出版物,然后将该模板合并以生成合并的页数据源中的信息。

数据源与合并模板合并以生成目录页

1 的数据源与记录的信息,如项目名称和说明。

2 目录合并与目录合并区模板发布和合并域占位符的记录的信息。

3 生成合并显示每页的多条记录的页面。

您可以将目录合并另存为新的出版物,或者您可以将其添加到现有出版物的末尾。您还可以保存目录合并模板并在数据源,若要创建其他合并页集更新信息时再次使用它。

开始前

下列提示将帮助您创建成功的目录合并:

  • 开始新的出版物中的目录合并。

  • 除了如封面页、 目录、 和订单窗体的表,授予您自己的合并字段的一页,甚至是通过您的目录将可能具有多个页面后创建合并的文档。

  • 设置目录合并模板所需的最终合并页的页面尺寸。

  • 如果您打算将合并您创建的页面添加到现有出版物的末尾,请确保目录合并模板通过以下方式与现有出版物相匹配:

    • 页面大小 (高度和宽度)

    • 页面视图 (单页或跨页)

    • 出版物类型 (Web 或打印)

    • 页面顺序 (从左到右或从右到左)

返回页首

规划您的目录

目录合并之前,请考虑要在最终合并页面中列出有关哪些类型的信息。

  • 列表项目名称和价格吗?

  • 您想要包括的每个项目的说明执行操作?

  • 若要包括的每个项目图片吗?

规划您的数据源

决定要包括在目录中的信息类型后,您可以创建将使用目录合并的数据源。如果您已有数据源,您可以确保它包含您要在合并中包括的所有信息。

Publisher 的目录合并可以使用各种数据源格式。如果您还没有要用于合并的数据源,您可以生成在 Publisher 中的一项。在 Microsoft Office Excel 工作表或 Microsoft Office Word 表格中,您也可以创建数据源。

数据字段包含在数据源中对应插入目录合并模板合并域。

设置您的数据源时, 创建每种类型的信息,如项目名称、 股票的号码和价格的列。每个行或记录中,对应于项目的信息。

重要 请确保您的数据源包括数据字段或列中,对于每种将合并的信息。根据您的数据源的类型,您可能能够对数据进行一些更改之后您连接到其在 Publisher 中,但最好是在开始之前确定最终信息。

如果您打算照片合并到目录页面,您需要包含您打算如何使用每个图片文件路径的栏。在数据源中不要包括实际图片或图像。

如果您打算在 Publisher 中创建数据源,您可以创建模板发布后执行的。

返回页首

创建模板出版物

现在,您可以创建目录合并模板出版物,设计的最终合并页面布局的位置。当您完成合并时,使用此目录合并模板以生成合并的页,您可以将其另存为新出版物或添加到现有出版物的末尾。

目录合并模板应具有相同的布局 (页面大小和方向) 所需的最终合并页。此外,它应包含任何文本或图形所需例如最终出版物的每个页面上显示、 背景图像或您的公司姓名和电话号码。 这是最佳完成合并模板的这些元素使用母版页。

如果您打算将合并的页面添加到现有出版物的末尾,请确保目录合并模板通过以下方式与现有出版物相匹配:

  • 页面大小 (高度和宽度)

  • 页面视图 (单页或跨页)

  • 出版物类型 (Web 或打印)

  • 页面顺序 (从左到右或从右到左)

创建目录合并模板

  1. 选择适合您的目录出版物模板。

  2. 在插入选项卡上,单击目录页。
    开始目录页合并

  3. 将使用默认目录合并区域创建目录页面和目录工具选项卡将显示在功能区上。此时,你可以将目录合并区域随着您希望在页面上,并添加任何文本或您希望在您的目录的每一页上显示的图像。小合并区、 多个目录项可以合并到的页面。例如,2"x 2"合并区域将重复多次比 4"x 4"合并区域。不必担心太多获取完全正确,您可以返回并在任何时间进行编辑这些项目。

    提示 不在此时间,等到就可以插入合并字段并从布局库使用预制设计方案之一配置目录合并区。

返回页首

连接到数据源

设置您的目录合并模板页面的格式后下, 一步是创建或找到并连接到数据源。选择下一步选项取决于您是否已拥有数据源或是否希望在 Publisher 中创建新的列表。

  1. 在目录工具选项卡,单击添加列表,然后执行下列操作之一:

    • 如果您需要创建合并的数据源,请选择键入新列表。

    • 如果您已有您要使用的数据源,请单击使用现有列表。

    • 如果您想要创建您的联系人的目录,请单击选择从 Outlook 联系人。

键入新列表

  1. 在新的产品列表对话框中,键入第一个项目或您想要包括在目录中的记录的信息。

    如果您想要添加或删除列 — 例如,如果未包括的图片,单击自定义列,然后进行所需的更改。

  2. 键入您的第一条记录的所有信息后,单击新建条目,,然后都键入下一条记录的信息。继续操作,直到您键入了为您想要包括的所有记录的信息。

  3. 完成您的新列表时,单击确定。

  4. 在保存地址列表对话框中,为新的列表中,键入一个名称,然后单击保存。

使用现有列表

  1. 在选择数据源对话框中,找到,然后单击所需的数据源。

    默认情况下,Publisher 在我的数据源文件夹中保存数据源。您可能需要通过浏览找到我的数据源文件夹以查找您的数据源。

  2. 单击打开。

    根据所选数据源的类型,可能出现其他对话框请求特定信息。例如,如果您的数据源是 Excel 工作表中包含多个选项卡的信息,必须选择包含所需的信息的选项卡,然后单击确定。

从 Outlook 联系人中选择

  1. 执行下列操作之一:

    • 在选择联系人对话框中,单击要使用的联系人列表中。

    • 在选择配置文件对话框中,选择要使用的联系人的正确配置文件。

  2. 单击“确定”。

添加更多列表

如果您想要在目录合并中使用多个列表,您可以添加列表。

  1. 单击编辑列表,然后在目录合并产品列表中,单击下添加到产品列表中,选择从 Outlook 联系人中选择现有列表 ,或键入新列表。
    Publisher 将提示您通过打开产品列表中的对话框中添加不同的源列表中的字段之间修复不匹配。

  2. 在添加到产品列表中的对话框中,匹配列中选择一个字段,未选中,选择要使其在产品列表字段与匹配的字段列表中对应的字段,然后单击匹配。

  3. 在匹配域对话框中,验证所选的字段列出下匹配到产品列表字段或选择另一个,然后单击确定。

  4. 如果您需要向收件人列表进行匹配,请选择您想要添加新列表 (在添加到收件人列表对话框左侧的列表) 中的字段添加新字段,单击添加,然后单击确定。
    添加字段在新域下显示要添加到收件人列表

选择要包括的记录

  1. 单击编辑列表。

  2. 在目录合并产品列表对话框中,执行下列操作之一:

    • 选择所需的记录旁边的复选框,然后清除要排除的记录旁边的复选框。

      提示 如果您想要仅包含几个记录列表中,单击全部清除,然后选择所需的记录。

    • 由特定条件筛选列表,单击要作为筛选依据的项目的列标题和然后单击要用作筛选器的值旁边的箭头。

      • (空白)显示对应的域为空白的所有记录。

      • (非空白) 显示相应的字段中包含的信息的所有记录。

        注意 如果您的数据源包含共享相同的信息,记录,并且有 10 个或更少的唯一值的列中,您可以筛选按特定信息。例如,如果您的数据源是销售的属性的列表,并且有多个属性记录北京市/县为该列表,您可以筛选北京。

        目录合并产品列表对话框中显示指定的记录。若要再次显示所有记录,请单击 (全部)。

    • 通过单击列标题中您想要作为排序依据的项目排序列表中的项目。例如,如果您想要按市/县按字母顺序显示列表,请单击城市中的位置列标题。

  3. 单击“确定”。

返回页首

插入合并域

现在,将会排列要显示出版物中的信息的时间。若要在页的布局,合并域添加到目录合并区域。每个合并域表示您的数据源中的列和目录合并区将显示一条记录中的信息的显示方式。

您所需方式排列目录合并区和您然后指定每一页上合并区域中的重复的次数。例如,您可能希望在每一页上显示四项。每个项目将显示在相同的方式,基于目录合并区的排列方式。您可以调整大小的每个项目,并且您可以更改目录合并区域的大小。

重要  如果插入目录合并区之外的合并域时,它们不会重复当您完成合并。

选择合并区域布局

  1. 在布局组中,执行下列操作之一:

    • 选择从一个预制的设计库。
      目录合并版式选项

    • 行和列下拉列表中选择每一页上行和列的数。
      目录页版式行和列

插入目录合并区的文本合并域

  1. 单击文本字段按钮,然后单击要插入的第一个合并域。
    在目录合并中插入文本域

  2. 在目录合并区域中,选择的合并域,然后移动,并通过执行下列操作来调整大小的合并域:

    • 若要移动的合并域,直到指针变为移动指针 移动指针 ,将鼠标指针置于合并域,然后将合并字段拖动到新位置。

    • 若要调整大小的合并域,在其中一个尺寸控点上的文本或图片框将鼠标指针,直到指针变为调整指针 移动标尺指针 ,然后拖动鼠标,直到文本或图片框是所需的大小。

  3. 单击以外的合并域,以便它不再处于选中状态。

  4. 重复步骤 1-3,直到您已插入的所有字段所需从数据源。

重要  在当前插入点 (插入点闪烁光标) 插入字段。如果没有插入点,将创建一个新的文本框和合并域放置在此新文本框。

设置格式的文本合并域

通过设置在目录合并模板合并字段的格式,可以设置格式的目录合并的数据。这些字段可以视为任何文本框中,您可以包括-合并文本和格式,以及已合并的项。

  1. 在目录合并模板中,选择包含要设置格式,信息的字段包括周围的合并域字符 (««»»)。

  2. 在文本框工具选项卡上,选择所需的选项。

目录合并区中插入图片合并域

  1. 单击图片域按钮,然后单击要插入的第一个合并域。

  2. 在目录合并区域中,选择的合并域,然后移动,并通过执行下列操作来调整大小的合并域:

    • 若要移动的合并域,直到指针变为移动指针 移动光标 ,将鼠标指针置于合并域,然后将合并字段拖动到新位置。

    • 若要调整大小的合并域,对文本或图片框上的控点之一将鼠标指针,直到指针变为调整指针 调整大小光标 ,然后拖动鼠标,直到文本或图片框是所需的大小。

  3. 单击以外的合并域,以便它不再处于选中状态。

  4. 重复步骤 1-3,直到您已插入的所有字段所需从数据源。

重要  在当前插入点 (插入点闪烁光标) 插入字段。如果没有插入点,将创建一个新的文本框和合并域放置在此新文本框。

移动或调整大小的目录合并区域

如果您已设置格式的合并域不再适合目录合并区中,您可以对其进行调整。

注意 如果增加的大小,您可能需要在每页上适合较少的项目或记录。

  1. 单击目录合并区域,以将其选中。

  2. 将鼠标指针置于目录合并区上的控点之一,然后拖动鼠标。

  3. 指定多少个项目应显示在每一页上键入所需的页面向下和目录合并版式工具栏上的页面跨项目的数字。

完成并预览模板

  1. 单击预览结果。

  2. 单击箭头以查看合并数据的每一页。
    目录预览组

    如果您决定不包括的项,请单击预览的项目,,然后单击预览页面组中的排除的项。

返回页首

完成、 打印和保存出版物目录

若要完成合并,您有三个选项:

  • 您可以直接打印合并的出版物。

  • 您可以创建和打印包含合并的内容的新出版物。将更改 Publisher 中的任何其他发布一样,您可以对此发布的内容进行更改。

提示 如果您想要包括在出版物中的多个目录合并,您需要创建一个新的出版物的合并页,如只能有一个组的每个发布的目录页面。

  • 您可以添加到现有出版物的合并的内容。

如果您想要添加的顶层并返回到您的出版物的封面,或者如果您想要添加的任何其他页面,您需要创建一个新的出版物,或将内容添加到现有出版物。

合并到一个新的出版物

如果您想要编辑合并的页面、 将其保存以备将来使用,或将在以后它们打印出来,您可以收集和将所有合并页面另存为一个新合并的出版物所包含的实际数据 — 例如,产品名称和价格,而不是合并域.

  1. 在合并组中,单击合并到新建。
    目录合并至新出版物
    publisher 创建一个新的出版物,您可以保存和编辑。您甚至可以添加前端和后封面。
    注意如果您打算打印您的目录为小册子,请确保总页数 4 的倍数。

  2. 在目录合并任务窗格中,单击保存此发布。

  3. 在文件名框,为新出版物中,键入一个名称,然后单击保存。

  4. 如有必要,还可以保存对目录合并模板所做的任何更改。您可以再次使用此目录合并模板以在您的数据源中更新信息时创建其他合并的页。

添加到现有出版物

如果您已经在单独的出版物中,设置您封面,或如果您希望放置在较长的出版物的末尾处的目录,您可以直接添加合并的内容。

向现有出版物的末尾添加合并的页面之前,请确保目录合并模板通过以下方式与现有出版物相匹配:

  • 页面大小 (高度和宽度)

  • 页面视图 (单页或跨页)

  • 出版物类型 (Web 或打印)

  • 页面顺序 (从左到右或从右到左)

注意 Publisher 无法将合并的页面添加到打开的出版物。如果您正在处理您想合并的出版物,请确保保存并完成合并之前将其关闭。

  1. 在合并组中,单击添加到现有。
    目录合并至现有出版物

  2. 在打开出版物对话框中,找到并选择您要向其添加合并的页中,的发布,然后单击打开。

    Publisher 将合并的页面添加到现有出版物的末尾。

    提示 若要重新排列中更新后的出版物的页面,请单击您想要移动页面导航窗格中,在任何页上,然后将其拖到所需的位置。

  3. 在现有出版物中,单击保存以保存您的更新。

  4. 如有必要,还可以保存对目录合并模板所做的任何更改。您可以再次使用此目录合并模板以在您的数据源中更新信息时创建其他合并的页。

打印合并的出版物

  • 在合并组中,单击打印。
    目录合并到打印机

    Publisher BackStage 视图中打开打印页面。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×