创建盒须图

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

如果你正在进行统计分析, 你可能希望创建标准的框绘图以显示一组数据的分布。在框绘图中, 数字数据分为 quartiles, 在第一个和第三个 quartiles 之间绘制一个框, 并在第二个四分条线上绘制一条附加线来标记中间值。在某些框的绘图中, 第一和第三个 quartiles 外部的最小和最大的和最大的行都用行来表示, 这通常称为

盒须图的各个部分

虽然Excel 2013没有用于框出图的图表模板, 但您可以通过执行下列步骤来创建框的绘图:

  1. 计算来自源数据集的四分位值。

  2. 计算四分位差。

  3. 从四分四个区域创建堆积柱形图类型。

  4. 将堆积柱形图转换为 "绘图" 样式。

在我们的示例中, 源数据集包含三列。每列包含以下范围内的30个条目:

  • 第1列 (2013): 100 –200

  • 第2列 (2014): 120 –200

  • 第3列 (2015): 100 –180

源数据表

本文内容

步骤 1: 计算四分位值

首先, 你需要计算数据集中的最小值、最大值和中值以及第一个和第三个 quartiles。

  1. 若要执行此操作, 请创建第二个表, 并使用以下公式填充它:

    公式

    最小值

    最小值 (单元格区域)

    第一条四分位

    求得.inc. (单元格区域, 1)

    中间值

    求得.inc. (单元格区域, 2)

    第三个四分位

    求得.inc. (单元格区域, 3)

    最大值

    MAX (单元格区域)

  2. 因此, 你应该获得包含正确值的表。从示例数据集计算以下 quartiles:

    最终的表和值

返回页首

步骤 2: 计算四分位差

接下来, 计算每个阶段之间的差异。实际上, 你必须计算以下各项之间的 differentials:

  • 第一个四分数值和最小值

  • 中间和首个四分位

  • 第三个四分位数和中间值

  • 最大值和第三个四分位

  1. 首先, 创建第三个表, 然后直接复制最后一个表中的最小值。

  2. 用Excel减法公式 (cell1 – cell2) 计算四分位差, 并用 differentials 填充第三个表。

对于示例数据集, 第三个表的外观如下所示:

返回页首

步骤 3: 创建堆积柱形图

第三个表中的数据非常适合用于盒须图, 我们将首先创建一个堆积柱形图, 然后我们将对其进行修改。

  1. 选择第三个表中的所有数据, 然后单击 "插入" > "插入柱形图" > "堆积柱形图"。

    首先选择堆积柱形图。

    最初, 图表并不类似于框出图, 因为Excel将默认情况下使用水平和非垂直数据集绘制堆积柱形图。

    具有堆积柱形图的默认图表
  2. 若要反转图表坐标轴, 请右键单击图表, 然后单击 "选择数据"。

  3. 单击 "切换行/列"。

    提示: 

    • 若要重命名列, 请在 "水平 (分类) 轴标签" 侧, 单击 "编辑", 选择第三张表中具有所需类别名称的单元格区域, 然后单击"确定"选择要重命名的单元格区域。

    • 若要重命名图例项, 请在 "图例项 (系列) " 旁边, 单击 "编辑", 然后键入所需的条目。

  4. 单击“确定”。

现在, 图表应如下所示。在此示例中, 图表标题也已编辑, 此时图例处于隐藏状态。

图表的样式现在应如图所示。

返回页首

步骤 4: 将堆积柱形图转换为 "绘图框" 样式

隐藏底部数据系列

若要将堆积柱形图转换为框图, 请首先隐藏底部数据系列:

  1. 选择列的底部部分。

    注意: 单击单列时, 将选中同一系列的所有实例。

  2. 单击 "格式" >当前选择>格式选择。将在右侧打开 "格式" 面板。

    “格式选择”位于“格式”选项卡中。
  3. 在 "填充" 选项卡上的 "正式" 面板中, 选择 "无填充"。

    底部的数据系列隐藏在图表中, 不可见。

    在此图中,底部数据处于隐藏状态。

为盒须图创建须

下一步是将顶部和底部 (图像中的深蓝色和橙色区域) 替换为带线条或的数据系列。

  1. 选择最顶端的数据系列。

  2. 在 "填充" 选项卡上的 "正式" 面板中, 选择 "无填充"。

  3. 从功能区中, 单击 "设计>"添加图表元素>误差线>标准偏差

    “添加图表元素”和“误差线”菜单。
  4. 单击绘制的误差线之一。

  5. 在 "格式" 面板中打开 "误差线选项" 选项卡, 然后设置以下内容:

    • 方向设置为减号

    • 将 "结束样式" 设置为 "无帽"。

    • 对于误差量, 请将 "百分比" 设置为100

      对于“误差量”,“百分比”应为 100%。
  6. 对第二个从底部的数据系列重复之前的步骤。

    堆积柱形图现在应该开始类似于框出图。

    最终图表中现在已经有了“须”。

为中间区域着色

框图通常以一种填充颜色绘制, 并带有轻微的轮廓边框。以下步骤介绍了如何完成布局。

  1. 选择盒须图的顶部区域。

  2. 在 "格式" 面板中的 "填充 & " 选项卡上, 单击 "纯色填充"。

  3. 选择填充颜色。

  4. 单击同一选项卡上的 "实线"。

  5. 选择轮廓颜色和笔划宽度

  6. 为您的框出图的其他区域设置相同的值。

    最终结果应类似于盒须图。

    最终的盒须图应如图所示。

返回页首

另请参阅

Office 中的可用图表类型

Power View 中的图表和其他可视化效果

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×