创建电子邮件合并

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

当您要发送大量几乎相同但又分别包含一些唯一性信息的邮件时,请使用电子邮件合并。例如,可以使用电子邮件合并来创建分别自定义的电子邮件,其中包含个性化注释或针对不同客户群发送的不同内容。还可以使用电子邮件合并来创建要发送给前 100 位客户的产品通知,其中出版物的大部分或全部文字都相同,但每位客户的电子邮件地址不同。

注意: 电子邮件合并要求使用 Microsoft Office Outlook 2007 或 Microsoft Outlook Express(5.0 版或更高版本)。

使用“电子邮件合并”任务窗格可以创建电子邮件合并。要在新的或现有的出版物中打开“电子邮件合并”任务窗格,请指向“工具”菜单上的“邮寄和目录”,然后单击“电子邮件合并”

本文内容

创建或连接到的收件人列表

准备您的出版物

创建合并的出版物

取消合并

创建或连接到收件人列表

要执行电子邮件合并,必须打开新的或现有出版物,然后连接到数据源,数据源是一个包含您要包括的唯一性信息的文件。数据文件可以包含姓名和电子邮件地址的列表、产品数据或图片。数据文件可采用多种格式,其中包括:

  • Microsoft Office Outlook 联系人列表

  • Microsoft Office Excel 工作表

  • Microsoft Office Word 表格

  • Microsoft Office Access 数据库表

  • 其中由制表符、逗号、分号或其他分隔符划分列并由段落分隔符划分行的文本文件

可以连接到现有列表或数据源,也可以创建新的收件人列表。如果只想在合并中使用列表中的某些条目,可以按照特定条件筛选列表。也可以按字母顺序对各条目排序。

注意: 如果您想要将图片合并到出版物页面,文件名或路径要合并的图片文件必须包含数据源。在数据源中不要包括实际图片或图像。

使用现有列表

  1. “创建收件人列表”下,单击“使用现有列表”,然后单击“下一步: 创建或连接到收件人列表”

    默认情况下,Microsoft Office Publisher 将数据源存储在“我的数据源”文件夹中。您可能需要通过浏览找到数据源。

  2. “选取数据源”对话框中,单击所需的数据源。

  3. 单击“打开”

    根据所选择的数据源类型,可能出现要求输入特定信息的其他对话框。

    例如,如果数据源是在多个工作表上都有信息的 Microsoft Office Excel 工作簿,则必须选择包含所需信息的工作表,然后单击“确定”

    列表中的所有联系人将出现在“邮件合并收件人”对话框中,可以在其中对要包含在合并中的收件人列表进行筛选和排序。

从 Outlook 联系人中选择收件人

  1. “创建收件人列表”下,单击“从 Outlook 联系人中选择”,然后单击“下一步: 创建或连接到收件人列表”

  2. 如果提示您选择邮件配置文件,则请单击所需的配置文件,然后单击“确定”

  3. “选择联系人”对话框中,单击所需的联系人列表,然后单击“确定”

    文件夹中的所有联系人都将出现在“邮件合并收件人”对话框中,可以在其中对要包含在合并中的收件人列表进行筛选和排序。

键入新列表

如果没有可以连接的现有列表,可以创建一个新列表。

  1. “创建收件人列表”下,单击“键入新列表”,然后单击“下一步: 创建或连接到收件人列表”

  2. “新建地址列表”对话框中,添加所需的任何新域或列标题。

    如何?

    “新建地址列表”对话框中,单击“自定义列”,然后执行下列任何一项操作:

    • 要添加域,请单击要添加的域的名称,然后单击“添加”

    • 要删除域,请单击要删除的域的名称,然后单击“删除”

    • 要重命名域,请单击要重命名的域的名称,然后在“重命名域”对话框的“重命名为”文本框中键入新名称。

    • 要在列表中向上或向下移动域,请单击要移动的域的名称,然后单击“上移”“下移”,直到该域到达期望的位置。

  3. 在相关域中键入第一个条目的信息,包括收件人的电子邮件地址。不必填写所有域。

  4. 完成第一个条目的信息输入后,请单击“新建条目”

  5. 重复步骤 3 和步骤 4,直到完成添加条目,然后单击“确定”

  6. “保存通讯录”对话框中的“文件名”框中键入地址列表的名称,然后选择要在其中保存该列表的文件夹。

    默认情况下,Microsoft Office Publisher 会将地址列表保存在“我的数据源”文件夹中。最好将地址列表保存在此处,因为该文件夹也是 Publisher 在其中查找数据源的默认文件夹。

    新列表中的所有联系人都将出现在“邮件合并收件人”对话框中,可以在其中对要包含在合并中的收件人列表进行筛选和排序。

选择收件人

“邮件合并收件人”对话框中,可以选择要包含在合并中的收件人。选中要包括的每个收件人旁边的复选框,并清除要排除的每个收件人旁边的复选框。

选中或清除列表中的所有条目

  • 选中或清除标题行中的复选框。

如果合并中只需要使用列表中的某些条目,则可以按照特定域或条件筛选列表。筛选列表后,可以使用复选框来包括和排除记录。

筛选列表中的条目

  1. 单击要作为筛选依据的项目的列标题旁边的箭头。

  2. 单击下列任意一项:

    • “(空白)”显示其中对应域为空的所有记录。

    • “(非空白)”显示对应域中包含信息的所有记录。

    • “(高级)”打开“筛选和排序”对话框,可用来依据多个条件进行筛选。还可以通过在“邮件合并收件人”对话框中单击“调整收件人列表”下的“筛选”来打开“筛选和排序”对话框。

      提示: 如果数据源包含在某些域中具有相同信息的多条记录,并且列中最多有 10 个唯一值,则可按特定信息进行筛选。例如,如果有多个地址将澳大利亚做为国家/地区列出,则可以按“澳大利亚”进行筛选。

      “邮件合并收件人”对话框仅显示与条件匹配的记录。要再次显示所有记录,请单击“(全部)”

如果要按字母顺序查看列表中的记录,可对列表中的记录进行排序。

排序列表中的条目

  • “邮件合并收件人”对话框中,单击要作为排序依据的项目的列标题。

    例如,如果要按姓氏的字母顺序显示列表,则请单击“姓氏”列标题。

  • 要使用多个条件进行排序,请在“邮件合并收件人”对话框中,单击“调整收件人列表”下的“排序”。在“筛选和排序”对话框中,选择要作为排序依据的条件。

单击“确定”以返回到“电子邮件合并”任务窗格。

返回页首

准备出版物

电子邮件合并可将包含每个副本中的相同信息的邮件和表示每个副本的唯一性信息的一个或多个占位符组合起来。创建出版物后,请插入要显示在每个电子邮件合并出版物版本中的任何附加文字(例如问候)以及表示唯一性信息的占位符(如收件人姓名)。

如果还未执行此操作,则请插入一个文本框,键入要显示在每个电子邮件合并出版物版本中的文字,并添加表示唯一性信息的占位符。

插入文本框

  1. 对象工具栏上单击文本框中 按钮图像

  2. 在出版物中,指向文本框的一个角要出现的位置,再沿对角线将文本框拖到所需的尺寸。

插入要在所有版本中显示的文字

  • 单击文本框内部,然后键入要在每个电子邮件合并出版物版本中出现的文字。

将数据域插入出版物中

  1. 在电子邮件合并出版物中,单击要插入数据字段的文本框的内部。

  2. 插入下列任意一项:

    地址字段

    “电子邮件合并”任务窗格中(“准备出版物”),从“准备出版物”下的列表中,将要包括的域拖入已为其创建的文本框中。

    注意: 

    • 也可以单击“其他项目”下的“地址域”,然后在“插入地址域”对话框中单击要包括的每个地址元素。

    • 如果数据源中数据域的名称与 Publisher 用于地址域的域名称不匹配,您可能需要单击“插入地址域”对话框中的“匹配域”。在“匹配域”对话框中,使用下拉列表从数据源中选择对应于 Publisher 域的域。

    个性化超链接

    1. “电子邮件合并”任务窗格(“准备出版物”)的“其他项目”下,单击“插入个性化超链接”

    2. “插入个性化超链接”对话框中,键入要显示的文本以及收件人单击超链接时希望收件人转到的网站地址。

    3. 如果要在显示文本中插入数据域,则请单击要在其中插入数据域的显示文本框的内部,然后在右侧的列表中单击要插入的数据域。

      注意: 如果插入数据域,可以为所有空白条目指定与插入的数据域对应的替换显示文本和 Web 地址。根据需要选中“为空白条目使用默认文本”“为空白条目使用默认超链接”复选框,并键入替换文本和 Web 地址。

    图片域

    1. “电子邮件合并”任务窗格(“准备出版物”)的“其他项目”下,单击“图片域”

    2. “插入图片域”对话框中,单击与要插入的图片文件名列表对应的域。

    问候语

    1. “电子邮件合并”任务窗格(“准备出版物”)的“其他项目”下,单击“问候语”

    2. “插入问候语”对话框中,选择问候语格式。每种问候语格式都包含称呼、姓名格式及随后的标点。

    3. 选择 Publisher 不能解释收件人的姓名时要显示的文字,例如,当数据源中不包含收件人的名字或姓氏而仅包含公司名称时。 

      注意: 如果数据源中数据域的名称与 Publisher 用于问候语的域名称不匹配,您可能需要单击“插入问候语”对话框中的“匹配域”。在“匹配域”对话框中,使用下拉列表从数据源中选择对应于 Publisher 域的域。

设置数据域的格式

如果需要,可将文本格式应用于数据域和添加的任何其他文本(例如问候您好或称呼亲爱的),以更改合并数据的外观。要设置已合并数据的格式,必须设置电子邮件合并出版物中数据域的格式。

  1. 在电子邮件合并出版物中,选择包含要设置格式的信息的域。

  2. “格式”菜单上,单击“字体”,然后选择所需的选项。

预览出版物的数据域中的收件人数据

现在,您可以查看当实际数据出现在合并的数据域中时出版物的外观。

  1. 要预览出版物,请执行下列任何一项操作:

    • 若要预览它们将出现在合并出版物顺序中的条目,请单击下预览收件人电子邮件合并任务窗格 “前进”按钮 [返回] 按鈕 的导航按钮。

      来自数据源第一条记录的信息将填充数据域。您无法在出版物页面上编辑数据源条目,但可以设置数据域的格式、移动或删除数据域。

    • 若要查找和预览数据源中的特定条目,请单击“查找收件人”,然后在“查找条目”对话框中输入搜索标准。

  2. 如有必要,可对收件人列表进行更改。请执行下列任何一项操作:

    • 若要从合并中排除特定收件人,请单击“排除此收件人”

    • 要更改收件人列表,请单击“编辑收件人列表”,然后在“邮件合并收件人”对话框中进行更改。

  3. 完成电子邮件合并出版物并插入所有合并域后,请单击“文件”菜单上的“另存为”。在“文件名”框中键入出版物的名称,然后单击“保存”

  4. 单击“下一步: 创建合并出版物”

返回页首

创建合并出版物

“电子邮件合并”任务窗格中的“选择电子邮件合并输出”下,可以执行下列操作:

  • 将合并出版物作为电子邮件发送。

  • 预览合并出版物(以便在发送所有版本之前确定其外观并解决潜在的问题)。

预览合并出版物

  1. 单击“电子邮件预览”

  2. 单击“下一页”“上一页”按钮,以预览每封电子邮件发送时的外观。

    注意: 如果“检查设计方案”发现可能使电子邮件合并无法成功完成的问题,则将在“电子邮件合并”任务窗格的“电子邮件预览”下通知您。要查看并解决潜在问题,请单击“检查设计方案”

返回页首

发送合并出版物

  1. 单击“发送电子邮件”

  2. “合并至电子邮件”对话框中,从“收件人”下拉列表中选择收件人域。在多数情况下,“电子邮件地址”是用于电子邮件合并的适当选择。

  3. “主题”下,键入主题行。在“要插入的项目”下,单击要在主题行中插入的所有数据域。

  4. 单击“选项”以指定所需的其他任何选项,例如抄送、密件抄送收件人或邮件附件。

  5. 单击“发送”

    此时将打开“发送合并的电子邮件”对话框,以便您通过查看是否向其发送电子邮件的收件人列表来确认邮寄。

返回页首

取消合并

在发送合并的电子邮件之前,可以随时取消合并,使电子邮件合并出版物与其数据源之间断开连接。

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“取消合并”

  2. 当询问是否要取消合并时,单击“是”

将断开出版物与其数据源之间的连接。

注意: 如果取消电子邮件合并,某些数据域将转换为文本,而地址块、地址域和问候语将保持为活动数据域。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×