创建新数据库

创建新数据库

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

本文介绍启动Access 和创建将在台式计算机 (而不是 Web) 上使用的数据库的基本过程。 它介绍了如何使用模板创建桌面数据库, 以及如何通过创建自己的表、窗体、报表和其他数据库对象从头开始构建数据库。 它还介绍了一些可用于将现有数据导入到新数据库中的技术。

本文内容

概述

使用模板创建数据库

在不使用模板的情况下创建数据库

将其他源中的数据复制到 Access 表中

导入、追加或链接到其他源中的数据

添加应用程序部件

打开现有 Access 数据库

使用 Access 2007?

概述

第一次启动 access 时, 或者在关闭数据库时未关闭 Access 时, 将显示 Microsoft Office Backstage 视图。

Backstage 视图是你可以从中创建新数据库、打开现有数据库、从Office.com 查看特色内容的起始点, 可以使用 Access 对数据库文件或数据库外部执行任何操作, 而不是在数据库中

创建数据库

打开 Access 时, Backstage 视图显示 "新建" 选项卡。 "新建" 选项卡提供了几种创建新数据库的方法:

  • 空白数据库    如果需要, 您可以从头开始。 如果你有非常具体的设计要求或拥有需要容纳或合并的现有数据, 这是一个不错的选择。

  • 随 Access 一起安装的模板    如果要启动新项目并希望开始使用模板, 请考虑使用模板。 Access 附带有多个默认安装的模板。

  • Office.com 中的模板    除了 Access 附带的模板外, 你还可以在Office.com 上找到更多的模板。 您甚至不必打开浏览器, 可以从 "新建" 选项卡中使用这些模板。

添加到数据库

在数据库中工作后, 您可以添加字段、表或应用程序部分。

应用程序部件是一项功能, 使你可以将多个相关的数据库对象一起使用, 就像它们是一个一样。 例如, 应用程序部分可能包含基于该表的表和窗体。 你可以使用应用程序部件同时添加表和窗体。

您还可以创建查询、窗体、报表、宏-所有用于处理的数据库对象。

使用模板创建数据库

Access 附带了各种可供您使用的模板, 或用作起始点的模板。 模板是一个随时可用的数据库, 其中包含执行特定任务所需的所有表、查询、窗体、宏和报表。 例如, 你可以使用模板来跟踪问题、管理联系人或保留费用记录。 某些模板包含一些示例记录, 可帮助演示它们的使用。

如果这些模板之一满足你的需要, 则使用它通常是启动数据库的最快方式。 但是, 如果你想要将数据导入到另一个程序中, 而你想要将数据导入 Access, 则可能会决定在不使用模板的情况下创建数据库是更好的方法。 模板已定义数据结构, 可能需要大量工作才能将现有数据改编到模板的结构中。

  1. 如果已打开数据库, 请在 "文件" 选项卡上单击 "关闭"。 Backstage 视图显示 "新建" 选项卡。

  2. 选项卡中提供了多组模板, 其中一些模板内置于 Access 中。 你可以从Office.com 下载其他模板。 有关详细信息, 请参阅本文下一节。

  3. 选择要使用的模板。

  4. Access 会在 "文件名" 框中建议数据库的文件名, 如果需要, 您可以更改文件名。 若要将数据库保存在 "文件名" 框下显示的另一个文件夹中, 请单击 " 按钮图像 ", 通过浏览找到要在其中保存该数据库的文件夹, 然后单击"确定"。 或者, 你可以创建数据库并将其链接到 SharePoint 网站。

    注意: 尽管它们都使用 SharePoint, 但链接到 sharepoint 网站的桌面数据库与使用 Access Services 的 web 数据库不同。 若要使用桌面数据库, 必须安装 Access。 web 数据库可以与 web 浏览器一起使用。

  5. 单击“创建”。

    Access 将从您选择的模板创建数据库, 然后打开数据库。 对于许多模板, 将显示一个窗体, 可在其中开始输入数据。 如果您的模板包含示例数据, 则可以通过单击记录选择器 (紧邻记录左侧的带阴影框或条) 来删除每条记录, 然后执行下列操作:

    在“开始”选项卡上的“记录”组中,单击“删除”。 按钮图像

  6. 若要开始输入数据, 请单击窗体上的第一个空单元格, 然后开始键入。 使用导航窗格 浏览其他可能要使用的窗体或报表。 某些模板包含允许你在不同数据库对象之间移动的导航窗体。

有关使用模板的详细信息, 请参阅使用模板创建 Access 桌面数据库一文。

返回页首

在不使用模板的情况下创建数据库

如果您对使用模板不感兴趣, 则可以通过构建自己的表、窗体、报表和其他数据库对象来创建数据库。 在大多数情况下, 这涉及以下一项或两项操作:

  • 在创建新数据库时创建的表中输入、粘贴或导入数据, 然后使用 "创建" 选项卡上的 "表格" 命令为创建的新表重复该过程。

  • 从其他源导入数据并在流程中创建新表。

创建空白数据库

  1. 在 "文件" 选项卡上, 单击 "新建", 然后单击 "空白数据库"。

  2. 在 "文件名" 框中键入文件名。 若要从默认值更改文件的位置, 请单击 "浏览位置" 以放置数据库 按钮图像 (在 "文件名" 框的旁边), 浏览到新位置, 然后单击"确定"

  3. 单击“创建”。

    Access 将使用名为 Table1 的空表创建数据库, 然后在数据表视图中打开 Table1。 将光标放在 "单击以添加" 列的第一个空单元格中。

  4. 开始键入以添加数据, 也可以粘贴来自其他源的数据, 如将来自其他源的数据复制到 Access 表中所述。

在数据表视图中输入数据的设计与在 Excel 工作表中工作非常相似。 在输入数据时创建表结构。 向数据表添加新列时, 表中将定义一个新字段。 Access 会根据您输入的数据自动设置每个字段的数据类型。

如果此时不想在 Table1 中输入数据, 请单击 "关闭 按钮图像 "。 如果对表格进行了任何更改, Access 会提示您保存所做的更改。 单击"是"保存所做的更改, 单击 "" 放弃这些更改, 或单击 "取消" 使该表保持打开状态。

提示:  Access 会在位于 [install drive]: \Program Files\Microsoft Office\Templates\1033\Access\. 的文件夹中查找名为 " .accdb " 的文件 如果存在, 则.accdb为所有新的空白数据库 (不包括 web 数据库) 的模板。 所有新的空白数据库将继承它所包含的任何内容。 这是一种分发默认内容 (如部件号或公司免责声明和策略) 的好方法。 请记住, .accdb不会对创建空白新 web 数据库产生任何影响。

重要: 如果关闭表1但不保存至少一次, Access 将删除整个表, 即使在其中输入了数据也是如此。

添加表格

可以使用 "创建" 选项卡上的 "" 组中的命令将新表添加到现有数据库中。

Access 功能区图像

创建表, 从数据表视图开始    在数据表视图中, 你可以立即输入数据, 让 Access 在幕后构建表结构。 字段名称按数字顺序 (Field1、Field2 等) 分配, Access 会根据您输入的数据自动设置每个字段的数据类型。

  1. 在“创建”选项卡上的“”组中,单击“”。 按钮图像

    Access 将创建表, 并选择 "单击以添加" 列中的第一个空单元格。

  2. 在 "字段" 选项卡上的 "添加 & 删除" 组中, 单击要添加的字段类型。 如果看不到所需的类型, 请单击 "更多字段 按钮图像 "。

  3. Access 将显示常用字段类型的列表。 单击所需的字段类型, Access 会将新字段添加到数据表中的插入点。

    可以通过拖动来移动字段。 拖动数据表中的字段时, 将在其中放置字段的垂直插入栏。

  4. 若要添加数据, 请开始在第一个空单元格中键入或粘贴来自其他源的数据, 如将其他源中的数据复制到 Access 表中所述。

  5. 若要重命名列 (字段), 请双击列标题, 然后键入新名称。

    你应该为每个字段提供有意义的名称, 以便你可以在 "字段列表" 窗格中看到它所包含的内容。

  6. 若要移动列, 请单击其标题以选择该列, 然后将该列拖动到所需的位置。 您也可以选择多个相邻的列, 然后将其一次性拖动到新位置。 若要选择多个连续的列, 请单击第一列的列标题, 然后在按住 SHIFT 的同时单击最后一列的列标题。

在设计视图中开始创建表    在 "设计" 视图中, 首先创建表结构。 然后, 你可以切换到数据表视图以输入数据, 或使用其他方法 (如粘贴或导入) 输入数据。

  1. 在“创建”选项卡上的“”组中,单击“表设计”。 按钮图像

  2. 对于表中的每个字段, 在 "字段名称" 列中键入一个名称, 然后从 "数据类型" 列表中选择一种数据类型。

  3. 如果需要, 您可以在 "说明" 列中键入每个字段的说明。 当光标位于 "数据表" 视图中的该字段中时, 该说明将显示在状态栏上。 该说明还用作窗体或报表中通过从 "字段列表" 窗格拖动字段而创建的任何控件的状态栏文本, 以及使用 "窗体向导" 或 "报表向导" 时为该字段创建的任何控件的状态栏文本。

  4. 添加完所有字段后, 保存表:

    • 在“文件”选项卡上,单击“保存”。

  5. 通过切换到 "数据表" 视图并在第一个空单元格中单击, 可以随时开始在表中键入数据。 您还可以粘贴来自其他源的数据, 如将其他源中的数据复制到 Access 表中所述。

在设计视图中设置字段属性    无论您创建表格的方式如何, 最好检查和设置字段属性。 虽然某些属性在数据表视图中可用, 但某些属性仅可在设计视图中设置。 若要切换到设计视图, 请在导航窗格中右键单击表, 然后单击 "设计视图"。 若要查看字段的属性, 请单击设计网格中的字段。 属性显示在设计网格下的 "字段属性" 下。

若要查看每个字段属性的说明, 请单击该属性, 然后阅读 "字段属性" 下的 "属性" 列表旁边的框中的说明。 可通过单击 "帮助" 按钮获取更多详细信息。

下表描述了通常调整的一些字段属性。

属性

说明

字段大小

对于文本字段, 此属性设置可存储在字段中的最大字符数。 最大值为255。 对于 "数字" 字段, 此属性设置将存储的数字类型 (长整型、双精度等)。 为了获得最高效的数据存储空间, 建议您为数据分配所需的最少数量的空间。 如果你的需求发生更改, 你可以稍后调整该值。

格式

此属性设置数据的显示方式。 它不会影响存储在字段中的实际数据。 你可以选择预定义的格式或输入自定义格式。

输入掩码

使用此属性为将在此字段中输入的所有数据指定一个模式。 这有助于确保正确输入所有数据, 并且包含所需的字符数。 有关生成输入掩码的帮助, 请单击属性框右侧的 " “生成器”按钮 "。

默认值

使用此属性指定每次添加新记录时将在此字段中显示的默认值。 例如, 如果您有一个日期/时间字段, 其中始终要记录添加记录的日期, 则可以输入 "Date ()" (不带引号) 作为默认值。

必需

此属性设置此字段中是否需要值。 如果将此属性设置为"是", 则 Access 不允许添加新记录, 除非为此字段输入了值。

返回页首

将其他源中的数据复制到 Access 表中

如果数据当前存储在其他程序 (如 Excel) 中, 则可以将其复制并粘贴到 Access 表中。 通常情况下, 如果你的数据已分到列中, 因为它们位于 Excel 工作表中, 因此效果最佳。 如果您的数据在字处理程序中, 最好使用制表符分隔数据列, 或在复制数据之前将数据转换为 word 处理程序中的表。 如果您的数据需要任何编辑或操作 (例如, 将全名分隔为名字和姓氏), 则可能需要在复制数据之前执行此操作, 尤其是在您不熟悉 Access 的情况下。

将数据粘贴到空表中时, Access 会根据字段在其中找到的数据类型设置每个字段的数据类型。 例如, 如果粘贴的字段包含不包含日期值的内容, Access 会将 "日期/时间" 数据类型应用于该字段。 如果粘贴的字段仅包含单词 "yes" 和 "no", 则 Access 将 "是/否" 数据类型应用于该字段。

Access 将根据在粘贴数据的第一行中找到的内容来命名字段。 如果粘贴数据的第一行与后续行的类型相似, Access 会确定第一行是数据的一部分, 并为字段分配通用名称 (F1、F2 等)。 如果粘贴的数据的第一行与后面的行不相似, Access 将确定第一行包含字段名称。 Access 会相应地命名字段, 并且不包含数据中的第一行。

如果 Access 分配通用字段名称, 则应尽快重命名字段以避免混淆。 使用以下过程:

  1. 按 CTRL + S 保存表。

  2. 在 "数据表" 视图中, 双击每个列标题, 然后为每个列键入一个描述性字段名称。

  3. 再次保存该表。

注意: 也可以通过切换到 "设计" 视图并编辑其中的字段名称来重命名字段。 若要切换到设计视图, 请在导航窗格中右键单击表, 然后单击 "设计视图"。 若要切换回数据表视图, 请在 "导航" 窗格中双击该表。

返回页首

导入、追加或链接到其他源中的数据

您可能有存储在另一个程序中的数据, 并且您希望将这些数据导入到新表中, 或将其追加到 Access 中的现有表中。 或者, 你可以与将其数据保留在其他程序中的人员配合使用, 并且希望通过链接访问它来在 Access 中处理数据。 无论使用哪种方式, Access 都可以轻松地处理其他源中的数据。 你可以从 Excel 工作表、SharePoint 列表中的表或其他各种源导入数据。 你所使用的进程稍有不同, 具体取决于你的源, 但以下过程将使你入门。

  1. 在 Access 中, 在 "外部数据" 选项卡上的 "导入 & 链接" 组中, 单击要导入的文件类型的命令。

    “外部数据”选项卡上的“导入和链接”组

    例如, 如果要从 Excel 工作表导入数据, 请单击 " Excel"。 如果看不到所需的程序类型, 请单击 "更多"。

    注意: 如果在 "导入 & 链接" 组中找不到正确的格式类型, 可能需要启动最初创建数据的程序, 然后使用该程序将数据保存为常见文件格式 (如带分隔符的文本文件 ), 然后才能 import 数据进入 Access。

  2. 在 "获取外部数据" 对话框中, 单击 "浏览" 查找源数据文件, 或在 "文件名" 框中键入源数据文件的完整路径。

  3. 在 "指定数据在当前数据库中的存储方式和存储位置" 下, 单击所需的选项 ("所有程序允许您导入" 和 "部分允许追加" 或 "链接")。 你可以创建使用导入数据的新表或 (使用某些程序), 你可以将数据追加到现有表, 或者创建一个链接表来维护指向源程序中的数据的链接。

  4. 如果启动向导, 请按照向导后面几页中的说明进行操作。 在该向导的最后一页上,单击“完成”。

    如果从 Access 数据库导入对象或链接表, 则会显示 "导入对象" 或 "链接表" 对话框。 选择所需的项目, 然后单击"确定"

    确切的过程取决于您选择导入、追加还是链接数据。

  5. Access 将提示您是否要保存刚刚完成的导入操作的详细信息。 如果您认为以后将再次执行此相同的导入操作, 请单击 "保存导入步骤", 然后输入详细信息。 此后, 您可以通过单击 "外部数据" 选项卡上的 "导入 & 链接" 组中的 "已保存的导入" 按钮图像 , 轻松地重复操作。 如果不想保存操作的详细信息, 请单击 "关闭"。

如果您选择导入一个表, Access 会将数据导入到一个新表中, 然后在导航窗格中的 "" 组下显示该表。 如果选择将数据追加到现有表中, 则会将数据添加到该表中。 如果您选择链接到数据, Access 将在导航窗格中的 "" 组下创建一个链接表。

返回页首

添加应用程序部件

你可以使用应用程序部件向现有数据库添加功能。 应用程序部件可以像单个表一样简单, 也可以包含多个相关对象, 例如表和绑定窗体。

例如, "注释" 应用程序部分由具有 "自动编号 ID" 字段、"日期字段" 和 "备注" 字段的表组成。 你可以将其添加到任何数据库并按原样使用, 或使用最少的自定义。

  1. 打开要向其中添加应用程序部件的数据库。

  2. 单击“创建”选项卡。

  3. 在 "模板" 组中, 单击 "应用程序部件"。 将打开可用部件的列表。

  4. 单击要添加的应用程序部件。

返回页首

打开现有 Access 数据库

  1. “文件”选项卡上,单击“打开”

  2. 在 "打开" 对话框中, 通过浏览找到要打开的数据库。

  3. 执行下列操作之一:

    • 双击数据库以在 " Access 选项" 对话框中指定的默认模式下打开该数据库或由管理策略设置的模式。

    • 单击 "打开" 以打开多用户环境中共享访问的数据库, 以便你和其他用户可以读取和写入数据库。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以只读打开" 以打开数据库以进行只读访问, 以便你可以查看它, 但不能进行编辑。 其他用户仍可以读取和写入数据库。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开" 以使用独占访问打开数据库。 当以独占访问方式打开数据库时, 尝试打开数据库的任何其他人都将收到 "已在使用的文件" 消息。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开" 以打开数据库以进行只读访问。 其他用户仍然可以打开该数据库, 但它们仅限于只读模式。

注意: 你可以直接以外部文件格式 (如 dBASE、Microsoft Exchange 或 Excel) 打开数据文件。 您也可以直接打开任何ODBC 数据源, 如 Microsoft SQL Server。 Access 会自动在与数据文件相同的文件夹中创建新的 Access 数据库, 并将链接添加到外部数据库中的每个表。

提示

  • 若要打开最近打开的数据库之一, 请在 "文件" 选项卡上单击 "最近", 然后单击该数据库的文件名。 Access 将使用上次打开数据库时的相同选项设置来打开数据库。 如果未显示最近使用的文件列表, 请在 "文件" 选项卡上单击 "选项"。 在 " Access 选项" 对话框中, 单击 "客户端设置"。 在 "显示" 下, 输入要在 "最近使用的文档" 列表中显示的文档数, 最大值为50。

    您还可以在 Backstage 视图的导航栏中显示最近的数据库, 双击 access: 1) "文件" 选项卡, 2) 要打开的最新数据库。 在 "最近" 选项卡底部的旁边, 选中 "快速访问此数目的 ' 最近使用的数据库'" 复选框, 然后调整要显示的数据库的数量。

  • 如果通过单击 "文件" 选项卡上的 "打开" 命令打开数据库, 您可以通过单击 "打开" 对话框中的"最近使用的文档" 来查看以前打开的数据库的快捷方式列表。

返回页首

使用 Access 2007?

第一次启动 access 时, 或者在关闭数据库时未关闭 Access 时, 将显示 "开始使用 Microsoft Office Access " 页面。

“开始使用 Microsoft Office Access”页

此页面是你可以创建新数据库、打开现有数据库或从 Microsoft Office Online 查看特色内容的起始点。

Access 提供了各种各样的模板, 可用于加快数据库创建过程。 模板是一个随时可用的数据库, 其中包含执行特定任务所需的所有表、查询、窗体和报表。 例如, 你可以使用模板来跟踪问题、管理联系人或保留费用记录。 某些模板包含一些示例记录, 可帮助演示它们的使用。 模板数据库可以按原样使用, 也可以对其进行自定义以更好地满足你的需求。

如果这些模板之一满足你的需要, 则使用它通常是启动数据库的最快方式。 但是, 如果你想要将数据导入到另一个程序中, 而你想要将数据导入 Access, 则可能会决定在不使用模板的情况下创建数据库是更好的方法。 模板已定义数据结构, 可能需要大量工作才能将现有数据改编到模板的结构中。

  1. 如果已打开数据库, 请单击 " microsoft office 按钮", 然后单击"关闭数据库 按钮图像 " 以显示 "开始使用 microsoft office Access " 页面。

  2. 多个特色模板在 "开始使用 Microsoft Office Access " 页面的中间显示, 当您单击 "模板类别" 窗格中的链接时, 这些模板也会更好用。 您可以从 Office Online 网站下载其他模板。 有关详细信息, 请参阅本文下一节。

  3. 单击要使用的模板。

  4. Access 会在 "文件名" 框中建议数据库的文件名, 如果需要, 您可以更改文件名。 若要将数据库保存在 "文件名" 框下显示的另一个文件夹中, 请单击 " 按钮图像 ", 通过浏览找到要在其中保存该数据库的文件夹, 然后单击"确定"。 或者, 你可以创建数据库并将其链接到 SharePoint 网站。

  5. 单击 "创建" (或下载Office Online 模板)。

    Access 将创建或下载数据库, 然后将其打开。 将显示一个窗体, 您可以在其中开始输入数据。 如果您的模板包含示例数据, 则可以通过单击记录选择器 (紧邻记录左侧的带阴影框或条) 来删除每条记录, 然后执行下列操作:

    在“开始”选项卡上的“记录”组中,单击“删除”。 按钮图像

  6. 若要开始输入数据, 请单击窗体上的第一个空单元格, 然后开始键入。 使用导航窗格浏览可能希望使用的其他窗体或报表。

如果在 "开始使用 Microsoft Office Access " 页面中找不到满足需要的模板, 并且您已连接到 Internet, 则可以浏览 Office Online 网站以获得更大的选择。

  1. 在 "开始使用 Microsoft Office Access " 页面上, 在 "有关Office Online 的详细信息" 下, 单击 "模板"。

    Office Online 上的模板主页将显示在浏览器窗口中。

  2. 使用 Office Online 导航和搜索工具查找你想要使用的访问模板, 然后按照说明下载它。 下载模板时, 数据库文件将下载到您的计算机并在 Access 的新实例中打开。 在大多数情况下, 模板设计为打开数据输入窗体, 以便您可以立即开始输入数据。

有关使用模板的详细信息, 请参阅使用模板创建 Access 桌面数据库一文。

返回页首

如果您对使用模板不感兴趣, 则可以通过构建自己的表、窗体、报表和其他数据库对象来创建数据库。 在大多数情况下, 这通常涉及以下一项或两项操作:

  • 在创建新数据库时创建的表中输入、粘贴或导入数据, 然后使用 "创建" 选项卡上的 "表格" 命令为创建的新表重复该过程。

  • 从其他源导入数据并在流程中创建新表。

  1. 在 "开始使用 Microsoft Office Access " 页面上, 在 "新建空白数据库" 下, 单击 "空白数据库"。

    “空白数据库”按钮

  2. 在 "空白数据库" 窗格中, 在 "文件名" 框中键入文件名。 如果不提供文件扩展名, Access 会为您添加文件扩展名。 若要从默认值更改文件的位置, 请单击 "浏览位置" 以放置数据库 按钮图像 (在 "文件名" 框的旁边), 浏览到新位置, 然后单击"确定"

  3. 单击“创建”。

    Access 将使用名为 Table1 的空表创建数据库, 然后在数据表视图中打开 Table1。 将光标放在 "添加新字段" 列中的第一个空单元格中。

  4. 开始键入以添加数据, 也可以粘贴来自其他源的数据, 如将来自其他源的数据复制到 Access 表中所述。

在数据表视图中输入信息非常类似于在Microsoft Office Excel 2007 工作表中工作。 表结构是在输入数据时创建的, 无论何时向表中添加新列, 都将定义一个新字段。 Access 会根据您输入的数据自动设置每个字段的数据类型。

如果此时不想在 Table1 中输入信息, 请单击 "关闭 按钮图像 "。 如果对表进行了任何更改, Access 会提示您保存对表所做的更改。 单击"是"保存所做的更改, 单击 "" 放弃这些更改, 或单击 "取消" 使该表保持打开状态。

重要: 如果关闭表1但不保存至少一次, Access 将删除整个表, 即使在其中输入了数据也是如此。

可以使用 "创建" 选项卡上的 "" 组中的命令将新表添加到现有数据库中。

Access 功能区图像

创建表, 从数据表视图开始    在数据表视图中, 你可以立即输入数据, 让 Access 在幕后构建表结构。 字段名称按数字顺序 (Field1、Field2 等) 分配, Access 会根据您输入的数据自动设置每个字段的数据类型。

  1. 在“创建”选项卡上的“”组中,单击“”。 按钮图像

    Access 将创建表, 并选择 "添加新字段" 列中的第一个空单元格。

    注意: 如果看不到 "添加新字段" 列, 则可能是在设计视图中, 而不是数据表视图中。 若要切换到数据表视图, 请在 "导航" 窗格中双击该表。 Access 将提示您保存新表, 然后切换到 "数据表" 视图。

  2. 在“数据表”选项卡上的“字段和列”组中,单击“新建字段​​”。 按钮图像

    Access 将显示 "字段模板" 窗格, 其中包含一组常用的字段类型。 如果双击其中一个字段或将其中一个字段拖动到数据表中, Access 将按该名称添加一个字段, 并将其属性设置为该类型字段的相应值。 如果需要, 您可以稍后更改这些属性。 如果拖动字段, 则必须将其拖动到包含数据的数据表区域。 将显示一个垂直插入栏, 显示字段将放置的位置。

  3. 若要添加数据, 请开始在第一个空单元格中键入或粘贴来自其他源的数据, 如将其他源中的数据复制到 Access 表中所述。

  4. 若要重命名列 (字段), 请双击列标题, 然后键入新名称。

    最好为每个字段提供有意义的名称, 以便你可以在 "字段列表" 窗格中看到它所包含的内容。

  5. 若要移动列, 请单击其标题以选择列, 然后将列拖动到所需位置。

    您也可以选择多个相邻的列, 然后将其一次性拖动到新位置。 若要选择多个连续的列, 请单击第一列的列标题, 然后在按住 SHIFT 的同时单击最后一列的列标题。

在设计视图中开始创建表    在 "设计" 视图中, 首先创建新表的结构。 然后, 你可以切换到数据表视图以输入数据, 或使用其他方法 (如粘贴或导入) 输入数据。

  1. 在“创建”选项卡上的“”组中,单击“表设计”。 按钮图像

  2. 对于表中的每个字段, 在 "字段名称" 列中键入一个名称, 然后从 "数据类型" 列表中选择一种数据类型。

    注意: 如果看不到 "字段名称" 和 "数据类型" 列, 则可能是在数据表视图中, 而不是在设计视图中。 若要切换到设计视图, 请在导航窗格中右键单击表, 然后单击 "设计视图 按钮图像 "。 Access 会提示您输入新表的名称, 然后切换到设计视图。

  3. 如果需要, 您可以在 "说明" 列中键入每个字段的说明。 当光标位于 "数据表" 视图中的该字段中时, 该说明将显示在状态栏上。 该说明还用作窗体或报表中通过从 "字段列表" 窗格拖动字段而创建的任何控件的状态栏文本, 以及使用 "窗体向导" 或 "报表向导" 时为该字段创建的任何控件的状态栏文本。

  4. 添加完所有字段后, 保存表:

    • 单击 " Microsoft Office 按钮", 然后单击 "保存", 或按 CTRL + S 按钮图像

  5. 通过切换到 "数据表" 视图并在第一个空单元格中单击, 可以随时开始在表中键入数据。 您还可以粘贴来自其他源的数据, 如将其他源中的数据复制到 Access 表中所述。

使用模板创建表格    Access 将提供常用的表类型的模板。 只需要单击鼠标, 即可创建一个完整的表格结构, 其中包含已配置好且可供使用的字段。 如果需要, 您可以添加或删除字段, 以便表满足您的需要。

  1. 在 "创建" 选项卡上的 "" 组中, 单击 "表模板", 然后从列表中选择一个可用的模板。

  2. 若要添加数据, 请开始在第一个空单元格中键入或粘贴其他源中的数据, 如将其他源中的数据复制到 Access 表中所述。

    • 删除列    

      1. 右键单击列标题, 然后单击 "删除列 按钮图像 "。

    • 添加新列    

      1. 在“数据表”选项卡上的“字段和列”组中,单击“新建字段​​”。 按钮图像

      2. Access 将显示 "字段模板" 窗格, 其中包含一组常用的字段类型。 如果双击其中一个字段或将其中一个字段拖动到数据表中, Access 将按该名称添加一个字段, 并将其属性设置为该类型字段的相应值。 如果需要, 您可以稍后更改这些属性。 如果拖动字段, 则必须将其拖动到包含数据的数据表区域。 将显示一个垂直插入栏, 显示字段将放置的位置。

  3. 保存表:

    • 单击 " Microsoft Office 按钮", 然后单击 "保存", 或按 CTRL + S 按钮图像

在设计视图中设置字段属性    无论您创建表格的方式如何, 最好检查和设置字段属性。 只能在 "设计" 视图中执行此操作。 若要切换到设计视图, 请在导航窗格中右键单击表, 然后单击 "设计视图"。 若要查看字段的属性, 请单击设计网格中的字段。 属性显示在设计网格下的 "字段属性" 下。

若要查看每个字段属性的说明, 请单击该属性, 然后阅读 "字段属性" 下的 "属性" 列表旁边的框中的说明。 您可以按 F1 获取更多详细信息。

下表描述了通常调整的一些字段属性。

属性

说明

字段大小

对于文本字段, 此属性设置可存储在字段中的最大字符数。 最大值为255。 对于 "数字" 字段, 此属性设置将存储的数字类型 (长整型、双精度等)。 为了获得最高效的数据存储空间, 建议您为数据分配所需的最少数量的空间。 如果你的需求发生更改, 你可以稍后调整该值。

格式

此属性设置数据的显示方式。 它不会影响存储在字段中的实际数据。 你可以选择预定义的格式或输入自定义格式。

输入掩码

使用此属性为将在此字段中输入的所有数据指定一个模式。 这有助于确保正确输入所有数据, 并且包含所需的字符数。 有关生成输入掩码的帮助, 请单击属性框右侧的 " “生成器”按钮 "。

默认值

使用此属性指定每次添加新记录时将在此字段中显示的默认值。 例如, 如果您有一个日期/时间字段, 其中始终要记录添加记录的日期, 则可以输入 "Date ()" (不带引号) 作为默认值。

必需

此属性设置此字段中是否需要值。 如果将此属性设置为"是", 则 Access 不允许添加新记录, 除非为此字段输入了值。

返回页首

如果数据当前存储在另一个程序 (如Office Excel 2007 ) 中, 则可以将其复制并粘贴到 Access 表中。 通常情况下, 如果你的数据已分到列中, 因为它们位于 Excel 工作表中, 因此效果最佳。 如果您的数据在字处理程序中, 最好使用制表符分隔数据列, 或在复制数据之前将数据转换为 word 处理程序中的表。 如果您的数据需要任何编辑或操作 (例如, 将全名分隔为名字和姓氏), 则可能需要在复制数据之前执行此操作, 尤其是在您不熟悉 Access 的情况下。

将数据粘贴到空表中时, Access 会根据字段在其中找到的数据类型设置每个字段的数据类型。 例如, 如果粘贴的字段包含不包含日期值的内容, Access 会将 "日期/时间" 数据类型应用于该字段。 如果粘贴的字段仅包含单词 "yes" 和 "no", 则 Access 将 "是/否" 数据类型应用于该字段。

Access 将根据在粘贴数据的第一行中找到的内容来命名字段。 如果粘贴数据的第一行与后续行的类型相似, Access 将确定第一行是数据的一部分, 并为字段分配通用名称 (F1、F2 等)。 如果粘贴的数据的第一行与后面的行不相似, Access 将确定第一行包含字段名称。 Access 会相应地命名字段, 并且不包含数据中的第一行。

如果 Access 分配通用字段名称, 则应尽快重命名字段以避免混淆。 使用以下过程:

  1. 保存表。

    • 单击 " Microsoft Office 按钮", 然后单击 "保存", 或按 CTRL + S 按钮图像

  2. 在 "数据表" 视图中, 双击每个列标题, 然后为每个列键入一个有效的字段名称。 它可能看起来好像你正在输入数据, 但列标题行包含字段名称, 而不是数据。

  3. 再次保存该表。

注意: 也可以通过切换到 "设计" 视图并编辑其中的字段名称来重命名字段。 若要切换到设计视图, 请在导航窗格中右键单击表, 然后单击 "设计视图"。 若要切换回数据表视图, 请在 "导航" 窗格中双击该表。

返回页首

你可能有存储在其他程序中的数据, 你希望将这些数据导入到新表中, 或将其追加到 Access 中的现有表中。 或者, 你可以与将其数据保留在其他程序中的人员配合使用, 并且希望通过链接访问它来在 Access 中处理数据。 无论使用哪种方式, Access 都可以轻松地处理其他源中的数据。 你可以从 Excel 工作表、SharePoint 列表中的表或其他各种源导入数据。 你所使用的进程稍有不同, 具体取决于你的源, 但以下过程将使你入门。

  1. 在 Access 中, 在 "外部数据" 选项卡上的 "导入" 组中, 单击要导入的文件类型的命令。

    Access 功能区图像

    例如, 如果要从 Excel 工作表导入数据, 请单击 " Excel"。 如果看不到所需的程序类型, 请单击 "更多"。

    注意: 如果在 "导入" 组中找不到正确的格式类型, 可能需要启动最初在其中创建数据的程序, 然后使用该程序将数据保存为常见文件格式 (如带分隔符的文本文件 ), 然后才能导入数据。 进入 Access。

  2. 在 "获取外部数据" 对话框中, 单击 "浏览" 查找源数据文件, 或在 "文件名" 框中键入源数据文件的完整路径。

  3. 在 "指定数据在当前数据库中的存储方式和存储位置" 下, 单击所需的选项 ("所有程序允许导入" 和 "部分允许您添加或链接")。 你可以创建使用导入数据的新表或 (使用某些程序), 你可以将数据追加到现有表, 或者创建一个链接表来维护指向源程序中的数据的链接。

  4. 如果启动向导, 请按照向导后面几页中的说明进行操作。 在该向导的最后一页上,单击“完成”。

    如果从 Access 数据库导入对象或链接表, 则会显示 "导入对象" 或 "链接表" 对话框。 选择所需的项目, 然后单击"确定"

    确切的过程取决于您选择导入、追加还是链接数据。

  5. Access 将提示您是否要保存刚刚完成的导入操作的详细信息。 如果您认为以后将再次执行此相同的导入操作, 请单击 "保存导入步骤", 然后输入详细信息。 然后, 可以稍后通过单击 "外部数据" 选项卡上的 "导入" 组中的 "已保存的导入" 按钮图像 , 轻松重复该操作。 如果不想保存操作的详细信息, 请单击 "关闭"。

如果您选择导入一个表, Access 会将数据导入到一个新表中, 然后在导航窗格中的 "" 组下显示该表。 如果选择将数据追加到现有表中, 则会将数据添加到该表中。 如果您选择链接到数据, Access 将在导航窗格中的 "" 组下创建一个链接表。

返回页首

  1. 单击“Microsoft Office 按钮”,然后单击“打开”。

  2. 在 "打开" 对话框中, 通过浏览找到要打开的数据库。

  3. 执行下列操作之一:

    • 双击数据库以在 " Access 选项" 对话框中指定的默认模式下打开该数据库或由管理策略设置的模式。

    • 单击 "打开" 以在多用户环境中打开数据库以进行共享访问, 以便你和其他用户可以读取和写入数据库。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以只读打开" 以打开数据库以进行只读访问, 以便你可以查看它, 但不能进行编辑。 其他用户仍可以读取和写入数据库。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开" 以使用独占访问权限打开数据库。 当以独占访问方式打开数据库时, 尝试打开数据库的任何其他人都将收到 "已在使用的文件" 消息。

    • 单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开" 以打开数据库以进行只读访问。 其他用户仍然可以打开该数据库, 但它们仅限于只读模式。

如果找不到要打开的数据库    

  1. 在 "打开" 对话框中, 单击 "我的电脑", 或者在 "查找范围" 下拉列表中单击 "我的电脑"。

  2. 在驱动器列表中, 右键单击您认为可能包含数据库的驱动器, 然后单击 "搜索"。

  3. 在 "搜索结果" 对话框中键入搜索条件, 然后单击 "搜索" 以搜索数据库。

  4. 如果找到该数据库, 请双击将其打开。

  5. 必须在 "打开" 对话框中单击 "取消" 以打开数据库。 然后, 关闭 "搜索结果" 对话框。

注意: 你可以直接以外部文件格式 (如 dBASE、Paradox、Microsoft Exchange 或 Excel) 打开数据文件。 您也可以直接打开任何ODBC 数据源, 如 microsoft SQL Server 或 microsoft FoxPro。 Access 会自动在与数据文件相同的文件夹中创建新的 Access 数据库, 并将链接添加到外部数据库中的每个表。

  • 若要打开最近打开的数据库之一, 请在 "开始使用 Microsoft Office Access " 页面上的 "打开最近的数据库" 列表中单击该数据库的文件名。 Access 将打开数据库, 其中包含上次打开时的相同选项设置。 如果未显示最近使用的文件列表, 请单击 " Microsoft Office 按钮", 然后单击 " Access 选项"。 在 " Access 选项" 对话框中, 单击 "高级"。 在 "显示" 下, 输入要在 "最近使用的文档" 列表中显示的文档数 (最多为9个)。

  • 如果您通过单击 " Microsoft Office 按钮", 然后使用 "打开" 命令打开数据库, 则可以通过单击 "打开" 中的"我的最近的文档" 查看以前打开的数据库的快捷方式列表。对话框 "。

返回页首

创建新的空白数据库时, Access 将打开一个新表, 您可以在其中输入数据, 但不会在数据库中创建任何其他对象。 如果您希望其他对象 (如窗体、报表、宏或其他表) 显示在创建的所有新数据库中, 则可以创建包含这些对象的自定义空白模板。 然后, 下次创建新数据库时, 它将在模板中包含这些对象。 除了这些对象, 模板还可以包括预填充了数据的表, 以及要在所有新数据库中使用的任何特殊配置设置、数据库属性、引用或代码。

例如, 假设你有一个宏集合, 你希望在所有项目中使用该集合。 如果创建包含这些宏的空白模板, Access 将在您创建的任何新数据库中包含这些宏。

你可以使用Office Access 2007 文件格式、access 2002-2003 文件格式或 access 2000 文件格式创建空白模板。 模板的 Office Access 2007 文件格式必须为文件格式, 而对于早期文件格式, 则为 .mdb。

  • 如果默认文件格式设置为 access 2000 或 access 2002-2003, Access 将使用空的 .mdb 作为空白模板文件名。 新数据库创建的文件格式与空 .mdb 相同。 例如, 即使默认文件格式是 access 2000, 如果名为 "空白" 的模板采用的是 access 2002-2003 文件格式, 您创建的任何新数据库都将采用 access 2002-2003 格式。

  • 如果默认文件格式设置为 Access 2007, Access 将使用 .accdb 作为空白模板的文件名。

如何更改默认文件格式?

  1. 单击“Microsoft Office 按钮”,然后单击“Access 选项”。

  2. 在 " Access 选项" 对话框中, 单击 "常用"。

  3. 在 "创建数据库" 下, 从 "默认文件格式" 下拉列表中选择所需的格式。

若要创建空白模板, 请执行下列操作之一:

  • 创建新数据库 (可以为其命名为空或为其命名), 然后导入或创建要包含在模板中的对象。

  • 创建已包含模板中所需对象的现有数据库的副本, 然后删除不需要的任何对象。

在模板中拥有所需的对象后, 必须将其保存到特定位置。

  1. 单击 " Microsoft Office 按钮", 然后指向 "另存为"。

  2. 在 "将数据库另存为其他格式" 下, 单击要用于模板的文件格式。

  3. 在 "另存为" 对话框中, 浏览到以下两个模板文件夹之一:

    • 系统模板文件夹    例如, C:\Program Files\Microsoft Office\Templates\1033\Access

    • 用户模板文件夹    例如:

      • 在Windows Vista    为 c:\users\ name\AppData\Roaming\Microsoft\Templates

      • 在 microsoft windows Server 2003 或 microsoft windows XP 中    C:\Documents 和 Settings\user name\Application Data\Microsoft\Templates

        注意: 系统模板文件夹中的空白模板将替代任何用户模板文件夹中的空白模板。

  4. 在 " 文件名" 框中, 键入 " .accdb " (或保留空白), 如果要创建早期版本的模板, 请单击 "保存"。

既然新模板已存在, 当你创建新的空白数据库时, 模板中的对象将包含在默认创建的任何新数据库中。 Access 将在数据表视图中打开一个新表, 就像在不使用模板的情况下创建新的空白数据库一样。

若要停止使用空白模板, 请删除或重命名名为 ".accdb" (对于早期版本的 Access) 的文件。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×