创建数据透视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

当数据位于巨大数据透视表中时,或者当您拥有许多复杂的工作表数据,其中包括文本和数字与列标题时,可能很难纵观全局,就像这样:

复杂工作表数据

数据透视图可以帮助您让这些数据变得有意义。就像标准图表一样,数据透视图显示数据系列、类别和图表坐标轴,它还在图表上向您提供交互式筛选控件,以便您可以快速分析数据子集。

显示筛选控件的数据透视图

对于工作表数据,您可以创建数据透视图,而无需首先创建数据透视表。您甚至可以创建为您的数据推荐的数据透视图。然后,Excel 将自动创建一个耦合数据透视表。工作方式如下:

  1. 单击数据中的任意位置。

  2. 在“插入”选项卡上的“图表”组中,选择“推荐的图表”。

    “插入”选项卡上的“推荐的图表”按钮

  3. 在“建议的图表”选项卡上,选择最上角带数据透视图图标 数据透视图指示器按钮 的任意图表。预览窗格中随即显示数据透视图的预览。

    显示推荐的数据透视图的“插入图表”对话框

  4. 一旦找到您喜欢的数据透视图,请单击“确定”。

注意:  如果没有找到您喜欢的数据透视图,请在“插入”选项卡上单击“数据透视图”,而不是“推荐的图表”。

  1. 在显示的数据透视图中,单击任何交互式控件,然后选择所需的排序或筛选选项。

    数据透视图的筛选和排序选项

    提示:  要删除不再需要的数据透视图,请选择它,然后按 Delete。

创建数据透视图的其他方法

如果您已拥有数据透视表,则可以基于该数据透视表创建数据透视图。或者,如果您已连接到外部联机分析处理 (OLAP) 或数据模型数据源,则可以创建独立的“去耦合”数据透视图,无需创建数据透视表。

为现有数据透视表创建数据透视图

连接到外部数据以创建数据透视图

使用现有外部数据连接创建数据透视图

为现有数据透视表创建数据透视图

  1. 单击数据透视表中的任意位置以在功能区上显示“数据透视表工具”。

    数据透视表工具

  2. 单击“分析”>“数据透视图”。

    “分析”选项卡上的“数据透视图”按钮

  3. 在“插入图表”对话框中,单击所需的图表类型和图表子类型。可以使用除 XY 散点图、气泡图或股价图以外的任意图表类型。

    数据透视图的“插入图表”对话框

要了解有关图表类型的详细信息,请参阅可用图表类型

  1. 单击“确定”。

  2. 在显示的数据透视图中,单击任何交互式控件,然后选择所需的排序或筛选选项。

返回页首

连接到外部数据以创建数据透视图

  1. 单击“数据”>“自其他来源”,然后选择所需的数据源。例如,选择“来自 Analysis Services”以连接到联机分析处理 (OLAP) 多维数据集文件。

    “数据”选项卡上的“自其他源”按钮

  2. 按照数据连接向导中的步骤操作,然后单击“完成”。

  3. 在“导入数据”对话框中,选择“数据透视图”,选择要放置数据的位置,然后单击“确定”。

    将显示空数据透视图和字段列表,以便你可以在数据透视图中添加或重新排列字段

  4. 在“字段列表”中,选择要显示在数据透视图中的字段。

显示字段部分和区域部分的字段列表

  1. 创建数据透视图后,可以对其进行自定义,与自定义任何标准图表的操作相似。当你选择数据透视图时:

  2. 两个按钮会显示图表旁边,以便您可以快速添加或更改图表元素,例如标题数据标签,或更改图表样式和数据透视图的颜色相同的方式在标准图表。

    数据透视图旁边的“图表元素”和“图表样式”按钮

  3. 功能区上将显示“数据透视图工具”。在“分析”、“设计”和“格式”选项卡上,您可以选择选项来处理或自定义数据透视图。

    功能区上的“数据透视图工具”

返回页首

使用现有外部数据连接创建数据透视图

  1. 单击“插入”>“数据透视图”。

    “插入”选项卡上的“数据透视图”按钮

  2. 在“创建数据透视图”对话框中,单击“使用外部数据源”,然后单击“选择连接”。

  3. 在“现有连接”对话框的“连接”选项卡上,双击所需的连接。

  4. 单击“确定”。

    将显示空数据透视图和字段列表,以便你可以在数据透视图中添加或重新排列字段

  5. 在“字段列表”中,选择要显示在数据透视图中的字段。

显示字段部分和区域部分的字段列表

  1. 创建数据透视图后,可以对其进行自定义,与自定义任何标准图表的操作相似。当你选择数据透视图时:

  • 两个按钮会显示图表旁边,以便您可以快速添加或更改图表元素,例如标题数据标签,或更改图表样式和数据透视图的颜色相同的方式在标准图表。

    数据透视图旁边的“图表元素”和“图表样式”按钮

  • 功能区上将显示“数据透视图工具”。在“分析”、“设计”和“格式”选项卡上,您可以选择选项来处理或自定义数据透视图。

    功能区上的“数据透视图工具”

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×