创建数据透视关系图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

本文内容

有关数据透视关系图和数据源

数据透视关系图的组成部分

示例方案

创建数据透视关系图

刷新数据透视关系图中的数据

筛选数据透视关系图中的数据

自定义数据透视关系图节点中的数据

限制级别中的节点数

关于数据透视关系图和数据源

数据透视关系图是按树结构排列的形状集合,它有助于您以一种可视化、易于理解的格式分析和汇总数据。它的起始点是单一形状,称为顶节点,其中包含从工作表、表格、视图或多维数据集导入的信息。您可以将顶节点分解为一个级别的子节点以便用不同的方式查看数据。

注意: 如果您希望工作表、 表或视图中的每一行的直观表示,但不需要分析或汇总数据,在数据选项卡上使用数据链接到形状功能。有关详细信息,请参阅使用数据图形增强数据

类别、级别和节点

要理解类别、级别和节点,请想一想数据源上下文中的每个元素:

  • 数据源的每列不是非数值就是数值。

  • 将非数值列视作各个类别 - 如“季度”、“销售人员”或“电话号码”。其中任一项都可以成为顶节点下的一个级别。请注意,一个列(如“电话号码”)下的值可能是数字,但是它们不是可以合计或以其他方式汇总的数字。 

  • 将数字列作为数据,如数字或货币。它们可以求和或求平均值,或者有最大值或最小值。

  • 将每个节点作为数据源中的一组行,这些行在指定列中有一个公共值。例如,对于“季度”类别,具有 QTR4 的所有行将被组合到一个节点。

数据源

您可以使用下列数据源创建数据透视关系图:

  • Microsoft Excel 工作簿

  • Microsoft Office Access 数据库

  • Microsoft SharePoint 列表

  • Microsoft SQL Server 数据库

  • Microsoft SQL Server Analysis Services

  • 其他 OLE DB 或 ODBC 数据源

返回页首

数据透视关系图的组成部分

数据透视关系图的组成部分

1. 数据透视关系图的名称

2. 数据透视关系图的顶节点

3. 细目形状

4. 数据图例

5. Qtr3 和 Qtr4 形状属于一个级别

6. 应用了形状以增添效果的结点

返回页首

示例方案

假设您有一个如下所示的 Excel 工作表,其中包含关于上两个季度体育用品销售情况的信息。

Excel 电子表格中的销售数据

您需要了解:

  • 每个体育部门赚了多少钱?

  • 每个季度赚了多少钱?

  • 每个销售人员创造了多少利润?

数据透视关系表可以通过显示在三个不同的树视图中排列的数据来回答上述三个问题。

下面的图表显示了查看源数据来回答特定问题的三种方法。

在数据透视关系图中分解数据的 3 种方法

返回页首

创建数据透视关系图

若要创建数据透视关系图,您可以使用数据透视关系图模板,或您可以在任何图表中插入数据透视节点形状。本主题介绍如何使用数据透视关系图模板创建单个数据透视关系图。有关将数据透视节点形状插入其他 Visio 图表的信息,请参阅插入插入任何绘图数据透视关系图。有关创建具有多个数据透视关系图的绘图的详细信息,请参阅添加到绘图中的多个数据透视关系图

当您创建数据透视关系图时,数据选取器向导会引导您选择数据源。然后将数据导入顶部的数据透视关系图节点,显示绘图中。然后,您可以展开顶节点以显示要分析的数据。

注意: 最好确保 Excel 工作表中每列的顶端单元格是列标题,而不是数据行。标题不是必需的,但是标题会使已完成的数据透视关系图更容易理解。

  1. 单击“文件”选项卡。

  2. 单击新建,单击业务,,然后双击数据透视关系图

  3. 按照数据选取器向导中的步骤操作。

    单击“完成”后,绘图页上会出现下面三个形状:

    • 包含关于数据源的信息的数据图例

    • 包含数据透视关系图名称的文本框

    • 包含导入数据集的顶节点

  4. 单击绘图页上的顶节点,然后在“数据透视关系图”窗口中,在“添加类别”下,单击要用作数据分组依据的类别(通常是数据源中的一列)。

    注意: 您可能需要最大化“数据透视关系图”窗口以便看到所有功能。

若要进一步展开新的子节点,以显示其他级别,请单击您想要展开,然后重复步骤 4 的节点。

返回页首

在数据透视关系图中刷新数据

您可以在现有数据透视关系图中刷新数据。如果绘图包含多个数据透视关系图,您可以刷新一个或所有数据透视关系图。

  • 若要刷新数据透视关系图,在绘图中将其选中。在数据透视关系图选项卡的数据组中,单击刷新

  • 若要刷新所有绘图中的数据透视关系图中,单击刷新下的箭头,然后单击全部刷新

返回页首

在数据透视关系图中筛选数据

数据透视关系图中一个级别的每个节点都代表数据源中的一组行,这些行共享一个公共值。例如,第四季度 (Qtr4) 的节点包含在“季度”列中具有 Qtr4 的各行的所有数字数据。

可以使用筛选器选择哪些节点出现在给定级别中。例如,如果对第一季度的数据不再感兴趣,您可以隐藏 Qtr1 节点:

  1. 数据透视关系图窗口中的添加类别下,右键单击您想要筛选的数据 (类别名称),然后单击配置列

  2. 配置列对话框中,在筛选器显示数据位置︰ 类别名称选择最左侧的列中的操作,将值键入最右侧的列,以指定要使用的数据。

    只有包含满足所选条件的信息的节点才会出现在绘图中。

要删除筛选器,请将“数据的显示位置”列表的最左边列中的操作重置为“(选择操作)”

注意: 如果您的数据源是 SQL Server Analysis Services 多维数据集,右键单击您想要筛选,请单击配置维度,在配置维度对话框中,单击配置级别的项目。在配置级别对话框中,在筛选器显示的数据,其中类别名称选择最左侧的列中的操作,将值键入最右侧的列,以指定要使用的数据。

返回页首

自定义数据透视关系图节点中的数据

当展开数据透视关系图节点时,默认的数据集会显示在每个节点中。您可以更改显示哪些数字数据、数据的名称以及数字数据的汇总方式。

显示或隐藏特定数据

当显示或隐藏数字数据(通常是数据源中的一列)时,此更改将应用到所选数据透视关系图中的所有节点。

  1. 选择数据透视关系图的任一节点。

  2. “数据透视关系图”窗口中的“添加汇总”下,选中或清除要显示或隐藏的数据的复选框。

更改数字数据的汇总方式

数据透视关系图节点中显示的默认数据是数据源第一列的总和。您可以将汇总函数从 Sum 更改为 Average、Min、Max 或 Count。

注意: 此项不适用于 SQL Server Analysis Services。

  • 数据透视关系图窗口中的在添加汇总,下,右键单击要更改的项目,然后选择要应用的汇总函数。

更改“添加类别”和“添加汇总”列表中各项的名称

  1. “数据透视关系图”窗口中的“添加类别”“添加汇总”下,右击要更改的项目,然后单击“配置列”

  2. “配置列”对话框的“名称”框中,键入一个新名称。

    要恢复到原来的名称,请单击“使用源名称”

返回页首

限制各级别中的节点数

您可以选择在数据透视关系表中的一个级别或所有级别中显示的节点数。如果您正在使用大型工作表、表格或视图,并且不需查看分解到各个节点中的所有数据,则此功能非常有用。

例如,您可能只想显示销售人员级别的前 5 个节点或订单级别的前 20 个节点。

限制所有级别中显示的节点数

  1. 单击要更改的数据透视关系图的顶节点。

  2. 数据透视关系图选项卡上的数据组中,单击数据选项对话框启动器。

  3. “数据透视关系图选项”对话框中的“数据选项”下,选中“限制每个细分中的项目数”复选框。

  4. “最大项目数”框中,键入要显示的最大节点数。

    对于每个级别,会在数据透视关系图中出现一个标题栏带有省略号 (...) 的新节点。这些形状包含每个级别的隐藏节点。

限制一个级别中显示的节点数

  1. 在图表中,选择要限制的级别的细目形状。

  2. 数据透视关系图选项卡上的排序和筛选组中,单击排序和筛选

  3. “细目选项”对话框中的“显示”下,选中“限制此细分中的项目数”复选框。

  4. “最大项目数”框中,键入要显示的最大节点数。

    在数据透视关系图中,会出现一个标题栏带有省略号 (...) 的新节点。此形状包含该级别的隐藏数据。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×