创建数据视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您的企业版功能可收集和存储数据 — 大量数据。要对您和您的工作组轻松地访问且可操作进行此数据,您希望创建跟踪或报告您的团队 Microsoft SharePoint 网站上的应用程序。在其中开始?

与Microsoft Office SharePoint Designer 2007,您可以快速创建名为数据视图的实时数据的自定义的视图。您可以使用数据视图以查看来自各种源,包括数据库查询、 XML 文档、 Web 服务、 SharePoint 列表和库和服务器端脚本的数据。

有两种方法在您的页面中插入数据视图。您可以通过拖到新的或现有网站中页面上拖动文件夹列表或数据源库中的数据源创建数据视图。或者,您可以通过使用插入数据视图命令创建数据视图,然后开始通过插入字段,并且想要从数据源详细信息任务窗格中显示立即修改视图。

本文介绍在数据视图。此外,本文介绍如何创建一个示例 XML 文件,以用作数据源,并且如何创建数据视图然后基于第一次使用拖放方法中,然后单击数据源详细信息任务窗格中的该数据。本文使用.xml 文件作为数据源,以便您可以轻松地创建数据源并跟踪。但是,下面的过程,处理任何数据源,尤其是 SharePoint 列表数据,这可能是最常见的数据源创建数据视图。

重要: 本文讨论在位于运行Windows SharePoint Services 3.0的服务器的 SharePoint 网站中创建数据视图。并非所有功能都可能如果您的网站不运行Windows SharePoint Services 3.0的服务器上可用。

本文内容

什么是数据视图?

创建一个.xml 文件作为示例数据源

通过拖动到绘图页上的数据源创建数据视图

通过使用数据源详细信息任务窗格中创建数据视图

建议的后续步骤

什么是数据视图?

数据视图是可自定义的实时视图,充分利用 Microsoft ASP.NET 技术的数据源。Office SharePoint Designer 2007可扩展标记语言 (XML) 形式的数据源检索数据,并使用可扩展样式表语言转换 (Xslt) 来显示该数据。您可以通过使用Office SharePoint Designer 2007修改数据视图。数据视图可以显示来自各种源,包括数据库查询、 XML 文档、 Web 服务、 SharePoint 列表和库和服务器端脚本数据。您也可以创建显示多个数据源的数据的数据视图。

数据视图从数据源检索数据并使用 XSLT 显示该数据

数据视图显示数据,您可以进行筛选、 排序或组中的实时的视图。也可以更改布局、 应用样式,或应用条件格式中完全所见即所得 (所见即所得) 环境。

数据视图插入您的页面后,您也可以在Office SharePoint Designer 2007使用所见即所得工具添加或删除列、 更改字体格式,或将颜色应用。在使用Office SharePoint Designer 2007中可用的所见即所得工具设置格式的数据视图中时可扩展样式表语言 (XSL) 直接插入 HTML。可以编辑的 XSL 直接在代码视图中时,您可以使用格式设置工具Office SharePoint Designer 2007快速应用 XSL 中轻松地不知道任何 XSL。

返回页首

创建一个.xml 文件作为示例数据源

罗斯文商贸是一种 gourmet 食品分布公司保留其产品列表中的 XML 格式。产品列表包括库存信息。现在,右侧团队跟踪库存通过分发给其他团队的打印报表。您建议他们创建其 intranet 网站上的数据视图,以便公司跨团队合作的用户可以访问产品库存信息快速、 轻松地,不再需要的打印的库存报表。

下面的过程要求使用.xml 文件作为数据源。如果您没有.xml 文件中您的 SharePoint 网站,您首先需要创建罗斯文商贸产品列表。创建列表后,您可以创建使用数据视图在列表中包含的数据视图。

创建视图

  1. 文件菜单上,单击打开网站

  2. 打开网站对话框中,浏览到并选择您的 SharePoint 网站,然后单击打开

  3. 如果出现提示,请在连接到对话框中,键入您的用户名和密码,,然后单击确定

  4. “文件”菜单上,单击“新建”

  5. 新建对话框中,双击文本文件

    在您的网站中将打开一个新的文本文件。

  6. 通过选择它们,然后按 CTRL + C 复制下面的代码行。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. 在Office SharePoint Designer 2007,顶部的页面上,将插入点的位置,然后按 CTRL + V 粘贴您刚刚复制到页面的代码。

  8. “文件”菜单上,单击“另存为”

  9. 另存为对话框中,在文件名框中,键入视图

  10. 保存类型列表中,单击XML,,然后单击保存

返回页首


通过拖动到绘图页上的数据源创建数据视图

当您将数据源拖动到页面中时,结果将是基本表中每一行中显示数据源中的前五个字段中的数据的默认视图。但是,在数据视图是完全可自定义。插入数据视图之后,您可以轻松地添加到列或最适合您的需要在数据视图中删除列。有关详细信息,请参阅主题修改数据视图中的列

数据视图基于 Microsoft ASP.NET 2.0 技术。若要创建数据视图,您必须从开始 ASP.NET 页 (.aspx 文件)。在此示例中,将创建一个新的 ASP.NET 页,然后通过拖动到绘图页上的数据源创建数据视图。

  1. “文件”菜单上,单击“新建”

  2. 新建对话框中,双击ASPX

    打开窗体标记的新页面。

    ASP.NET form 标记

  3. 执行下列操作之一:

    • 文件夹列表中,找到您的数据源,在此示例中,视图,然后将其拖到绘图页上。

    • 任务窗格菜单上,单击数据源库。在数据源库任务窗格中,找到您的数据源-在此示例中,视图,然后将其拖到绘图页上。

      您在页面上,现在显示在数据视图和数据源详细信息任务窗格随即打开。

      通过拖动数据源创建的数据视图,显示数据源的前五个域
      基本表格布局中显示的前五个字段。

返回页首


通过使用数据源详细信息任务窗格中创建数据视图

当使用数据源详细信息任务窗格中创建数据视图时,您首先将数据视图插入页。然后选择在数据源库任务窗格管理 SharePoint 网站的可用数据源的数据源。选择数据源后,数据源详细信息任务窗格随即打开。在数据源详细信息任务窗格中,选择您想要显示,然后将其插入数据视图中的字段。

数据视图基于 ASP.NET 2.0 技术。若要创建数据视图,您必须从开始 ASP.NET 页 (.aspx 文件)。在此示例中,将创建一个新的 ASP.NET 网页,并使用数据源详细信息任务窗格,然后创建数据视图。

  1. “文件”菜单上,单击“新建”

  2. 新建对话框中,双击ASPX

    打开窗体标记的新页面。

    ASP.NET form 标记

  3. 数据视图菜单上,单击插入数据视图

    在页面上,现在显示空数据视图和数据源库任务窗格随即打开。

    空数据视图

    既然您已插入数据视图中,您就可以添加数据。

  4. 数据源库任务窗格中,找到您的数据源,单击它,,然后单击显示数据

    在示例中,在XML 文件,下单击视图,,然后单击显示数据。如果XML 文件标题折叠,请单击加号 (+) 以将其展开。

  5. 数据源详细信息任务窗格中,单击要插入数据视图中的字段。

    提示: 若要选择多个字段,请在按住 CTRL 的同时单击它们。

    在示例中,在ProductsRoot文件夹中的在产品下,单击ProductName。按下并按住 CTRL 的同时单击库存UnitsOnOrder,然后再订购量

    在“数据源详细信息”任务窗格中选定的域

  6. 单击插入为选定的域,然后单击插入数据视图中所选的数据的多个项目视图

    注意: 单项目视图数据视图中显示一条记录。多个项目视图显示多个记录,且带有标题的每一列的列中的字段。

    在表中显示您现在在数据源详细信息任务窗格中选择的字段。

    数据视图中显示的 products.xml

    创建数据视图之后,您可以使用所见即所得工具,如格式工具栏修改字体、 对齐的文本,或将颜色应用。应用到数据视图中的数据点的新格式时, Office SharePoint Designer 2007将格式应用于所有 XML 中同一级别的数据通过修改 XSLT 样式表附加到该页上。例如,在上图中,如果您选择德威,然后单击格式工具栏上的加粗Office SharePoint Designer 2007同一格式应用于所有产品名称字段中显示的内容。

    将加粗格式应用到“ProductName”域中的所有数据

返回页首


建议的后续步骤

数据视图是强大、 完全可自定义的实时数据。既然您已经学习了如何创建数据视图,您可能希望了解操作方法︰

  • 在数据视图中筛选数据   您可以轻松地筛选数据视图中的数据。有关详细信息,请参阅在数据视图中筛选数据

  • 排序数据视图中的对数据进行分组和    可以快速排序或分组数据视图中的数据。有关详细信息,请参阅排序数据视图中的对数据进行分组和

  • 向数据视图应用条件格式   您可以应用特定格式向数据视图时数据视图中的数据符合特定条件。有关详细信息,请参阅向数据视图应用条件格式

  • 创建数据视图中的公式栏    您可以与一样电子表格创建数据视图,以显示其他列计算得出的计算的列。例如,可以乘以单价的库存单位数,并在单独的列中显示项目的总计值。有关详细信息,请参阅创建数据视图中的公式栏

  • 数据视图中修改列   您可以轻松地添加、 删除或排列数据视图中的列。有关详细信息,请参阅修改数据视图中的列

  • 显示单个数据视图中的多个来源的数据    您可以将两个或更多相关的数据源链接和单个数据视图中显示这些来源的数据。有关详细信息,请参阅显示单个数据视图中的多个来源的数据

  • 数据视图中显示示例数据    数据视图中,您可以轻松地显示示例数据。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×