创建数据可视化工具图表

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

想通过 Excel 工作簿自动创建详细精美的 Visio 流程图吗?可使用数据可视化工具模板实现这一点。每个模板均关联有 Excel 工作簿,用于将处理数据转换为 Visio 中的流程图。还可使用自己的自定义 Excel 模板,在“从数据创建图表”向导中将 Excel 数据映射到形状,并自动创建图表。甚至可在 Excel 中添加其他已转换为 Visio 形状数据的数据列。

Visio 还支持 Visio 图表和 Excel 工作簿间的双向同步。不仅可以通过编辑 Excel 中的数据并刷新 Visio 中的图表来创建流程图,还可以对 Visio 图表进行更改,然后更新图表中的 Excel 数据。 

数据可视化工具概述

在当前发布频道上,只能通过 Visio Online 计划 2 使用数据可视化工具模板。如果不确定所使用的 Visio 版本,请选择“文件”>“帐户”>“关于 Visio”。若要深入了解 Visio 的订阅版本,请参阅 Visio Online 计划 2

如果没有看到数据可视化工具模板或对入门教程有其他疑问,请访问数据可视化工具常见问题解答页面。

注意: 若要使用此功能,必须有 Office 365 订阅。如果你是 Office 365 订阅者,请确保拥有最新版本的 Office。如果是管理 Office 365 更新进程的 IT 专业人员,请查看频道发布页面,了解每个频道提供哪些更新。

本文内容

创建数据可视化工具图表

开始之前

整理你的想法,在纸上或通过墨迹书写以草稿形式将想法整理出来。此草稿可以帮助你迅速开始工作,并能够使以下步骤更顺利地进行。

若要创建数据可视化工具图表,可以在 Excel 和 Visio 中同时操作。在 Windows 设备上或多显示器环境中使用两个窗口进行操作可能会更方便。直观地对 Excel 和 Visio 之间的工作进行比较有助于确保事情在你的掌握之中。

建议    观看此 Microsoft Office 视频,查看真实操作过程:数据可视化工具:演示

步骤 1:选择数据可视化工具模板

  1. 打开 Visio,或者如果正在编辑图表,选择“文件”>“新建”。

  2. 选择“模板”。

    TEMPLATES 命令
  3. 选择“流程图”。

    “流程图”命令
  4. 选择基本流程图-数据可视化工具跨职能流程图-数据可视化工具,或审计图的数据可视化工具

    数据可视化工具模板

    数据可视化工具模板在左上角有一个 Excel 图标。

有关流程图及其形状的详细信息,请参阅创建基本流程图创建跨职能流程图

步骤 2:创建 Excel 工作簿

  1. 在模板预览中,选择“Excel 数据模板”。

    选择 Excel 数据模板链接

    注意    若要使用本文中的示例 Excel 模板进行参考,可通过以下链接下载:

  2. 选择“文件”>“保存”,指定计算机、网络服务器或 SharePoint 文档库,输入文件名,然后选择“保存”。

  3. 若要添加新的工作表,请在工作簿底部选择“新键工作表“新工作表”按钮

  4. 创建 Excel 表格。有关使用 Excel 表格的详细信息,请参阅 Excel 表格概述创建或删除 Excel 表格通过添加或删除行和列重设表格大小

  5. 向表用于创建 Visio 图表中添加行和列。有一些特定要求的 Excel 表格列标题和值。使用部分中,为视频指南如何将 Excel 列与 Visio 流程图组件进行交互

步骤 3:在 Excel 表格中添加其他形状数据(可选)

  1. 检查 Excel 模板中的“流程图”选项卡。Excel 表格中的列为蓝色和绿色。这两种颜色直观地显示了列之间的差异。

    蓝色列用于在 Visio 图表中创建流程图。所有列都会作为形状数据进行添加。

  2. 若要添加其他的形状数据,请在 Excel 表中添加一个或多个列。

    绿色列指示了可以添加到每个形状的其他形状数据。可以添加任意数量的其他列。默认情况下,此数据在图表中不可见,除非你添加了数据图形。若要查看 Visio 图表中的形状数据,请选择“数据”>“形状数据窗口”。有关形状数据和数据图形的详细信息,请参阅将数据添加到形状数据图形概述

步骤 4:使用向导创建 Visio 图表

  1. 切换回 Visio,在模板预览中选择度量单位,然后选择“创建”。

  2. 在“通过数据创建图表”向导的第一页中,执行以下操作:

    1. 在“想要通过数据创建哪种类型的图表?”下,选择一个模板:“基本流程图”、“跨职能流程图(水平)”或者“跨职能流程图(垂直)”。

    2. 在“选择 Excel 工作簿”下,从最近使用的工作簿列表中选择一个工作簿,或者通过选择“浏览”来找到在步骤 2 中创建的工作簿。

    3. 在“从工作簿中选择表格或自定义范围”下,选择包含 Excel 流程数据的表格。

    4. 选择“完成”。此操作接受了 Visio 在向导其他页中填写的所有默认值。

结果是在容器内自动创建一个图表。可能会添加其他 Visio 页,具体取决于流程图大小。

步骤 5:保存 Visio 图表

  • 选择“文件”>“保存”,查找位置,输入文件名,然后选择“保存”。

建议将 Excel 和 Visio 文件放在同一位置,因为这二者密切相关。

步骤 6:同步数据和图表

使用数据可视化工作创建图表后,可能想对其进行更改。Visio 支持源数据和图表间的双向同步。

提示   处理完两个文件后,请使其保持同步和最新。更改 Excel 数据时,请刷新图表;更改图表内容时,请更新 Excel 数据。

修改 Excel 中的数据,然后刷新图表

  1. 对 Excel 表格中的源数据进行更改。可以添加、更新或删除行。

  2. 保存 Excel 工作簿。

  3. 在 Visio 中,单击图表容器,以启用功能区中的“数据工具设计”选项卡,然后选择“刷新图表”。

此后,在 Excel 工作表中进行的更改会显示在 Visio 图表中。请注意以下几点:

  • 如果对图表进行的任何更改在刷新后可能会丢失,则 Visio 会显示“刷新图表冲突”对话框。

  • 刷新只会更改容器内的形状和连接。

  • 对容器内的形状或连接线所做的任何格式更改将被保留。

  • 保留容器内的所有图表形状和连接线。在页面上但是在容器外的所有其他对象不受影响。有关容器的详细信息,请参阅使用容器和列表阐明图表结构

修改图表中的内容,然后更新 Excel 中的数据

  1. 对 Visio 图表进行更改。可以添加、更新或删除形状和连接线。

  2. 如果 Excel 工作簿位于台式计算机或网络文件服务器中,请务必将其保存和关闭。

  3. 单击图表容器以启用功能区中的“数据工具设计”选项卡,然后选择“更新源数据”。

此后,在在 Visio 图表中进行的更改会显示 Excel 工作簿中。如果数据在 Excel 中可能丢失,Visio 将显示“更新源数据冲突”对话框。为避免问题,请采用以下最佳做法:

  • 保存 Excel 数据的备份,再覆盖更改。

  • 在 Excel 工作簿中,使用 Excel 表格作为数据源,而不是自定义区域。在“更新源数据”对话框中选择“覆盖”后,Visio 会将自定义区域转换为 Excel 表格。

  • 请勿在 Excel 数据源中使用公式。在“更新源数据”对话框中选择“覆盖”后,Visio 会将公式转换为公式结果。

  • 使用以下选项在“通过数据创建图表”向导中创建了图表,数据列映射到函数和阶段:“映射”>“更多选项”>“创建时保留数据中列值的顺序”>“选择函数或泳道”或“选择阶段或时间线”。在本例中,Visio 需要数据中有额外的一列来表示形状间的连接。在“更新源数据”对话框中选择“覆盖”后,随即添加该额外列。

  • 使用基于 Excel 中数据值顺序的泳道和阶段,创建了跨职能流程图。使用以下选项在“从数据创建图表”向导中创建了图表,数据列连接到过程步骤和活动:“映射”>“指定连接流程步骤/活动的方式”>“按顺序连接”。在本例中,Visio 需要数据中有额外的一列来表示形状间的连接。如果更改图表中泳道或阶段的顺序,则数据源中的顺序也会发生改变。在“更新源数据”对话框中选择“覆盖”后,图表中的泳道和阶段不再遵循 Excel 工作簿中数据的顺序。

步骤 7:自定义 Excel 表格和 Visio 图表之间的交互(可选)

有时你可能想自定义数据可视化工具图表的创建。例如,你可能想使用其他形状来满足组织的标准,或者映射到 Excel 表格中其他列名称。

  1. 选择“创建”,进入“通过数据创建图表”向导,并在第一页上输入值(请参阅步骤 4)之后,选择“下一步”或“返回”,显示向导的任何一个页面。

  2. 选择“帮助(?)”,深入了解如何自定义页面上的每个选项。有关详细信息,请参阅使用“通过数据创建图表”向导

返回页首

Excel 列与 Visio 流程图组件如何交互

通过下图演练来了解如何将 Excel 的每一列用于创建 Visio 流程图。

流程步骤 ID   此数字标识流程图中的每个形状。此列为必填字段。Excel 表格中的每个值都必需是唯一的,并且不能为空。此值不会显示在流程图中。

Excel 流程图与 Visio 流程图的交互:流程步骤 ID

流程步骤描述   添加到流程图中每个形状的文本。

Excel 流程图与 Visio 流程图的交互:流程步骤描述

下一步 ID   按顺序下一形状的流程步骤 ID。分支形状具有两个下一步,因此以逗号分隔的数字表示,例如 4,5。你还可以使用两个以上的下一步。

Excel 流程图与 Visio 流程图的交互:下一步 ID

连接线标签   对于分支形状,连接线标签以使用逗号分隔的文本表示,例如 Yes,No。在此示例中,Yes(是)对应 4,No(否)对应 5。

Excel 流程图与 Visio 流程图的交互:连接线标签

形状类型   想在 Visio 图表中显示的形状类型,例如“流程”或者“决策”。Microsoft 建议使用下拉列表来帮助验证所做的选择。

Excel 流程图与 Visio 流程图的交互:形状类型

职能和阶段   每个形状所属的职能(或泳道)和阶段(或时间线)。此列仅适用于跨职能流程图,基本流程图会图略此列。

Excel 流程图与 Visio 流程图的交互:职能和阶段

返回页首

使用其他模具创建数据可视化工具图表

除了使用的数据可视化工具模板,您可以使用其他模板中的模具时创建的数据可视化工具图。例如,创建流程图财务交易或库存管理。有其他包括 BPMN 基本和工作流对象的模板的面向流程的模具。您甚至可以通过使用我的形状模具中添加自定义形状。有关详细信息,请参阅创建、 保存和共享自定义模具

  1. 打开已创建的数据可视化工具图表(基本流程图或跨职能流程图)。

  2. 选择“创建”,进入“通过数据创建图表”向导,并在第一页上输入值,然后选择“下一步”,直到向导中显示出“形状映射”页面。

  3. 使用“更多形状”选项添加一个或多个模具。

  4. 选择任意形状,并通过拖动将其映射到“形状类型”列的数据值。

返回页首

对图表应用数据图形​​

可以通过添加数据图形来完善图表,此操作有助于将图表上的形状数据可视化。实际上,可以将图表转换成流程仪表板。在流程仪表板中,数据图形将根据你的形状数据以数据图形图标的形式显示关键绩效指标 (KPI) 信息。

  1. 打开数据可视化工具图表。

    选择要对其应用数据图形的图表。

  2. 选择“数据”>“数据图形字段”。

  3. 选择要添加到图表的数据图形字段。

    对 Visio 数据可视化工具应用数据图形的图表

    数据图形将应用于整个图表。若要隐藏特定形状的数据图形,请在这些行的 Excel 工作簿中将数据列的值留空。

  4. 根据需要在“数据”选项卡中设置其他选项。有关详细信息,请参阅数据图形概述

返回页首

后续步骤

创建了数据可视化工作图表之后建议执行以下任务。

  • 主题    Visio 中的主题是一组颜色和效果,只需单击一次即可将其应用于绘图中。主题可以快速为绘图提供专业设计的外观。有关详细信息,请参阅通过主题为绘图应用专业外观

  • 布局    Visio 提供了手动定位参考线和自动工具来帮助确保图表中形状的保持对齐状态和并有适当的间距。这有助于绘图尽量保持简洁并呈现有序的外观。有关详细信息,请参阅图表中的对齐和位置形状

  • 导出​​    将数据可视化工具图表及关联的 Excel 工作簿导出到 Visio 模板包 (.vtpx)。Visio 模板包将保存图表设置、模具和数据,以便其他人基于此快速创建自己的数据可视化工具图表。其他用户可在其计算机上安装模板包。有关详细信息,请参阅导出并安装数据可视化工具模板包

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×