创建或运行宏

在 Word 中, 您可以通过创建和运行宏自动执行常用任务。 宏是作为单个命令组合在一起以自动完成任务的一系列命令和指令。

若要节省花费在经常执行的任务上的时间,可以将多个步骤捆绑到一个宏中。 首先,需要录制宏。 然后,您可以通过单击“快速访问”工具栏上的按钮或按键组合来运行该宏。 具体取决于您的设置方式。

  1. 单击“视图”>“”>“录制宏”。

    “录制宏”命令

  2. 键入宏的名称。

    “宏名”框

  3. 若要在创建的所有新文档中使用此宏,请确保“将宏保存在”框中显示了“所有文档 (Normal.dotm)”。

    用于选择宏存储位置的框

  4. 若要通过单击按钮运行宏,请单击“按钮”。

    单击以将该宏指定到某个按钮

  5. 单击新宏(其名称类似于 Normal.NewMacros.<您的宏名>),然后单击“添加”。

    宏和“添加”按钮

  6. 单击“修改”

    在“自定义快速访问工具栏”框中修改按钮

  7. 选择按钮图像,键入所需的名称,然后单击两次“确定”。

    “修改按钮”框中的按钮选项

  8. 现在,便可以开始录制步骤了。 单击命令或者按下任务中每个步骤对应的键。 Word 将会录制您的单击和键击动作。

    注意: 录制宏时,使用键盘选择文本。 宏不会录制使用鼠标所做的选择。

  9. 若要停止录制,请单击“视图”>“”>“停止录制”。

    “停止录制”命令

宏的按钮将显示在快速访问工具栏上。

快速访问工具栏上的“宏”按钮

若要运行该宏,请单击其按钮。

  1. 单击“视图”>“”>“录制宏”。

    “录制宏”命令

  2. 键入宏的名称。

    “宏名”框

  3. 若要在创建的所有新文档中使用此宏,请确保“将宏保存在”框中显示了“所有文档 (Normal.dotm)”。

    用于选择宏存储位置的框

  4. 若要通过按键盘快捷方式运行宏,请单击“键盘”。

    单击以将该宏指定到某个键盘快捷方式

  5. 在“请按新快捷键”框中键入组合键。

  6. 检查该组合键是否已指定给其他项目。 如果已被指定,请尝试其他组合键。

  7. 若要在创建的所有新文档中使用此键盘快捷方式,请确保“将更改保存在”框中显示了“Normal.dotm”。

  8. 单击“指定”。

  9. 现在,便可以开始录制步骤了。 单击命令或者按下任务中每个步骤对应的键。 Word 将会录制您的单击和键击动作。

    注意: 录制宏时,使用键盘选择文本。 宏不会录制使用鼠标所做的选择。

  10. 若要停止录制,请单击“视图”>“”>“停止录制”。

    “停止录制”命令

若要运行该宏,请按相应的键盘快捷键。

若要运行宏,请单击“快速访问”工具栏上的按钮、按键盘快捷键,也可以从“”列表运行宏。

  1. 单击“视图”>“”>“查看宏”。

    “查看宏”命令

  2. 在“宏名”下面的列表中,单击要运行的宏。

  3. 单击“运行”

若要在所有文档中使用从某一个文档录制的宏,请将该宏添加到 Normal.dotm 模板。

  1. 打开包含该宏的文档。

  2. 单击“视图”>“”>“查看宏”。

    “查看宏”命令

  3. 单击“管理器”。

    “查看宏”框中的“管理器”按钮

  4. 单击要添加到 Normal.dotm 模板的宏,然后单击“复制”。

  1. 单击“文件”>“选项”>“自定义功能区”。

  2. “从下列位置选择命令”下,单击“宏”

  3. 单击所需的宏。

  4. 在“自定义功能区”下,单击要在其中添加该宏的选项卡和自定义组。

如果没有自定义组,请单击“新建组”。 然后单击“重命名”并键入自定义组的名称。

  1. 单击“添加”

  2. 单击“重命名”以选择该宏的图像并键入所需的名称。

  3. 单击两次“确定”。

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

  2. 在“宏名”框中,键入宏名称。

    注意: 如果为新宏指定的名称与 Word 中的内置宏同名, 则新宏操作将替换内置宏。 若要查看内置宏列表, 请在 "宏的来源" 列表中单击 " Word 命令"。

  3. 在 "宏的来源" 列表中, 单击要在其中存储宏的模板或文档。

    若要使宏在所有文档中可用, 请确保单击 " normal.dotm"。

  4. 单击 "创建" 以打开 "Visual Basic 编辑器"。

打开 Visual Basic 编辑器后, 您可能需要有关使用 Visual Basic for Applications 的详细信息。 有关详细信息, 请单击 "帮助" 菜单上的 " Microsoft Visual Basic 帮助" 或按 F1。

你可以录制操作序列, 也可以通过在 Visual Basic 编辑器 中输入 Visual Basic for Applications 代码来从头开始编写宏。

注意: 若要在 Office Word 2007 中使用宏, 需要显示 "开发工具" 选项卡。

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Word 选项”。

  2. 单击“常规”。

  3. 在 "使用Word 时的最佳选项" 下, 选中 "在功能区中显示 ' 开发工具 ' 选项卡" 复选框。

    注意: 功能区是 Microsoft Office Fluent 用户界面的一个组件。

  1. “开发工具”选项卡上的“代码”组中,单击“录制宏”

    “开发工具”选项卡上的“代码”组
  2. 在“宏名”框中,键入宏名称。

    注意: 如果为新宏指定的名称与 Office Word 2007 中的内置宏同名, 则新的宏操作将替换内置宏。 若要查看内置宏列表, 请在 "开发工具" 选项卡上的 "代码" 组中, 单击 ""。 在 "宏的来源" 列表中, 单击 " Word 命令"。

  3. 在 "将宏保存在" 框中, 单击要在其中存储宏的 模板 或文档。

    重要: 若要使宏在所有文档中可用, 请确保单击 " normal.dotm"。

  4. 在 "说明" 框中, 键入宏的说明。

  5. 执行下列操作之一:

    • 开始录制    若要开始录制宏而不将其分配到 "快速访问工具栏" 上的按钮或快捷键, 请单击"确定"

    • 创建按钮    若要将宏分配给 "快速访问工具栏" 上的按钮, 请执行下列操作:

      1. 单击 "按钮"。

      2. 在 "自定义快速访问工具栏" 下, 选择要将宏添加到 "快速访问工具栏" 的文档 (或所有文档)。

        重要: 若要使宏在所有文档中可用, 请确保单击 " normal.dotm"。

      3. 在 "从对话框中选择命令" 框中, 单击要录制的宏, 然后单击 "添加"。

      4. 若要自定义按钮, 请单击 "修改"。

      5. 在 "符号" 下, 单击要用于按钮的符号。

      6. 在 "显示名称" 框中, 键入要显示的宏名称。

      7. 单击"确定"两次, 开始录制宏。

        您选择的符号将显示在 "快速访问工具栏" 中。 当您指向该符号时, 将显示您键入的名称。

    • 指定键盘快捷方式    若要将宏分配给键盘快捷方式, 请执行下列操作:

      1. 单击“键盘”。

      2. 在 "命令" 框中, 单击要录制的宏。

      3. 在 "请按新快捷键" 框中, 键入所需的键序列, 然后单击 "分配"。

      4. 单击 "关闭" 开始录制宏。

  6. 执行要包括在宏中的操作。

    注意: 录制宏时, 可以使用鼠标单击命令和选项, 但不能选择文本。 必须使用键盘选择文本。 有关使用键盘选择文本的详细信息, 请参阅选择文本

  7. 若要停止录制操作, 请单击 "代码" 组中的 "停止录制"。

更改宏的键盘快捷方式

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Word 选项”。

  2. 单击“自定义”。

  3. 单击 "键盘快捷方式" 旁边的 "自定义"。

  4. 在 "类别" 列表中, 单击 ""。

  5. 在 "" 列表中, 单击要更改的宏。

  6. 在 "请按新快捷键" 框中, 键入要选择的组合键。

  7. 选中 "当前快捷键" 框, 确保未分配已用于执行其他任务的组合键。

  8. 在 "将更改保存在" 列表中, 单击与要运行宏的位置相匹配的选项。

    重要: 若要使宏在所有文档中可用, 请确保单击 " normal.dotm"。

  9. 单击“关闭”。

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

    “开发工具”选项卡上的“代码”组

  2. 在 "宏名称" 下的列表中, 单击要运行的宏。

  3. 单击“运行”

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

    “开发工具”选项卡上的“代码”组

  2. 在“宏名”框中,键入宏名称。

    注意: 如果为新宏指定的名称与 Office Word 2007 中的内置宏同名, 则新的宏操作将替换内置宏。 若要查看内置宏列表, 请在 "宏的来源" 列表中单击 " Word 命令"。

  3. 在 "宏的来源" 列表中, 单击要在其中存储宏的 模板 或文档。

    若要使宏在所有文档中可用, 请确保单击 " normal.dotm"。

  4. 单击 "创建" 以打开 "Visual Basic 编辑器"。

打开 Visual Basic 编辑器后, 您可能需要有关使用 Visual Basic for Applications 的详细信息。 有关详细信息, 请单击 "帮助" 菜单上的 " Microsoft Visual Basic 帮助" 或按 F1。

若要快速处理经常执行的任务, 可以在桌面版本的 Word 中将步骤捆绑到通过单击时运行的宏。 在 Word 网页版 中, 你必须手动逐步执行此类任务。

如果您有 Word, 请先单击 "在 word 中打开" 以在 word 中打开文档。

Word Online 中“在 Word 中打开”命令的图像

然后按照桌面版本的Word的说明进行操作。

当您在 Word 中运行宏并保存文档时, 当您在 Word 网页版 中重新打开文档时, 将看到宏的结果。

注意:  本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 能否告知我们此信息是否有所帮助? 下面是该参考内容的英文版

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×