创建分组报表或汇总报表

信息很方便地了解其划分为组时。例如,分组地区销售总结的报表可以突出显示趋势,否则可能会被忽略。此外,将汇总放置在报表中的每个组的末尾可以替换多个与计算器手动交互。

Microsoft Office Access 2007轻松使用分组报表。您可以通过使用报表向导创建基本的分组的报表,您可以添加分组和排序在现有报表,或您可以修改分组和排序已定义的选项。

本文内容

了解分组、 报表节和控件

使用报表向导生成新的分组的报表

微调报表

在现有报表中添加字段或其他控件

添加或修改现有报表中分组和排序

保存、 打印或发送您的报表

说明

了解分组、 报表节和控件

如果您没有使用过的分组报表,很有帮助的一些背景分组和排序,以及不同报表节和控件的类型。如果您已经熟悉了这些概念,您可以跳过此部分并转到生成新的分组的报表,使用报表向导部分。

有关分组和排序

打印报表时,您通常想要组织特定的顺序中的记录。例如,如果要打印的供应商的列表,您可能希望按公司名称的字母顺序排序记录。

对于多个报表,仅对记录排序还不够。您可能还想要将其划分为组。是记录,以及显示的记录,如页眉任何介绍性和汇总信息的集合。组包含组页眉、 嵌套组 (如果有)、 主体记录以及组页脚。

分组允许您直观地分隔的记录组,并显示每个组的介绍性和汇总数据。例如,以下报表按发货日期分组的销售额和计算的每一天的总数量的销售额。

带汇总的分组报表

1.日期划分组。

2.合计是组。

您可以看到分组是如何工作的比较按类别报表 (如下图所示) 到其基础查询,产品列表中的数据表的产品列表。报表和查询排序按产品类别,但是报表还会将每个类别的名称打印在单独的行的每个组 (在组页眉中) 开始和在单独的行末尾 (在组页脚) 每个组的每个类别的产品编号。

“按类别分组的产品”报表

1.类别名称显示在数据表中的每一行。

2.类别名称一次出现在报表中,在组页眉中的每个组。

3.类别总显示在组页脚中的每个组的末尾。

4.记录显示为数据表中的一个大的组。

5.对于每个类别记录显示为报表,跟在组页眉中后, 跟组页脚中单独的分区。

您可以在任何字段和您作为排序依据 (最多为 10) 的表达式进行分组。您可以多次分组在同一字段或表达式。当您按多个字段或表达式,组Office Access 2007嵌套根据其分组级别。在分组的第一个字段是第一个和最重要的组级别;分组的第二个字段的下一个组级别;等等。下图显示了如何Office Access 2007嵌套组。

页眉页脚层次结构

1.每个组页眉与组页脚配对。

您通常使用组页眉中显示数据,用于标识组的开头单独的分区中的组。您通常使用组页脚来汇总数据的组在单独的分区组的末尾。

返回页首

关于报表的节

在 Access 中,报表的设计分为多节。若要创建有用的报表,您需要了解每个节的工作方式。例如,部分中选择要放置计算的控件决定 Access 如何计算结果。以下列表显示部分类型和其使用方法的摘要。

  • 报表页眉   一次打印报表的开头。使用报表页眉的封面,如徽标、 标题或日期可能会正常显示的信息。报表页眉打印之前的页面页眉。在报表页眉将计算的控件时,显示整个报表的计算值。例如,将在报表页眉中使用Sum聚合函数的控件放计算整个报表的总计。

  • 页面页眉   在每页顶部打印。例如,使用页面页眉下,重复报表标题在每页上。

  • 组页眉   打印的每个新记录组的开头。使用组页眉中打印组名称。例如,在报表中分组的产品,使用组页眉中打印产品名称。当您将在组页眉中使用Sum聚合函数的计算的控件时,总和是当前组。

  • 详细信息   一次打印的记录源中的每一行。主体节是组成报表主体的控件所在的位置。

  • 组页脚   打印在每个组记录的结尾处。使用组页脚打印组的摘要信息。

  • 页面页脚   打印在每页的末尾。使用页面页脚可打印的页码或每页信息。

  • 报表页脚   一次打印报表的末尾。整个报表中使用报表页脚打印的报表总和或其他汇总信息。

    注意: 在设计视图中,报表页脚页面页脚下方显示。但是,打印或预览报表时,报表页脚出现上方页面页脚中,只需之后最后一页上最后一个组页脚或明细数据行。

返回页首

有关控件

控件是显示数据、 执行的操作,并允许您查看和使用增强的用户界面,如标签和图像的信息的对象。Access 支持三种类型的控件︰ 绑定、 未绑定和计算。以下列表显示这些控件和其使用方法的摘要。

  • 绑定控件   控件的数据源是表或查询中的字段。绑定的控件用于显示数据库中的字段中的值。值可以是文本、 日期、 数字、 是/否值、 图片或图形。文本框是最常见的绑定控件类型。例如,显示员工姓氏的窗体中的文本框中从雇员表中的姓氏字段可能会收到此信息。

  • 未绑定控件   没有数据源控件。使用未绑定的控件以显示信息、 线条、 矩形和图片。例如,显示报表的标题标签是未绑定的控件。

  • 计算控件   控件的数据源是表达式,而不是一个字段。通过定义表达式的控件的数据源,可以在控件中指定所需的值。表达式是运算符的组合 (如=+ ),控件名称、 字段名称、 返回单个值,以及常量值的函数。例如,下面的表达式计算项 25%折扣的价格常量值单价字段中的值相乘 (。 75)。

= [Unit Price] * .75

从报表的基础表或查询中的字段或报表上的控件,表达式可以使用数据。

创建报表时,它可能是最有效来添加和排列所有绑定的控件首先,尤其是构成的大部分报表上的控件。然后,您可以添加完成设计通过使用设计选项卡的控件组中的工具的未绑定控件和计算控件。

Access 功能区图像

通过标识控件从中获取其数据的字段,您将控件绑定到的字段。您可以创建绑定到所选的字段从字段列表窗格中的字段拖动到报表的控件。(字段列表窗格中显示报表的基础表或查询的字段。若要显示字段列表窗格中,执行下列操作之一︰

  • 设计选项卡的工具组中,单击添加现有字段按钮图像

  • 按 Alt+F8。

当您双击字段或将其从字段列表窗格拖动到报表时,您可以创建绑定的控件。

或者,可以在控件本身或控件的属性表中的控件来源值的框中键入字段名称字段绑定到控件。属性表定义该控件,如其名称的特征,其数据,以及其格式的源。若要显示属性表,请按 F4。

创建绑定的控件有两种原因最佳方法是使用字段列表窗格中︰

  • 绑定的控件附加的标签,并且默认标签采用字段 (或为该字段的基础表或查询中定义的标题) 的名称作为其标题,因此您不必自己键入标题。

  • 绑定的控件都将继承许多相同的设置的基础表或查询 (如格式小数位数,和输入掩码属性) 中的字段。因此,您可以确保每当您创建绑定到该字段的控件,这些属性的字段保持相同。

如果您已经拥有未绑定的控件,并且想要绑定到某个字段,设置控件的控件来源属性为该字段的名称。

返回页首

使用报表向导生成新的分组报表

报表向导将向您提出一系列问题,然后根据您的回答生成报表。在这些问题中,有一个是要求您提供一个或多个用于对报表进行分组的字段。报表创建之后,您可以按原样使用该报表,或根据需要修改报表。在开始使用报表向导之前,必须确定数据源。

选择记录源

报表包含的信息从一个表或查询,提取和报表设计,例如标签、 标题和图形存储的信息。表或查询,它提供的基础数据,也称为是报表的记录源。创建报表在开始之前,首先应考虑要包含的信息。在您选择必须是那些的字段之间您想要分组或汇总。如果您想要包括所有的字段存在一个表中,将该表格用作记录源。如果字段来自多个表,您需要将查询用作记录源。该查询可能已存在于数据库中,或者您可能需要创建专门用于的报表需求的查询。

若要了解有关查询的详细信息,请按照本文的另请参阅部分中的链接。

启动报表向导

  1. 创建选项卡上的报表组中,单击报表向导按钮图像

    Access 将启动报表向导

    报表向导中的字段选择

  2. 单击“表/查询”下拉列表并选择包含报表中要用到的字段的表或查询。

  3. 双击“可用字段”列表中的字段以选择这些字段。

    Access 将它们移到“选定字段”列表中。或者,可单击位于“可用字段”框和“选定字段”框之间的按钮,以添加或移除选定字段或所有字段。

  4. 如果还要将其他表或查询中的字段放在报表上,则再次单击“表/查询”下拉列表,并选择其他表或查询,然后继续添加字段。

  5. 添加完字段之后,单击“下一步”。

在报表向导中分组记录

通过分组,可以按组(如按地区或业务员)来组织和排列记录。组可以嵌套,这样便能轻松地确定各个组之间的关系,并迅速找到所需的信息。还可以使用分组来计算汇总信息,如汇总和百分比。

如果在报表中包含多个表,则向导将检查表之间的关系,并确定您希望以何种方式查看信息。

  1. 在询问“是否添加分组级别?”的报表向导页上,单击列表中的某个字段名称,然后单击“下一步”。

  2. 若要添加分组级别,请双击列表中的任何字段名称以将其添加到报表中。

    还可以通过在对话框右侧的页面显示中双击某个分组级别来将其移除。可以使用箭头按钮来添加和移除分组级别,还可通过选择分组级别并单击向上或向下优先级按钮来调整分组级别的优先级。Access 添加每个分组级别,并将其嵌套显示在其父分组级别中。

    在报表向导中添加分组级别

  3. 单击“分组选项”以显示“分组间隔”对话框。

    报表向导中的分组间隔

  4. (可选)对于每个组级字段,选择一个分组间隔。

    分组间隔,可以自定义的分组记录的方式。在上图中,按发货日期字段中,这是日期/时间数据分组记录类型。报表向导中提供的分组间隔列表中的字段类型与相应的选项。因此,因为发货日期日期/时间类型,您可以选择要作为分组依据实际值 (正常),季度小时分钟。如果字段是文本数据类型,您可以选择按整个字段 (普通) 或分组可能是第一个 1 到 5 个字符。对于数值数据类型,您可以选择通过值 (正常),或选择增量区域进行分组。

    选择分组间隔之后,单击“确定”。

  5. 单击“下一步”转到向导的下一页。

对记录进行排序和汇总

可以按升序或降序对记录进行排序,最多可以使用四个字段作为排序依据。

  1. 单击第一个下拉列表,并选择作为排序依据的字段。

    单击列表右侧的按钮可以在升序和降序之间切换(默认为“升序”)。此外,还可以单击第二、第三和第四个下拉列表以选择更多排序字段(可选)。

    报表向导中的排序顺序

  2. 若要对任何数值字段进行汇总,请单击“汇总选项”。

    注意,仅当报表的“主体”节中包含一个或多个数值字段时,“汇总选项”按钮才可见。向导将显示可用的数值字段。

    报表向导中的汇总选项

  3. 选中“汇总”、“平均”、“最小”或“最大”选项下的复选框,将这些计算加入到组页脚中。

    还可以选择同时显示明细和汇总,或者只显示汇总。对于后一种情况,将显示每个“发货日期”值的汇总(例如,如果选择了“汇总”复选框),但会省略订单明细。另外,还可以选择显示汇总计算值占总计的百分比。

  4. 单击“确定”。

  5. 按照报表向导其余页上的指示执行操作。在最后一页上,可以编辑报表的标题。此标题将显示在报表的第一页上,并且 Access 还将使用此标题作为保存报表的文档名称。标题和文档名可在以后进行编辑。

  6. 单击“完成”。Access 将自动保存报表,并在“打印预览”中按照打印时的外观显示报表。

可以使用预览窗格底部的导航按钮,按顺序查看报表的各页或跳至报表的任一页。单击某个导航按钮或在页码框中键入想要查看的页码,然后按 Enter。

在“打印预览”中,可以放大以查看细节,也可以缩小以查看数据在页面上的位置布局。将鼠标指针放在报表上方,单击一次。若要使缩放效果相反,则再单击一次。此外,还可以使用状态栏中的缩放控件。

返回页首

微调报表

很可能报表向导将不会产生精确您正在寻找在报表中的结果。例如,您可能想要添加文本、 调整列的宽度、 添加徽标等。Access 提供了两种视图,您可以在其中进行修改报表︰ 布局视图和设计视图。下面简要讨论此部分中。

关于布局视图

布局视图更改报表的最简单易用的视图,并提供了大部分需要微调报表的工具。可以调整列的宽度、 重新排列列,以及添加或修改分组级别和汇总。您可以将新字段放在报表设计并设置为报表及其控件的属性。布局视图的优点是,您可以更改为报表格式,这样就可以立刻看到所做的更改如何影响数据的显示时看到您的数据。

若要在布局视图中打开报表,请右键单击导航窗格中的报表,然后单击布局视图 按钮图像

您可以使用属性表中修改报表及其控件和节的属性。若要显示属性表,请按 F4。

您可以使用字段列表窗格中将字段从基础表或查询添加到您的报表设计。若要显示字段列表窗格中︰

  1. 格式选项卡上的控件组中,单击添加现有字段 按钮图像

    提示: Access 2010 中包含新可以显著提高可读性报表的条件格式功能。

有关设计视图

如果您不能对报表在布局视图中进行的特定更改,请尝试设计视图。设计视图显示您的报表,基础结构,并提供更多的设计工具和功能比布局视图。例如,就可以更广泛的报表上的控件,可以更精确地,调整控件的对齐方式和必须能够设置不是您在布局视图中执行更多属性。

要在设计视图中打开报表,请右键单击导航窗格中的报表,然后单击设计视图 按钮图像

返回页首

在现有报表中添加字段或其他控件

使用某些类型的控件创建每个字段、 标签、 线条或您在报表看到的图片。报表上的最常用的控件是文本框。这是什么通常用于显示报表的基础记录源中的数据。您可以创建记录源中的域已通过从字段列表窗格添加字段绑定的文本框或您可以将它们添加到报表设计视图中工作时 (但然后您必须""将它们绑定到的记录源中的字段自己)。设计视图是您可以添加许多其他类型的控件除了利用绑定文本框,例如矩形、 分页符和图表。本节介绍这两种方法向报表添加控件。

将字段添加到现有报表

布局视图建议视图将字段添加到报表,但也可以在设计视图中。要添加字段,请首先确保,将显示字段列表窗格。字段列表窗格中包含所有可用放置在报表上的字段的列表。若要显示字段列表窗格,请按 ALT + F8。

从字段列表窗格添加字段

  • 若要添加一个字段,将字段拖动从字段列表窗格中的部分报表上您希望显示。

  • 若要一次添加多个字段,请单击的第一个字段,然后在按住 CTRL,然后单击所需的每个附加字段。然后,拖动所选的字段拖到报表。

当将字段放置时,Access 将创建的每个字段绑定的文本框控件,并自动每个字段旁边放置一个标签控件。

注意: 

  • 如果您将域添加相关表中,Access 将为您添加相应的分组级别。

  • 如果从另一个 (非相关) 表中添加字段,则 Access 将显示一个对话框,您可以在其中指定如何将表关联到报表的现有数据源。

若要查看哪些表关系中已指定为您的数据库,或添加新的︰

  1. 数据库工具选项卡上的显示/隐藏组中,单击关系按钮图像

有关详细信息,请参阅创建、 编辑或删除关系一文。

在现有报表中添加其他控件

当向您的报表,可以从字段列表窗格添加字段时,为其绑定的文本框控件自动创建。通过切换到设计视图中,使用设计选项卡上的控件组中的工具,可以添加其他控件,例如标签、 线条和图像。

Access 功能区图像

确定工具的名称

  • 将鼠标指针放在该工具。

    Access 将显示工具的名称。

通过使用控件组中的工具来创建控件

  • 单击您想要添加的控件的类型的工具。例如,若要创建复选框,请单击 按钮图像 复选框工具。

  • 在报表设计要放置该控件的左上角的位置单击。单击一次以创建默认大小的控件,或单击并拖动中报表,以创建所需大小的控件。

  • 如果您不定位到第一次尝试理想的控件,可以移动它使用以下过程︰

    • 单击该控件以将其选中。

    • 将指针置于控件直到它变为四向箭头 移动指针 ,到,然后将该控件拖到所需的位置。

此过程创建一个"未绑定"控件。控件是否可显示数据 (文本框或复选框,例如) 类型,您需要输入字段名称或表达式控件来源属性中的控件才能显示任何数据。

显示属性表

  • 按 F4。

注意: 完成您的新报表时,请务必保存所做的工作。

返回页首

在现有报表中添加或修改分组和排序

如果已经有了现成的报表,并且要在其中添加排序或分组,或者要修改该报表现有的排序或分组,则本节将帮助您着手进行。

在布局视图中添加分组、 排序和汇总

您可以执行简单的排序、 分组和汇总操作通过右键单击布局视图中的字段,然后从快捷菜单中选择所需的操作。若要切换到布局视图中,右键单击导航窗格中的报表,然后单击布局视图 按钮图像

注意: 虽然本节中的说明没有直接使用“分组、排序和汇总”窗格,但在操作时最好打开该窗格并观察该窗格的变化。您将更好地了解 Access 的工作过程,在您能更熟练地使用“分组、排序和汇总”窗格之后,可以使用该窗格对报表进行进一步调整。若要显示“分组、排序和汇总”窗格,请执行以下操作:

  1. 格式选项卡上的分组和汇总组中,单击分组和排序按钮图像

单字段排序

  • 右键单击要排序的字段中的任何值。

  • 在快捷菜单上,单击所需的排序选项。例如,要将文本字段按升序排序,请单击排序 A 到 Z 按钮图像 。若要对数值字段按降序顺序进行排序,请单击降序 按钮图像

Access 将根据指定的设置对报表进行排序。如果“分组、排序和汇总”窗格已打开,则可以看到该字段新增了“排序依据”行。

多字段排序

注意: 应用排序,请右键单击布局视图中的字段时,您可以仅一次排序一个字段。应用到另一个字段排序中删除的第一个字段进行排序。这不同于在表单中,在其中可以通过依次右键单击每个字段,并选择所需的排序顺序建立多个排序顺序的排序行为。若要创建多个排序级别,请参阅部分中添加分组、 排序和汇总使用分组、 排序和汇总窗格

对字段进行分组

  • 在要进行分组的字段中,右键单击任意值。

  • 在快捷菜单上,单击分组形式 按钮图像

Access 将添加分组级别,并为其创建组页眉。如果“分组、排序和汇总”窗格已打开,则可以看到该字段新增了“分组形式”行。

添加字段的汇总

通过此选项,可以计算字段的合计、平均值、计数或其他汇总。报表的结尾将添加总计,报表上的所有组将添加组小计。

  • 在要进行汇总的字段中,右键单击任意值。

  • 单击“汇总”。

  • 单击您要执行的操作:“合计”、“平均值”、“记录计数”(统计所有记录的数目)、“值计数”(只统计此字段中有值的记录的数目)、“最大值”、“最小值”、“标准偏差”或“方差”。

Access 在报表页脚添加一个计算文本框控件,该控件创建总计。同时,如果报表中有任何分组级别,则 Access 将添加组页脚(如果尚不存在),并在每个组页脚中放置小计。

您可以也添加汇总︰ 单击要进行汇总的字段,然后在格式选项卡的分组和汇总组中,单击汇总 按钮图像

使用“分组、排序和汇总”窗格添加分组、排序和汇总

若要在报表中添加或修改分组、排序顺序或汇总选项,使用“分组、排序和汇总”窗格可以为您提供最大的灵活性。此外,布局视图是首选的操作视图,因为在该视图中更易于看到所做的更改如何影响数据的显示。

显示“分组、排序和汇总”窗格

  • 在布局视图中︰

    格式选项卡上的分组和汇总组中,单击分组和排序按钮图像

  • 在设计视图中︰

    设计选项卡上的分组和汇总组中,单击分组和排序按钮图像

Access 将显示分组、 排序和汇总窗格。

“分组、排序和汇总”窗格

若要添加新的排序和分组级别,请单击“添加组”或“添加排序”。

分组、排序和汇总”窗格中将添加一个新行,并显示可用字段的列表。

“分组、排序和汇总”窗格中的字段列表

您可以单击一个字段名称,或者您可以单击下输入表达式的字段列表中的表达式。一旦您选择域或输入表达式,Access 会向报表添加分组级别。如果您是在布局视图中,显示将立即更改要显示分组或排序顺序。

注释: 

  • 如果已经定义了多个排序或分组级别,则可能需要向下滚动“分组、排序和汇总”窗格才能看到“添加组”或“添加排序”按钮。

  • 一个报表最多可定义 10 个分组和排序级别。

更改分组选项

每个排序级别和分组级别都包含大量选项,您可以通过设置这些选项来获得所需的结果。

分组选项

  • 若要显示分组级别或排序级别的所有选项,请在要更改的级别上单击“更多”。

    分组选项(已展开)

  • 若要隐藏选项,请单击“更少”。

排序顺序    可以通过单击排序顺序下拉列表,然后单击所需的选项来更改排序顺序。

分组间隔    此设置用以确认记录的分组方式。例如,可根据文本字段的第一个字符进行分组,从而将以“A”开头的所有文本字段分为一组,将以“B”开头的所有文本字段分为另一组,依此类推。对于日期字段,可以按照日、周、月、季度进行分组,也可输入自定义间隔。

汇总    若要添加汇总,请单击此选项。可以添加多个字段的汇总,并且可以对同一字段执行多种类型的汇总。

“汇总”弹出窗口

  • 单击“汇总方式”下拉箭头,然后选择要进行汇总的字段。

  • 单击“类型”下拉箭头,然后选择要执行的计算类型。

  • 选择“显示总计”以在报表的结尾(即报表页脚中)添加总计。

  • 选择“显示组汇总占总计的百分比”,以在组页脚中添加用于计算每个组的小计占总计的百分比的控件。

  • 选择“显示在组页眉中”或“显示在组页脚中”以将汇总数据显示在所需的位置。

选择字段的所有选项之后,可从“汇总方式”下拉列表中选择另一个字段,重复上述过程以对该字段进行汇总。否则,单击“汇总”弹出窗口外部的任何位置以关闭该窗口。

标题    通过此选项,可以更改汇总字段的标题。此选项可用于列标题,还可用于标记页眉与页脚中的汇总字段。

若要添加或修改标题,请执行以下操作:

  • 单击“有标题”后面的蓝色文本。

    缩放”对话框随即出现。

  • 在该对话框中键入新的标题,然后单击“确定”。

有/无页眉节    此设置用于添加或移除每个组前面的页眉节。在添加页眉节时,Access 将分组字段移到页眉。当移除包含非分组字段的控件的页眉节时,Access 会询问是否确定要删除该控件。

有/无页脚节    使用此设置添加或移除每个组后面的页脚节。在移除包含控件的页脚节时,Access 会询问是否确定要删除该控件。

将组放在同一页上    此设置用于确定在打印报表时页面上组的布局方式。您可能需要将组尽可能放在一起,以减少查看整个组时翻页的次数。不过,由于大多数页面在底部都会留有一些空白,因此这往往会增加打印报表所需的纸张数。

  • 不将组放在同一页上    如果您不在意组被分页符截断,则可以使用此选项。例如,一个包含 30 项的组,可能有 10 项位于上一页的底部,而剩下的 20 项位于下一页的顶部。

  • 将整个组放在同一页上    此选项有助于将组中的分页符数量减至最少。如果页面中的剩余空间容纳不下某个组,则 Access 将使这些空间保留为空白,换而从下一页开始打印该组。较大的组仍需要跨多个页面,但此选项将把组中的分页符数尽可能减至最少。

  • 将页眉和第一条记录放在同一页上    对于包含组页眉的组,此选项确保组页眉不会单独打印在页面的底部。如果 Access 确定在该页眉之后没有足够的空间至少打印一行数据,则该组将从下一页开始。

更改分组级别和排序级别的优先级

若要更改分组或排序级别的优先级,请单击“分组、排序和汇总”窗格中的行,然后单击该行右侧的向上或向下箭头。

删除分组级别和排序级别

若要删除分组或排序级别,请在“分组、排序和汇总”窗格中,单击要删除的行,然后按 Delete 或单击该行右侧的“删除”按钮。在删除分组级别时,如果组页眉或组页脚中有分组字段,则 Access 将把该字段移到报表的“主体”节中。组页眉或组页脚中的其他任何控件都将被删除。

返回页首

创建汇总报表(无记录详细信息)

如果您想要显示汇总,仅 (即只页眉和页脚的行中的信息),在格式选项卡上 (或在设计视图中的设计选项卡上),在分组和汇总组中,单击隐藏明细数据。执行此操作隐藏分组,得到的汇总数据更紧凑演示文稿中的下一个较低级别的记录。尽管记录处于隐藏状态,但不会删除隐藏的节中的控件。单击隐藏明细数据,以还原到报表的明细数据行。

不使用标题创建分组效果

您可以获得分组效果在无需使用标题的报表。删除页眉创建更紧凑报表,因为垂直空间更少由标题行。

常规过程涉及删除每个组,将每个分组字段移动到详细信息部分中的报表的标题。若要还原可视化分组效果,您将每个分组字段隐藏重复项属性设置为

示例

请考虑使用组页眉此典型分组的报表︰

带有组页眉的分组报表

每个订单 ID 一样每个公司名称您可以看到,占据了一整行

在此示例中,将编辑报表,以便它类似于下图︰

移除了组页眉的分组报表

  1. 通过在导航窗格中,右键单击它,然后单击视图 按钮图像 在布局视图中打开报表。

  2. 格式选项卡上的分组和汇总组中,单击分组和排序按钮图像

    注意: 它是个好主意启动与最低级别组和您的方式工作否则,显示的报表可以变得混乱工作时。

  3. 单击在列表中的最低分组级别,然后单击更多

  4. 从页眉节下拉列表中,选择无页眉节

    删除页眉时,Access 将保留分组字段的文本框中通过将其移动到详细信息部分中。但是,可能会删除在组页眉中的任何其他控件。Access 会警告您如果任何控件将被删除因此操作。如果您想要保留的组页眉中的控件,请务必执行此步骤之前将其移动到另一个报表的节。您将需要切换到设计视图,以将控件移动到其他分区。

    生成报表如下图所示。请注意,第一个订单 id 在同一行在第一个明细记录,而不是在自己的行。

    移除了“订单 ID”页眉的分组报表

    很遗憾,每个明细行,重复订单 id,这使得很难查看完全有多少订单。此时,将文本框控件的隐藏重复属性设置很有用。请按照下列步骤设置此属性︰

    • 选择其中一个重复值。

    • 如果当前未显示属性表,请按 F4 显示该表。

    • 在属性表的格式选项卡上,单击隐藏重复控件的下拉列表,然后单击

      重复的订单 Id 处于隐藏状态。请注意,您可以看到订单数,以及有多少产品每个订单。

      隐藏了重复“订单 ID”的分组报表

  5. 对于此示例中,我们将重复步骤 4 的公司名称分组级别。最终报表类似于下图︰

    移除了组页眉的分组报表

    公司名称值现在位于同一行在第一个明细记录,并隐藏重复属性可防止公司名称值重复出现在每一行。有关使用多个分组级别的长报表,这可能会导致节省大量纸张。

返回页首

保存、 打印或发送您的报表

保存报表设计后,可以多次使用它。报表的设计保持不变,但您将看到当前数据,每次打印报表。如果您的报表需求更改时,您可以修改报表设计或创建新的、 类似的报表基于原始。

保存报表

  1. 单击 Office 按钮图像 Microsoft Office 按钮,然后单击保存或按 CTRL + S 按钮图像

    或者,您可以单击快速访问工具栏上的保存 按钮图像

  2. 如果报告未命名,在报告名称框中键入名称,然后单击确定

保存报表设计新的名称

  1. 单击 Office 按钮图像 Microsoft Office 按钮,然后再单击另存为 按钮图像

  2. 另存为对话框中,在将报表保存到框中键入名称,单击报表中的作为框中,,,然后单击确定

打印报表

从打印预览,请在布局视图、 设计视图、 报表视图或导航窗格中,您可以打印报表。在打印之前,您应仔细检查页面设置,如页边距和页面方向。Access 报表中,使用保存页面设置,因此您需要一次只能对其进行设置。以后,如果需要更改,您可以保存设置。

更改页面设置

  1. 在任何视图中打开报表。

  2. 页面布局选项卡的页面组中,单击一个选项︰

    • 大小 按钮图像 允许您选择的纸张大小或输入自定义的纸张大小。

    • 纵向 按钮图像 纵向排列页面。

    • 横向 按钮图像 水平排列页面。

    • 页边距 按钮图像 使您可以选择从多个预定义的边距宽度,或者您可以单击高级通过使用页面设置对话框中输入自定义页边距宽度。

    • 显示边距切换显示边距打开和关闭 (仅在布局视图中)。

    • 将显示页面设置对话框。输入您希望设置所需的列大小,,然后单击确定列数。

    • 仅打印数据禁止打印有放置在报表上的任何标签。将打印控件绑定到基础表或查询中的数据。此功能很有帮助在您有时在预印表单打印的报表。可以取消打印的标签在这些情况下,并在空白纸张上打印报表时,然后启用打印的标签。

注意: 使用更详细的页面设置,请单击页面设置按钮以显示页面设置对话框中的页面布局组右下角。若要调整在页面布局选项卡可用的所有设置并选择特定打印机的报表,可以使用页面设置对话框。

将报表发送到打印机

  1. 在任何视图中,打开该报表,或只需在导航窗格中选择的报告。

  2. 单击 Office 按钮图像 Microsoft Office 按钮,然后单击打印“打印”按钮

  3. 打印对话框中,输入您选择的选项,例如打印机、 打印范围和份数。

  4. 单击“确定”

返回页首

将报表作为电子邮件

作为电子邮件,而不是打印书面副本,可以向用户发送您的报表。

  1. 在导航窗格中,单击以选中它,单击 Office 按钮图像 Microsoft Office 按钮,然后单击电子邮件 按钮图像 的报表。

  2. 对象发送为对话框中,单击要使用的文件格式。

    “对象发送为”对话框

  3. 完成其余的对话框。

  4. 出现电子邮件程序时,键入邮件的详细信息,然后发送邮件。

返回页首

备注

如果您在查阅字段,有.accdb 文件中进行排序或组中的报表,可能会出现问题,并且想要将该报表导入到.mdb 文件,然后与早期版本的 Access 中打开它。

内部的方法依据的查阅字段进行排序和分组.accdb 文件中不兼容的.mdb 文件。如果您在使用.accdb 文件中创建报表进行分组或排序在查阅字段,然后将其导出到.mdb 文件 (或使用另存为命令将数据库另存为.mdb 文件),然后尝试打开该报表与早期版本的访问权限,报表将无法加载。

若要修改报表,以便您可以将它导入.mdb 文件,并在早期版本的 Access 中打开它,请执行下列操作︰

  1. 在.accdb 文件中,创建报表的副本。

  2. 在布局视图中打开报表的副本。

  3. 如果未显示分组、 排序和汇总窗格中︰

    1. 格式选项卡上的分组和汇总组中,单击分组和排序按钮图像

  4. 通过单击删除按钮右侧的每一行中删除分组、 排序和汇总窗格中的所有行。

  5. 单击 Office 按钮图像 Microsoft Office 按钮,然后单击保存或按 CTRL + S 按钮图像

  6. 单击 Office 按钮图像 Microsoft Office 按钮,,然后单击关闭数据库按钮图像

  7. 单击 Office 按钮图像 Microsoft Office 按钮,,然后单击打开按钮图像

  8. 通过浏览找到您要向其导入报表,.mdb 文件,然后单击打开

  9. 将报表副本导入到.mdb 文件。

    方法

    1. 外部数据选项卡上的导入组中,单击Access按钮图像

    2. 单击“浏览”。

    3. 浏览到包含该报表的.accdb 文件,然后单击打开

    4. 您不会导入任何表时,因此不管您选择导入或链接到源数据。单击确定以继续。

    5. 导入对象对话框中,单击报表选项卡。

    6. 单击您要导入的报表,然后单击确定

    7. 如果成功导入操作,Access 会询问您是否要保存导入步骤以备将来使用。如果您想要保存的步骤,,您可以选择保存导入步骤复选框,输入所需的信息,然后单击保存导入。如果您不想要保存的步骤,请单击关闭

      Access 导入报表,并将其显示在导航窗格中。

  10. 在布局视图中打开报表。

  11. 如果未显示字段列表窗格中︰

    1. 格式选项卡上的控件组中,单击添加现有字段 按钮图像

  12. 相关表中的可用字段窗格中,找到包含要在报表中显示的字段的表。此字段将包含相同当前看到显示由报表上查阅字段的值。

  13. 将字段拖动到报表。

    现在,您有两个列显示相同的信息。

  14. 右键单击刚添加的显示字段,然后单击要使用的排序选项。

  15. 删除您刚刚添加并排序显示字段。

  16. 如果未显示分组、 排序和汇总窗格中︰

    1. 格式选项卡上的分组和汇总组中,单击分组和排序按钮图像

  17. 单击添加组

  18. 字段中的表达式弹出窗口中,单击在报表的查阅字段的名称。

报表现在排序和分组为.accdb 文件中。保存并关闭报告。

返回页首

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×