创建一个框平面图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您正在进行统计分析,您可能想要创建一个标准框平面图,显示一组数据的分布。在框绘图,数值数据分为四分位数,,然后绘制一个框之间第一个和第三个四分位数的附加行绘制沿标记值的第二个四分位与。在某些框图,最小值和最大值之外的第一个和第三个四分位数描绘的行,通常被称为

盒须图的各个部分

同时Excel 2013没有框绘图的图表模板,您可以通过执行以下步骤创建框图:

  1. 计算源数据集的四分位点值。

  2. 计算四分位数的差异。

  3. 从四分位点区域中创建堆积的柱形图类型。

  4. 堆积的柱形图转换为框中绘图样式。

在本示例中,源数据集包含三列。每一列具有以下范围内从 30 条目:

  • 第 1 列 (2013): 100-200

  • 第 2 列 (2014 年): 为 120-200

  • 第 3 列 (2015): 100-180

源数据表

本文内容

步骤 1: 计算四分位点的值

首先,您需要计算最小值、 最大值和中间值,以及第一个和第三个四分位数的数据集。

  1. 若要执行此操作,创建第二个表,并填充下面的公式:

    公式

    最小值

    最小值 (单元格区域)

    第一个四分位点

    四分位点。INC (单元格区域,1)

    中间值

    四分位点。INC (单元格区域,2)

    第三个四分位点

    四分位点。INC (单元格区域,3)

    最大值

    最大值 (单元格区域)

  2. 因此,您应该收到包含正确的值的表。下面的四分位数计算从示例数据集:

    最终的表和值

返回页首

步骤 2: 计算四分位数的差异

接下来,计算每个阶段之间的差异。实际上,您必须计算下列之间的差异:

  • 第一个四分位点和最小值

  • Median 和第一个四分位点

  • 第三个四分位点和中间值

  • 最大值和第三个四分位点

  1. 首先,创建第三个表,并直接从的最后一个表复制的最小值。

  2. 计算对Excel减法公式 (cell1-cell2) 的四分位点差异和填充第三个表与差异。

示例数据集,第三个表的外观如下所示:

返回页首

步骤 3: 创建堆积的柱形图

第三个表中的数据是适合于框中绘图区,我们将首先创建堆积的柱形图,然后,我们将修改。

  1. 从第三个表中,选择所有数据,然后单击插入>插入柱形图>堆积柱形图

    首先选择堆积柱形图。

    首先,图表不尚未类似于框中绘图区为Excel从水平和垂直不数据集默认绘制堆积的柱形图。

    具有堆积柱形图的默认图表
  2. 要反转图表的坐标轴,请在图表中,右键单击,然后单击选择数据

  3. 单击切换行/列

    提示: 

    • 若要重命名列,侧水平 (分类) 轴标签,单击编辑,选择所需,类别名称与第三个表中的单元格区域单击确定选择要重命名的单元格区域。

    • 若要重命名您的图例项,请在图例项 (系列)的一侧,单击编辑,并键入所需的条目。

  4. 单击“确定”。

现在,该图形应类似于下面的一个。在此示例中,也已编辑图表标题,,此时隐藏图例。

图表的样式现在应如图所示。

返回页首

步骤 4: 将堆积的柱形图转换为框中绘图区样式

隐藏底部数据系列

要转换为框绘图的堆积的柱形图,首先隐藏底部数据系列:

  1. 选择列的下半部分。

    注意: 当您单击单个列上时,选择同一系列的所有实例。

  2. 单击格式>当前所选内容>选定内容的格式。在右侧打开格式面板。

    “格式选择”位于“格式”选项卡中。
  3. 填充选项卡上,在正式面板中,选择无填充

    从图表中的可见隐藏底部数据系列。

    在此图中,底部数据处于隐藏状态。

创建框绘图的图

下一步是将替换的顶层和第二从底部 (的深蓝色和橙色区域中的图像) 与线条或的数据系列。

  1. 选择最顶层的数据系列。

  2. 填充选项卡上,在正式面板中,选择无填充

  3. 从功能区中,单击设计>添加图表元素>误差线>标准偏差

    “添加图表元素”和“误差线”菜单。
  4. 单击其中一个绘制的误差线。

  5. 格式面板中,打开误差线选项选项卡,然后设置下列各项:

    • 设置为减去方向

    • 设置为无线端结束样式

    • 误差量,设置为100百分比

      对于“误差量”,“百分比”应为 100%。
  6. 第二从底部数据系列重复上述步骤。

    堆积的柱形图现在应开始类似于框绘图。

    最终图表中现在已经有了“须”。

颜色的中间区域

通常一个填充颜色,带有轻微边框中绘制框图。以下步骤介绍如何完成布局。

  1. 选择框中绘图的顶部区域。

  2. 格式面板中的填充和线条选项卡上 单击纯色填充

  3. 选择填充颜色。

  4. 在同一选项卡上,单击实线

  5. 选择轮廓颜色和笔划宽度

  6. 设置其他领域的框绘图相同的值。

    最终结果应如下所示框绘图。

    最终的盒须图应如图所示。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

另请参阅

可用图表类型

图表和其他可视化效果中的 Power View

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×