创建、运行、编辑或删除宏

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

若要保存您经常执行的任务的时间,您可以为宏录制这些任务的步骤。然后,当您想要执行这些记录任务之一,您可以激活要执行的步骤为您的宏。

Word

在 Word 2016 for Mac,您可以创建具有键盘快捷键的宏、 运行宏,和删除不再需要的宏。

  1. 单击“视图”>“”>“录制宏”。

    在“视图”选项卡上,单击“宏”,然后单击“录制宏”,可开始创建宏。
  2. 为该宏,请键入一个名称或接受默认的Word提供。

    在“宏名”中输入宏的名称,或接受 Word 提供的通用名称。
  3. 若要在您创建的所有新文档中使用此宏,验证的所有文档 (Normal)已都选中将宏保存在列表。

  4. 单击键盘将组合键分配给您的宏。

    Word显示自定义键盘对话框。

  5. 按新快捷键框中键入组合键。

    如果有组合键,则在你按组合键后,Word 将显示已分配给该组合的命令或宏。

    当你按的键组合时, Word显示的命令或当前分配给该组合键,如果任何操作。

  6. 如果已分配您选择的键组合,从按新快捷键框中,将其删除,然后选择新的键组合。

    转到下一步之后您已经找到未分配的键组合。

    当你按下尚未分配给命令或宏的组合键时,Word 可识别出来。
  7. 若要使用此键盘快捷方式中的所有新文档,请确保Normal.dotm,全局模板中,选中将更改保存在列表中。

    选择“Normal.dotm”,以使宏可供在你创建的新文档中使用。
  8. 单击“指定”

  9. 若要录制的宏,准备就绪后,单击确定

  10. 单击命令或任务中按的键的每个步骤。

    Word记录您单击和键击,但它不记录您使用鼠标选择的文本。若要录制宏时选择文本,请使用键盘。

  11. 若要停止录制,请单击“视图”>“”>“停止录制”。

    单击“宏”菜单上的“停止录制”,可以停止录制宏。

若要运行宏,请按键盘快捷键分配,或从列表中运行宏。

  1. 单击“视图”>“”>“查看宏”。

    单击“查看宏”可查看和编辑与当前文档相关联的宏。
  2. 宏名下的列表中,选择要运行的宏。

  3. 单击“运行”

    在“宏名”中选择宏后,单击“运行”以运行它。

  1. 单击“视图”>“”>“查看宏”。

    单击“查看宏”可查看和编辑与当前文档相关联的宏。
  2. 验证指定中的宏的位置,包括您确实要删除的宏的位置。

    选择想要在列表中“宏”查看的宏的位置。

    列表将包含在当前窗口中,以及全局模板和Word命令打开文档。

  3. 宏名下选择您想要删除的宏,然后单击列表下方减号 (-)。

    选择要删除的宏,然后在列表中单击减号 (-)。
  4. Word要求确认您确实要删除的宏,请单击

Excel

在 Excel 2016 for Mac,您可以创建具有键盘快捷键的宏、 运行宏,和删除不再需要的宏。

录制宏时,宏录制器的所有步骤所都需的记录完成所需的宏执行的操作。这些步骤可以包括键入的文本或数字,单击单元格或命令或功能区上菜单、 格式、 选择单元格、 行或列,并拖动鼠标以选择您的电子表格上的单元格。

注意: 还有功能区上的开发工具选项卡上的命令将录制、 创建和删除宏,以及其他高级的功能。有关使用开发工具选项卡的详细信息,请参阅使用开发工具选项卡可创建或删除 Excel 2016 for Mac 中的宏

  1. 选择工具>>新记录

    选择工具,然后宏,然后录制新宏

  2. 在“宏名”框中,输入宏的名称。

    输入宏名称、 位置和快捷方式键

  3. 若要创建键盘快捷键的宏,请在Option + Cmd框中键入一个字母。

  4. 从下拉列表中选择该宏的位置。

    保存宏

    单击

    在文档中您正在创建宏

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

  5. (可选)添加您的宏的描述。

  6. 当准备好进行录制时,单击确定

  7. 单击命令或任务中按的键的每个步骤。

  8. 若要停止录制,请选择工具>>停止录制。(此步骤中将不会录制在宏中。)

    选择停止录制

若要运行宏,请按键盘快捷键分配,或从对话框中运行宏。

  1. 在“视图”选项卡上,单击“查看宏”。

  2. 单击中弹出菜单,然后选择此工作簿

  3. 从列表中选择宏,然后单击“运行”。

    Excel for Mac 中的“宏”对话框

  1. 选择工具>>

    选择宏,然后选择宏

  2. 选择要删除的宏,然后按减号 (-)。

    选择宏名,然后选择减号 (-)

  3. 将出现一条确认消息。单击以确认删除。

    确认删除操作

您也可以从开发工具选项卡中删除宏。

  1. 在“开发工具”选项卡上,单击“”。

  2. 在列表中,单击要删除的宏,然后单击删除按钮。

    选择一个宏,然后单击减号将其删除

Word

要自动执行重复任务,可以在 Word 中快速创建宏。 也可以在 Microsoft Visual Basic for Applications 中使用Visual Basic 编辑器编写你自己的宏脚本,或将一个宏的全部或部分脚本复制到新宏中。

录制宏时,录制完成所需的宏执行的操作所需的所有步骤。但是,返回到停止录制选项卡导航未包括在记录的步骤。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,输入宏的名称。

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    [文档名](文档)

    所有已打开的文档中

    所有文档 (Normal)

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,单击“停止”。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“Word”菜单上,单击“关闭并返回 Microsoft Word”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“Word”菜单上,单击“关闭并返回 Microsoft Word”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Word 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

PowerPoint

若要自动执行重复性任务,您可以使用 Visual Basic 应用程序在 PowerPoint 中创建宏 。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“PowerPoint”菜单上,单击“关闭并返回 Microsoft PowerPoint”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“PowerPoint”菜单上,单击“关闭并返回 Microsoft PowerPoint”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "PowerPoint 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

Excel

要自动执行重复任务,可以在 Excel 中快速创建宏。 也可以在 Microsoft Visual Basic for Applications 中使用Visual Basic 编辑器编写你自己的宏脚本,或将一个宏的全部或部分脚本复制到新宏中。

将录制完成希望宏执行的所有操作所需的全部步骤。 但是,录制的步骤中不包括为了停止录制而返回选项卡的导航。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,输入宏的名称。

    提示: 要为宏创建键盘快捷方式,请在“Option+Cmd+”框中键入一个字母。

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

    个人宏工作簿位于 users /用户名/库/应用程序支持 / Microsoft/Office/Excel。

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,再次单击“录制”。

可以使用内置的 Visual Basic 编辑器创建宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“编辑器”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 如果需要插入模块,请在 Visual Basic 编辑器的“插入”菜单上,单击“模块”。

  3. 在模块的代码窗口中,键入或粘贴要使用的宏代码。

  4. 完成后,在“Excel”菜单上,单击“关闭并返回 Microsoft Excel”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要运行的宏,然后单击“运行”。

    提示: 要通过使用键盘快捷键运行宏,请按 OPTION + COMMAND + 创建该键盘快捷键时键入的字母。

要编辑宏,可以使用 Visual Basic 编辑器。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要编辑的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 进行所需的更改。

  4. 完成后,在“Excel”菜单上,单击“关闭并返回 Microsoft Excel”。

完成此过程之后,只要打开包含宏的工作簿,都将运行该宏。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“录制”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在“宏名”框中,键入 Auto_Open

  3. 在“宏保存于”弹出菜单中,执行下列操作之一:

    宏的保存位置

    单击

    正在创建宏的文档中

    此工作簿

    所有已打开的文档中

    新工作簿

    只要使用 Excel 即可用

    个人宏工作簿

  4. 单击“确定”,然后执行要录制的操作。

  5. 在“开发工具”选项卡上的“Visual Basic”下,再次单击“录制”。

  6. “文件”菜单上,单击“另存为”

  7. 在“格式”弹出菜单上,单击“启用宏的 Excel 工作簿(.xlsm)”,然后单击“保存”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要复制的宏,然后单击“编辑”。

    将打开 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器的代码窗口中,选择要复制宏的行。

    提示: 若要复制整个宏,请在选定区域中包括“Sub”和“End Sub”行。

  4. 在“编辑”菜单中,单击“复制”。

  5. 在代码窗口的“项目”框中,单击要在其中放置代码的模块。

  6. 在“编辑”菜单上,单击“粘贴”。

  1. 在“开发工具”选项卡上的“Visual Basic”下,单击“”。

    "Excel 开发工具"选项卡,Visual Basic 组

    如果“开发工具”选项卡不可用

    1. 在功能区的右侧,单击 操作弹出菜单 ,然后单击“功能区首选项”。

    2. 在“自定义”下,选中“开发工具”复选框。

  2. 在列表中,单击要删除的宏,然后单击“删除”。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×