准备 Word 邮件合并的 Excel 数据源

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Word邮件合并过程中的基本步骤是设置并准备数据源。您可以使用现有Excel数据源,或创建一个新导入以制表符分隔 (.txt) 或逗号分隔值 (.csv) 文件。之后您已设置并准备好您的数据源,您可以执行邮件合并通过分步邮件合并向导中使用动态数据交换 (DDE)或使用手动邮件合并方法。

如果您未使用邮件合并Excel现有数据源,您可以使用联系人列表或.txt 或.csv 文件中的通讯簿。文本导入向导将指导您完成步骤才能保证.txt 或.csv 文件Excel到中的数据。

  1. 打开Excel。

  2. 数据选项卡上选择获取外部数据>从文本

    “数据”选项卡上已突出显示“从文本”选项。

  3. 选择.txt 或.csv 所需文件,然后选择导入

  4. 文本导入向导原始数据类型窗格中,选择分隔符号

    从文本,文本导入向导,步骤 1 / 3 的 Excel 获取外部数据

  5. 如果您要导入的文件具有标题,选择预览窗格上方的我的数据包含标题复选框,然后选择下一步

  6. 分隔符窗格中,选择您的数据使用的相匹配的分隔符 (如制表符或逗号) 复选框,然后选择下一步

    “文本导入向导”中已突出显示“分隔符”的选项。

    提示: 数据预览窗格中显示结果以表格格式的外观。

  7. 数据预览,选择包含邮政编码或邮政编码的列,然后在列数据格式下选择文本

    “文本导入向导”中已突出显示“列”数据格式的“文本”选项。

    注释: 

    • 可用的格式的常规文本日期。每次将数据格式应用于一列,该列的表格表头中显示格式的名称。

    • 列包含数值数据,例如百分比或货币值,例如,可以仅将格式设置之后在导入该文件。请参阅"设置格式Excel中的数值数据"的小节后面的详细信息。

  8. 重复步骤 7 是有必要,请选择您想要更改的列和要应用的数据格式。

  9. 选择“完成”。

  10. 导入数据对话框中,接受默认设置的现有工作表和单元格地址,,然后选择确定

    在导入数据对话框中,选择要将数据放在现有工作表,默认设置,或在新工作表

    警告: 在导入数据对话框中的单元格地址显示当前选定的单元格。导入数据后开头的命名的单元格地址。

  11. 完成后,请使用新的文件名保存数据源。

Excel中数值数据的格式

设置任何数值数据,如百分比或在Excel您打算使用Word邮件合并中的任何新的或现有数据源中的货币值的格式。若要保留您已在邮件合并过程格式化为百分比,或为货币格式的数值数据,请按"步骤 2︰ 使用邮件合并动态的数据交换 (DDE)"部分。

在Excel数据源,您将使用Word邮件合并中的邮件列表,请确保正确设置格式的数值数据的列。 设置列格式包含数字,例如,以匹配特定类别,如货币。

  1. 打开Excel数据源。

  2. 选择要设置格式的列。

  3. 开始选项卡的数字组中,选择数字格式(常规) 框中向下箭头,,然后在列表中选择一个选项。

    在 Excel 中,在开始选项卡上数字组中,选择常规框中,选择要使用的数字格式中的向下箭头。

  4. 根据需要重复步骤 2 和 3。

  5. 完成后,选择保存

当您有包含百分比和货币值等格式的数字的Excel数据源时,数值数据的一些可能未保留其格式的邮件合并过程。你将收到的邮件合并结果需要,可以通过 DDE 保留在Excel数值数据的格式。

通过使用或不使用动态数据交换同期相比工作合并域的 Excel 数据格式

注意: 如果您决定不使用 DDE,请按照使用邮件合并发送批量电子邮件中的指导。

  1. 打开Word,选择文件>选项>高级

  2. 常规,然后选择打开时确认文件格式转换下选中框。

    “打开时确认文件格式转换”选项

  3. 选择“确定”。

  4. 邮件选项卡上选择开始邮件合并> Step by Step 邮件合并向导

    在 Word 中,在邮件选项卡上,选择开始邮件合并,然后选择 Step by Step 邮件合并向导

  5. 邮件合并窗格中,在选择收件人中选择使用现有列表

    在 Word 中,邮件合并任务窗格打开时您选择邮件合并组中的步骤的邮件合并向导

  6. 使用现有列表下选择浏览,,然后打开格式化的电子表格。

  7. 确认数据源对话框中,选择全部显示复选框,选择MS Excel 工作表通过 DDE (*.xls) >确定

    “确认数据源”对话框

  8. Microsoft Excel对话框中,选择整个电子表格>确定

    Word 中的“Microsoft Excel”对话框

  9. 当打开邮件合并收件人对话框中时,选择确定

    邮件合并收件人的对话框,显示为数据源用于邮寄列表的 Excel 电子表格的内容

  10. 继续使用字母电子邮件标签信封合并。

提示: 您可以阻止Word每次打开数据文件提示。连接到您的邮件列表之后,请转至文件>选项>高级。在常规下清除打开时确认文件格式转换复选框。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×