准备 Word 邮件合并的 Excel 数据源

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

Word邮件合并过程中的基本步骤是设置并准备数据源。您可以使用现有Excel数据源或生成一个新导入以制表符分隔 (.txt) 或逗号分隔值 (.csv) 文件。之后您已设置并准备好您的数据源,您可以执行邮件合并通过分步邮件合并向导中使用动态数据交换 (DDE)或使用手动邮件合并方法。

如果您未使用邮件合并Excel现有数据源,您可以使用联系人列表或.txt 或.csv 文件中的通讯簿。文本导入向导将指导您完成步骤才能保证到Excel.txt 或.csv 文件中的数据。

  1. 打开 Excel。

  2. 数据选项卡上,选择从文本/CSV

  3. 选择.txt 或.csv 所需文件,然后选择导入

  4. 在“文本导入向导”的“原始数据类型”窗格中,选择“分隔符”。

    Excel 从文本中获取外部数据 - 文本导入向导步骤 1(共 3 个步骤)

  5. 如果要导入的文件包含标题,请选择“预览”窗格上方的“我的数据具有标题”复选框,然后选择“下一步”。

  6. 在“分隔符”窗格中,选择与数据所用的分隔符相匹配的复选框(如制表符或逗号),然后选择“下一步”。

    “文本导入向导”中已突出显示“分隔符”的选项。

    提示: “数据预览”窗格显示表格格式下的结果的样式。

  7. 在“数据预览”下,选择包含邮政编码的列,然后在“列数据格式”中选择“文本”。

    “文本导入向导”中已突出显示“列”数据格式的“文本”选项。

    注意: 

    • 可用的格式是常规文本日期。每次将数据格式应用于一列,该列的表格表头中显示格式的名称。

    • 列包含数值数据,例如百分比或货币值,例如,可以仅将格式设置之后在导入该文件。请参阅"设置格式Excel中的数值数据"的小节后面的详细信息。

  8. 选择要更改的列和要应用的数据格式,根据需要重复步骤 7。

  9. 选择“完成”。

  10. 在“导入数据”对话框中,接受“现有工作表”和单元格地址的默认设置,然后选择“确定”。

    在“导入数据”对话框中,选择将数据放入现有工作表、默认设置或新工作表中

    警告: “导入数据”对话框中的单元格地址显示当前所选的单元格。从已命名的单元格地址开始导入数据。

  11. 完成后,请使用新的文件名保存数据源。

Excel中数值数据的格式

设置任何数值数据,如百分比或在Excel您打算使用Word邮件合并中的任何新的或现有数据源中的货币值的格式。若要保留您已在邮件合并过程格式化为百分比,或为货币格式的数值数据,请按"步骤 2: 使用邮件合并动态的数据交换 (DDE)"部分。

在Excel数据源,您将使用Word邮件合并中的邮件列表,请确保正确设置格式的数值数据的列。设置列格式的数字,例如,以匹配特定类别,如货币。

  1. 打开Excel数据源。

  2. 选择要设置格式的列。

  3. 在“开始”选项卡的“数字”组中,选择“数字格式”(常规)框向下箭头,然后选择列表中的选项。

    在 Excel“主页”选项卡的“数字”组中,选择“常规”框中的向下箭头,从而选择要使用的数字格式。

  4. 根据需要重复步骤 2 和 3。

  5. 完成后,选择保存

当您有包含带格式的数字,如百分比和货币值Excel数据源时,数值数据的一些可能未保留其格式的邮件合并过程。你将收到的邮件合并结果需要,可以通过 DDE 保留在Excel数值数据的格式。

通过使用或不使用动态数据交换同期相比工作合并域的 Excel 数据格式

注意: 如果您决定不使用 DDE,请按照使用邮件合并发送批量电子邮件中的指导。

  1. 打开Word,选择文件>选项>高级

  2. 常规下选择打开时确认文件格式转换复选框。

    “打开时确认文件格式转换”选项

  3. 选择“确定”。

  4. 邮件选项卡上选择开始邮件合并> Step by Step 邮件合并向导

    在 Word 中,在邮件选项卡上,选择开始邮件合并,然后选择 Step by Step 邮件合并向导

  5. 邮件合并窗格中,在选择收件人中选择使用现有列表

    在 Word 中,邮件合并任务窗格打开时您选择邮件合并组中的步骤的邮件合并向导

  6. 使用现有列表下选择浏览,,然后打开格式化的电子表格。

  7. 确认数据源对话框中,选择全部显示复选框,然后选择MS Excel 工作表通过 DDE (*.xls) >确定

    “确认数据源”对话框

  8. Microsoft Excel对话框中,选择整个电子表格>确定

    Word 中的“Microsoft Excel”对话框

  9. 当打开邮件合并收件人对话框中时,选择确定

    邮件合并收件人对话框,显示为数据源用于邮寄列表的 Excel 电子表格的内容

  10. 继续使用字母电子邮件标签信封合并。

提示: 您可以阻止Word每次打开数据文件提示。连接到您的邮件列表之后,请转至文件>选项>高级。在常规下清除打开时确认文件格式转换复选框。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×