准备、发布和维护 Publisher 网站

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

注意: 本文已完成其工作,随后将不再使用。为防止出现“找不到页面”问题,我们将删除已知无效的链接。如果创建了指向此页面的链接,请删除这些链接,以便与我们一起为用户提供通畅的 Web 连接。

注意: Web 出版物仅在 Publisher 2007 和更早版本中可用。

在Microsoft Office Publisher 2007中规划和创建 Web 出版物之后, 您可以将其发布到 web、网络服务器或您自己的计算机上的共享文件夹。无论是哪种目标, Publisher 都会从 Web 出版物创建经过筛选的 HTML 文件。您可以在任何 Web 浏览器 (如 Windows Internet Explorer) 中打开和读取这些 HTML 文件。

带有导航栏、文本和图片的 Web 出版物

本文内容

本文介绍了以 HTML 文件的形式创建和发布 Web 出版物的过程, 以及如何通过编辑 Web 出版物并重新发布来更新您的网站。

准备网站

带有导航栏、文本和图片的 Web 出版物

维护您的网站

准备网站

您的网站是您、您的企业和业务品牌的扩展。创建网站之前, 请对其进行规划。

最佳工具是什么?

当您规划网站和其将提供的信息时, 请考虑哪种创作工具适合您的需要。Office Publisher 2007是一种出色的创作工具, 当您希望快速创建、发布和管理与您的商业品牌匹配且需要仅修订文本和图形的简单静态网站时, 可以使用它。在以下情况下, Office Publisher 2007不是合适的工具:

  • 如果您的网站需要交互性或数据库驱动的内容, 以便访问者可以在 Web 日志 (博客) 中响应或在购物车中购买项目

  • 如果您的网站需要数据验证, 例如用于验证信用卡号

  • 在Office Publisher 2007中创建网站后, 如果你希望以后在 html 编辑器中更改原始 HTML 代码, 这会将 html、XML 和 VML 代码组合在一起, 从而生成网站

创建网站

您可以在Office Publisher 2007中创建新的 Web 出版物。如果要处理没有 Web 出版物的现有网站, 您可以将内容从发布的网页复制并粘贴到新的 web 出版物中, 这会将网站重新创建为 Web 出版物, 也可以使用 HTML 编辑工具。

  1. 在 "文件" 菜单上, 单击 "新建"。

  2. 在 "出版物类型" 列表中, 单击 "网站"。

  3. 执行下列操作之一:

    • 若要创建基于您的网站目标的自定义网站, 请确保选中 "使用简单 Web 向导" (位于 "选项" 任务窗格中), 然后单击所需的设计。

    • 若要从头开始创建网站, 请在 "网站" 下单击 "空白大小", 然后单击所需的大小。

  4. 单击“创建”

  5. 如果您选择使用 "简易 web 向导", 请在 "简易网站生成器" 对话框中选择所需的选项, 然后单击"确定"

  6. 将内容添加到出版物, 并进行所需的任何更改。

    提示: 避免将对象放置在 Web 出版物中的母版页上。在某些 Web 浏览器中查看时, Office Publisher 2007母版页上放置的对象不能正确显示。

查看 Web 出版物

在发布网站之前, 请检查以确保网站按预期工作, 并解决可能会出现的所有可能问题。

您可以使用 "检查设计方案" 并预览您的网站来查找问题。

使用 "检查设计方案" 查找并修复问题

"检查设计方案" 是一个功能强大的工具, 可用于查找潜在问题。其中许多检查用于基本格式设置问题。但是, 某些检查专门用于可能会影响 Web 出版物的问题。若要运行 "检查设计方案", 请执行下列操作:

  1. 在 "工具" 菜单上, 单击 "检查设计方案"。

  2. 在 "检查设计方案" 任务窗格中, 选中 "运行常规设计检查" 和 "运行网站检查" 复选框。

    注意: 请确保未选中 "运行专业印刷检查" 复选框。

  3. 在 "检查设计方案" 任务窗格中, 在 "选择要修复的项目" 下, 单击要修复的项目旁边的箭头, 然后执行下列操作之一:

    • 单击 "自动修复" 以自动修复项目的问题。

      根据问题的不同, 自动修复会有所不同。在大多数情况下, 没有自动修复可用。

    • 单击 "转到此项目" 以转到所选问题项目所在的页面。

      然后, 你可以通过进行任何必要的更改来纠正此问题。

    • 单击 "说明" 以打开帮助主题, 该主题更全面地说明问题, 并提供有关如何修复该问题的建议。

    • 单击 "不再运行此检查" 以关闭该复选。

      单击此选项将影响问题的所有实例。

预览网站

  • 在 "文件" 菜单上, 单击 "网页预览"。

您的网站将在默认浏览器中预览。在预览中检查以下内容:

  • 网站随即打开, 所有页面都可访问。

  • 所有超链接都按预期方式工作。

  • 导航控件按预期工作。

  • 没有元素丢失。

  • 任何背景声音都按预期播放。

查找 Web 托管服务

您需要订阅由 Internet 服务提供商 (ISP) 提供的 web 托管服务, 然后才能在 web 上发布您的网站。此服务将向你提供 Internet 访问、web 服务器上的存储空间以及统一资源定位符 (URL), 以便用户可以访问你的网站。在发布您的网站之前, 请与您的 ISP 或系统管理员联系以获取所需信息, 以及您可以在其中保存文件的FTP网站的地址的 URL。

你所在地区可能提供多个 isp。请确保您订阅的 ISP 提供所需的支持类型。如果你在发布到 web 时没有经验丰富的体验, 你可能会希望 ISP 能够帮助你完成任何潜在问题。

显示页首

带有导航栏、文本和图片的 Web 出版物

在检查并预览 web 出版物并订阅 web 托管服务之后, 即可发布您的网站。

您可以将网站发布到Web 服务器、网络服务器、文件传输协议 (FTP) 服务器或您自己的计算机上的文件夹。

将网站发布到计算机上的某个位置可以满足以下几个目的:

  • 在 web 上提供文件之前, 您可以使用已发布的文件来测试您的网站。

  • 你可以使用 FTP 实用工具将文件从计算机上的文件位置上传到 web, 将其发布到 web。

  • 保存 HTML 文件和 Web 出版物的本地副本。

你的 ISP 可以向你提供帮助你确定最适合你的发布方法的信息。

无论发布到 web 还是您的计算机, Office Publisher 2007会将其创建的所有相关文件汇编在一个文件夹中。Office Publisher 2007创建的文件包括组成网站的其他 HTML 页、您在页面上使用的 GIF 和 JPEG 图形以及嵌入的声音文件。

你可以将Office Publisher 2007设置为以两种方式之一在其中发布网站的文件夹中组织这些文件。默认情况下, Office Publisher 2007将创建单个主页和一个子文件夹, 其中包含您的网站所需的所有支持文件。或者, 您可以将您的网站的所有支持文件组织到一个文件夹中的 "主页" 页面。

如何控制Office Publisher 2007组织发布的网站文件的位置?

在 "工具" 菜单上, 单击 "选项", 单击 " Web " 选项卡, 然后执行下列操作之一:

  • 若要将主页与支持文件分开, 请选中 "组织文件夹中的支持文件" 复选框。

  • 若要对同一文件夹中的主页和所有支持文件进行分组, 请清除 "组织文件夹中的支持文件" 复选框。

当你将出版物发布到 web 时, Office Publisher 2007会创建经过筛选的 html 文件, 它比未筛选的 html 文件更快地传播到 web。由于Office Publisher 2007创建的筛选的 HTML 文件中不包含任何 Microsoft Office 特定的标记, 因此无法在Office Publisher 2007中打开 HTML 文件并对其进行编辑。您必须在 web 出版物中对网站进行更改, 然后将网站重新发布到 web。

将网站发布到 Internet 或网络上的某个位置

在执行此过程之前, 请与您的 ISP 或系统管理员联系以获取您需要发布的信息和您可以在其中保存文件的网站的 URL。

  1. 在 "文件" 菜单上, 单击 "发布到 Web"

  2. 在 "发布到 Web"对话框中的 "文件名 " 框中, 键入要在其中保存您的网站的 Web 或网络服务器的 URL。例如, 键入 " http://www.northwindtraders.com"。

  3. 单击“保存”。

  4. 如果出现提示, 请键入您的用户名和密码, 然后单击"确定"

    与您的 URL 相关联的目录将显示在 "发布到 Web"对话框中。

  5. 双击要在其中保存您的网站的文件夹。

  6. 在 " 文件名" 框中, 选择index作为主页面的默认名称, 然后单击 "保存"。

    " index.htm " 是默认选择。选择index作为主页的名称可更轻松地访问和阻止用户查看组成您的网站的文件的列表。

  7. 在系统提示时,单击“确定”。

使用 FTP 发布网站

在执行此过程之前, 请与您的 ISP 或系统管理员联系以获取发布到FTP网站所需的信息。还必须在ftp 位置中创建 ftp 站点。

ftp 位置中的列表中添加 ftp 网站之前, 您必须具有访问 Internet 或 intranet 的权限。

  1. 在 "文件" 菜单上, 单击 "发布到 Web"

  2. 在 "发布到 Web"对话框中, 单击 "工具", 然后单击 "映射网络驱动器"。

  3. 在 "映射网络驱动器" 对话框中, 执行下列操作:

    • 在 "驱动器" 列表中, 单击驱动器号。你可以选择任何可用的字母。

    • 若要在每次登录计算机时都进行连接, 请选中 "登录时重新连接" 复选框。

    • 单击 "连接到可用于存储文档和图片的网站"。

  4. 在 "添加网络位置" 向导中单击 "下一步", 单击 "选择自定义网络位置", 然后单击 "下一步"。

  5. 在 " Internet" 或 "网络地址" 框中, 键入 FTP 网站的地址 (例如, 键入ftp://ftp.microsoft.com), 然后单击 "下一步"。

    注意: 如果无法连接到网络驱动器或文件夹, 则计算机可能已关闭, 或者你可能没有正确的权限。如果无法连接, 请与您的网络管理员或 ISP 联系。

  6. 如果不希望匿名登录, 请清除 "匿名登录" 复选框, 在 "用户名" 框中键入用户名, 然后单击 "下一步"。

  7. 键入此网络位置的名称, 然后单击 "下一步"。

  8. 单击“完成”

  9. 在 "文件" 菜单上, 单击 "发布到 Web"

  10. 在 "保存位置" 列表中, 单击 " FTP 位置"。

  11. 在 FTP 网站列表中, 双击所需的网站, 然后双击要在其中发布网站的文件夹。

    注意: 如果你的 ISP 要求你使用特定程序来上传你的网站, 或者如果你要将网站发布到公司 intranet, 你可能需要以特定的HTML文件格式保存网站的某个版本, 并按照其他过程进行发布您的网站。有关如何保存和发布网站的信息, 请咨询您的 ISP 或系统管理员。

将网站发布到您的计算机上的文件夹

  1. 在 "文件" 菜单上, 单击 "发布到 Web"

  2. 地址栏中, 单击要在其中发布网站的驱动器或文件夹, 如 "文档" 文件夹。

    如果要将您的网站添加到新文件夹, 请单击工具栏上的 "新建文件夹" 以创建一个新文件夹, 键入新文件夹的名称, 然后按 enter。

  3. 在 " 文件名" 框中, 选择index作为主页面的默认名称, 然后单击 "保存"。

    " index.htm " 是默认选择。选择index作为主页的名称可更轻松地访问和阻止用户查看组成您的网站的文件的列表。

维护您的网站

发布网站后, 您可以根据需要对其进行更新以反映新信息。但是, 你无法在 Publisher 中打开经过筛选的 HTML 文件。您必须打开原始 Web 出版物, 进行所需的更改, 然后将网站重新发布到 Web。

注意: 不应尝试使用文本编辑器 (如 microsoft 记事本或 microsoft 写字板) 更新经过筛选的 HTML 文件。虽然可以执行此操作, 但 Publisher 生成的 HTML 非常复杂, 您可能会发现很难手动进行编辑。为了获得最佳效果, 请始终使用 web 出版物更新 Publisher 网站, 然后将其重新发布到 Web。

仅发布更改的内容

在Office Publisher 2007中, 你可以通过使用 "增量方式发布到 web" 快速发布对以前发布的网站的更新, 这将仅发布你已更新的页面。如果你计划经常更新你的网站, 或者如果你的网站较大且复杂, 则增量发布到 web 可以加快更新你的网站的任务。

但是, 如果你直接在Office Publisher 2007外部对你的网站进行更改, 而启用 "增量方式发布到 web", 则可能会阻止你使用 "发布到 web"命令将后续更新发布到你的网站上Web 服务器 。如果你计划直接在 web 服务器上管理网站文件 (如通过单独的FTP程序), 则应关闭 "增量方式发布到 web"。

注意: 默认情况下, Publisher 中的 "增量方式发布" 功能处于启用状态。

打开或关闭 "增量方式发布到 web"

  1. 在 "工具" 菜单上, 单击 "选项", 然后单击 " Web " 选项卡。

  2. 在 "保存" 下, 执行下列操作之一:

    • 若要关闭 "增量方式发布到 web", 请清除 "启用增量方式发布到 web"复选框。

    • 若要打开 "增量方式发布到 web", 请选中 "启用增量方式发布到 web " 复选框。

将更改发布到您的网站

发布网站更新与首次发布网站稍有不同。将网站发布到网站上的某个位置后, web 服务器或网络服务器的快捷方式将显示在 "网上邻居" 中。

  1. 在 "文件" 菜单上, 单击 "发布到 Web"

  2. 在 "发布到 Web"对话框中的 "导航窗格" 中, 单击 "这台电脑"。

  3. 在文件列表中, 双击要在其中发布网站的 web 服务器或网络服务器上的文件夹的快捷方式。

  4. 双击要在其中保存文件的文件夹。

  5. 在 " 文件名" 框中, 键入要更新的文件的名称, 然后单击 "保存"。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×