关于“共享工作簿”功能

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

重要: “共享工作簿”是一项旧功能,通过它可与多名人员协作处理工作簿。此功能存在许多限制,已被共同创作替代。仅特定 Excel 版本才提供共同创作,其中包括适用于 Office 365 订阅者

试用 Office 365 或最新版本的 Excel 的 Excel 2016。

启用“共享工作簿”功能

  1. 继续操作之前,请确定需要使用此方法。“共享工作簿”有许多限制,因此强烈建议使用共同创作代替。

  2. 创建新工作簿或打开现有工作簿。然后将其放置在网络位置上。例如,放置于 \\server_name\folder_name 等位置。请勿将文件放在 OneDrive 或 SharePoint​​ 上。如果更喜欢将文件放于这些位置,请改为共同创作工作簿

  3. 单击“审阅”>“共享工作簿”。

    请注意,Excel 较新版本中已隐藏“共享工作簿”按钮。此处为取消隐藏的方法

  4. 在“编辑”选项卡上,选择“允许多用户同时编辑...”复选框。

  5. 在“高级”选项卡上,选择要用于跟踪和更新更改的选项,然后单击“确定”。

  6. 如果工作簿是新工作簿,请在“文件名”框中键入名称。如果工作簿是现有工作簿,请单击“确定”保存工作簿。

  7. 如果工作簿包含指向其他工作簿或文档的链接,请验证链接并更新任何损坏的链接。

  8. 单击“文件”>“保存”。

  9. 完成后,Excel 窗口顶部文件名旁边会显示“- 已共享”。

其他信息

请注意,共享工作簿是一种旧式共享方法。因此,使用此方法时许多项目和操作不受支持。下表列出了部分不受支持的功能。

不支持的项目:

不支持的操作:

创建或插入表格

插入或删除单元格块

添加或更改条件格式

删除工作表

添加或更改数据有效性

合并单元格或拆分合并的单元格

创建或更改图表或数据透视表

按格式排序或筛选

插入或更改图片或其他对象

使用绘图工具

插入或更改超链接

分配、更改或删除密码

创建、更改或查看方案

保护或取消保护工作表或工作簿

插入自动分类汇总

组合或分级显示数据

创建数据表

编写、记录、更改、查看或分配宏

创建或更改数据透视表

更改或删除数组公式

创建或应用切片器

添加、重命名或删除 XML 映射

创建或修改迷你图

将单元格映射到 XML 元素

添加或更改 Microsoft Excel 4 对话框工作表

使用 XML 源任务窗格、XML 工具栏或“数据”菜单上的 XML 命令

导入、刷新和导出 XML 数据

使用数据表单添加新数据

断开用户连接前,请确保用户已完成工作簿的工作。如果删除活动用户,用户所有未保存的工作都将丢失。

  1. 单击“审阅”>“共享工作簿”。

    请注意,Excel 较新版本中已隐藏“共享工作簿”按钮。此处为取消隐藏的方法

  2. 在“编辑”选项卡上的“正在使用本工作簿的用户”列表中,查看用户的名称。

  3. 选择要断开其连接的用户的名称,然后单击“删除用户”。请注意,虽然此操作会断开用户与工作簿的连接,但不会阻止该用户再次编辑工作簿。

  4. 若要删除被删除用户的任何个人视图设置,请单击“视图”>“自定义视图”,然后删除任何其他用户视图。

关闭此功能前,你可能需要保存更改历史记录副本。首先确保所有其他用户已完成其工作。

  1. 单击“审阅”>“修订”>“突出显示修订”。

    请注意,Excel 较新版本中已隐藏“修订”按钮。此处为取消隐藏的方法

  2. “时间”列表中,选择“全部”

  3. 取消选中“修改人”“位置”复选框。

  4. 选中“在新工作表上显示修订”复选框,然后单击“确定”

  5. 现在可打印“历史记录”工作表,或者将历史记录复制粘贴到另一个工作簿。

  1. 单击“审阅”>“共享工作簿”。

    请注意,Excel 较新版本中已隐藏“共享工作簿”按钮。此处为取消隐藏的方法

  2. 在“编辑”选项卡上,确保你是“正在使用本工作簿的用户”列表中列出的唯一用户。

  3. 取消选中“允许多用户同时编辑...”复选框。如果复选框不可用,则必须首先取消工作簿保护。执行下列操作:

    1. 单击“确定”关闭“共享工作簿”对话框。

    2. “审阅”选项卡上的“更改”组中,单击“撤消对共享工作簿的保护”

    3. 如果出现系统提示,请输入密码,然后单击“确定”。

    4. 在“审阅”选项卡上的“更改”组中,单击“共享工作簿”。

    5. 在“编辑”选项卡上,取消选中“允许多用户同时编辑...”复选框。

    6. 当系统提示会对其他用户产生影响时,请单击“”。

启用“共享工作簿”功能

  1. 继续操作之前,请确定需要使用此方法。“共享工作簿”有许多限制,因此强烈建议使用共同创作代替。

  2. 创建新工作簿或打开现有工作簿。然后将其放在网络位置。不要将放在 OneDrive 或 SharePoint 上的文件。如果您喜欢的文件,这些位置共同创作工作簿改为

  3. 单击“审阅”>“共享工作簿”。

  4. 在“编辑”选项卡上,选择“允许多用户同时编辑...”复选框。

  5. 在“高级”选项卡上,选择要用于跟踪和更新更改的选项,然后单击“确定”。

  6. 如果这是新工作簿,请在另存为框中键入名称。或者,如果这是现有工作簿,请单击确定保存工作簿。

  7. 如果工作簿包含指向其他工作簿或文档的链接,请验证链接并更新任何损坏的链接。

  8. 单击“文件”>“保存”。

  9. 完成后,Excel 窗口顶部文件名旁边会显示“- 已共享”。

其他信息

请注意,共享工作簿是一种旧式共享方法。因此,使用此方法时许多项目和操作不受支持。下表列出了部分不受支持的功能。

不支持的项目:

不支持的操作:

创建或插入表格

插入或删除单元格块

添加或更改条件格式

删除工作表

添加或更改数据有效性

合并单元格或拆分合并的单元格

创建或更改图表或数据透视表

按格式排序或筛选

插入或更改图片或其他对象

使用绘图工具

插入或更改超链接

分配、更改或删除密码

创建、更改或查看方案

保护或取消保护工作表或工作簿

插入自动分类汇总

组合或分级显示数据

创建数据表

编写、记录、更改、查看或分配宏

创建或更改数据透视表

更改或删除数组公式

创建或应用切片器

添加、重命名或删除 XML 映射

创建或修改迷你图

将单元格映射到 XML 元素

添加或更改 Microsoft Excel 4 对话框工作表

使用 XML 源任务窗格、XML 工具栏或“数据”菜单上的 XML 命令

导入、刷新和导出 XML 数据

使用数据表单添加新数据

断开用户连接前,请确保用户已完成工作簿的工作。如果删除活动用户,用户所有未保存的工作都将丢失。

  1. 单击“审阅”>“共享工作簿”。

  2. 在“编辑”选项卡上的“正在使用本工作簿的用户”列表中,查看用户的名称。

  3. 选择要断开其连接的用户的名称,然后单击“删除用户”。请注意,虽然此操作会断开用户与工作簿的连接,但不会阻止该用户再次编辑工作簿。

  4. 若要删除被删除用户的任何个人视图设置,请单击“视图”>“自定义视图”,然后删除任何其他用户视图。

关闭此功能前,你可能需要保存更改历史记录副本。首先确保所有其他用户已完成其工作。

  1. 单击“审阅”>“修订”>“突出显示修订”。

  2. “时间”列表中,选择“全部”

  3. 取消选中“修改人”“位置”复选框。

  4. 选中“在新工作表上显示修订”复选框,然后单击“确定”

  5. 现在可打印“历史记录”工作表,或者将历史记录复制粘贴到另一个工作簿。

  1. 单击“审阅”>“共享工作簿”。

  2. 在“编辑”选项卡上,确保你是“正在使用本工作簿的用户”列表中列出的唯一用户。

  3. 取消选中“允许多用户同时编辑...”复选框。如果复选框不可用,则必须首先取消工作簿保护。执行下列操作:

    1. 单击“确定”关闭“共享工作簿”对话框。

    2. 审阅选项卡上,单击保护工作簿

    3. 如果出现系统提示,请输入密码,然后单击“确定”。

    4. 审阅选项卡,共享工作簿

    5. 在“编辑”选项卡上,取消选中“允许多用户同时编辑...”复选框。

关闭此功能前,你可能需要保存更改历史记录副本。首先确保所有其他用户已完成其工作。

  1. 单击“审阅”>“修订”>“突出显示修订”。

  2. “时间”列表中,选择“全部”

  3. 取消选中“修改人”“位置”复选框。

  4. 选中“在新工作表上显示修订”复选框,然后单击“确定”

  5. 现在可打印“历史记录”工作表,或者将历史记录复制粘贴到另一个工作簿。

  1. 单击“审阅”>“共享工作簿”。

  2. 在“编辑”选项卡上,确保你是“正在使用本工作簿的用户”列表中列出的唯一用户。

  3. 取消选中“允许多用户同时编辑...”复选框。如果复选框不可用,则必须首先取消工作簿保护。执行下列操作:

    1. 单击“确定”关闭“共享工作簿”对话框。

    2. 审阅选项卡上,单击保护工作簿

    3. 如果出现系统提示,请输入密码,然后单击“确定”。

    4. 审阅选项卡,共享工作簿

    5. 在“编辑”选项卡上,取消选中“允许多用户同时编辑...”复选框。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×