修改、编辑或更改报表

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

本主题介绍可用于修改现有的 Access 报表的技巧。Access提供了可用于对报表进行更改的两种视图: 布局视图和设计视图。选择您要使用哪个视图取决于特定任务的完成。最终可能会使用这两种视图进行更改。

你想进行什么操作?

了解布局视图

了解设计视图

视图之间切换

修改在布局视图中报告

修改报表设计视图中

了解布局视图

布局视图是最直观的视图,用于修改报表,并可用于几乎所有要对报表中Access进行的更改。在布局视图中报告实际上正在运行,因此一样使用它将显示在打印时,您可以查看您的数据。但是,您还可以对该视图中的报表设计进行更改。在修改报表时,您可以查看数据,因为它是用于设置列宽非常有用的视图、 添加分组级别,或执行影响的外观和报告的可读性几乎所有其他任务。下图显示了在布局视图中的客户电话簿报表。

布局视图中的报表

在布局视图中看到的报表不查找不完全相同为打印的报表。例如,在布局视图中没有分页符。此外,如果您有用于页面设置格式的报表列,列不会显示在布局视图中。但是,布局视图为您提供非常接近打印的报表。如果您想要查看报表打印时的外观,,使用打印预览。

某些任务不能执行在布局视图中,并且需要切换到设计视图。在某些情况下,Access 会显示一条消息告诉您必须切换到设计视图,以使特定的更改。

了解设计视图

在设计视图提供更详细的视图的报表的结构。您可以查看报表、 页面和组的页眉和页脚的镶边。报表并不真正运行在设计视图中,以便您看不到使用; 时的基础数据但是,是可以更轻松地执行比在布局视图中的设计视图中的某些任务。您可以:

  • 将更广泛的控件添加到报表,如标签、 图像、 线条和矩形。

  • 在文本框本身中编辑文本框控件来源,而无需使用属性表。

  • 更改某些在布局视图中不可用的属性。

下图显示了在设计视图中的客户电话簿报表。

“设计”视图中的报表

在视图之间切换

Access 提供多种方法视图之间切换。如果报表已打开,您可以切换到另一个视图通过执行下列操作之一:

  • 右键单击导航窗格中的报表,然后单击快捷菜单的所需的视图。

  • 右键单击报表的文档选项卡或标题栏,然后单击快捷菜单的所需的视图。

  • 开始选项卡,在视图组中,单击视图按钮,可用视图之间切换。或者,可以在视图中,单击箭头,然后从菜单中选择其中一个可用的视图。

  • 右键单击报表本身的空白区域,然后单击所需的视图。在设计视图中打开报表时,您必须在设计网格之外右键单击。

  • 单击其中一个 Access 状态栏上的小视图图标。

如果报告未打开,双击以将其打开报表视图中导航窗格中的报表。若要在另一个视图中打开报表,请右键单击导航窗格中的报表,然后单击快捷菜单的所需的视图。

注意: 如果你正在修改的报表在其中有用于页面设置创建多个列 (例如,邮件标签报表),您可以仅查看打印预览中的列。在报表视图或布局视图中查看报表时,Access 将显示在一列的数据。

修改在布局视图中报告

本节介绍了一些您可以在布局视图中执行常见报表修改。

更改在布局视图中的列或字段宽度

  1. 单击要调整的列中的项目。

    指示已选定的字段的项目周围绘制边框。

  2. 拖动边框的左或向右边缘,直到得到所需的列宽。

更改在布局视图中的行或字段高度

  1. 单击要调整的行中的项目。

    指示已选定的字段的项目周围绘制边框。

  2. 拖动边框的顶部或底部边缘,直到达到所需的行高。

在布局视图中添加字段

  • “设计”选项卡上的“工具”组中,单击“添加现有字段”

    将显示可用字段的列表。如果有可用的其他表中的域,这些将显示在下其他表中的可用字段:

  • 将字段从字段列表拖动到报表。移动字段时,突出显示的区域将指示该字段在释放鼠标按钮时的放置位置。

    注意: 若要一次添加多个字段,请按住 CTRL 键并单击所需的字段列表中的每个字段。然后,释放 CTRL 键并拖动到报表的字段。要在相邻的放置字段。

返回页首

了解控件布局

控件布局是水平和垂直对齐控件的参考线以使统一的外观的报表。可以将控件布局视为一个表,其中的表的每个单元格包含一个控件。下面的过程显示如何添加、 删除或重新排列控件布局中的控件。

控件布局分为两种类型: 表格式和堆叠式。

  • 在表格式控件布局中的行和列,如电子表格中,使用顶部的标签排列控件。表格式控件布局中始终范围报表; 两个的部分表格式控件位于标签是在其上方部分中。下图显示了基本表格式控件布局。

    基本表格式控件布局

  • 在堆叠式布局,您可能会看到在纸质表单的左侧的每个控件标签等垂直排列控件。堆叠式的布局始终包含一个报表节内。下图显示了一个基本堆叠式的控件布局。

    基本堆叠式控件布局

您可以报表上有两种类型的多个控件布局。例如,您可能有表格式布局创建的每条记录中,数据行和下方,包含同一记录的更多数据然后一个或多个堆叠式的布局。

创建新的控件布局

在下列情况下,access 会自动创建纵栏式控件布局:

  • 您可以通过单击创建选项卡上的报表组中的报表 按钮图像 创建新的报表。

  • 您可以通过单击创建选项卡上的报表组中的空报表 按钮图像 ,然后从字段列表窗格拖动字段创建新的报表。

在现有报表中,您可以创建新的控件布局通过执行下列操作:

  1. 选择您想要向布局添加控件。

  2. 如果您想要将其他控件添加到相同的布局,请按住 SHIFT 键,同时选择这些控件。

  3. 执行下列操作之一:

    • 排列选项卡上的表格组中,单击表格堆积

    • 右键单击所选的控件,指向布局,,然后单击表格堆积

Access 将创建控件布局,并向其添加选定的控件。

从表格式控件布局切换到堆积或从堆积到表格式

若要切换到另一种类型的布局从整个布局:

  • 通过单击布局左上角的橙色布局选择器中选择控件布局。

    选择布局中的所有单元格。

  • 执行下列操作之一:

    • 排列选项卡上的表格组中,单击所需 (表格堆积) 的布局类型。

    • 右键单击控件布局,指向布局,,然后单击所需的布局类型。

Access 重排到所选的布局类型的控件。

将一个控件布局拆分为两个布局

通过使用以下过程,可以将控件布局拆分为两个布局:

  1. 按住 SHIFT 键,然后单击要移动到新的控件布局的控件。

  2. 执行下列操作之一:

    • 排列选项卡上的表格组中,单击所需的新的布局 (表格堆积) 的布局类型。

    • 右键单击选定的控件,指向布局,,然后单击所需的新布局的布局类型。

Access 将创建新的控件布局,并向其添加选定的控件。

重新排列控件布局中的控件

  • 您可以通过将其拖动到所需的位置来移动控件布局中的控件。拖动字段时,一个水平或垂直条指示它将在释放鼠标按钮时放置。

  • 您可以将从一个控件布局的控件移到相同类型的其他控件布局。例如,您可以从一个堆叠式布局拖动控件到另一个堆叠式布局,但不能为表格式布局。

将控件添加到控件布局

若要从字段列表窗格中的新字段添加到现有控件布局   

  • 只需将字段从字段列表窗格拖动到布局。一个水平或垂直条指示该字段在释放鼠标按钮时的放置位置。

若要将现有控件添加到现有控件布局   

  1. 选择您想要添加到控件布局的第一个控件。

  2. 如果您想要将其他控件添加到相同的布局,请按住 SHIFT 键,同时选择这些控件。您可以选择其他控件布局中的控件。

  3. 执行下列操作之一:

    • 在设计视图中打开报表时,拖动到布局的所选的字段。一个水平或垂直条指示字段在释放鼠标按钮时的放置位置。

    • 如果在布局视图中打开报表:

      1. 排列选项卡上的表格组中,单击要添加到的布局类型。如果您要添加到表格式布局,请单击表格。如果您要添加到堆叠式布局,请单击堆积

        Access 将创建新的布局,并向其添加选定的控件。

      2. 将新的布局拖动到现有版式。一个水平或垂直条指示字段在释放鼠标按钮时的放置位置。

从控件布局中删除控件

从控件布局中删除控件,可将其放置任意位置报表上而不会影响任何其他控件的位置。

  1. 选择要删除的版式中的控件。若要选择多个控件,请按住 SHIFT 键,然后单击您想要删除的控件。若要选择的所有控件布局中,单击布局选择器框左上角的布局。

  2. 右键单击其中一个选定的控件,指向布局,,然后单击删除版式

    Access 从布局中删除选定的控件。

提示: 若要防止控件插入控件布局移动时,请按住 CTRL 键,然后将该控件拖到所需的位置。

返回页首

删除字段或列

  1. 单击某个字段或列被删除,或者单击其标签或列标题。

    Access 会绘制指示它已选定的项目周围的边框。

  2. 按 Delete。

更改页面设置

使用页面设置选项卡上的页面大小页面布局组更改大小、 方向、 页边距和等等。

  1. 单击页面设置选项卡。

  2. 页面大小组中,单击大小以选择不同的纸张大小。

  3. 页面大小组中,单击页边距调整报表的页边距。

  4. 页面布局组中,单击纵向横向以更改纸张方向。

更改字段的格式

  1. 选择要设置格式的域。

  2. 格式选项卡中,使用字体组中的工具以应用所需的格式。

将文本框绑定到另一个字段 (更改控件的控件来源)

  1. 单击内的列或您要更改的控件来源字段。

    指示已选定的字段的项目周围绘制边框。

  2. 如果当前未显示属性表,请按 F4 显示该表。

  3. 在属性表的数据选项卡上,设置为新字段的控件来源属性。您可以从下拉列表中,选择一个字段,也可以在框中键入表达式。

更改报表的记录源

  1. 如果未显示属性表,请按 F4 显示该表。

  2. 在属性表顶部的下拉列表中,单击报表

  3. 在属性表中,单击“数据”选项卡。

  4. 记录源下拉列表中,选择要用于记录源的查询的表,或单击 “生成器”按钮 以显示查询生成器。

    注意: 如果报表当前基于表,Access 会询问您是否要创建基于表的查询。单击以显示查询生成器并创建查询,或单击以取消操作。如果您选择创建查询,新查询将成为报表的记录源。将用作"嵌入式"查询 — 即存储在报表的记录源属性中,而不是一个单独的查询的查询。

在字段中自动换行

  1. 如果未显示属性表,右键单击要在其中的文本换行,的字段,然后单击属性。否则,只需单击字段以将其选中。

  2. 在属性表的格式选项卡上,将可以扩大属性设置为

添加网格线

如果控件布局中包含您的控件,您可以添加网格线,可提供更多可视化分隔控件。

  1. 单击控件布局中的任何字段。

    指明已选中该字段周围绘制边框。

  2. 排列选项卡上的表格组中,单击网格线

  3. 从下拉列表中选择所需的网格线的样式。

注意: 您还可以添加网格线,方法是: 右键单击控件布局中的任何字段,指向布局,指向网格线,然后选择所需的网格线的类型。

返回页首

添加或修改徽标或其他图像

以下过程介绍了如何将徽标添加到报表,使用徽标工具中,以及如何调整图像控件或图像控件内的图像。

添加徽标

  • 设计选项卡上的页眉/页脚组中,单击徽标

    将显示插入图片对话框。

  • 浏览到存储徽标文件的文件夹,然后双击该文件。

    Access 将徽标添加到报表的左上角。

调整大小的控件,包含徽标或其他图像

  1. 单击包含图像的控件。

    要指示它已选定的控件周围绘制边框。

  2. 将指针放在边框上。当指针变为双向箭头时,您可以指示要放大或缩小使图像控件的箭头的方向拖动它。

请注意,默认值的图像的大小模式属性剪辑,表示该图像将保持相同的大小,而不考虑多大或使图像控件的小。如果您想要获得更大或变小调整控件的图像,请执行下列操作:

调整徽标或控件内的图像

  1. 选择图像。

  2. 如果尚未显示属性表,请按 F4 显示该表。

  3. 在属性表的格式选项卡上,将大小模式属性设置所需的选项:

设置

说明

剪贴画

图像保持相同的大小,而不考虑如何大或小您进行图像控件。如果使图像控件小于的图像,则剪裁图像。

拉伸

垂直或水平拉伸图像以匹配图像控件的大小。不保留原始纵横比的图像,使此设置会导致扭曲图像,除非您精确地设置高度和图像控件的宽度。

缩放

调整图像控件的大小,如图像调整为而不影响原始图像的纵横比尽可能大。

返回页首

添加或编辑报表标题

以下过程介绍如何添加或编辑包含报表的标题标签。

向报表添加标题

  • 设计选项卡上的页眉/页脚组中,单击标题

    向报表页眉中,添加新的标签和报告名称为您输入作为报表标题。

  • 创建标签时,因此,如果您想要更改的文本,您就可以开始键入所需的标题为您选择标签中的文本。

  • 完成后,请按 ENTER。

编辑报表标题

  1. 双击包含要将光标放在标签中的报表标题的标签。

  2. 键入您想要用作报表标题的文本,然后按 ENTER,当您完成。

添加页码、 当前日期或当前时间

以下过程介绍了如何将页码添加到报表,以及如何添加当前日期或当前时间。

添加页码

  • 设计选项卡上的页眉/页脚组中,单击页码

    将显示页码对话框。

  • 选择格式、 位置和所需的页码的对齐方式。

  • 如果您不希望第一页上的数字,请清除首页显示页码复选框。

  • 单击“确定”

    页码添加到报表中。切换到打印预览,若要查看数字的打印报表。

添加日期或时间

  • 设计选项卡的页眉/页脚组中,单击日期和时间

    将显示日期和时间对话框。

  • 如果不想包括的日期,请清除包含日期复选框。

  • 如果您想要包括的日期,请单击所需的日期格式。

  • 如果不想包括的时间,请清除包括时间复选框。

  • 如果您想要包括的时间,请单击所需的时间格式。

    在对话框中的示例区域中出现的日期和时间,在您选择的格式的示例。

  • 单击“确定”

修改报表设计视图中

在某些情况下,您不能在布局视图中执行某些修改报表和必须改为使用设计视图。

添加行号

  1. 在“设计”选项卡上的“控件”组中,单击“文本框”。

  2. 单击部分中所需的行号,若要显示的位置打开区域。在大多数情况下,这将显示详细信息部分。您将将文本框移至其最终位置更高版本。

    单击报表时,Access 将创建一个新的未绑定文本框。

  3. 单击标签 (只需到新文本框的左侧),然后按 DELETE。

  4. 在新的文本框中,以选中它,一次单击,然后再次单击将光标定位在文本框中。

  5. 键入= 1 ,然后按 ENTER。

  6. 如果尚未显示属性表,请按 F4 显示该表。

  7. 在属性表的数据选项卡上,将运行总和属性设置为在所有

    注意: 如果这是分组的报表,并且您想要对每个组从 1 开始编号,请将属性设置为在新组

  8. 调整指针放在文本框中的右边缘上的尺寸控点,将其拖动到左侧的文本框中为较小的宽度。将您会看到此报表上的最大行号足够的空间。

  9. 如果需要留出空间文本框最左侧边缘上的详细信息部分中通过将该分区中的现有控件拖到右侧,或调整该分区中最左侧的控件。

  10. 将新文本框拖动到希望它在报表上的位置。

  11. 切换到报表视图、 打印预览或布局视图以查看行号。

使每个页面顶部显示组页眉

对于跨越多页的组,它也有助于有组页眉显示在每页的顶部,以便您可以轻松地查看哪些数据所在的组。您可以在布局视图中选择组页眉中,但很方便地执行此操作在设计视图中。

  1. 双击组页眉节选择器 (在组页眉节上方的水平条)。

  2. 在属性表的格式选项卡上,将重复节属性设置为

自己设计视图窗口中打开子报表

当您在设计视图中打开报表时,也将在设计视图中打开包含在报表上的任何子报表。但是,每个子报表其子报表控件内显示而不是作为单独的窗口。由于子报表控件通常是太小无法轻松地在中工作的因此,通常会更方便在其自身的窗口中打开子报表,然后对其进行编辑。若要在新窗口中打开子报表,请执行下列操作之一:

  • 选择子报表,然后在设计选项卡的工具组中,单击在新窗口中的子报表

  • 单击一次以外的子报表控件以确保它未选中,和子报表控件内然后右键单击,然后单击在新窗口中的子报表

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×